Jump to content
adamsalac

WORKING Solution for Marvell Yukon 2 88E8040 Fast Ethernet!

158 posts in this topic

Recommended Posts

Thanks for this slice, worked a treat here. Do you reckon there's any way of using your working code to detect the MAC address and patching it in? Would be nice to save just changing the default MAC. If not this seems to be a good enough solution anyway.

My working codes are easy

	// read the mac address and place it somewhere safe for later use
char* ptrB0 =(char *)csrBase + B2_MAC_1;
bcopy (ptrB0, &addrMAC, ETH_ALEN);

But they are larger then the place in existing AppleYukon2.kext so I don't know how to apply its.

Share this post


Link to post
Share on other sites
Advertisement

I'm posting a new kext!

 

It's a modified 9J27(!-released today) AppleYukon2.kext with all device IDs.

 

I can't test it right now as I screwed up my Mac OSX installation.

 

Please report as soon as possible if it works.

 

 

 

Adam

9J27.zip

Share this post


Link to post
Share on other sites
I'm posting a new kext!

 

It's a modified 9J27(!-released today) AppleYukon2.kext with all device IDs.

 

I can't test it right now as I screwed up my Mac OSX installation.

 

Please report as soon as possible if it works.

 

 

 

Adam

 

Thanks, could you upload the vanilla too please?

Share this post


Link to post
Share on other sites
I'm posting a new kext!

 

It's a modified 9J27(!-released today) AppleYukon2.kext with all device IDs.

 

I can't test it right now as I screwed up my Mac OSX installation.

 

Please report as soon as possible if it works.

 

 

 

Adam

 

I know this made sound like a uber newb question. But do I just put this kext in my extensions folder and restart? I just have a basic install of osx and not sure on how to update a driver for this kext?

 

can someone give me quick instructions on how to do it? thanks!

Share this post


Link to post
Share on other sites

@Neonkoala:

Sorry,but this might take a while.I hope that it isn't too bad.I have to recover/reinstall my Mac OS X.

That's the disadvantage when you're too lazy to repartition the drive to GPT and you still use MBR....

 

Adam

Share this post


Link to post
Share on other sites
@Neonkoala:

Sorry,but this might take a while.I hope that it isn't too bad.I have to recover/reinstall my Mac OS X.

That's the disadvantage when you're too lazy to repartition the drive to GPT and you still use MBR....

 

Adam

 

No hurry, current one is fine for now. Thanks.

Share this post


Link to post
Share on other sites

@juch: yep exactly.And remove System/Extensions.mkext. It's even easier with OSx86 Tools or Kext Helper.You can find both in this forum.

 

Adam

Share this post


Link to post
Share on other sites

@Neonkoala: is the issue with incorrect MAC adress fixed?

Does the RomLessUnit error appear?

 

Thx,

 

Adam

Share this post


Link to post
Share on other sites
Hi,

 

finally I found a solution for the Marvell Yukon 2 88E8040 Fast Ethernet Device...

 

 

I'm very happy about any feedback.

 

Greetings from Czech Republic,

 

Adam

 

works like a charm on my samsung nc10. THANKS !!! you made my day dude !!!

Share this post


Link to post
Share on other sites

@palomu and all others having problems with recognition of their ethernet ports in Mac OS X even though the correct device IDs are included:

 

Try it with installing this

 

IOPCIFamily.kext 2.5.4

It's actually from Slice's signature! It might solve bad recognition of devices.

 

Post if this solution works! If not don't worry.There must be a solution!

 

Adam

Share this post


Link to post
Share on other sites
@Neonkoala: is the issue with incorrect MAC adress fixed?

Does the RomLessUnit error appear?

 

Thx,

 

Adam

 

Nope, still "AppleYukon2 - RomlessInit - getProperty failed" with invalid MAC.

Share this post


Link to post
Share on other sites
@palomu and all others having problems with recognition of their ethernet ports in Mac OS X even though the correct device IDs are included:

 

Try it with installing this

 

IOPCIFamily.kext 2.5.4

It's actually from Slice's signature! It might solve bad recognition of devices.

 

Post if this solution works! If not don't worry.There must be a solution!

 

Adam

Unfortunately that didn't do the trick. So the same problem still exists.

 

Br,

Rooster

Share this post


Link to post
Share on other sites

once again @palomu,RealRooster and all others having problems with recognition of their ethernet ports in Mac OS X even though the correct device IDs are included:

 

Try this kexts (install them both). If it still doesn't work , try booting with -f .

Credits for these kexts to Chun-Nan.

 

IOPCIFamily_by_chunnan_.zip

 

Report if it works or not.

 

Adam

Share this post


Link to post
Share on other sites
once again @palomu,RealRooster and all others having problems with recognition of their ethernet ports in Mac OS X even though the correct device IDs are included:

 

Try this kexts (install them both). If it still doesn't work , try booting with -f .

Credits for these kexts to Chun-Nan.

 

IOPCIFamily_by_chunnan_.zip

 

Report if it works or not.

 

Adam

Still no luck. :D

This is really strange 'cause I haven't got any problems with my NC10 before.

Is there any other way to check the Device ID than this:

 

1st do following command

sudo ioreg -lxw 1024 |less

2nd inside less, input /thernet

3rd look after

device id and vendor id nearby

 

Because I cannot find any marks about Ethernet adapter doing so. There is only WLAN and Bluetooth...

 

Br,

Rooster

Share this post


Link to post
Share on other sites
I'm posting a new kext!

 

It's a modified 9J27(!-released today) AppleYukon2.kext with all device IDs.

 

I can't test it right now as I screwed up my Mac OSX installation.

 

Please report as soon as possible if it works.

 

 

 

Adam

 

confirm, it's working well under 10.5.6 on compaq mini 700.

the only issue is 00:11:22:33:44:55 mac address (same story like for Slice)

let's think about some kind of Yukon Inject? anybody know if AppleYukon2 able to read mac from DSDT?

Share this post


Link to post
Share on other sites
confirm, it's working well under 10.5.6 on compaq mini 700.

the only issue is 00:11:22:33:44:55 mac address (same story like for Slice)

let's think about some kind of Yukon Inject? anybody know if AppleYukon2 able to read mac from DSDT?

Read my post carefully.

Share this post


Link to post
Share on other sites
once again @palomu,RealRooster and all others having problems with recognition of their ethernet ports in Mac OS X even though the correct device IDs are included:

 

Try this kexts (install them both). If it still doesn't work , try booting with -f .

Credits for these kexts to Chun-Nan.

 

IOPCIFamily_by_chunnan_.zip

 

Report if it works or not.

 

Adam

 

Hello adamsalac,

 

Thanks for your effort on this issue. I own NC10 and have the same problem with palomu. When I boot my machine with XP, Windows recognize this adaptor as "Generic Marvell Yukon 88E8048".

 

I tried your new kext above, but I got kernel panic.

 

Regards,

Aaron

Share this post


Link to post
Share on other sites

Hmmm, I don't understand it. I bet the problem IS the IOPCIFamily kernel extension.

It would be amazing if we had the source code of the beta driver from 9J22/9J27.

As we have the source code of Slice's driver,which recognizes the MAC adress.

We could modify the source code of the Apple kernel extension to recognize the MAC adress.

But that's only if if if....

Our hope is the final version of 10.5.7.But I wouldn't rely on this as there's no sence for Apple to develop a driver

for FAST ETHERNET 88E8040. I even don't get the the point why they're developing a driver for 88E804Z or Y or what ever that is nearly 100% compatible to our 88E8040.

The new Mac Pro is compatible with 10.5.6 excluding the new ATI Radeon 4870 which needs longer time for shipping (as far as I've heard it).

The new iMac is already shipping and works with 10.5.6 (excl. ATI Radeon 4850 24").

The Mac mini works 100% with 10.5.6.

That means there're no new ethernet devices in these models.

All have got Gigabit ethernet.

 

 

Adam

Share this post


Link to post
Share on other sites
Hi,

I have dell inspirion 1525 and it`s working with Mac OS X Leopard 10.5.2 Kalyway. Does this fix work for me ???

 

How about you try it. It most likely will work.

Share this post


Link to post
Share on other sites
Hi,

I have dell inspirion 1525 and it`s working with Mac OS X Leopard 10.5.2 Kalyway. Does this fix work for me ???

 

 

Work`s fine. I just can`t change the mac adress permanently. Now at every start I must change it again and again with a program called "Change mac". Does somebody has a fix for this ???

Share this post


Link to post
Share on other sites

Oh god. It worked for me too :)

The trick with HexEdit did the job and I can now pass the MAC control with my lab's router!

 

I did what Slice explained on his post and on reboot, the system used the right MAC address.

 

Thanks to everybody that worked on this, and good luck to those that don't have the chance I had.

Share this post


Link to post
Share on other sites

Hi ! Adam,

 

I confirm that the kext in AppleYukon2new.zip worked for me with 10.5.6 on Dell inspiron 1525 with a Yukon 88E8040 card.

 

Thanks a ton. I had given up on Ethernet with OS X.

 

Regards

 

Ravi

 

 

Hi,

 

finally I found a solution for the Marvell Yukon 2 88E8040 Fast Ethernet Device.

The key is Leopard 10.5.7 9J22. In this build there's an updated version of the IONetworkingFamily.kext exactly like in Snow Leopard 10A261 , but the Snow Leopard kernel extension DOESN'T work in Leopard.

 

And yesterday,I installed Leopard 10.5.7 9J22 and tada... my Ethernet port works.

 

Please report if the 9J22 kext works in older stable releases and if all dependencies are covered.

If not please tell me and I'll add the missing kernel extension(s).

 

Here's the proof:

71039462.th.png

 

Sorry,the screenshot is in German , even though I'm not German,but it's the language I speak the best.

 

Hope it works. The kernel extension is attached here. AppleYukon2.zip

 

UPDATE: Here's a new modified kext including 88E8040T support and corrected Info.plist device name AppleYukon2new.zip

 

I'm very happy about any feedback.

 

Greetings from Czech Republic,

 

Adam

Share this post


Link to post
Share on other sites

Kext is working for me too. I don't really worry about Mac Adress, as I don't need the correct one, but what really bothers me is that Ethernet isn't working after sleeping the computer until a complete restart. When I wake the computer, the yellow led flashes for about a minute and networking options show me that it's connected correctly, but I don't have access to the internet until I reboot.

 

It also doesn't matter whether I put the kext in /Extensions or replace the old on inside the networking kext.

 

Any suggestions?

 

Maybe it would work with the complete networking kext from 10.5.7. Could someone please post ist? Thanks in advance.

 

Ps: I'm on a Dell XPS 1530 88e8040. Apple shows 88e804z instead.

 

PPs: Current rumors talk of a possible Apple Netbook. Maybe this might come with Marvell fast Ethernet...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×