Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
gary88

ADI AD2000b works with applehda

117 posts in this topic

Recommended Posts

OH MY GOODNESS!!! I HAVE AUDIO!!!!

 

WOOT!!!

 

I have been fighting with this 10.5.6 setup for my P6T Deluxe ADI audio for about 2 weeks now. Reading and reading and reading...

 

i removed the AppleHDA.kext from my extensions folder, installed the ADI-AD2000b.PKG file from this thread (posted earlier) and VIOLA!! Sound! Beautiful sound!

 

MANY MANY MANY Thanks!

 

Bluehopper

Share this post


Link to post
Share on other sites
Still waiting for the kernel panic fix. :(

Use the drivers linked here (AD2000b.HDA.FIX.kext in the ad2000b archive, and HDAEnabler.kext), they work with shutdown. You can also put them in /Extra/Extensions, as Beerkex'd said. I have now a fully working retail leo, without touching /System/Library/Extensions :)

Share this post


Link to post
Share on other sites

Eh, I can't test those kexts right now because my hackintosh install broke, I'm just waiting for my MacBook now.

Share this post


Link to post
Share on other sites

hi garry88,

Great work here. Grats. I've been using your kext successfully until I updated my hackintosh to 10.5.7.

Can you please patch the new kext to make it work with our audio chip?

Share this post


Link to post
Share on other sites

Amaizing, I deleted the AppleHDA.kext and installed the pkg and works like a charm :happymac:

 

Almost have a full working machine now.

 

Thanks

Share this post


Link to post
Share on other sites

Hi gary88, I have two questions:

 

1_ Are you going to update these kexts to work in Snow Leopard in 32 & 64 bit modes?

 

2_ You said that AD2000b is the same as AD1989b so is there a possibility to get it working with DSDT? If I remember I saw AD1989b working using the DSDT way.

 

Thanks in advance.

Share this post


Link to post
Share on other sites

I've been trying for hours to make audio work on my Asus P6T Deluxe V2, after doing a vanilla 10.6 installation (everything else works, I'm stuck on audio then it's perfect).

 

Nothing in this thread has worked so far; the .pkg installer linked earlier, The King's kexts, AppleAzalia, VoodooHDA, nothing.

 

Is anyone else completely without luck on the P6T with Snow Leopard, or if someone has gotten it to work can you explain exactly how?

 

Edit: I magically made it work, not sure what changed but VoodooHDA 0.2.1 ended up working. I put it in both /Extra/Extensions/ and /System/Library/Extensions/, verified permissions and rebuilt Extensions.mkext with Kext Utility, and rebooted. System Profiler shows nothing but the Audio prefpane does, and now iTunes works and most importantly, sound comes out of my rear line-out. Headphone jack seems not to work, not a big deal, I'll work on it later.

Share this post


Link to post
Share on other sites

VooodooHDA works on the Rampage II Extreme too. King's modified plist is supposed to also work under SL, but I for the life of me can't make it happen. I'm not sure what the issue is, the plist and the enabler check out.

Share this post


Link to post
Share on other sites
I've been trying for hours to make audio work on my Asus P6T Deluxe V2, after doing a vanilla 10.6 installation (everything else works, I'm stuck on audio then it's perfect).

 

Nothing in this thread has worked so far; the .pkg installer linked earlier, The King's kexts, AppleAzalia, VoodooHDA, nothing.

 

Is anyone else completely without luck on the P6T with Snow Leopard, or if someone has gotten it to work can you explain exactly how?

 

Edit: I magically made it work, not sure what changed but VoodooHDA 0.2.1 ended up working. I put it in both /Extra/Extensions/ and /System/Library/Extensions/, verified permissions and rebuilt Extensions.mkext with Kext Utility, and rebooted. System Profiler shows nothing but the Audio prefpane does, and now iTunes works and most importantly, sound comes out of my rear line-out. Headphone jack seems not to work, not a big deal, I'll work on it later.

 

it won't work if its in /Extra/E, you just need to put it into S/L/E.

Still waiting for the new version of AppleHDA works for snow leopard.

Share this post


Link to post
Share on other sites

I got The King's modified plist kext working on Snow Leopard, here is what I did:

HDAEnabler.kext-32-64-bit.zip -> /System/Library/Extensions/HDAEnabler.kext

HDEFEnabler.x64.zip -> /Extra/Extensions/HDEFEnabler.kext

AD2000b.zip (only the fix) from THe KiNG -> /Extra/Extensions/AD2000b.HDA.FIX.kext

Share this post


Link to post
Share on other sites
I got The King's modified plist kext working on Snow Leopard, here is what I did:

HDAEnabler.kext-32-64-bit.zip -> /System/Library/Extensions/HDAEnabler.kext

HDEFEnabler.x64.zip -> /Extra/Extensions/HDEFEnabler.kext

AD2000b.zip (only the fix) from THe KiNG -> /Extra/Extensions/AD2000b.HDA.FIX.kext

 

Hi, thank you for share.

but how can i get thoese kexts?

Share this post


Link to post
Share on other sites

King has created a new version of his AD2000B.kext that supersedes the old one, which didn't work all that well in the first place (Mic issues). This works with Leopard and Snow Leopard, and Mics fully work.

 

It is designed with front panel support(mic as internal and headphones) 3 line out(first as speaker) digital in/out and back mic(as line in, I will explain later why 3 analog inputs dosen't work with hda)

 

You can grab it at RapidShare.

 

For people that are on SL, I'm also attaching the kext along with the new 32bit/64bit of HDAEnabler. These are the only kexts you need to get the AD2000B working under SL. HDEFEnabler is not required.

 

Snow_Leopard_AD2000b.zip

Share this post


Link to post
Share on other sites

Same here... sound works probably one in ten reboots... Motherboard is Asus P5Q-E with AD2000B. Anyone have any ideas what would cause this.

 

I'm using AD2000B.kext and HDAEnabler.kext from above in /S/L/E.

 

Thanks,

G.

Share this post


Link to post
Share on other sites

The new version by the King only requires AD2000B.kext and HDAEnabler.kext. Works great on 10.6.0 and 10.6.1.

 

Gaveen and masa, maybe you have a permissions issue? also have you tried rebuild your kext cache?

Share this post


Link to post
Share on other sites

I managed to get this method working only by placing the kexts in the following locations.

 

HDAEnabler.kext in System/Library/Extensions/

HDAEnabler.kext and AD2000B.kext in Extra/Extensions/

 

Removing either of the HDAEnabler.kexts disables sound.

 

Hope this helps those having issues.

 

Working great with all inputs appearing under system profiler ==> audio

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×