Jump to content
cFoo

Waiting on IOProviderClass..IOResources

12 posts in this topic

Recommended Posts

After upgrading from 10.5.4 (Kalyway) to 10.5.5 I'm getting the dreaded messages:

 

"Waiting for boot volume with UUID *randomly generated array of numbers and letters*" Then

"Waiting on <dict ID='0'><key>IOProviderClass</key><string ID='1'>IOResources</string><key>IOResourceMatch</key><string ID='2'>boot-uuid-media</string></dict>"

 

It works fine if I boot with -f -v

 

Does anyone have any idea what's going on? I don't get why it would work if I add a -f in the boot parameter. Thanks!

Share this post


Link to post
Share on other sites
Advertisement

I have the same problem, but this happens when I insert the XxX 10.5.6 install DVD to a new computer. The motherboard used is MSI G31M3-L V2, with a G31 chipset (with BIOS patched). All SATA drives.

 

I can't get past it even with -f -v. Does anyone know whats going on?

Share this post


Link to post
Share on other sites

I get this same message on iPC 10.5.6 PPF5 when I put in the disc

 

Can't even get to the installer :)

 

 

 

*Edit: but when I tried booting with -f -v flags, I got one line past the IOProviderClass:

 

"ApplePS2Trackpad: Synaptics TouchPad v6.3"

 

 

Not exactly something useful, but it adds, right? :)

Share this post


Link to post
Share on other sites

hey did any one find solution to this problem? I am also stuck at this line...

waiting on IOProviderClass

 

I tried installing with iPC 10.5.7 and its not moving past it....

any one have solutions please help me out!

Share this post


Link to post
Share on other sites

I don't remember how exactly I resolved it, but I remember that one of the things I did was use the cpus=1 flag and turned off some things in the BIOS.

 

USB Legacy Support > Disabled

Execute Disabled bit > Enabled

Max CPUiD Value Limit > Disabled

 

After that it all booted up, and after the install I didn't need the cpus=1 flag. If it doesn't work with just that flag try adding the -f -v too.

 

Good luck.

Share this post


Link to post
Share on other sites
I don't remember how exactly I resolved it, but I remember that one of the things I did was use the cpus=1 flag and turned off some things in the BIOS.

 

USB Legacy Support > Disabled

Execute Disabled bit > Enabled

Max CPUiD Value Limit > Disabled

 

After that it all booted up, and after the install I didn't need the cpus=1 flag. If it doesn't work with just that flag try adding the -f -v too.

 

Good luck.

 

I tried it but it did not work

my system is dell inspiron 1501, and all the hardware are compatible... i used iPC to do this but cant get past this error can some1 help?

Share this post


Link to post
Share on other sites

Has anyone found a solution yet for this? I am getting the same problem. I used iDeneb 1.6. In my BIOS, i don't have an option to manually turn of Legacy support...

Share this post


Link to post
Share on other sites

i have same problem but my laptop is Acer Aspire 5738PG (touchscreen version)

some details:

 

C2D 2.2ghz T6600

4Gb RAM

ATI Radeon HD 4570 512mb vram

Share this post


Link to post
Share on other sites

I think I found the solution.

 

This occurs when you are using Kernal Flags and set rd= pointing to a partition which is not the partition which you want to load your MacOSX system from.

 

For instance I had an installation on partition 2 of my hard disk. I have Chameleon running so in /Extras/com.apple.Boot.plist I had the following entries:

 

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
       <key>Kernel</key>
       <string>mach_kernel</string>
       <key>Kernel Flags</key>
       <string>arch=i386 [color="#FF0000"][i][b]rd=rdisk0s2[/b][/i][/color]</string>
       <key>GraphicsEnabler</key>
       <string>No</string>
       <key>Timeout</key>
       <string>5</string>
       <key>Legacy Logo</key>
       <string>Yes</string>
       <key>EthernetBuiltIn</key>
       <string>Yes</string>
       <key>Theme</key>
       <string>Bullet</string>
       <key>Graphics Mode</key>
       <string>1680x1050x32</string>
</dict>
</plist>

 

Later I made a disk image of the volume and restored it to a different partition, but I kept getting the IOProviderClass error.

 

After I removed the rd Kernal Flag I was able to boot again. I don't know why I originally put that that kernal flag in there but it must of been out of some noobish sense that it would some how help me.

 

But, hypothetically you could just set the rd kernal flag to point to the partition with the MacOSX system you wish to load, but unless you specifically need to use it for some reason, I would just remove it all together because it will effectively prevent you from booting into multiple MacOSX systems on the one machine.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×