Jump to content
DiaboliK

Asus P5N7A-VM

1,295 posts in this topic

Recommended Posts

Hi dgsga,

Is there any chance of you posting details of how you go about patching the ASUS Bios with the new DSDT. I'd like to try some experiments of my own.

Thanks.

 

Hey Zanc, thanks for the DSDT update. I've currently got V5 with your DSDT fully functional, with USB detected on sleep, but I can't wake from sleep using USB, just power button. Next is trying to get functional sleep with additional Vid Card.

Share this post


Link to post
Share on other sites
Advertisement
Hey Zanc, thanks for the DSDT update. I've currently got V5 with your DSDT fully functional, with USB detected on sleep, but I can't wake from sleep using USB, just power button. Next is trying to get functional sleep with additional Vid Card.

Hi kramer2k. I'm a little confused, as I've never posted a DSDT. However, I would be interested in your configuration above. Having USB wake correctly from sleep (especially Bluetooth) even if I can only wake via the power button would simplify use of the Plex/HTPC system by the rest of the family.

 

Does your new configuration suffer from BIOS reset after a restart after a sleep, as that is another pain with the system fans going into roar mode.

 

With regard to USB behaviour after sleep, I have noticed some unpredictability. Originally, I had to add kextunload/kextload a USB extension, using sleepwatcher, for the system to recognise the Apple remote after a sleep. Recently, it has started working without sleepwatcher actions. I don't like unpredictable behaviour.

 

I've tried a number of kextunload/kextload and restarting blued sequences to fix the Bluetooth keyboard and mouse on wakeup but have had no success. As traffic is one way (device -> system) I suspect the keyboard/mouse software handler does not know the extension has been removed for some time after the kext is unloaded and so does not try to reconnect. Hopefully with your work this will no longer be needed.

Share this post


Link to post
Share on other sites
My bad...meant to be @sylph93

 

And you won't be able to wake from BT unless it's apple genuine (per my understanding).

Won't need to wake from BT keyboard. In fact, I would prefer it that way as there would be less chance of accidently waking up the system. Have you the details of how you patch the DSDT into the BIOS?

Share this post


Link to post
Share on other sites
I finally found the solution for USB replugging.

 

I've also used dgsga's moded rom (V4)

 

Today I made dsdt file for this.

 

If it works for you, then please merge this to mod bios. :)

 

sylph93

Tried your DSDT after making changes to support DVI/DVI video out, overriding dgsga's v4 ROM. However, I did not get any change in behaviour. In particular, Bluetooth keyboard/mouse and EyeTV failed to restart after a wake, although Apple remote worked fine. Could you explain a bit more about your DSDT. What were the differences you achieved when compared with dgsga's v4/v5 ROMs. Has anyone been able to include your DSDT into a ROM image. I tried using cbrom.exe, from advice from dgsga, but every time I tried to use it it would hang. Also, what are the differences between the two DSDT files you posted in post #1095.

Share this post


Link to post
Share on other sites

Thanks.

 

This is a copy of a guide someone was asking for regarding this board:

 

See attachment.

 

This was originally part of a lifehacker guide and partly made up from Hutch's guide.

I've explained a few things and included photos for reference and put it into pdf.

Share this post


Link to post
Share on other sites

My Hardware

MB : Asus P5G41 ML E

VGA : INTEL GMA X4500

Ram : 2 Gigs

HDD : 500 & 80 Gigs ( Sata )

CPU : Intel Core 2 Due E7500 [MMX,SSE(1,2,3,3S,4.1),EM64T,VT-X]

My problem :

After boot os x86 DVD , Before the Apple logo appears , System restart

 

What is the problem?

Share this post


Link to post
Share on other sites
My Hardware

MB : Asus P5G41 ML E

VGA : INTEL GMA X4500

Ram : 2 Gigs

HDD : 500 & 80 Gigs ( Sata )

CPU : Intel Core 2 Due E7500 [MMX,SSE(1,2,3,3S,4.1),EM64T,VT-X]

My problem :

After boot os x86 DVD , Before the Apple logo appears , System restart

 

What is the problem?

wrong board for this thread, thats the problem

Share this post


Link to post
Share on other sites

hi

 

use iatkos v5i for install on my system

 

boot dvd and Before Apple logo appear my system Automatically Restart

 

use cpus=1 Apple logo Appear and stop  (No Work )

 

 

 

 

Help Me

Share this post


Link to post
Share on other sites

Can you provide more details on how you did this? I'd like to get to 10.6.3 but I'm currently on 10.5.6.

 

Hey, I have successfully updated to 10.6.3.

I’m using dgsga's moded rom (V4). The only thing I had to do was to backup Applehda.kext in /System/Library/Extensions before I started the update. If you don’t do a backup and reinstall the old Applehda it will break your audio. Alternatively you can go over to this thread http://www.insanelymac.com/forum/index.php?showtopic=161430 and look for a new Applehda for /Extra/Extensions. But until now I haven't checked..

Share this post


Link to post
Share on other sites

Hey all,

 

Just installed Snow Leopard on my P5N7A-VM. Everything went well, thanks to the dgsga modded rom .

 

Everything works well,

But, if I shutdown my computer, I can hear the harddisk spinning down, but the CPU fan and case fans won't go off.

 

When performing a sleep, the CPU fan and case fans do go off.

This is making me think that a little change in the configuration should solve this shutdown problem?

 

Am I right?

 

Anybody has a clue?

 

My configuration:

 

Asus P5N7A-VM

Intel Core 2 Quad Q9550 (2.83Ghz)

8GB 800Mhz memory

Geforce 7900 GTO 512mb

 

Mac OSX Snow Leopard 10.6 (Retail) with PC EFI 10.6 (graphicsenabler=yes) with the following extra extensions:

FakeSMC

EvOReboot

ApplePS2Controller

LegacyAppleHDA

JMicronATA (64-bit version)

Share this post


Link to post
Share on other sites
Hey all,

 

Just installed Snow Leopard on my P5N7A-VM. Everything went well, thanks to the dgsga modded rom .

 

Everything works well,

But, if I shutdown my computer, I can hear the harddisk spinning down, but the CPU fan and case fans won't go off.

 

When performing a sleep, the CPU fan and case fans do go off.

This is making me think that a little change in the configuration should solve this shutdown problem?

 

Am I right?

 

Anybody has a clue?

 

My configuration:

 

Asus P5N7A-VM

Intel Core 2 Quad Q9550 (2.83Ghz)

8GB 800Mhz memory

Geforce 7900 GTO 512mb

 

Mac OSX Snow Leopard 10.6 (Retail) with PC EFI 10.6 (graphicsenabler=yes) with the following extra extensions:

FakeSMC

EvOReboot

ApplePS2Controller

LegacyAppleHDA

JMicronATA (64-bit version)

 

Try the later modded ROM http://www.insanelymac.com/forum/index.php...t&p=1341125

Share this post


Link to post
Share on other sites

@ Treble,

 

I think I figured it out. From my investigating extracting DSDT from dsdga's mods, he has left in the IRQ flags under RTC on his modded BIOS, which may be the cause of the bios reset after sleep.

 

However, I can't get the ACPI patcher to patch the bios for the life of me.

 

@ sylph93

With regards to the USB Fix, you may have unknowingly (or knowningly) changed the _ADR of both EHC1 and EHC2 from

Name (_ADR, 0x00040001) ---> Name (_ADR, 0x001D0007)

Name (_ADR, 0x00060001) ---> Name (_ADR, 0x001D0007)

 

And omitted ---> Name (_S1D, One)

 

I was having an error on verbose regarding USB being unloaded across sleep, which went away when I changed the _ADR back to the original values, but keeping the 'Built-in' modifications.

 

And I'm not sure what the _S1D does, if anything.

Share this post


Link to post
Share on other sites
Apparently there is a new bios for this great motherboard...519.

 

You can see this when viewing the bios history on its support page.

 

However, curiously the bios is not listed as a download.

 

However, a copy can be obtained using this internal link:

 

http://dlsvr04.asus.com/pub/ASUS/mb/socket...N7A-VM-0519.zip

 

dl'ing now.....any idea what changes there are (that affect OSX)?

 

EDIT: It's been blocked....!

Share this post


Link to post
Share on other sites
dl'ing now.....any idea what changes there are (that affect OSX)?

 

EDIT: It's been blocked....!

 

No one that I know has tested this in their hack.

 

The link works...click the link displayed on the blocked page works here...

 

Hope someone tests this and reports back.

Share this post


Link to post
Share on other sites
Apparently there is a new bios for this great motherboard...519.

 

You can see this when viewing the bios history on its support page.

 

However, curiously the bios is not listed as a download.

 

However, a copy can be obtained using this internal link:

 

http://dlsvr04.asus.com/pub/ASUS/mb/socket...N7A-VM-0519.zip

 

From Asus's support website

 

P5N7A-VM BIOS 0519

1. Fix the system does not beep when booting up.

2. Fix the HDD size is shown incorrectly when the size is bigger than 2.2TB.

3. Fix the system may hang at ExpressGate.

Share this post


Link to post
Share on other sites
Ok First off i flashed to dgdga's p5n7avmv3.rom bios.

next i installed mac os sl as per freshcocoa's tutorial, up until the computer restarts. then

 

run install for chameleon rc4-r684

 

i copied the following:

 

smbios.list into extras

fakesmc.kext and openhaltrestart.kext into extras/extentions

 

 

then i dragged the following into kextulility:

LegacyAppleHDA.kext

OpenHaltRestart.kext

 

 

after this i ran kext ulility on its own so that it could fix permissions for the files in Extra and E/E.

 

lastly I downloaded the latest pc_efi boot file..boot_10.5 and put it in root

 

 

p.s. after sl update 10.6.2 i re copied all the above mentioned files.

 

 

let me know if this works for you.

 

 

on a different note i decided to fun some benchmarks.

my spec:

Q9550@ 2.83Ghz

2GB DDRII @ 800 Mhz - Kingston ValueRam(2x1GB)Thinking about upgrading to 4x2GB Kingston HyperX DDRII-1066. Good Idea?

intergrated graphics @ 256MB

160GB Samsung HDD

asus wl-138g v2 wireless lan card

some $10 generic usb bluetooth stick

2 X lg 22x dvd writers.. Though i cannot ipmort 2 cds at once in itunes !!!!

 

results:

 

cinebench 10:

OpenGL standard test - CB 4899

 

Single CPU Render test - CB 3293

 

Multiple CPU Render test - CB 10434. Render time was 00:01:24

 

Geekbench:

 

Geekbench score - 6050

 

URL - http://browse.geekbench.ca/geekbench2/view/203354

 

Xbench:

 

Result - 170.4

 

 

just interesting...

post your results and lets see how different setups compare

 

It almost worked for me.

 

I installed everything and was working perfectly in 10.6

Needed to update to 10.6.2 for the new bt al kb to be recognized properly.

Updating with the combo failled so i had to first up to 10.6.1 and then 10.6.2.

At that moment usb is failing to load my usb wifi and usb hds after wake up.

Any ideas or help would really be appreciated.

 

Thanks to everybody for your patience, work and knowledge!

Share this post


Link to post
Share on other sites
From Asus's support website

 

P5N7A-VM BIOS 0519

1. Fix the system does not beep when booting up.

2. Fix the HDD size is shown incorrectly when the size is bigger than 2.2TB.

3. Fix the system may hang at ExpressGate.

 

This bios works 100% fine without adding any errors or difficulties using SNOW LEOPARD 10.6.3.

 

FYI in case anyone wanted to jump on it...

Share this post


Link to post
Share on other sites
This bios works 100% fine without adding any errors or difficulties using SNOW LEOPARD 10.6.3.

 

FYI in case anyone wanted to jump on it...

But what if the method dsga, I have modified the BIOS version 4, and all my work without DSDT table, if I update bios to the new, which I guarantee that everything will remain in working condition and will not have to use tables DSDT, please explain it to someone with that faced by details, and what to expect when you upgrade to a new BIOS v519. I am grateful for their assistance.

Share this post


Link to post
Share on other sites
This bios works 100% fine without adding any errors or difficulties using SNOW LEOPARD 10.6.3.

 

FYI in case anyone wanted to jump on it...

 

Are you saying that USB devices (e.g. Bluetooth, Elgato EyeTV) work after wake from sleep?

Share this post


Link to post
Share on other sites

Thread of noobs?

 

No...I'm saying this bios works just the same or equal to the one before it.

 

No one mentioned anything about sleep, some dsdt hacks, or anything.

 

Sometimes reinventing the wheel (aka the perfect hackintosh) is a huge wild goose chase...

 

I'll not post here again.

Share this post


Link to post
Share on other sites
Thread of noobs?

 

No...I'm saying this bios works just the same or equal to the one before it.

 

No one mentioned anything about sleep, some dsdt hacks, or anything.

 

Sometimes reinventing the wheel (aka the perfect hackintosh) is a huge wild goose chase...

 

I'll not post here again.

 

Sorry to have offended you, it must have ben my interpretation of 100% working. Obviously any hackintosh can be a compromise, but the overall intention of those with the hacking capability is to get as close as is practicable to a fully working Macintosh, and that includes sound, video, wake, sleep and attached devices.

 

Obviously you have more talent at these things than I, so if I have driven you away I'll refrain from posting here again so you can contribute without my naive interruptions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×