Jump to content
Sign in to follow this  
Followers 0
Madremiha

Installation iDeneb 1.3 sur HP DV 9760EF (Et dual boot avec Vista) (Kext inclus valables pour d'autres DV serie 9000)

61 posts in this topic

Recommended Posts

Bonjour

 

Vu que mon probleme est résolu j'edite donc mon post pour les prochains :(

Ma version installée est la iDeneb v1.3

 

Merci a ceux qui m'ont aidé (particulierement ZI instigator)

 

Et j'inclus donc les kexts correspondant a ma config:

Le zip contient les kexts pour:

L'Audio

L'Ethernet

Le trackpad (tap & scrolling comme sous Vista)

Le lecteur de cartes

Le lecteur DVD

 

 

Message original du sujet:

J'ai installé la semaine derniere OS X Tiger sur mon PC HP en passant par VMWare et... ça m'as plu :(

Maintenant j'aimerais passer a la vitesse supérieure donc je souhaiterai l'installer sur mon disque dur.

Je me pose donc mille et une question concernant l'installation pour ne pas merder au moment venu.

 

Notamment concernant le Dual Boot:

J'ai cru comprendre que le dual boot ne fonctionnait pas terrible avec Vista et qu'il vallait mieux s'en passer et utiliser le BIOS pour choisir le disque de démarrage, quel est la meilleure solution?

 

Ensuite concernant les pilotes relatifs à mon PC, pour le son, le trackpad, la carte wifi, et la résolution (par extension ma carte graphique) enfin tout le matériel quoi...Ou puis je trouver ces pilotes? Dans ma version d'OS X (10.4.8) lors de l'install que j'avais effectué sous VMWare il y avait à selectionner les pilotes a installer concernant le proc (intel ou amd) la carte graphique (nvidia ou ati (il me semble)) et d'autres trucs que je n'ai plus en tete...J'avais installé ce qui me semblait correspondre et ça marchait bien sauf pour le wifi qui ne marchait pas mais normal VMWare le prends pas en charge et la resolution qui n'etait pas affichée en 1440x900...

 

Voila mon materiel:

HP Pavilion DV9760EF

 

Processeur: Intel T7250 2GHZ

Memoire: DIMM 1024x2

Carte Wifi: Intel Wireless Wifi 4965AGN

Carte Reseau: Realtek RTL8168B/8111B

Clavier: Périphérique clavier PIH

Clavier: Standard 101/102-Key or Microsoft Natural PS/2 Keyboard with HP QLB

Souris: Synaptics PS/2 Port TouchPad

2 Disques durs: Toshiba MK1637GSX 160Go

Carte Graphique: NVIDIA GeForce 8600M GS

Type de bios: Phoenix

Carte Audio Haut parleur Realtek High Def

Lecteur cartes memoires Ricoh

 

Voila j'espere avoir été assez precis et que vous pourrez m'apporter de l'aide.

 

[EDIT] La version que j'ai sous la main est OS X 10.4.8 JAS PPF1 PPF2 mais peut etre je devrai partir sur une autre version...

Drivers_MAC.zip

Share this post


Link to post
Share on other sites
Advertisement

j'ai vu une video sur Youtube d'un gars qui avait installé Kalyway 10.5.1 sur un HP DV9000 ça a l'air de bien tourner mais l'histoire ne dit pas comment il s'y est pris et quels pilotes et comment les installer?

Devrais je tenter celle ci ou je dois plutot tester une plus récente?

Share this post


Link to post
Share on other sites

bonsoir ,

essaye une distib comme Ipc ou Ideneb qui sont récentes.

Par contre , tu sera obligé de changer ta carte wifi pour avoir internet ( si tu passe par le wifi ).

Share this post


Link to post
Share on other sites

Donc plus recentes qu'OS X 10.5.1 (Kalyway)?

Ce qui me permettrai d'avoir un meilleur support des pilotes tu penses?

Sinon petite question comment fait on pour installer des pilotes lorsque les peripheriques ne marchent pas aprés l'install d'OS X? Doit on désinstaller les anciens? si oui comment? ou doit on réinstaller OS X en n'installant pas les pilotes des periphs qui bloquent?

Et comment installer les nouveaux pilotes aprés installation d'OS X?j'ai vu qu'il y avait plusieurs formats de fichiers de pilotes...A force de lire pleins de trucs je commence a avoir l'esprit un peu embrouillé :P

Peut tu me donner les versions de distro Ipc et Ideneb car je suppose qu'il y en a plusieurs...

 

Si d'autres veulent aussi me donner leurs avis pas de soucis (non pas que je remet en doute tes conseils mannox ;) mais j'aime bien etre sur et avoir plusieurs avis)

Share this post


Link to post
Share on other sites

Bonsoir ,

Pour installer les drivers sous OSX , il faut que tu utilise kext helper , facilement trouvable avec google. Ensuite , il faut que tu es les " drivers " , qui sont sous cette forme : .kext .

POur les versions , tu as :

Ipc en 10.5.6

et ideneb v1.3 qui est en 10.5.5 ( c'est cette version que j'ai installer sur mon ordi )

Share this post


Link to post
Share on other sites

Pour les drivers si j'en crois ce que j'ai lu dans la page wiki que l'on retrouve dans plusieurs posts ici, je devrais avoir besoin de drivers qui ne sont pas intégrés pour ma carte graphique et pour le wifi mais vu que j'ai la même carte que toi ca ne devrai pas marcher comme le pilote est encore en dev.Par contre pour le pilote Son à l'install il va me proposer plusieurs drivers ? Je fais quoi je les installe tous ou aucun ou autre ?

J'ai iDeneb sous la main et demain si j'ai suffisamment bien assimilé je me lance

Corrige moi si je dis des conneries s'il te plait

Share this post


Link to post
Share on other sites

Salut Madremiha,

 

J'ai un dv9649em, un poil plus ancien que le tiens, donc, même si on a peut prèt la même config.

J'ai installé la Kalyway 10.5.2 puis la maj 10.5.5 dispo sur ce forum.

J'ai testé la iDeneb 10.5.5, la iPc 10.5.6, sont moins stable sur ma machine que la kalyway. (la iDeneb etait mieux, de tête..)

Je ne saurais te conseiller la kalyway, etant donné que mon hp ne tourne plus quasiment que sous osx, maintenant.. et c'est machine principale : ca tourne très bien. Si tu as besoins d'autres infos, hesite pas.

Share this post


Link to post
Share on other sites

Merci pour ton support

Donc j'ai installé iDeneb sur le HD

En fait j'ai 2 DD le premier est partionné en 3:

1Partition principale:Vista

2Stockage des fichiers Temp de Vista

3Recovery Vista de HP

 

Le 2eme DD partionné en 2

1DATA contient tous mes docs

2OS X

 

J'ai donc fais l'install comme il fallait (a mon avis) j'ai installé les pilotes qui me semblait convenir et ai finalisé l'install

Au moment de redémarrer juste aprés l'extinction j'ai ouvert le lecteur DVD pour ne pas booter dessus mais du coup j'ai démarrer sur vista

J'ai donc redémarrer avec le DVD dedans mais la je tombe sur l'ecran ou je devais choisir F8 et -v pour le lancement de l'install d'OS X j'ai donc redémarré en essayant de taper sur les touches F au démarrage pour essayer de trouver un indice pour pouvoir booter sur OS X...

J'ai pas trouvé si quelqu'un peut me dire que faire et mieux comment je peux avoir un écran qui me demande quel OS je veux lancer... :D

Share this post


Link to post
Share on other sites

Le bootloader a pas du s'installer..

Ca m'est arrivé aussi avec la iDeneb (et pas qu'avec celle là, en fait..) et Vista.

Qu'à tu sélectionné comme bootloader lors de l'install ? (si tu as bien sélectionné quelque chose, c'est bien souvent automatique)

Essaie avec la kalyway, en ne prenant que (scuse, dans le désordre) :

 

- Les fonts : rien

- Language tranlation : rien (ou FR, si tu veux l'install en Français)

- Kernel : Speedstep

- Graphics Driver : nvinject correspondant à ta ram

- Audio : si tu trouve quelques choses qui correspondant, dans le doute rien.

- Network : idem audio

- Mobo : Tout

- Third application : Tout

- SSE2 : rien

- Patches : de tête j'ai mis le powermanagement, le clavier FR.

- AMD : rien

 

Avec ça, j'avais une super base bien stable avant d'appliquer le reste des patches.

 

Mais je crois que tu n'as qu'une 10.5.1, ce sera pas pareil.. Et je la connais pas (jamais testé.)

Share this post


Link to post
Share on other sites

En fait j'avais pas spécialement d'option concernant le boot mais il semblerait que ce soit le boot de windows qui prenne le dessus

J'ai lu quelquepart qu'il fallait mettre chain0 à un emplacement particulier pour que le boot de windows propose au démarrage l'OS à lancer OS X ou vista mais la manip n'est pas clairement détaillée donc j'ai pas su ou trouver ce chain0 , ce que c'est et ou et comment le déplacer

C'est ce qui me conviendrai le mieux pour le dual boot

Share this post


Link to post
Share on other sites

Bon j'ai trouvé ce fameux chain0: je l'ai extrait avec Winrar de l'iso d'iDeneb maintenant il faut le placer dans C:/ et aprés il faut modifier le fichier boot.ini qui se trouve aussi dans C:/ c'est la que les soucis commencent; Vista ne fonctionne pas avec boot.ini son remplacant est bootmgr mais je ne sais pas comment l'ouvrir pour le modifier et ajouter cette ligne C:\chain0="Mac OS X86"

j'ai essayé avec Blocnotes mais j'ai plein de caracteres bizarres; si quelqu'un a une idée de comment le modifier...

Share this post


Link to post
Share on other sites

Ca y est je l'ai fait !!!

J'ai installé EasyBCD 1.7.2 sous Windows et j'ai ajouté une nouvelle entrée:MAC OS X

J'ai aussi placé comme dit précedemment dans C:/ le fichier chain0

 

Et maintenant au démarrage du PC j'ai l'ecran avec le choix entre Windows Vista et OS X!!!

 

Maintenant me reste a installer les drivers pour l'audio, pour les 2fingers scroll, pour l'ethernet et aprés je me pencherai sur l'achat d'une carte wifi...A il me faut aussi arriver a supprimer le temps de choix de l'OS sous le bootloader Darwin.

Share this post


Link to post
Share on other sites

 

Ben en fait j'ai réussit; j'ai installer HDAenabler ensuite le fichier ALC268 qui etait joint avec dans un sujet du forum mais ça ne marchait pas donc j'ai installé Madtux ALC268 A et ça marchait toujours pas j'ai testé ensuite le Madtux ALC268 B et la ça marche trés bien aucun soucis pour l'extinction du pc ou le redemarrage et la prise casque fonctionne aussi donc du tout bon mais pour le coup je ne sais pas si ce que j'ai installé avant était necessaire ou pas?...

 

Par contre maintenant j'aurais bien besoin d'un coup de main pour l'ethernet j'ai cherché longtemps mais les explications ne sont pas claires du tout

Ma carte ethernet est Realtek 8111 tu aurais ça sous la main avec une petite explication pour l'install stp?

 

Ton wifi est il le meme que moi? (intel wireless 4956AGN) A ce que j'ai compris le dev etait en cours mais faute de moyens materiels le dev n'as pu continuer...

 

Sinon tu as changé ta carte wifi? Car je suis pret a la changer mais je voudrai qu'elle soit aussi compatible avec vista...

 

Merci pour ton aide.

Share this post


Link to post
Share on other sites

Pour l'ethernet va falloir que je me repenche dessus (je ne m'en sers jamais, même si je sais que cela fonctionne).

 

J'ai trouvé ça, rapidement :

 

http://forum.insanelymac.com/index.php?sho...436&hl=8111

 

 

Pour le wifi, d'origine j'avais une 3945. Je l'ai remplacée par une Broadcom 4311 en mini PCI-E.

Je l'ai payé 25 euros avec les FDP sur ebay. Aucun problème avec cette carte sous Vista.

 

Le problème est que ton bios (comme le mien) est bridé pour ne pas accepter un changement de carte wifi, il veut que tu gardes la 3945/4965. Mieux vaut être prévenu avant, au boot, il t'envoie un message :

 

104-Unsupported wireless network device detected

 

Et t'empêche d'aller plus loin.

 

Il faut donc flasher ton bios. Pour mon ordi, j'ai trouvé un truc tout fait par un des membres de ce forum, à tester sur ta machine (c'est pas difficile, mais risqué, tu t'en doutes!)

 

 

edit d'après le café :

 

Sur le cd de la Kalyway, tout bêtement, tu dois avoir : RealtekR1000 (ou un nom approchant) qui contient le kext qu'il te faut. soit tu l'installe avec Pacifist, soit avec Kext Helper si tu retrouve le Kext par recherche sur le forum. :)

Share this post


Link to post
Share on other sites

Javais trouvé ce lien et j'avais telechargé le pack donné mais une fois ouvert je ne trouve pas de kext l'installation a l'air plus compliqué que ça et je ne trouve pas de post l'expliquant correctement.

Si tu trouve ce kext ce serait cool que tu me le postes car je n'ai pas la kalyway et par contre les kext de l'audio je les ai installé avec OSX86Tools et non avec les autres prog que tu cites OSX86Tools permet d'installer le kext et de remettre les permissions et de nettoyer le cache des kext dans la meme fenetre.(c'est la meme chose je pense non?)

Je suis vraiment tenté par le changement de carte wifi mais j'ai vraiment les boules de flasher le bios; je l'ai jamais fait...

 

[EDIT] Je viens de trouver le post concernant le flash du bios des HP series DV9000

http://forum.insanelymac.com/index.php?showtopic=120190

 

Apparemment ça conviendrai pour tout les 9000 mais bon je me tates a prendre le risque ou pas...

Peut tu me decrire la manipulation que tu as faites pour le flasher?

Share this post


Link to post
Share on other sites

Re,

 

Pour le bios, c'est bien ce topic (hop, en favoris..) qui m'avait permis de flasher mon bios.

J'ai fait exactement ce que lrzrage a écrit, et c'est parfaitement passé.

 

Ceci dit, pour le flash : Ton pc sous vista branché au secteur, aucun programme ne tourne ne tache de fond, pas de machin branché en usb, en FW..

 

Tu lance le truc, et le prog te dira, de toutes façon, si le bios que tu installe correspont à ta machine ou pas (cette derniere est à prendre avec des pincettes, je ne veux pas me retrouver responsable de la mort de ta machine :police: )

 

Niveau Kext Helper ou Osx86Tools : à ce niveau oui, c'est pareil (même utilitée) sauf que Osx86Tool à justement plus de "Tools" que l'autre.

Share this post


Link to post
Share on other sites

Merci beaucoup pour ces réponses qui m'eclaire beaucoup et me reconfortent ;)

J'ai quand meme appelé un magasin spec informatique pour savoir si en cas de pepins ils sont capable de remettre le bios a zero et il m'as dit oui (45€ quand meme)

J'avais hesité entre ça ou prendre une clé wifi mais c'est quand meme plus pratique de l'avoir intégré

Bon je vais deja commandé la carte et aprés passage au flash :(

Et pour l'ethenet tu as retrouvé quelquechose?

 

[EDIT]Pour l'ethernet j'ai re-regardé dans le dossier que j'ai dld sur le forum (ou plutot sur sourceforge) et j'ai trouvé dans un dossier "build" deux dossiers; un dossier "Debug" et un autre "Release" contenant chacun le fameux fichier "Realtekr1000.kext" j'ai donc installé le kext avec OSX86Tools et avant de redémarrer j'ai reparé les permissions et vider le cache des extentions mais aprés redémarrage j'ai branché mon cable et quand je vais dans Préferences systeme/Reseau il y a marqué a gauche "cable ethernet débranché"...

J'ai testé la meme manip avec le fichier se trouvant dans "Debug" mais toujours pareil

Je suis perdu maintenant...

 

[RE EDIT]J'ai remarqué aussi que le lecteur DVD n'est pas reconnu ;)

Share this post


Link to post
Share on other sites
pour le lecteur de dvd non detecté, tu peux poster une pic de ton systeme profiler / dic burning ?

(c'est bizarre, le mien est detecté d'office..)

 

Ca veut dire quoi? Pour le coup je fais vraiment le newb la :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×