Jump to content
RoberT_XeS

MAC OS X LEOPARD RETAIL ON ASUS P5Q / P5Q PRO / P5Q-EM AND OTHERS

Installed Mac OS X Retail Successfully  

736 members have voted

  1. 1. Were you able to install Mac OS X Retail Successfully

    • Yes
      559
    • No
      180

868 posts in this topic

Recommended Posts

I managed to get anything working. I just can't figure out how to boot from the first FAT32 partition I made. Might be a good idea to put that section on the beginning of the guide. Now I have only OSX installed and no way to run syslinux on that partition to make it bootable. Any ideas?

Share this post


Link to post
Share on other sites
Advertisement

After much reading and deliberating as to whether or not patch my bios, I went for it.

 

Patched BIOS.

Set RAID to AHCI.

Installed relevent windows drivers so I can run both OS's.

 

Only I used a different distro altogether and have successfully installed 10.5.6 on my P5Q! Instead of jumping through all the hoops in this thread to get things working I figured to try something different. So i used the iPC OSx86 Leopard 10.5.6 distro in the new releases thread.

 

One thing that might have helped is that I run only SATA devices. No IDE at all.

 

One thing though that i'm not sure how to fix, or even if i can. I have nVidia 9800 GT and from the iPC distro installed the 9800 GTX driver, after a few attempts of other drivers that failed, this is the closest. I have all resolutions availble but Q/E is not enalbed even after using OSXTools to try to enable it.

 

I using Chameleon for boot (i think) and am not sure if PCEFI is being utilised or not so if i were to use OSXTools to generate an EFI string, would it work? How can I find out if I have EFI working?

 

I'm still a bit of a noob to OSX86 life but pick things up quickly if anyone is willing to help?

 

Thanks for the great advice in this thread for me to get this far ;)

Share this post


Link to post
Share on other sites
I managed to get anything working. I just can't figure out how to boot from the first FAT32 partition I made. Might be a good idea to put that section on the beginning of the guide. Now I have only OSX installed and no way to run syslinux on that partition to make it bootable. Any ideas?

 

 

I also had difficulties with this small FAT32 partition. So I ended up installing without it. Hopeing for a solution a long the path..

What possibly made my problems was that I maybe had the usb-stick inserted in a port and the pc tried to boot from it..

 

Anyway I continued without just to see if things would work.

There are tools to make this partition afterward I believe, although I don't think it is a good solution.

 

 

I had an old Belkin pci network card, just put it in, and it worked right out of the box!

Now my P5Q is online :)

Share this post


Link to post
Share on other sites
After much reading and deliberating as to whether or not patch my bios, I went for it.

 

Patched BIOS.

Set RAID to AHCI.

Installed relevent windows drivers so I can run both OS's.

 

Only I used a different distro altogether and have successfully installed 10.5.6 on my P5Q! Instead of jumping through all the hoops in this thread to get things working I figured to try something different. So i used the iPC OSx86 Leopard 10.5.6 distro in the new releases thread.

 

One thing that might have helped is that I run only SATA devices. No IDE at all.

 

One thing though that i'm not sure how to fix, or even if i can. I have nVidia 9800 GT and from the iPC distro installed the 9800 GTX driver, after a few attempts of other drivers that failed, this is the closest. I have all resolutions availble but Q/E is not enalbed even after using OSXTools to try to enable it.

 

I using Chameleon for boot (i think) and am not sure if PCEFI is being utilised or not so if i were to use OSXTools to generate an EFI string, would it work? How can I find out if I have EFI working?

 

I'm still a bit of a noob to OSX86 life but pick things up quickly if anyone is willing to help?

 

Thanks for the great advice in this thread for me to get this far :(

 

 

You will find some help here for your Graphics Card

http://forum.insanelymac.com/index.php?showtopic=143948

 

I managed to get anything working. I just can't figure out how to boot from the first FAT32 partition I made. Might be a good idea to put that section on the beginning of the guide. Now I have only OSX installed and no way to run syslinux on that partition to make it bootable. Any ideas?

 

You can try this next time when you create a bootable Fat32 Drive

syslinux.exe -ma -f D: if your drive letter is D:

Share this post


Link to post
Share on other sites

Thank you Robert, i will check that thread out.

 

Incidentally, apologies for posting here rather than in the iPC thread. Just wanted

to let you know P5Q is good for other distros too. :wacko:

 

Thanks,

Share this post


Link to post
Share on other sites

@Robert_XeS:

 

Where do I run that command? You can't do that in OSX. You'll need Windows but I don't have that anymore.

 

Another issue. I installed the NVkush file which works fine. It just shows only 256 MB of memory but I have a 8800 GTS with 640 MB. The NVKush installer tells me to go to their plister to generate a .plist file. I did with the correct device ID but after restarting my X server dies or something. I just get a black screen with a mouse pointer. Any ideas on how to utilise the full 640 MB?

Share this post


Link to post
Share on other sites
Triple boot:

More or less as RoberT_Xes says..

 

Installed XP first (used IDE settings in Bios, later did a change to XP I found on the net, and set it to AHCI. (because my xp don't have any support for this ahci, can be slipstreamed i guess)

Installed iDeneb.

Darwin gave me options to choose xp or osx.

Installed W7.

W7 or vista bootloader gave me xp or w7 to choose from.

Used easybcd to add osx.

Vista loader let me choose from xp, osx and w7.

When choosing osx, I get into darwin, and must choose between the three again. But I don't mind.

Time out works as before..

 

Too bad there's no LAN fix for the Atheros..

 

Booting from USB.. it won't overide vista boot loader?? Or will it, but only when it's in there?

 

If i use the darwin bootloader booting stops at the apple logo and a neverending spinning wheel. Only booting via the usbstick works for me.

Any idea for that?

Share this post


Link to post
Share on other sites
If i use the darwin bootloader booting stops at the apple logo and a neverending spinning wheel. Only booting via the usbstick works for me.

Any idea for that?

 

Sure it is spinning ?? :)

Try booting with option -x (and -v) (both)

Have you flashed the BIOS?

Have you tried verifying and repairing disk permission? (I saw it in a post, don't actually know if it's needed. I did)

But it looked like to me as installing nvidia kexts was what I needed to boot without -x. I installed nvidia kexts while in safemode (-x).

Share this post


Link to post
Share on other sites
@Robert_XeS:

 

Where do I run that command? You can't do that in OSX. You'll need Windows but I don't have that anymore.

 

Another issue. I installed the NVkush file which works fine. It just shows only 256 MB of memory but I have a 8800 GTS with 640 MB. The NVKush installer tells me to go to their plister to generate a .plist file. I did with the correct device ID but after restarting my X server dies or something. I just get a black screen with a mouse pointer. Any ideas on how to utilise the full 640 MB?

 

When you boot into Mac OS X you might be getting a Boot Menu......In that just select the Partition in which you have the Windows and press Enter it should load windows.

 

If you have Vista then just insert the DVD and then repair and it should get back the boot menu for you.

 

If that does not work then you can try to use some Bootable CD's to rewrite the MBR....like Paragon Recovery CD

Share this post


Link to post
Share on other sites
Sure it is spinning ?? :thumbsup_anim:

Try booting with option -x (and -v) (both)

Have you flashed the BIOS?

Have you tried verifying and repairing disk permission? (I saw it in a post, don't actually know if it's needed. I did)

But it looked like to me as installing nvidia kexts was what I needed to boot without -x. I installed nvidia kexts while in safemode (-x).

 

Yes i am sure it`s spinning.

I have flashed the bios and i am not using a nvdia card but an ati.

I will try the boot arguments later.

 

But if booting would be that simple (just via darwin) why we have to create a seperate partition (or keep using usbstick)?

Share this post


Link to post
Share on other sites

I have a problem, I can't install on my machine.

Q6600@2.4

Ati raeon 4850 pro

S.B. Live 5.1

Asus P5Q

Hdd1 vista

Hdd2 (for mac)

 

 

I read and follow all the instruction.

I want use the HDD2 for mac and for some data of windows, so i made an HD with this partitio

1 - 38mb (fat 32)

2 - MACOSX 25 GB (HFS+)

3 - RETAIL IMAGE 15 GB (HFS+)

4 - Extended DATA (NFTS)

 

When I try to launch iakatos i have this error.

th.2145041231965904.gif

 

Can Anyone help me?

 

I want the 1st disk only for vista (for launch it I have to select IDE mode) and the 2nd disk for OSX (+ some space for vista data).

 

 

EDit.

I read some topic and I read that I can depend that the dvd drive is not sata. It's possibile?

I have 2 dvd-r connected by IDE (1 primary and 1 slave).

The 2 hd are connected by sata II (change AHCI mode in BIOS)

Share this post


Link to post
Share on other sites

All this seems so complicated. Why not just install the retail with a 132 boot CD custom made for the board (is there even one?)? Or is it not possible?

Share this post


Link to post
Share on other sites
I have a problem, I can't install on my machine.

Q6600@2.4

Ati raeon 4850 pro

S.B. Live 5.1

Asus P5Q

Hdd1 vista

Hdd2 (for mac)

 

 

I read and follow all the instruction.

I want use the HDD2 for mac and for some data of windows, so i made an HD with this partitio

1 - 38mb (fat 32)

2 - MACOSX 25 GB (HFS+)

3 - RETAIL IMAGE 15 GB (HFS+)

4 - Extended DATA (NFTS)

 

When I try to launch iakatos i have this error.

th.2145041231965904.gif

 

Can Anyone help me?

 

I want the 1st disk only for vista (for launch it I have to select IDE mode) and the 2nd disk for OSX (+ some space for vista data).

 

 

EDit.

I read some topic and I read that I can depend that the dvd drive is not sata. It's possibile?

I have 2 dvd-r connected by IDE (1 primary and 1 slave).

The 2 hd are connected by sata II (change AHCI mode in BIOS)

 

Your error message is not getting loaded properly, I cant see the error message image properly........

Share this post


Link to post
Share on other sites
Your error message is not getting loaded properly, I cant see the error message image properly........

 

OK.

I repost image

2145041231965904tb9.jpg

 

IT's "still waiting for root device"

 

:wacko:

Share this post


Link to post
Share on other sites
OK.

I repost image

2145041231965904tb9.jpg

 

IT's "still waiting for root device"

 

;)

 

 

This kind of error message occurs when the Bios is not properly flashed or if the Storage Configuration is not set to AHCI.

 

I want to know if this error message is while installing iDeneb or Mac OS X Retail

Share this post


Link to post
Share on other sites
This kind of error message occurs when the Bios is not properly flashed or if the Storage Configuration is not set to AHCI.

 

I want to know if this error message is while installing iDeneb or Mac OS X Retail

 

The bios it's ok.

I reflashed it and the storaage are set to AHCI (HDD, the dvd player no, are EIDE).

Error are when I try to install iakatos.

Now I try with Ideneb and if it's not work, i try to install ideneb on a flash drive and install it. If don't work I buy a new storage dvd sata.

;)

Share this post


Link to post
Share on other sites
The bios it's ok.

I reflashed it and the storaage are set to AHCI (HDD, the dvd player no, are EIDE).

Error are when I try to install iakatos.

Now I try with Ideneb and if it's not work, i try to install ideneb on a flash drive and install it. If don't work I buy a new storage dvd sata.

:)

 

You can also buy a IDE to Sata Convertor............ instead of a Sata DVD Writer.

Share this post


Link to post
Share on other sites
You can also buy a IDE to Sata Convertor............ instead of a Sata DVD Writer.

 

Miracle.

I try to use ideneb versiona and I install on my system (no problem root).

Now I have another problem.

AT Ideneb start I have to select language and keybord, after if I want trasfer data form another mac ecc...

after this last step (I select I don't want trasfert nothing), the system after 2 or 3 minute, go in the first screen :)

Share this post


Link to post
Share on other sites
Miracle.

I try to use ideneb versiona and I install on my system (no problem root).

Now I have another problem.

AT Ideneb start I have to select language and keybord, after if I want trasfer data form another mac ecc...

after this last step (I select I don't want trasfert nothing), the system after 2 or 3 minute, go in the first screen :)

 

Enable Firewire on your bios and this should resolve the issue for you....

 

Let me know once done...........

Share this post


Link to post
Share on other sites

RoberT,

 

Excellent work with this tutorial!!

 

A question I have, and sorry if maybe it has already been asked, but I have a retail version of OSX. I'm not interested in having a dual boot or ever using XP or VISTA on this machine. Can I use the retail disk to install, instead of the "Mac OS X Leopard 10.5.4 9E25 Retail.dmg"?

 

system;

 

Asus P5Q PRO

Intel dual-core 3.0 GHz

4GB DDR2

SATA HD & DVD

EN8800GS

Share this post


Link to post
Share on other sites
RoberT,

 

Excellent work with this tutorial!!

 

A question I have, and sorry if maybe it has already been asked, but I have a retail version of OSX. I'm not interested in having a dual boot or ever using XP or VISTA on this machine. Can I use the retail disk to install, instead of the "Mac OS X Leopard 10.5.4 9E25 Retail.dmg"?

 

system;

 

Asus P5Q PRO

Intel dual-core 3.0 GHz

4GB DDR2

SATA HD & DVD

EN8800GS

 

Yes you can,

 

if you are installing using a Retail DVD then you should create the partition with GUID and then install MAC OS X Retail.

Share this post


Link to post
Share on other sites

Thanks RoberT_XeS

 

Firewire looks great and now I can boot my retail

Only problem, my keyboard is PS2 and I need USB keyboard.

Tomorrom I go to buy PS2->USB

 

After I work on driver.

 

1 question. In intallation of retail, I not select only my language but all language, I can delete someone for have more free space on my hd?

Can I delete Retail partition once Retail is installed?

Share this post


Link to post
Share on other sites
Thanks RoberT_XeS

 

Firewire looks great and now I can boot my retail

Only problem, my keyboard is PS2 and I need USB keyboard.

Tomorrom I go to buy PS2->USB

 

After I work on driver.

 

1 question. In intallation of retail, I not select only my language but all language, I can delete someone for have more free space on my hd?

Can I delete Retail partition once Retail is installed?

 

You can delete the partition in which you have restored your image now after the installation............

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×