Jump to content
RoberT_XeS

MAC OS X LEOPARD RETAIL ON ASUS P5Q / P5Q PRO / P5Q-EM AND OTHERS

Installed Mac OS X Retail Successfully  

736 members have voted

  1. 1. Were you able to install Mac OS X Retail Successfully

    • Yes
      559
    • No
      180

868 posts in this topic

Recommended Posts

Advertisement
Does win 7 works after flashing the Bios ??

 

Yes... works just fine ...

the modification in bios as i understood them are not majors ...

 

Here is what i found ...

They change some lines

Original BIOS Lines:

 

Scope (_PR)

{

Processor (P001, 0×01, 0×00000810, 0×06) {}

Alias (P001, CPU1)

Processor (P002, 0×02, 0×00000000, 0×00) {}

Alias (P002, CPU2)

Processor (P003, 0×03, 0×00000000, 0×00) {}

Alias (P003, CPU3)

Processor (P004, 0×04, 0×00000000, 0×00) {}

Alias (P004, CPU4)

}

 

Modified BIOS Lines:

 

Scope (_PR)

{

Processor (P001, 0×01, 0×00000810, 0×06) {}

Processor (P002, 0×02, 0×00000000, 0×00) {}

Processor (P003, 0×03, 0×00000000, 0×00) {}

Processor (P004, 0×04, 0×00000000, 0×00) {}

}

 

Share this post


Link to post
Share on other sites
Marvell kext for IDE HDD and DVD Drives: ASUS_P5Q_RX_MARVELL_IDE_DRIVER.zip Install this if you are not able to see the IDE Drive, otherwise no need to install this driver.

 

I don't know if this has been posted but using the above text did not work on 64 bit. i do a kextload and it yields the wrong arc error. so I used the drivers here: http://www.kexts.com/view/87-appleviaata_f...ow_leopard.html

 

You don't have reboot with -f option. Just use kexthelper or kext installer to install the driver. then log into shell as root and type:

 

kextload /System/Library/Extensions/AppleVIAATA.kext

 

you should not get an output and your IDE drive/DVD ROM is now recognized. again i tested this driver on a 64 bit system.

Share this post


Link to post
Share on other sites

 I want to install MAC OS X iDeneb 1.5.7 on a P5Q based board from asus (I have an asus V4-P5G45 barebone with a P5Q-EM-V-P5G45 board) but unfortunately I couldn't find any modified bios for that. Can someone please modify the latest bios (0405) for me or tell me how the bios can be modified. I look around but couldn't find any tutorial on modifying the bios. 

Share this post


Link to post
Share on other sites

 Hi Robert,

 

Just one question: why do I need patch BIOS? I looked through the thread but didn't find any explanation - just a recomendation apply patch.

 

 

Actually I have successfully installed SL 10.6.2 on my P5Q PRO TURBO with standard BIOS but I use chameleon installed on usb drive. OS installed without sound, net, video drivers - that's why I got into this thread. I hope drivers you recommended here will help.

Share this post


Link to post
Share on other sites

hello community,

 

i am totally new into this - worked with mac's at OSX 9.5x Times & before, just DL'ed the 2102 Bios MOD for my

P5Q Pro, System got a 1TB Samsung HD103SJ SATAII HDD, 4 GB Ram (A-Data PC2-800@CL 4-4-4-12) and a

Intel e8400 3 GHz DualCore C2D CPU. After many install attempts without a working system ([url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url], iDeneb, EmpireEFI)

is it just easy as that? could i boot the Retail OSX 10.6.3 SL DVD?

 

thanks for serious answers. :)

Share this post


Link to post
Share on other sites

My Hackintosh P5Q Pro Turbo is awesome. I love being able to get over on Apple/Steve Jobs simply because there charging way too much for there computers hardware. The OS itself has great price and Id be willing to spend a few hundred dollars more for Apples OS just to have it run perfectly on a PC.

Anyways, I have a minor issue that I don't understand how to fix. The problem is that Sometimes when I start up

I get a kernal panic as soon as I start to start up in Snow Leopard but I push reset and then everything loads as normal like a real Mac computer would do. So its weird because it does this at random and not every time. It usual happens

about 35% of he time and I can't find out what it might be because of this of behavior. Its not consistent so I don't know whats causing it. I don't want to have to go through kext by kext by kext to try and figure it out If there is an easy fix that somebody knows? Oh, also it never kernal panics or freezes once its been booted completely. I also have tested all my hardware/USB hardware too to make sure it wasn't caused from something plugged in to the computer. I have checked my BIOS but maybe I am forgetting something important there so maybe thats why there is the occasional kernal panic? But I don't know? My specs are below. Thanks for any feedback!

 

1. P5Q Pro Turbo

2. ATI 4670 1GB DDR3 "HIS"

3. Intel Q9550 Core 2 Quad

5. Hard drive and RAM Shouldn't be problem. But if it could be then please let me know.

 

 

 

 

 

 

 

P5QPL-AM MODDED BIOS FOR MAC URGENT

 

 

What the hell is this? So you need a sperate moded BIOS for your Asus MB because the P5Q BIOS doesn't work? If thats the case then look around because I am pretty sure its probably somewhere. I will go ahead and upload the Moded BIOS for P5Q PRO just in case you need it and can't find it for some reason.

I hope its all you need.

 

Go here for a faster response. http://www.insanelymac.com/forum/index.php?showtopic=213336

 

I just made the same mistake by posting here because I forgot about Robert changing the forum to a different more up to date forum that he checks regularly to answer anyones questions about the P5Q Pro and snow leopard.

P5Q_PRO_TURBO_0602_SLIC_MAC_SLI_shaumux.zip

P5Q_PRO_TURBO_0602_SLIC_MAC_SLI_shaumux.zip

Share this post


Link to post
Share on other sites

(RoberT_XeS @ Jan 7 2009, 05:45 PM) post_snapback.gifMan....Someone voted as No......

 

At least they should let us know the issue......right? blowup.gif

 

Before voting no... unsure.gif ...my issue resides in my bios i think. I'm using iDeneb and [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] on a P5Q (E3790? <-what it says on the instruction manual...).

 

I've tried "P5Q Asus 2208 by smith@@", but OS X either freezes at the apple boot screen with the loading wheel stopped, or before getting to the loading wheel, I get a dialog telling me to restart.

 

Any help?

Share this post


Link to post
Share on other sites

You can't boot a distro DVD with a boot CD!

Boot CDs are for booting the retail OS X install DVD. ideneb already has a bootloader on it.

 

Go back to the latest available unmodified ASUS BIOS and use a retail DVD plus one of these boot CDs:

http://www.insanelymac.com/forum/index.php?showtopic=234196

 

Someone voted as No......

At least they should let us know the issue......right?

A lot of people did, but you didn't bother to read the thread.

Share this post


Link to post
Share on other sites

great tutorial how did you solve the rpoblem with the shutdown etc? i already installed the [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] bootloader with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url] and it works fine but i cant shutdown the system the screen turns off but the hardware still working.... :)

Share this post


Link to post
Share on other sites

Hi,

 

I got the Asus P5QL Pro.

I want setup SnowLeopard (any Version > 10.6.3).

 

I got big issues to setup my bios. I downloaded

 

P5QL ASUS PRO1004_by smith@@.ROM.zip

 

before I had the one from Jazzy

 

Now I cant boot the system (my hack 10.6.1)

in verbose mode it tells me

 

vmnet: invalidating peer info for hub 0 port 2

vmnet: VnetUserIfFree: freeing UserIf at 0x72af300.

vmnet: netif-vmnet0: adding protocol 2.

 

 

 

 

I am not sure if the bios is setup right . Do I have to manually change settings in the bios after flashing the bios?

WHAT CAN I DO ?

 

Thanks

Mogio

Share this post


Link to post
Share on other sites

I know guys this is a very old thread but I still own a vanilla version of Asus P5Q with E7600 cpu and nvidia 460GTX... Is there a modded bios version 2009 with slic 2.1 and relevant DSDT to configure a mavericks installation? I found some modded bios files around but not sure how to use them.. also the links given are no longer available...

 

Please help me out.

BR,

f

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×