Jump to content
RoberT_XeS

MAC OS X LEOPARD RETAIL ON ASUS P5Q / P5Q PRO / P5Q-EM AND OTHERS

Installed Mac OS X Retail Successfully  

736 members have voted

  1. 1. Were you able to install Mac OS X Retail Successfully

    • Yes
      559
    • No
      180

868 posts in this topic

Recommended Posts

I tried to install SL Retail (GM version) on the configuration signature.

I have the boot stops AppleSMBusPCI start bringing failes to get acpi path for provider.

I used Chamaleon 2 RC1 with the Extra / Extensions The following kext:

AHCIPortInjector.kext

IOAHCIBlockStorageInjector.kext

ATAPortInjector.kext

NullCPUPowerManagement.kext

AppleIntelPIIXATA.kext

OpenHaltRestart.kext

AppleRTC.kext

PlatformUUID.kext

 

Please help

Share this post


Link to post
Share on other sites
Advertisement

Hey man; thanks to you and all others who have posted "how-to" guides specific to the P5Q series of boards. I can't wait to try it out on my P5Q-E!

Share this post


Link to post
Share on other sites

Now Shutdown work. What I did? here.....

 

Boot with -v mode and went to shutdown. So I found out why KP is occured because of the "AppleHDAController.kext". Then I searched a couple of websites and found that kext is located in AppleHDA.kext which I installed to get my audio work.

That one was giving me a problem so I deleted it as usual way and boot with -f again.

 

After that I reinstalled the original AppleHDA.kext using kext helper, reboot the system and boot with -f again.

 

I installed this two kexts (AD2000b.HDA.FIX.kext AND HDAEnabler.kext) to S/L/E folder using kext helper.

 

You can download those files here... To download (Thanks and Credits go to THe KiNG)

 

Then reboot and boot with -f as usual. Now I can manage to get shutdown work as well as audio. :)

Share this post


Link to post
Share on other sites
I tried to install SL Retail (GM version) on the configuration signature.

I have the boot stops AppleSMBusPCI start bringing failes to get acpi path for provider.

I used Chamaleon 2 RC1 with the Extra / Extensions The following kext:

AHCIPortInjector.kext

IOAHCIBlockStorageInjector.kext

ATAPortInjector.kext

NullCPUPowerManagement.kext

AppleIntelPIIXATA.kext

OpenHaltRestart.kext

AppleRTC.kext

PlatformUUID.kext

 

Please help

help ... help installing snow leopard on the P5Q-em ... what are the kext to be included in Extra / Extensions please ... thanks

Share this post


Link to post
Share on other sites

Hey guys I have been having issues installing iatkos v7 for the last couple of days... i am using brand new OOB parts for this project this are some of the hardware that i have...

 

ASUS P5Q

8 GB RAM

GeFORCE 9800 GT 512MB 256-bit GDDR3

Intel® Core™2 Quad Processor Q9400 2.66 GHz

 

I don't care to use windows at all so i dont need duo partition i just want OS X 10.5.7+.

 

first my disk wouldn't boot and when it did it gave me an "system config'/com.apple.boot.slist" error... so I flashed the system BIOS and updated with 2102 BIOS and it fixed that issue, so if anyone is having that problem try doing that... anyway I am using an IDE DVD ROM... i configured my BIOS to AHCI since I'm installing the software on a 1T SATA drive. I formated my drive to MAC OS EXTENDED JOURNALED.

 

so now under my custom install i'd tried different packages and is not working... i keep getting a Kernel Panic

 

i'd tried different bootloaders, i change my kernel and so on... I am looking for guidance if any one can help me with this it would be highly appreciate and simply awesome!!!

 

im about to give up on iatkos and try other distros... :\ feed back Please!

Share this post


Link to post
Share on other sites

YES !!!!! YES perfectly. Running now OSX 10.5.8, with XFX 9600GT 512Mb everything smooth.

 

like a real MAC..

 

i have to find out, how to upload to my ftp server.

 

i uploaded the picture

Only, one thing...my memory is in the bios on 1066, but the mac says 667 soo you know what it now realy is.

 

 

thank you very very much.

 

gr.

Appie

10.5.8.tiff

Share this post


Link to post
Share on other sites

Hi there!

 

Sorry to post such a lengthly "newb" question :rolleyes: ... but I'm a little afraid of breaking my (currently ;-) ) fine running Win7 installation. So I thought I'd better ask you pros around here what you would suggest.

 

First my hardware configuration:

- ASUS P5Q Pro

- Intel Quad Core Q9550 (not overclocked!)

- 8 GB RAM (unfortunately I don't know exactly which kind but the system is running extremely stable)

- NVIDIA GeForce 9600 GT 512MB

- USB Mouse & PS2 Keyboard :D

- LG DVD Burner SATA(!)

- 2x Seagate 1TB SATA HDDs

 

I already installed/flashed the newest P5Q Pro Bios (2102) from Juzzi! And I installed Win7 already with AHCI only, so I didn't have to switch to it now!

So I guess my hardware should be ok already?

 

My "problem" is the slightly unusual partition configuration:

 

1st 1TB SATA HDD:

[[[ 120MB NTFS boot/sys partition (active Win7 boot loader, ~90MB free) ]]] [[[ ~930GB NTFS data partition ]]]

 

2nd 1TB SATA HDD:

[[[ 100GB NTFS boot/sys partition (main Win7 system/software partition) ]]] [[[ ~830GB unpartitioned/free (want to put OSX somewhere here ;-) ) ]]]

 

So the first small (~120MB) NTFS partition on the first HDD boots up the main Win7 partition on the 2nd HDD.

So my big question is... what's the best way to make a permanent dual boot configuration with this partition layout?! (to be able to choose between Win7 and OS-X) .. or do I have to switch the hard drives first? Or shouldn't that be a problem at all?

Do I need Boot 132, Chameleon - or only on the HFS partition? Can I integrate OS-X into the Win7 boot manager (with EasyBCD)?

 

And could (should?) I try to directly install the newest OS-X... 10.6 .. Snow Leopard.. or would this be too problematic?

I still need to replace the OSInstall.mpkg, right? Will the replacement file from Juzzi that I downloaded here still work?

As I understood I only need a few drivers after I patched my BIOS... namely for onboard Audio and Lan (somebody recently uploaded a 64bit kext for the Attansic L1E which I guess is supposed to work with 10.6?!).

 

So I guess I would just follow the tutorial here but I'm not sure which kexts I have to select with the iDeneb install with my configuration.. and which boot loader I should install on which partition.. :-(

I'm afraid to make my Win7 unbootable (I know it should be "repairable" with the Win7 DVD... hopefully...)

 

I would be so happy for any tips or input you guys could give me!

 

Thanks for all the great work everyone put into this.. can't believe we even got a working LAN driver now! :)

 

Cheers

-Sören

Share this post


Link to post
Share on other sites

Hey Guys,

 

I got the following Problem:

 

I installed everything as explained and it worked. So I installed updates 10.5.6 to 10.5.8 (in steps!). After installing 10.5.7 i could not boot with "-v" - it shows an panic error. So i bootet up in safe mode ("-x -F") and it worked so i installed 10.5.8 and i still get this panic error.

 

 

Here are my system specs:

 

Asus P5Q-Pro

E8500

Geforce 8800GTX

Share this post


Link to post
Share on other sites

Hi guys,

 

still some questions and problems.

 

First.

 

1. I want to update to SL. My config P5Q Pro with 4870 1GB ... What have I to do ?

2. Still using Boot 132 with CD ... to get it to boot the 132 files from the disk ... :P Some help ?

3. Still dont cant use second Display port. Is tehre a trick for my 4870 ?!

 

4. Want to Build a second hackintosh with P5Q Board ... Which one can I take ? P5Q Pro VM ? Want to take a cheap board ... any suggestions ?

5. Same on Graphic Card ... Which one ? 4830 ? Geforce 9600 ? I need Dual Display !!!!

 

 

please give some help thx !

Share this post


Link to post
Share on other sites

Hey RoberT_XeS,

 

For when a tutorial on how to instal Snow Leopard on P5Q Family board like you did for the Leopard installation ?

 

I have successful instaled Leopard 10.5.4 on my P5Q-PRO, thanks to your tutorial, and i would love to update the Leopard to Snow Leopard.

 

so once again, when will we see a Snow Leopard tutorial for our P5Q boards ?

 

Thanks in advance man. ;)

Share this post


Link to post
Share on other sites
Hey RoberT_XeS,

 

For when a tutorial on how to instal Snow Leopard on P5Q Family board like you did for the Leopard installation ?

 

I have successful instaled Leopard 10.5.4 on my P5Q-PRO, thanks to your tutorial, and i would love to update the Leopard to Snow Leopard.

 

so once again, when will we see a Snow Leopard tutorial for our P5Q boards ?

 

Thanks in advance man. :whistle:

 

 

hey i am looking for a update too.. pleeeeease make one as soon as possible... thx :(^_^

Share this post


Link to post
Share on other sites
hey i am looking for a update too.. pleeeeease make one as soon as possible... thx :):(

 

My ASUS P5Q Motherboard is not working and I have to give it for a Replacement, also I am thinking about upgrading the motherbaord.......

 

I need to download Snow Leopard First........I have not yet figured out from where to download Snow Leopard..........

 

I will try to download Snow Leopard this week..............

 

Can you guys tell which one is the best and latest Asus Motherboard currently?

Share this post


Link to post
Share on other sites
My ASUS P5Q Motherboard is not working and I have to give it for a Replacement, also I am thinking about upgrading the motherbaord.......

 

I need to download Snow Leopard First........I have not yet figured out from where to download Snow Leopard..........

 

I will try to download Snow Leopard this week..............

 

Can you guys tell which one is the best and latest Asus Motherboard currently?

 

Hi, i have a P5Q Deluxe, it's the best!!

Share this post


Link to post
Share on other sites
I am thinking about going for ASUS P5QC which has support for both DDR2 and DDR3........What do you people think is the best P5Q Motherboard ?

 

I was precisely recommending you that board, just because it as support for DDR3

Share this post


Link to post
Share on other sites

Hey, RoberT_XeS, awesome guide! Thanks to the tutorial, I just finished installing the iDeneb! So far so good, I still have some steps left. I have a question: I'm stuck on Step 7 part 5, where it tells me to Restore the RETAIL IMAGE partition. I selected the mac dmg for source, but can't understand the next part (for destination) It says to drag n drop the RETIAL IMAGE drive, but when I try to do that, it doesn't work. :D

 

Also, something that I just noticed: I used GParted to make the partition, I named them MACOSX and RETAIL IMAGE. But in the disk utillity, they are named diskOS2 and diskOS3 (though was able to change the diskOS2 name to MACOSX during iDeneb installation)

Share this post


Link to post
Share on other sites

Hi, Robert

 

I'm glad we have peoples like you I install my Leopard on my machine maybe before 3 mounts and i have over 40days uptime.I make retail image and its very very stable and it's so fast Im from Bulgaria and our firm is the biggest client of apple we have over 50 macs and my machine its near MacPro.

MB:Asus p5ql-e SPEC

RAM: 2x2G /800MHz (sorry no DDR3 here)

Video:Gigabyte 8500GT 256MB

 

My new laptop HP mini 1151nr its too 10.5.8 with kernel from 10.5.7 (kernel 9.7.0 because sleep problems with 10.5.8) and its very fast I test it with our MacBook Pro and its better WTF ?!

 

I will wait to make some guide for Snow Leopard now I use 10.5.7 and I will clone my machine to another HDD and try to upgrade it to 10.6 but I work on that machine and need to have it all working.I watching for Asus support 10.6 but still waiting in fact as everybody know first release is full with bugs 10.6.2-3 will be more stable in production I wait to 10.x.4-5 or make all test I need

 

Greetings

Share this post


Link to post
Share on other sites

ohh yeah robert. a guide for 10.6 would be fine..

 

 

I cloned my System with carbon copy cloner. When I put in Snow Leo retail DVD It installs than it restart... but always goes again into 10.5.8 ...

 

Hmmm I dont know to upgrade ?!?!

Share this post


Link to post
Share on other sites

Hi guys i am in the process of installing a retail image on a P5Q PRO mobo.

I am stuck in the step of installing iAtkos. The installation finishes but i can't boot to the system.

It get's stuck in the apple logo screen with a stop sign on top of it. Any recommendations?

Share this post


Link to post
Share on other sites
Hi guys i am in the process of installing a retail image on a P5Q PRO mobo.

I am stuck in the step of installing iAtkos. The installation finishes but i can't boot to the system.

It get's stuck in the apple logo screen with a stop sign on top of it. Any recommendations?

 

Same here, it's getting annoying :/

Share this post


Link to post
Share on other sites
Same here, it's getting annoying :/

 

I think my method may help you see here you, the original build works well on many gigabyte models. I succesfully modded for P5KPL\1600 ASUS

Share this post


Link to post
Share on other sites

Ok i managed to pass this step using -x option on boot.

How can i figure out what is wrong and iDeneb doesn't boot in normal mode?

Share this post


Link to post
Share on other sites

I've been using a P5Q setup, with xp, win7 and osx.

I use step 11, method #3. I think that was the only one at that time (?!)

That means I have a tiny partition on my hd, with the bootmenu.

 

My problem is that sometimes (I don't know why) the bootpartition doesn't work. I have to make my xp partition active with a live-cd or gparted-cd, then boot xp and do the "syslinux.exe - d:", then make the bootpartition active again, and everything is ok.

 

How can I prevent that my bootpartition gets changed??

 

Or how can I do the "syslinux.exe"-part from a linux live-cd? Linux have such unfamiliar "directorynames.." / structure..

 

I hope someone will make a 10.5.x -> 10.6 update guide :)

 

As someone mentioned, cloning the hdd is probably a good idea to keep things running along. A lot of work making everything from scratch again.

What sw to use that handles both fat32, ntfs, and hfs+??

Share this post


Link to post
Share on other sites

Hi

 

I followed it through, but win rar says the asus p5q rar is corrupt, when I add the files to the usb bootable?

 

Still, I have a proper 10.5.7 retail disk.

 

So I installed ideneb, and then used the restore option from retail - with a patched OSInstall.

 

However, when I go to the RETAIL IMAGE it hangs on startup - with a spinning ball.

 

I have patched the bios, and firewire is inststalled. Ideneb runs fine.

 

What can I do from here?

 

I have tried -x -v but it goes through to the galaxy desktop.

 

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×