Jump to content
locoputo

Assassin's Creed - unofficial cider

92 posts in this topic

Recommended Posts

Alright, just had a quick messaround on it yesterday, its working fine, tested it on minimum graphics though. In gameplay, the fonts for changing controls (only in what control button its already set to) are NOT visible, but I'll give a go at fixing that.

Another problem is the screen sync, the screen constantly 'blends' between rgb and back. This will most probably also be due to the dlls and a few settings. Besides the rgb problem, there is a slight 'matrix' effect! Ok, it looks slightly cool, and disabling a few settings makes the game easier, but overall, the game IS playable. And I'll work on fixing the remaining problems over the next few days..

 

Attached you will find a text file with debug info that the game gives after starting a new game save (i.e. when the rgb problems are first seen)

 

 

If anybody has ideas on fixing these, any suggestions are welcome! ;)

Regards

assassin_s_creed_debug.txt

Share this post


Link to post
Share on other sites
Advertisement

This sounds very promising, hopefully you can work out the last few bugs. If this works out then Prince of Persia 4 should be a snap as it uses the same engine.

Share this post


Link to post
Share on other sites

Yeah, as far as I'm aware though, people with more experience than me have already tried to cider that (and failed). I think I will try that once a new cider version surfaces..

Share this post


Link to post
Share on other sites

Alright, final update regarding this I think. My attempts to improve the graphics and sound quality failed. The game is playable, but the sound loops back on itself (as it does in PoP:Two thrones) and graphics only work with all display options set to a minimum. Gameplay is fun, but some parts may need patience. I will probably upload in a few places for those caring to continue my work or those who are happy with it the way it is.

Share this post


Link to post
Share on other sites

Yes, game playable on cider 2060. (minimal settings)

maximum settings on nV8800GS

QWeTLS0q1B.jpg

 

But sounds loop.

if disable sounds in config file (set to 0) - no lags, but no sounds (ambient music work)

Share this post


Link to post
Share on other sites

If anybody wants to continue with my work, here is the cider wrapper:

http://www.megaupload.com/?d=C6RCXKQ4

 

The full game will be uploaded elsewhere (as I don't think wares are allowed in this forum are they?)

 

Regards

Share this post


Link to post
Share on other sites

From the Crossover Games Forum

 

While Codeweavers and the WINE project are great people and the software they develop is incredible the reason why Left 4 Dead doesn't work isn't there fault.

 

Most recently released games are using OpenGL, DirectX 9c or DirectX 10 to render games. The situation on compatibility goes as follows.

 

OpenGL= works great with Crossover on mac and linux

 

DirectX 9c= Crossover itself is completely compatible, works on Linux

 

DirectX 10= doesn't work at all, although it is in the works

 

Left 4 Dead uses DirectX 9c and the rendering called GLSL. Now only certain video cards work with GLSL in Crossover and WINE. These are Nvidia cards but only recently with updates to the video card drivers has this been possible for Crossover and WINE. Now all Linux computers with a Nvidia card should be able to run GLSL fine and run DirectX 9c. Now here's the problem. Apple has not updated the video cards drivers for Nvidia video cards. This creates the problem on Macs. When you enable GLSL in regedit (see Tips & Tricks section) this causes all DirectX rendering to be inefficient. It uses all the computer's processing power and causes the game to lag terribly.

 

Bottom line is that Apple needs to update their drivers.

 

Solutions

 

-For Linux users with ATI cards, if you can update to a nvidia card do so because gaming and Compiz-Fusion on Linux is much more efficient with Nvidia cards because ATI drivers are up to snuff. But Left 4 Dead even in Linux is a work in progress but should be fixed fast.

 

-Almost all new macs now use Nvidia cards but for those with ATI cards tough luck.

 

-If you have a Nvidia card and really need Left 4 Dead, download a Linux distro (I like Ubuntu) and install it on your mac. From there you can install the free open source project WINE which codeweavers uses for Crossover and they support strongly. Or you can purchase the Linux version of Crossover Games. But Left 4 Dead even in Linux is a work in progress but should be fixed faster because Codeweavers and the WINE project can solve these problems.

 

-If you're patient (or extremely stubborn like me) you can pressure Apple to update their Nvidia and ATI drivers to support GLSL. This choice is the true solution because no new game will work in Crossover Mac without this.

Share this post


Link to post
Share on other sites

FIRST RESULTS

 

I've mixed your wrapper with my pre-installed Assassin's Creed (pre-cracked (Russian) version) and launch it (I've to change path in info.plist to do it) on:

 

Intel iMac 2.4 GHz, ATI HD2600 256 MB, 4GB RAM, OS X 10.5.5

 

I've used your config settings first (1024x600 with all low video settings) - have a problem with graphics - some objects are not presented properly (missing or partly invisible) - and a problem with sound - echoing and looping sometimes (as it was already reported) - tried various DARE.INI settings but audio is still buggy.

 

Tested also at max 1920x1200 with all maximum video settings - very slow, really unplayable.

 

Have not tested it long - may be settings tweaking and wrapper file replacement will help, I'll see it later.

 

Thanks anyway.

 

P.S.

Both 'ShadersLevel' should be 3.0 - if 2.x you'll have a black screen.

Share this post


Link to post
Share on other sites

I've answered the same post of yours in C4M forums.

 

The black screen isn't a problem with the configuration about the shaderlevels. Modifying the dll's incorrectly will result in a black screen also.. Otherwise I would've been able to make the game even faster.

Share this post


Link to post
Share on other sites

It works! Reassembled the game (your wrapper + my cracked game) one more time and made necessary changes to accommodate it to my particular Mac - now the graphics is OK in most scenes, sound is still buggy but better then before (sometimes it is OK but become more buggy in action scenes and dialogs). The game is still a bit slow even on 1024x600 with all low video settings but more or less playable on:

 

Intel iMac 2.4 GHz, ATI HD2600 256 MB, 4GB RAM, OS X 10.5.6

Share this post


Link to post
Share on other sites

Test run and what a see how fix this?

 

xxxx:~ xxx$ /Users/xxxx/Desktop/Assassin\'s\ Creed/Assassin\'s\ Creed.app/Contents/MacOS/cider ; exit;

fixme:win32:PE_CreateModule Security directory ignored

Warning: Language 'en_UA' was not found, retrying without country name...

For language 'en' several language ids were found:

en_US - 0409; en_GB - 0809; en_AU - 0C09; en_CA - 1009; en_NZ - 1409; en_IE - 1809; en_ZA - 1C09; en_JM - 2009; en_ - 2409; en_BZ - 2809; en_TT - 2C09;

Instead of using first in the list, suggest to define

your LANG environment variable like this: LANG=en_US

fixme:profile:PROFILE_Open no encoding specified for L"/Users/xxxx/Library/Preferences/Assassin's Creed Preferences Preferences/win.in"... - defaulting to ASCII

wine: Unhandled exception, starting debugger...

fixme:module:SXS_AssemblyFromDoc unsupported node in assembly: description

fixme:module:SXS_AssemblyFromDoc unsupported node in assembly: ttrustInfo

fixme:ntdll:NtQuerySystemInformation (0x00000005,0x112418,0x00001000,0x0), mostly-stub!

fixme:dbghelp:dump_system_info fill in CPU vendorID and feature set

err:dbghelp:pe_load_debug_info loading debug information failed for module '"assassinscreed_dx9"'

err:dbghelp:pe_load_native_module could not open the executable image

err:dbghelp:pe_load_native_module could not open the executable image

err:dbghelp:pe_load_native_module could not open the executable image

err:seh:start_debugger Couldn't start debugger ("winedbg -- --auto 1 88") (998)

Read the Wine Developers Guide on how to set up winedbg or another debugger

logout

 

[Process completed]

Share this post


Link to post
Share on other sites

Hmm, I'm not sure what you've managed there, might be your nocd patch. Might be easiest for you to download my full game from C4M (thats nearly done uploading) or the cd patch ive used, which I will upload after the game is done.

Share this post


Link to post
Share on other sites

Here are some screenshots for Assassin's Creed (Cider) running now on my Intel iMac 2.4 GHz, ATI HD2600 256 MB, 4GB RAM, OS X 10.5.6 (1024x768 with all minimal graphics settings):

 

- original wrapper - severe graphics problems, very slow, buggy audio, not playable

 

- current state (screens are for whole first level) - system.reg replaced, recommended tweaks - graphics problems are solved, fast enough, audio mostly fixed, playable

 

- remaining graphics bugs (one map only)

 

http://www.megaupload.com/?d=1PS90WSQ

Share this post


Link to post
Share on other sites

I've tested the full (6 GB) version by devilfire and it seems that it have a bug on the first saved level (Memory Block 1, Solomon's Temple) - the intro scene with three assassins don't finish - third assassin should leave the view at the end of it - and so I can't proceed with the game further. Does anybody else have found the same result? In my Russian version (wrapper + my game) everything works OK in the same place.

 

I've also found that not all existing PC versions of Assassin Creed will work with devilfire's cracked application - my Russian version for example need another crack, it won't start with devilfire's. So if you can't launch your own assembled version it should be the case.

 

For now I have two different versions. Russian is February 2008, English is March 2008 - probably later build. Russian is about 5,6 GB, English is about 6,8 GB and difference is not only due to sound files. English has 4 levels of graphics quality in menu, Russian - 3 levels only and graphics quality for the same level 1 in English version is lower so it can run faster with all minimal graphics settings in the same resolution with better sound. Applications are different, data files are not compatible. Seems that there is a bug in English version - see above.

 

On my Mac

 

Intel iMac 2.4 GHz, ATI HD2600 256 MB, 4GB RAM, OS X 10.5.6

 

both game versions are playable (more or less) in 1024x768 with all minimal graphics settings.

Share this post


Link to post
Share on other sites
I've tested the full (6 GB) version by devilfire and it seems that it have a bug on the first saved level (Memory Block 1, Solomon's Temple) - the intro scene with three assassins don't finish - third assassin should leave the view at the end of it - and so I can't proceed with the game further. Does anybody else have found the same result? In my Russian version (wrapper + my game) everything works OK in the same place.

 

I've also found that not all existing PC versions of Assassin Creed will work with devilfire's cracked application - my Russian version for example need another crack, it won't start with devilfire's. So if you can't launch your own assembled version it should be the case.

 

For now I have two different versions. Russian is February 2008, English is March 2008 - probably later build. Russian is about 5,6 GB, English is about 6,8 GB and difference is not only due to sound files. English has 4 levels of graphics quality in menu, Russian - 3 levels only and graphics quality for the same level 1 in English version is lower so it can run faster with all minimal graphics settings in the same resolution with better sound. Applications are different, data files are not compatible. Seems that there is a bug in English version - see above.

 

On my Mac

 

Intel iMac 2.4 GHz, ATI HD2600 256 MB, 4GB RAM, OS X 10.5.6

 

both game versions are playable (more or less) in 1024x768 with all minimal graphics settings.

 

I'm looking for a different english iso as we speak. Thanks for the report.

Share this post


Link to post
Share on other sites

Could you all please post the current state files? As system.reg and etc? So we can test on new ciders.. .the City of Heroes latest version is 207x maybe it has some new implements... any news?

Share this post


Link to post
Share on other sites
Could you all please post the current state files? As system.reg and etc? So we can test on new ciders.. .the City of Heroes latest version is 207x maybe it has some new implements... any news?

 

I've managed to partition my drive (after lots of work on defrag etc etc etc) so now boot camps running well and as I no longer have a need for cider I'm not really working on improvements anymore, sorry! Maybe pluto999 is..

 

-loco

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×