Jump to content
Trauma!

PCEFI v9 Installer

50 posts in this topic

Recommended Posts

Advertisement

netkas said that PC_EFI v9 was Snow Leopard compatible, not sure if anyone has tested that. And by the way, afaik PC_EFI v9 is not the official Chameleon 1.0.12. The final release of the new Chameleon will have more features that the current PC_EFI v9

Share this post


Link to post
Share on other sites
netkas said that PC_EFI v9 was Snow Leopard compatible, not sure if anyone has tested that. And by the way, afaik PC_EFI v9 is not the official Chameleon 1.0.12. The final release of the new Chameleon will have more features that the current PC_EFI v9

 

I hope so, the next chameleon release will certainly be wonderfull !

 

About Snow Leo, i can tell you that PCEFI v9 is able to boot it !!! I've tested it my self with the snow leopard devlopers preview. :)

 

Bye.

Share this post


Link to post
Share on other sites

Yeah, but it seems to be problems with newest build of Snow Leo. (found at headline info #snowleopad irc).

But it doenst matter for me, i didnt use dev builds, i was only interested to try out and the V9 , which bootes up (at least safe mode) with last Snow build, it cant boot (at all) with newest build.

Lots of time for that bootloader dev teams to fix that -SL will arrive summer 2009, not now :rolleyes:

Share this post


Link to post
Share on other sites

do i need to install this efi? im just askin, and i will be compatabile to run it? im running 10.5.6 right now

end yeah, i cant dl on mediafire it says invalid file.

Share this post


Link to post
Share on other sites

Mediafire says

 

The key you provided for file download was invalid. This is usually caused because the file is no longer stored on Mediafire. This occurs when the file is removed by the originating user or Mediafire.

 

%(

Share this post


Link to post
Share on other sites

Hy all,

 

The original link steel working fine here ! Anyway i've added two new links to the file.

 

Good download.

Share this post


Link to post
Share on other sites

hi everyone.

Can it be used to install a real leopard dvd and not patched dvd's?

if yes, how?

thanks.

 

pardon me, I'm new to computer, and specially mac.

 

thanks again.

Share this post


Link to post
Share on other sites
Snow Leopard 10A222 don't work on it.....=((((10A190 Works!

Thanks. I was not sure if i made an mistake with V9 or i missed some special Snow Leo boot option.

Share this post


Link to post
Share on other sites

Having an odd issue with all of the EFI v9 / recent Chameleon installers. They work and boot wonderfully when used off of the DVD but I simply cant get them to install onto a hard drive have have the bootstrap load on boot without using the DVD and waiting for a time out. EFI v7 worked wonderfully and so did prior Chameleon installs. I always had to do it manually though in a terminal. Any idea why this would be or how to fix this?

Share this post


Link to post
Share on other sites
Having an odd issue with all of the EFI v9 / recent Chameleon installers. They work and boot wonderfully when used off of the DVD but I simply cant get them to install onto a hard drive have have the bootstrap load on boot without using the DVD and waiting for a time out. EFI v7 worked wonderfully and so did prior Chameleon installs. I always had to do it manually though in a terminal. Any idea why this would be or how to fix this?

 

Hy,

 

Make sure you don't have any spaces into the name of your partition. One user, with bad axe 2 mobo

has experienced the same problème!!! He was forced to to a manual installation.

 

 Suppose that your installation is on /dev/disk0s2

  - Install boot0 to the MBR:
  		fdisk -f boot0 -u -y /dev/rdisk0

  - Install boot1h to the partition's bootsector:
	  dd if=boot1h of=/dev/rdisk0s2

  - Install boot to the partition's root directory:
	  cp boot /

 No need to use startupfiletool anymore!

Share this post


Link to post
Share on other sites

Figured it out, apparently most installers and automated scripts don't realize that even if OS X detects it raw as disk0s2 it may physically be disk 0 partition first partition. Had to go into Fdisk and manualy set disk one partition one as active.

Share this post


Link to post
Share on other sites

hi trauma,

 

i have used pcwiz installer for pcefiv9.

is there a difference in extra functionality ?

 

if, i want yours and a hint how to install it , or does your installer erase the other stuff ?

Share this post


Link to post
Share on other sites
Hy,

 

They are using the same base : Kaly's Chameleon v1.0.11 Installer. The difference is that this one still provide the "Extra content" fonctionality !!!

The idea is providing a set of tools everyone can use to build there own retail patch or UOI plugin.

 

Cheers.

 

 

Same question than on page one ! So that's the same answer ! No need for you to reinstall PCEFI v9 then ....

 

No differences with the use of Extra, the only things is that you can put /Extensions and Extensions.mkext in "Extra Contents" and the installer will do the rest...

 

Bye.

Share this post


Link to post
Share on other sites

having a problem with this installer.....i installed it successfully when rebooted it said

 

boot 0: MBR

boot 0: done

boot 1: error

 

can't boot without DVD now.... can u plzz help me

Share this post


Link to post
Share on other sites
having a problem with this installer.....i installed it successfully when rebooted it said

 

boot 0: MBR

boot 0: done

boot 1: error

 

can't boot without DVD now.... can u plzz help me

 

Try to reistall a second time, if it's fail try this :

 

Suppose that your installation is on /dev/disk0s2

 

- Install boot0 to the MBR:

fdisk -f boot0 -u -y /dev/rdisk0

 

- Install boot1h to the partition's bootsector:

dd if=boot1h of=/dev/rdisk0s2

 

- Install boot to the partition's root directory:

cp boot /

 

No need to use startupfiletool anymore!

 

Goodluck !

Share this post


Link to post
Share on other sites

after using this tool I cannot find my com.apple.boot.plist file. If I mash f8 as its booting I can still get to the partition selection menu, choose the proper partition, and boot.

 

Is there a simple way to fix this?

 

Currently my solution is just to use the XXX distro that has pcefi 9 already, and it works great - but it'd be nice to have a good "post installation method" that worked smoothly.

Share this post


Link to post
Share on other sites

Q:

Does anyone know whats the "-nowake" boot flag is for ?

Since i use PCEFI 9 i have problem with sleep.

Sleep works but at wakeup: rebooting

I use S3 (suspend to ram), (pmset) hibernate mode = 0, no sleepimage

Share this post


Link to post
Share on other sites
Q:

Does anyone know whats the "-nowake" boot flag is for ?

Since i use PCEFI 9 i have problem with sleep.

Sleep works but at wakeup: rebooting

I use S3 (suspend to ram), (pmset) hibernate mode = 0, no sleepimage

You can boot normally (bypassing wake), when your sleepimage is corrupted or something else goes wrong

Share this post


Link to post
Share on other sites
You can boot normally (bypassing wake), when your sleepimage is corrupted or something else goes wrong

 

Thanks. I will try that.

Perhaps PCEFI V9 make an deeper sleep (hibermode =1) which saves status in RAM and also in an sleepimage.

My bios maybe not make the sleepimage possible and wakeup end in an reboot because no sleepimage found ?

Share this post


Link to post
Share on other sites

Hi Trauma!,

 

I got my 10.5.5 working right now, I having simple and success upgrade from 10.5.2 to 10.5.6, wanted to upgrade to 10.5.6, and it would required EFI V8 and above, I do not install any EFI before, is it safe for me to install with my current system configuration, and most important, will it had anything to do with my Vista? Just afraid of getting crash or something.

 

Thanks ;)

 

EDIT: Thanks for the tools, it works like a charm for newbie like me! Had my 10.5.6 Combo update without a sweat.

Share this post


Link to post
Share on other sites
having a problem with this installer.....i installed it successfully when rebooted it said

 

boot 0: MBR

boot 0: done

boot 1: error

 

can't boot without DVD now.... can u plzz help me

I have a look like problem...

When the installation finishes, it restart the computer...

Then, boot into the DVD again...

After it enters automatically in a blank screen with an apple in the middle and cursor below with a no sign above the apple, and don't scape from that. It stops there...

Then, I decided to boot without the DVD, and it boots into the hard drive and appear the same three lines.

Finally, it won't boot with DVD and won't boot into hard drive. What could be?

Share this post


Link to post
Share on other sites
Try to reistall a second time, if it's fail try this :

 

Suppose that your installation is on /dev/disk0s2

 

- Install boot0 to the MBR:

fdisk -f boot0 -u -y /dev/rdisk0

 

- Install boot1h to the partition's bootsector:

dd if=boot1h of=/dev/rdisk0s2

 

- Install boot to the partition's root directory:

cp boot /

 

No need to use startupfiletool anymore!

 

Goodluck !

After that, the same error is still occuring...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×