Jump to content
mercurysquad

[How to] Intel GMA 900 done right: full QE/CI for leopard

117 posts in this topic

Recommended Posts

Some one could get working on resolutions greater than 1024x768 with a GMA915???

I'll expect to get 1280 at least!!!!

 

Thanks a lot for your help!!!

 

Regards

Share this post


Link to post
Share on other sites
Advertisement
Any idea on this working with Snow Leopard?

 

Works for me on Snow Leopard. Just install the ElliottAppleIntelGMA950LegacyEnabler.kext into /S/L/E, repair permissions and rebuild the kext cache - reboot and all is well! Just make sure you're using the stock SL framebuffer kext - the one in the first post didn't work for me.

 

Only problem I have so far (very limited testing) is that the Arabesque and RSS Visualizer screensavers cause an instant reboot when going full-screen. They appear fine in the tiny preview window, but hit the Preview button and bye-bye system. Flurry works perfectly though, and the desktop speed is nicely boosted.

 

Oh, and GMA900 / GMA915 doesn't appear in System Profiler any more - it just says "Type: GPU", no chipset model info.

 

Just make sure you're using the stock SL framebuffer kext - the one in the first post didn't work for me.

 

I am telling lies. I must have messed up installing the framebuffer kext. Just tried again and it is PERFECT under Snow Leopard. Arabesque works, correct info in System Profiler - even the screen is detected correctly. Excellent! ;)

 

Now I could just do with adding it to /Extra instead of in /S/L/E. Not sure on the dependencies, though.

Share this post


Link to post
Share on other sites
Now I could just do with adding it to /Extra instead of in /S/L/E. Not sure on the dependencies, though.

 

And one last update - the only additional dependency that needs to be satisfied is IOGraphicsFamily.kext. Drop the vanilla version you have in /S/L/E into your /Extras/CustomExtensions (or your equivalent) along with AppleIntelIntegratedFramebuffer.kext and ElliottAppleIntelGMA950LegacyEnabler.kext - repair permissions, rebuild the kext cache and reboot. And smile. :wacko:

 

I'd read so many threads saying GMA900 / 915 was impossible (or too much work) to support on OS X - this solution works perfectly even for Snow Leopard. Top stuff!

Share this post


Link to post
Share on other sites

This thread really should be sticky wonder how much valuable info gets burried in these old threads. Man for me to find this one we´re talking a few hours (read days) on the search.

Share this post


Link to post
Share on other sites

Funny, I couldn't get this to work after working on it for hours. I could change the resolution, but still had no QE/CI. I decided to do the Mac Upgrade to 10.6.1 and work on the video later.

 

After the Mac software update, I magically have QE/CI. LOL!

 

Thanks Apple!! :)

Share this post


Link to post
Share on other sites

I am on GMA900 but still getting some superficial corruption of the graphics... ie: the menu bar is shifted, blocky.

 

Does anyone know if the Dell Mini GMA950 10.6 mods use this method or they use the vanilla method?

Share this post


Link to post
Share on other sites

It doesn't want to work for me in 10.5.8 (iDeneb), it worked with 10.5.6 (iPC). How come some people can make it work in Snow Leopard but it doesn't work in 10.5.8? Anybody got the gma900 working in that version?

 

I'm using a D915GUX motherboard.

Share this post


Link to post
Share on other sites

Hi guys!

 

i am in desperate need of help...s

 

i have tried install IAKTOS DVD but that didnt start, and then i installd Kalyway, and im in. but....

 

I have tried to get my ethernet/airport connetion, network card to work.

 

and my graphic card too.. now i only have lika 50% of screen no widescreen. 1024x768 i think.

 

i downloaded some kext and kexthelper but it didnt work.. so what do i do? i am new at this and dont know so much about it, please help my, i have search a lot of time on forums but i dont get it, my spec is below.

 

Sony Vaio VGN-TZ21XN

 

Mobile intel 945 express chipset graphics card

 

Marvll Yukon 88E8055 PCI-E ethernet

 

Intel pro/wireless 3945ABG

 

Thanks !

 

 

 

Hey Guys,

 

I installed IDeneb 1.3 (10.5.5) on my m55-s3293 laptop with the following specs:

 

http://www.clearanceclub.com/depot/quelle_...om.cgi?sku=4935

 

the laptop has an intel 900 display, but after I installed the kexts you provided, I don't get support for Quartz Extreme nor Core Image. I am able to change resolutions though so I don't know what I did wrong.

 

attached is a screenshot of system profiler of the Graphics driver as well as another screenshot of the extentions folders showing the kext files I have installed.

 

Thanks in advance guys!

 

(By the way, it took me a while to get to this point, so if anyone needs help installing iDeneb 1.3 on a similar system, let me know. I will be happy to help)

 

 

Hi guys!

 

i am in desperate need of help...s

 

i have tried install IAKTOS DVD but that didnt start, and then i installd Kalyway, and im in. but....

 

I have tried to get my ethernet/airport connetion, network card to work.

 

and my graphic card too.. now i only have lika 50% of screen no widescreen. 1024x768 i think.

 

i downloaded some kext and kexthelper but it didnt work.. so what do i do? i am new at this and dont know so much about it, please help my, i have search a lot of time on forums but i dont get it, my spec is below.

 

Sony Vaio VGN-TZ21XN

 

Mobile intel 945 express chipset graphics card

 

Marvll Yukon 88E8055 PCI-E ethernet

 

Intel pro/wireless 3945ABG

 

Thanks !

Share this post


Link to post
Share on other sites
And one last update - the only additional dependency that needs to be satisfied is IOGraphicsFamily.kext. Drop the vanilla version you have in /S/L/E into your /Extras/CustomExtensions (or your equivalent) along with AppleIntelIntegratedFramebuffer.kext and ElliottAppleIntelGMA950LegacyEnabler.kext - repair permissions, rebuild the kext cache and reboot. And smile. :P

 

I'd read so many threads saying GMA900 / 915 was impossible (or too much work) to support on OS X - this solution works perfectly even for Snow Leopard. Top stuff!

 

Works fine on my acer aspire 3620 in Snow Leopard 10.6.2. I do get minor artifacts though. Not mouse artifacts but here and there on the screen. Thank for the kexts! ps if someone knows how to get rid of the artifacts let me know :)

Share this post


Link to post
Share on other sites
It doesn't want to work for me in 10.5.8 (iDeneb), it worked with 10.5.6 (iPC). How come some people can make it work in Snow Leopard but it doesn't work in 10.5.8? Anybody got the gma900 working in that version?

 

I'm using a D915GUX motherboard.

 

10.5.8 is no problem. just update, and then start the computer with the ipc dvd again and only! choose gma900 drivers from the customize list. it will overwrite the framebuffer kext and reinstall the elliotenabler kext. and except for artifacts, all will be well again :)

 

i'm amazed that no fix has been found so far for the mouse artifact problem though.

Share this post


Link to post
Share on other sites
Works fine on my acer aspire 3620 in Snow Leopard 10.6.2. I do get minor artifacts though. Not mouse artifacts but here and there on the screen. Thank for the kexts! ps if someone knows how to get rid of the artifacts let me know :D

 

So you don't have any other problems (with the non-64bit/non-sse3 cpu) like Safari beachballing andhigh cpu usage in your apps?

Share this post


Link to post
Share on other sites
So you don't have any other problems (with the non-64bit/non-sse3 cpu) like Safari beachballing andhigh cpu usage in your apps?

 

 

Actually yes I did have that problem. Bought extra ram but that did not help. So I'm back to 10.5.8 which runs just fine...

Share this post


Link to post
Share on other sites
Look really interesting, however I just fried my main laptop's gpu. So I dare not try to overclock it without more success stories.

 

What GPU was that? Nvidia or Intel?

Share this post


Link to post
Share on other sites
What is it? This is an enabler kext which gives your Intel GMA900 (i915) graphic card hardware acceleration (QE/CI) support under Leopard. This is not a patched or modified kext. It is supposed to be used in addition to the GMA950 kexts that come with leopard.

 

Details: There are a lot of patched kexts floating around for GMA900 support in Leopard. dfe aka David Elliott has made a great enabler kext which allows GMA900 cards to use stock GMA950 kexts. This means NO patching or hacking is required and you can keep using Apple software updates and take advantage of updated graphic kexts.

 

How to use -

 

Install these two kexts. Reboot. That's all.

 

This works for all GMA900 device IDs (0x2582, 0x2592, 0x2792)

 

 

Notes

  • You must have all stock kexts. If you are using patched kexts currently, please revert all AppleIntelGMA* to the ones that came with your version of Leopard.
  • The framebuffer is old. Some people may be able to use stock framebuffer too, but most often you will need this older framebuffer kext.
  • Resolution changing and mouse artifacts are related to framebuffer. So if you are trying to fix those, the framebuffer kext is what you want to experiment with first, followed by original GMA950 kexts.
  • Please no OpenGL.framework hacking either. Everything should be original Leopard version.

I have not made these kexts, the work is dfe's, I am only bringing it to the OSx86 community and therefore cannot offer any support except maybe adding any new device IDs

 

 

After installing iAtkos 10.5.5, i added these two files and it fixed my issue not able to change resolution but it is not detecting my 2nd display i have connected.

 

I have core image - hardware accelerated

 

i have q/e - supported

 

Display status - no display connected/attached but it is.. it is connected to a JVC television.

 

I know the display works with my windows and when i bring up the install disk, it displays on both my lcd and tv.

 

Any ideas of what i am doing wrong?

 

My specs are:

 

Dell Inspiron 6000; Intel 915gm video card, Broadcom Network

 

Installation consisted of:

 

iATKOS v5i Main System

->Bootloader

--> PC EFI V9

->X86 Patches

--> Decrypters

---> AppleDecrypt

--> SMBIOS driver

---> SMBIOS Enablers

----> SMBIOS - EFI Air

---> SMBIOS for X86

----> AppleSMBIOS-27 6th rev. MacBook

--> Kernel

---> 9.5.0 kernal voodoo

--> ACPI

---> APIC driver

--> Disabler.kext

--> OHR

--> Remove Thermal kexts-> Drivers

--> VGA

---> Graphics Update

---> Intel

----> GMA950

-----> GMA950 b

--> System

---> SATA/IDE

----> Intel SATA

----> Intel AHCI SATA

--> Speedstep

---> Intel Speedstep b

---> Laptop Battery

---> NTFS-3G

--> Network

---> Broadcom 440x

* Done

* Install

 

Thanks for any help you can provide

 

LIZ

Share this post


Link to post
Share on other sites

Hi,

I also have Snow Leopard running on Intel GMA900. It's working well but there is something that I consider as a problem and that is Time Machine. I can backup with time machine but I can't enter the time machine. You know all the Graphics and the Space like interface with lots of finder windows, I can't enter the time machine. I had reinstalled Snow Leopard many times because of the graphics card driver (testing Kexts). Now I am tired of reinstalling OS X again. That's why, I wanted to know if any of you all had access to enter time machine after installing the kexts on Snow Leopard or not.

Share this post


Link to post
Share on other sites
What is it? This is an enabler kext which gives your Intel GMA900 (i915) graphic card hardware acceleration (QE/CI) support under Leopard. This is not a patched or modified kext. It is supposed to be used in addition to the GMA950 kexts that come with leopard.

 

Details: There are a lot of patched kexts floating around for GMA900 support in Leopard. dfe aka David Elliott has made a great enabler kext which allows GMA900 cards to use stock GMA950 kexts. This means NO patching or hacking is required and you can keep using Apple software updates and take advantage of updated graphic kexts.

 

How to use -

 

Install these two kexts. Reboot. That's all.

 

This works for all GMA900 device IDs (0x2582, 0x2592, 0x2792)

 

 

Notes

  • You must have all stock kexts. If you are using patched kexts currently, please revert all AppleIntelGMA* to the ones that came with your version of Leopard.
  • The framebuffer is old. Some people may be able to use stock framebuffer too, but most often you will need this older framebuffer kext.
  • Resolution changing and mouse artifacts are related to framebuffer. So if you are trying to fix those, the framebuffer kext is what you want to experiment with first, followed by original GMA950 kexts.
  • Please no OpenGL.framework hacking either. Everything should be original Leopard version.

I have not made these kexts, the work is dfe's, I am only bringing it to the OSx86 community and therefore cannot offer any support except maybe adding any new device IDs

Share this post


Link to post
Share on other sites

I think this will solve an issue I'm having with my Dell Dimension 3100. I just installed Hazard's 10.6.2 build, but when I try to boot, I get pages and pages of scrolling text, followed by a blank, black screen.

 

Is this the solution I'm looking for? How do I install a kext? Thanks!

 

What is it? This is an enabler kext which gives your Intel GMA900 (i915) graphic card hardware acceleration (QE/CI) support under Leopard. This is not a patched or modified kext. It is supposed to be used in addition to the GMA950 kexts that come with leopard.

 

Details: There are a lot of patched kexts floating around for GMA900 support in Leopard. dfe aka David Elliott has made a great enabler kext which allows GMA900 cards to use stock GMA950 kexts. This means NO patching or hacking is required and you can keep using Apple software updates and take advantage of updated graphic kexts.

 

How to use -

 

Install these two kexts. Reboot. That's all.

 

This works for all GMA900 device IDs (0x2582, 0x2592, 0x2792)

 

 

Notes

  • You must have all stock kexts. If you are using patched kexts currently, please revert all AppleIntelGMA* to the ones that came with your version of Leopard.
  • The framebuffer is old. Some people may be able to use stock framebuffer too, but most often you will need this older framebuffer kext.
  • Resolution changing and mouse artifacts are related to framebuffer. So if you are trying to fix those, the framebuffer kext is what you want to experiment with first, followed by original GMA950 kexts.
  • Please no OpenGL.framework hacking either. Everything should be original Leopard version.

I have not made these kexts, the work is dfe's, I am only bringing it to the OSx86 community and therefore cannot offer any support except maybe adding any new device IDs

Share this post


Link to post
Share on other sites

anyone have issues with no resolutions matching your laptop display using these drivers? mine is 1280x800 and the highest resolution I can get is 1024x768

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×