Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
VCH888

ALC889A, Gigabyte (Intel): now having a working front mic

1,157 posts in this topic

Recommended Posts

Thanks for work!!! I'm using 1.5.7a24 4outs3ins analog regular kext: sound is perfect and clear but i have this error in console

 

24/01/09 05:53:59 kernel Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

 

I've read errors.pdf but I haven't found this one... How can I fix it? Thank in advance

 

P.s I can't use modded AppleSMBIOS because I use original one with AppleSMBIOSEFI.kext

Share this post


Link to post
Share on other sites
Thanks for work!!! I'm using 1.5.7a24 4outs3ins analog regular kext: sound is perfect and clear but i have this error in console

 

24/01/09 05:53:59 kernel Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

 

I've read errors.pdf but I haven't found this one... How can I fix it? Thank in advance

 

P.s I can't use modded AppleSMBIOS because I use original one with AppleSMBIOSEFI.kext

 

Same error with 1.6.2.a37 3outs3ins regular kext at boot and when I listen music. Sound is perfect and clear.

Share this post


Link to post
Share on other sites
Same error with 1.6.2.a37 3outs3ins regular kext at boot and when I listen music. Sound is perfect and clear.

 

Thank for your reply. I will test all regular kexts and find out what is wrong tonight.

Share this post


Link to post
Share on other sites

I tried your Lagacy 4+3 analog HD headphone and it worked nicely! Now to figure out which combo I really need.

 

Thanks tmongkol!

Share this post


Link to post
Share on other sites

I Tried your new Lagacy_4outs3ins_analog_HDA_headphone.

Sound work!

Thanks!

 

But I have one error.

Sound assertion "0 == fMikeyDriver" failed in

"/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDADriver.cpp" at line 1063 goto handler

Read errors.pdf,can't fix this error.

Share this post


Link to post
Share on other sites
I just uploaded AppleHDA.kext(s). So, you can choose which one is the best for you. Don't forget to read "readme.pdf."

Hi tmongkol, I have an issue with the Digital Out.

 

If I use the 1.5.7a24 AppleHDA for 888 from post #12 I could have 5.1 on the digital (Encoded Digital Audio option apears on Audio MiDi setup).

 

But if I use Legacy HDA with 1.6.2a37 vanilla kext the Digital Out can handle only stereo output (Encoded Digital Audio option doesn't apear on Audio MiDi setup).

Even if I copy the values from the 1.5.7a24 kext to the legacy kext that option still wont appear. So do you have an idea where could be the difference to make the 5.1 out available?

Share this post


Link to post
Share on other sites
Thank for your reply. I will test all regular kexts and find out what is wrong tonight.

Thank you too for your work! Your contribute is important for most users!

Share this post


Link to post
Share on other sites
Thanks for work!!! I'm using 1.5.7a24 4outs3ins analog regular kext: sound is perfect and clear but i have this error in console

 

24/01/09 05:53:59 kernel Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

 

I've read errors.pdf but I haven't found this one... How can I fix it? Thank in advance

 

P.s I can't use modded AppleSMBIOS because I use original one with AppleSMBIOSEFI.kext

 

@Rik26

 

First, I thought it's maybe about my CodeVerbs and front audio kit. I removed front audio kit (not support HDA) from a cheap case, and I connected it to EP35-DS3P. I tested many kexts without issues. Finally, I built Extensions.mkext, including AppleSMBIOSEFI.kext, and tested some of my edited kexts. I found the problem as followings:

 

1.6.2a37 3+3 digital regular + AppleSMBIOSEFI.kext

 

kernel[0]: Sound assertion "0 == fMikeyDriver" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDADriver.cpp" at line 1063 goto handler

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDAEngine.cpp" at line 2645 goto Exit

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDAEngine.cpp" at line 2645 goto Exit

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDAEngine.cpp" at line 2645 goto Exit

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDAEngine.cpp" at line 2678 goto Exit

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDAEngine.cpp" at line 2645 goto Exit

.

.

.

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-162.1.37/AppleHDA/AppleHDAEngine.cpp" at line 2678 goto Exit

 

 

------------

1.5.7a24 4+3 analog regular + AppleSMBIOSEFI.kext

 

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2363 goto Exit

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2363 goto Exit

.

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2363 goto Exit

.

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2363 goto Exit

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

 

 

 

------------

1.5.7a24 3+3 digital HDA + AppleSMBIOSEFI.kext

 

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2363 goto Exit

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

.

.

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2363 goto Exit

.

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2363 goto Exit

.

.

kernel[0]: Sound assertion "0 == entry" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDAEngine.cpp" at line 2396 goto Exit

 

To solve the issue is to use SMBIOSResolver.kext or latest modded AppleSMBIOS.kext instead of AppleSMBIOSEFI.kext. However, if you are using SMBIOSResolver.kext and listening to music, you will hear unlike popup sound at the beginning.

 

Note:

 

While I am typing this reply and listening to music, my regular front kit is still connected to MOBO. I will test AppleSMBIOSEFI.kext and HDA front audio kit. ---> tested and got the same issues.

 

If you didn't tell me that you want to use AppleSMBIOSEFI.kext, I might not find out what cause is.

Share this post


Link to post
Share on other sites
Hi tmongkol, I have an issue with the Digital Out.

 

If I use the 1.5.7a24 AppleHDA for 888 from post #12 I could have 5.1 on the digital (Encoded Digital Audio option apears on Audio MiDi setup).

 

But if I use Legacy HDA with 1.6.2a37 vanilla kext the Digital Out can handle only stereo output (Encoded Digital Audio option doesn't apear on Audio MiDi setup).

Even if I copy the values from the 1.5.7a24 kext to the legacy kext that option still wont appear. So do you have an idea where could be the difference to make the 5.1 out available?

 

@macgirl

 

I am studying your case. Can you tell me what legacy you are using? Did you try to use stickpin's legacy for 888? I will try to fine out although I don't have MOBO w/ALC888. Also, can you submit your edited legacy?

 

From my experience, I could not get optical output (red light is off.), unless I have to use the latest modded AppleSMBIOS.kext. I will test my coaxial output tomorrow because I have to move my receiver close to PC.

 

While I am using Boot-132 w/SMBIOSResolver.kext (red light's optical output's off.), I can select Digital Output for setting Aggregate Devices.

Share this post


Link to post
Share on other sites
@Rik26

 

First, I thought it's maybe about my CodeVerbs and front audio kit. I removed front audio kit (not support HDA) from a cheap case, and I connected it to EP35-DS3P. I tested many kexts without issues. Finally, I built Extensions.mkext, including AppleSMBIOSEFI.kext, and tested some of my edited kexts. I found the problem as followings:

To solve the issue is to use SMBIOSResolver.kext or latest modded AppleSMBIOS.kext instead of AppleSMBIOSEFI.kext. However, if you are using SMBIOSResolver.kext and listening to music, you will hear unlike popup sound at the beginning.

 

Note:

 

While I am typing this reply and listening to music, my regular front kit is still connected to MOBO. I will test AppleSMBIOSEFI.kext and HDA front audio kit. ---> tested and got the same issues.

 

If you didn't tell me that you want to use AppleSMBIOSEFI.kext, I might not find out what cause is.

I removed AppleSMBIOSEFI.kext and I tried to use karaakeha1's patched AppleSMBIOS.kext. Now I've only 1 fMikey error in console as you wrote in readme. Thanks a lot

Share this post


Link to post
Share on other sites

1.6.2a37_3outs3ins_digital_HDA_headphone.zip works perfectly with GA-EP45-DQ6.

 

Thank you!

Share this post


Link to post
Share on other sites
.

.

EDIT:

I use AppleSMBIOSEFI but also tested with SMBIOSResolver (same thing).

 

 

@macgirl

 

I got legacy for 888 from stickpin's thread. I just copied CodecVerbs from your edited legacy and added OSBundleRequired key to stickpin's legacy. I don't know what your MOBO is.

 

Picture of hdaenabler in a zip file;

You will see data of PinConfigurations, but not for 885/889. I don't know about this.

layout-id is "x." It's <7803000>. Dec of 888 ---> Hex of 0x378.

 

Picture of controller in a zip file;

See PreservePinConfigurations, your edited legacy does not have it.

 

For my 889/885, I could enter some CodecVerbs (about 6 or 7) with having PreservePinConfigurations to get it works the same one which has all CodecVerbs of ConfigData. But, it would not show devices in System Profiler.

 

Your edited legacy;

Controller: LayoutID is 888.

Platform: LayoutID is 12.

In this issue, AppleHDA.kext should not be loaded. I was confused how you got as you posted.

 

deleted

 

Don't forget to install vanilla AppleHDA.kext to S/L/E. It can be 1.5.7a24 or 1.6.2a37.

 

 

 

I've been editing stickpin's legacy for 883 to work on my GA-945GCM-S2L (ALC662). Now, outputs (internal speaker, Line Out at blue, headphone, and digital) are working, but I need to solve the problem of input. I got name of internal & external microphones. I tested both AppleHDA.kext 1.5.7a24 and 1.6.2a37.

Also, I have the same problem of digital (got only 2ch) for 945GCM. If I can fix this problem, I will tell you.

Share this post


Link to post
Share on other sites
I have the same problem of digital (got only 2ch) for 945GCM. If I can fix this problem, I will tell you.

 

On my GA EP45T DS3 ALC889a I also get only 2 chanels out of the digital ( I haven't tested but in the Aggregate Device editor it shows only 2 ch out under digital out)

 

Is that normal ?

 

I know some people on this forum use only the digital out to get their logitech digital 5.1 speakers working..

 

does it show more channels out if we plug a digital 5.1 speaker system?

Share this post


Link to post
Share on other sites
On my GA EP45T DS3 ALC889a I also get only 2 chanels out of the digital ( I haven't tested but in the Aggregate Device editor it shows only 2 ch out under digital out)

 

Is that normal ?

 

I know some people on this forum use only the digital out to get their logitech digital 5.1 speakers working..

 

does it show more channels out if we plug a digital 5.1 speaker system?

 

@indraganzo

 

Q: Is that normal ?

A: Yes, in Aggregate Device editor, it shows only 2 ch.

 

post-93383-1233244283_thumb.jpg

 

However, your system can or cannot send the signal of encoded digital audio, you have to check as picture below. If "Encoded Digital Audio" does not show, it means your receiver will get only 2 ch. For now I know if using legacy method for such ALC888 & ALC662, it will get only 2 ch through Digital Out. Otherwise, ALC888 & ALC662 will get "Encoded Digital Audio", it got to use a working patched AppleHDA.kext.

 

post-93383-1233244154_thumb.jpg

 

Q: does it show more channels out if we plug a digital 5.1 speaker system?

A: No.

Share this post


Link to post
Share on other sites

Not working in iDeneb 10.5.5 upgraded to 10.5.6, nor in iPC 10.5.6. I'm using a gigabyte P35-DS3 with ALC889A.

I tried almost all drivers. It does show a volume manager and sound preferences all work after installing the driver, but it just gives no sound. It does work in a plain iDeneb 10.5.5 (and installed drivers from DVD)...

edit: After trying 10 drivers I found out I had to enable the Internal Speakers in the Sound Preferences under Output :/ I feel so stupid now lol. Thanks for the great drivers.

Share this post


Link to post
Share on other sites
After trying 10 drivers I found out I had to enable the Internal Speakers in the Sound Preferences under Output :/ I feel so stupid now lol. Thanks for the great drivers.

 

Whoa - thanks man... you just made my day! Thought I'd be too stupid for this, too...

But seriously... "internal speaker"? Who would've thought that...?

 

Thanks and greetings,

Daniel

Share this post


Link to post
Share on other sites

Do you think that these AppleHDA kexts will work for ALC861... Because I'm having cracked sound on startup and when running on battery

 

Thanks for your help

Share this post


Link to post
Share on other sites
Do you think that these AppleHDA kexts will work for ALC861... Because I'm having cracked sound on startup and when running on battery

 

Thanks for your help

 

No. These kexts are for ALC889A. If you hear popup sound occurs before playing songs, try latest AppleSMBIOS.kext on the 1st post.

Share this post


Link to post
Share on other sites
@macgirl

 

I got legacy for 888 from stickpin's thread. I just copied CodecVerbs from your edited legacy and added OSBundleRequired key to stickpin's legacy. I don't know what your MOBO is.

 

Picture of hdaenabler in a zip file;

You will see data of PinConfigurations, but not for 885/889. I don't know about this.

layout-id is "x." It's . Dec of 888 ---> Hex of 0x378.

 

Picture of controller in a zip file;

See PreservePinConfigurations, your edited legacy does not have it.

 

For my 889/885, I could enter some CodecVerbs (about 6 or 7) with having PreservePinConfigurations to get it works the same one which has all CodecVerbs of ConfigData. But, it would not show devices in System Profiler.

 

Your edited legacy;

Controller: LayoutID is 888.

Platform: LayoutID is 12.

In this issue, AppleHDA.kext should not be loaded. I was confused how you got as you posted.

 

Please try this and see system.log

And, compare to the working kext.

 

Don't forget to install vanilla AppleHDA.kext to S/L/E. It can be 1.5.7a24 or 1.6.2a37.

I've been editing stickpin's legacy for 883 to work on my GA-945GCM-S2L (ALC662). Now, outputs (internal speaker, Line Out at blue, headphone, and digital) are working, but I need to solve the problem of input. I got name of internal & external microphones. I tested both AppleHDA.kext 1.5.7a24 and 1.6.2a37.

Also, I have the same problem of digital (got only 2ch) for 945GCM. If I can fix this problem, I will tell you.

@tmongkol, I din't have time to test, I got a heacy load of work, even on weekends, hope can test ASAP.

Share this post


Link to post
Share on other sites
those of you with ALC888 and cant get it working, try one of these 3 attached kext folders. the guy over at osxupdate.blogspot.com gave me permission to post them, as long as i mentioned that its all Taruga's work.

 

Very nice. This was the missing piece to my Gigabyte GA-EX58-UD3R. Made my system 100% in my eyes. I used the 0.2 version. Hendrix is playing through the speakers as I type :)

Share this post


Link to post
Share on other sites

I have A MSI 975x Platinum PU edition even though the manufacturer states that the audio codec integrated on the motherboard is ALC 882M , my Linux dumps tell me that it is actually ALC 888. ( just like 889a is actually 885)

Using the information on this forum I have edited the 1.6.2.a37 HDA kexts and was able to get all the analog ports working!!! :)

and the credit obviously goes to Tmongkol , The King , Taurga and everybody else who has contributed to working HDA

 

Working

Rear pink mic working

Rear green Internal Speakers working

Rear Blue line in working

Rear Black line out working

Rear Orange line out working

Rear Grey line out working

SPDIF in and out working ( People with digital audio equipment please confirm, I do not have the equipment to check)

Also Surround sound is fully working analog and digital (Stereo ,5.1 ,6.1 ,7.1,7.1 rear ,Quadraphonic ,Hexegonal ,Octagonal and Encoded Digital Audio)

 

Not Working

 

Front green Head Phones not working

Front pinkExternal Mic not working

 

I could not configure the external microphone front pink due to the codecs limitations it has only two analog ports in and one digital .. I had to chose in between ext mic or Line out.....

 

Somehow OSX does not allow more than 4 outputs therefore I have edited two different Kexts one only anolog outputs and one with 3 anolg outputs and a digital output ;

 

ALC888 Address 0 AppleHDA 1.6.2.a37 4 Anolog Outputs 2 Analog & 1 Digital inputs (Click to Download)

 

 

4Aout2Ainsysprefs.jpg4Aout2AinOutput.jpg

4Aout2AinInput.jpg4Aout2Ainsurround.jpg

 

 

 

 

 

ALC888 Address 0 AppleHDA 1.6.2.a37 3 Anolog 1 Digital Outputs 2 Analog & 1 Digital inputs (Click to Download)

3A1Dout2Ainsysprefs.jpg3A1Dout2AinOutput.jpg

4Aout2AinInput.jpg3A1Dout2Ainsurround.jpg

 

I hope It works for you

 

 

 

@ Tmongkol

 

Internal speakers working fine but Some how The HeadPhone doesn't work from the front green no mater what I did, I have used your AppleHDAplatform structure as a template checked the routing over and over seems to be correct but no success.....

can you help please...

 

thnx in advance

Share this post


Link to post
Share on other sites

Indraganzo

 

Sounds very promising, I'd like to try your kexts but cannot download them. Each time a click on the link I get a 'do not have permission' error from the forum server despite being logged in. Could you check your attachments are uploaded OK??

 

Thanks!

Share this post


Link to post
Share on other sites

I can't download it too. It says "Sorry, but you do not have permission to use this feature. If you are not logged in, you may do so using the form below if available."

Share this post


Link to post
Share on other sites

I don't know what went wrong must be some sort of permission error in the forum code I can use it no problems

 

Anyways for people who can not access these

 

try this one

 

ALC888 4A out & 2A 1D in 1.6.2.a37

 

ALC888 3A 1D out & 2A 1D in 1.6.2.a37

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×