Jump to content
InsanelyMac Forum
VCH888

ALC889A, Gigabyte (Intel): now having a working front mic

Recommended Posts

Hi tmongkol, my sig is indeed outdated. I run 10.6.1, but hardware is still the same.

Do not have hdaenabler, nor efi strings (guess you mean those strings in com.apple.boot.plist)

 

thanks.

 

btw, what revision is your board? do you have the latest BIOS version F6?

maybe I could check your dsdt.aml and use the legcay kext you are using (if we share the same board).

 

Here is my DSDT. Just use it for comparing. Don't use my DSDT.

EP35DS3P_ALC885.zip

 

I have the same revision and the F6c bios. I got it from German Gigabyte website.

Share this post


Link to post
Share on other sites
Advertisement

Thanks tmongol.. it really drives me nuts.. tried all possible combination of HDEF/codec and legacyhda.

Just now it came up in me to check if AppleHDA loads. Don't know it doesn't load because of my dsdt + legacy.

bash-3.2# kextutil /System/Library/Extensions/AppleHDA.kext
/System/Library/Extensions/AppleHDA.kext is invalid; can't resolve dependencies.
/System/Library/Extensions/AppleHDA.kext is invalid; can't resolve dependencies.
/System/Library/Extensions/AppleHDA.kext is invalid; can't resolve dependencies.
/System/Library/Extensions/AppleHDA.kext has problems:
Validation Failures: 
Kext has a CFBundleExecutable property but the executable can't be found: 
	AppleHDAHardwareConfigDriver

Warnings: 
The booter does not recognize symbolic links; confirm these files/directories aren't needed for startup: 
	/System/Library/Extensions/AppleHDA.kext/Contents/CodeDirectory
	/System/Library/Extensions/AppleHDA.kext/Contents/CodeRequirements
	/System/Library/Extensions/AppleHDA.kext/Contents/CodeResources
	/System/Library/Extensions/AppleHDA.kext/Contents/CodeSignature

bash-3.2# kextload /System/Library/Extensions/AppleHDA.kext
/System/Library/Extensions/AppleHDA.kext failed to load - (libkern/kext) validation failure (plist/executable); check the system/kernel logs for errors or try kextutil(8).

 

DMESG:

Not loading kext com.apple.driver.AppleHDAController - not found and kextd not available in early boot.

 

Is something wrong with AppleHDA?

Share this post


Link to post
Share on other sites

Got it working... Seems it was a corrupted AppleHDA.kext.

Extracted from Install DVD, reboot and sound.

 

I placed LegacyHDA for ALC889a code-id 885 (4outs2ins HDA headphone)

Have sound only when selecting "internal speakers".

 

Guess this is they way you got it working?

 

 

Anyhow, the message I saw at boot time is still there

"Not loading kext com.apple.driver.AppleHDAController - not found and kextd not available in early boot."

post-39930-1256165693_thumb.png

Share this post


Link to post
Share on other sites
Got it working... Seems it was a corrupted AppleHDA.kext.

Extracted from Install DVD, reboot and sound.

 

I placed LegacyHDA for ALC889a code-id 885 (4outs2ins HDA headphone)

Have sound only when selecting "internal speakers".

 

Guess this is they way you got it working?

 

 

Anyhow, the message I saw at boot time is still there

"Not loading kext com.apple.driver.AppleHDAController - not found and kextd not available in early boot."

 

According to THe KiNG, posted on other forum,

Those AppleHDAController warnings are normal b/c the dummy.kext loads earlier in the boot process and since it cant find AppleHDAController.kext (that is loaded later) it prints that.
The only way to get rid of those is to patch/fix original applehda.kext info.plist's, but that say bye to "on the fly" patching... 
After AppleHDAController will be deprecated and removed by apple we will get rid of those "natural" <IMG style="VERTICAL-ALIGN: middle" border=0 alt=smile.gif src="style_emoticons/default/smile.gif" emoid=":)">

Share this post


Link to post
Share on other sites

Hi!

 

I got a small problem, my headphone auto detection doesn't work anymore. I use DSDT to inject the HDEF device (ALC889a, Gigabyte EP45-UD3R), and a LegacyHDA.kext (which doesn't show up in kextstat | grep Legacy btw, is that normal?) I still get audio from the front headphone jack, but I have to change the audio output manually from sound prefs. (Internal Speaker -> Headphones et vice versa)

 

I also get this error upon boot:

10/22/09 1:16:39 AM	kernel	Sound assertion "0 == mMikeyInterruptSource" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyACPI.cpp" at line 260 goto Exit
10/22/09 1:16:39 AM	kernel	Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyI2C.cpp" at line 197 goto handler
10/22/09 1:16:39 AM	kernel	Sound assertion "mMikeyReceiverFound && 0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyI2C.cpp" at line 247 goto Exit
10/22/09 1:16:39 AM	kernel	Sound assertion "0 != readRegisters ( (UInt8*)&mRegisterCache )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyI2C.cpp" at line 104 goto handler

 

 

I've attached both the kext and my DSDT.dsl. But any ideas are welcome! :)

 

This is really one of my last quirks that I need to sort out before having THE perfect mac hack. :rolleyes:

DSDT_mm67_stripped3_ud3r.dsl.zip

LegacyHDA.kext.zip

Share this post


Link to post
Share on other sites
Hi!

 

I got a small problem, my headphone auto detection doesn't work anymore. I use DSDT to inject the HDEF device (ALC889a, Gigabyte EP45-UD3R), and a LegacyHDA.kext (which doesn't show up in kextstat | grep Legacy btw, is that normal?) I still get audio from the front headphone jack, but I have to change the audio output manually from sound prefs. (Internal Speaker -> Headphones et vice versa)

 

I also get this error upon boot:

10/22/09 1:16:39 AM	kernel	Sound assertion "0 == mMikeyInterruptSource" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyACPI.cpp" at line 260 goto Exit
10/22/09 1:16:39 AM	kernel	Sound assertion "0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyI2C.cpp" at line 197 goto handler
10/22/09 1:16:39 AM	kernel	Sound assertion "mMikeyReceiverFound && 0 != result" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyI2C.cpp" at line 247 goto Exit
10/22/09 1:16:39 AM	kernel	Sound assertion "0 != readRegisters ( (UInt8*)&mRegisterCache )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleMikeyDriver/AppleMikeyI2C.cpp" at line 104 goto handler

 

 

I've attached both the kext and my DSDT.dsl. But any ideas are welcome! :)

 

This is really one of my last quirks that I need to sort out before having THE perfect mac hack. :D

 

@oxpher

 

I was thinking that the patched DSDT would be the cause of sound assertions. Can you patch your dsdt only for RTC (preventing CMOS resetting) and HDEF, not like the patched one you posted? The LegacyHDA.kext you posted, I tested it and it's OK. Any kind of legacy/dummy kext should not be shown up in kextstat since it contains only info.plist, not binary file.

 

If the patched DSDT you posted causes the assertions, you may ask Master Chief for fixing it in DSDT fixes for Gigabyte boards topic.

Share this post


Link to post
Share on other sites

Hi there,

 

first thnx, tmongkol for all your work and help.

I'm looking for a legacy kext for alc889a id 0x1458A102 layout 12 0x0000000c ; 0x0c, 0x00, 0x00, 0x00 (ga-eg45m-ud2h)

Right now i'm using the patched applehda.kext 1.4.0a22.zip from the first post and it's working great.

Is there already someone who is using a legacy version for this.

 

Thnx for any help

T.

Share this post


Link to post
Share on other sites

Thanks a lot for your great work.

A quick question, how I can get my devices layout-id?

I'm using GA-X58-Extreme, I believe it's 885 series.

Share this post


Link to post
Share on other sites
Thanks a lot for your great work.

A quick question, how I can get my devices layout-id?

I'm using GA-X58-Extreme, I believe it's 885 series.

 

 

Your GA-X85-Extreame has ALC889A (=ALC885). So, you can use LecagyHDA.kext from LegacyHDA 885 folder. If you don't edit DSDT with HDEF, you can use HDAEnabler for Snow, using #885. LayoutID or layout-id can be any number. I always say that the important thing is CodecID. For example, HEX of ALC885 is 0x10EC0885 and DEC of ALC885 is 283904133. So, CodecID of ALC889A/ALC885 is 283904133.

Share this post


Link to post
Share on other sites
Your GA-X85-Extreame has ALC889A (=ALC885). So, you can use LecagyHDA.kext from LegacyHDA 885 folder. If you don't edit DSDT with HDEF, you can use HDAEnabler for Snow, using #885. LayoutID or layout-id can be any number. I always say that the important thing is CodecID. For example, HEX of ALC885 is 0x10EC0885 and DEC of ALC885 is 283904133. So, CodecID of ALC889A/ALC885 is 283904133.

 

 

Thanks a lot for your kind reply. Could you consider giving a step by step guide of how to make all of those changes for most of the new members? Such like how to get those informations(CodecID), and how to install you supplied kext? If failed, how to rollback and try again?

 

Very appreciated for your helps!

Share this post


Link to post
Share on other sites
Thanks a lot for your kind reply. Could you consider giving a step by step guide of how to make all of those changes for most of the new members? Such like how to get those informations(CodecID), and how to install you supplied kext? If failed, how to rollback and try again?

 

Very appreciated for your helps!

 

At this point, I will tell you how to install LegacyHDA.kext and HDAEnabler.kext. You will get Extra folder after you install Chameleon boot loader (installing package). You just copy LagacyHDA.kext and HDAEnabler.kext into /Extra/Extensions folder. This way has been worked for me. I often test my LegacyHDA.kexts when I try a new thing. If I want to use DSDT w/ HDEF, I just remove HDAEnabler.kext from /E/E.

 

If you want to learn how to edit info.plist of AppleHDA.kext, please go to THe KiNG's guide.

Share this post


Link to post
Share on other sites

I have the EVGA x58 board w/ ALC889 and I have been trying to find a 64-bit audio solution other than voodoohda for almost two weeks.

 

The codec dump and verbs can be found on airwalks post at the bottom here:

 

http://www.infinitemac.com/f57/guide-how-t...3981/page6.html

 

Any help is appreciated. I have tried porting applehda and modifying my DSDT w/o success

Share this post


Link to post
Share on other sites
Front mic or rear mic doesn't work? Front mic will not work.

 

I am using DSDT with HDEF inject, legacyHDA(4out2in)(E/E) from Legacy series for my ALC889a on SL 10.6.

Sound working fine for Output and rear Mic but Front mic does not work.

System profile under Audio (built-in) show both Internal and External Mic but Output list only show Internal Mic.

I have many legacyHDA but so far none can enable the external Mic.

How can I get External Mic on the Input list?

Thanks

Share this post


Link to post
Share on other sites
I am using DSDT with HDEF inject, legacyHDA(4out2in)(E/E) from Legacy series for my ALC889a on SL 10.6.

Sound working fine for Output and rear Mic but Front mic does not work.

System profile under Audio (built-in) show both Internal and External Mic but Output list only show Internal Mic.

I have many legacyHDA but so far none can enable the external Mic.

How can I get External Mic on the Input list?

Thanks

 

I rememberd that I attempted to make a front mic to be working as External Microphone for SL but it gave me "none" in Sound Preferences. That meant a front mic could not work. I also made a front mic to be acting as Internal Microphone and it failed.

 

If you want to get a front mic, you need to trade off. You got to run 32bit mode and use an old patched 1.5.7a24 AppleHDA.kext as I am thinking.

Share this post


Link to post
Share on other sites
I rememberd that I attempted to make a front mic to be working as External Microphone for SL but it gave me "none" in Sound Preferences. That meant a front mic could not work. I also made a front mic to be acting as Internal Microphone and it failed.

 

If you want to get a front mic, you need to trade off. You got to run 32bit mode and use an old patched 1.5.7a24 AppleHDA.kext as I am thinking.

 

Thanks for your prompt advise. Where should the patched 1.5.7a24 AppleHDA.kext go, E/E or /S/L/E?

If in /S/L/E, then need reinstallation after any update. Is that correct?

Thanks and have a nice day.

Share this post


Link to post
Share on other sites
Thanks for your prompt advise. Where should the patched 1.5.7a24 AppleHDA.kext go, E/E or /S/L/E?

If in /S/L/E, then need reinstallation after any update. Is that correct?

Thanks and have a nice day.

 

Any AppleHDA.kext must be in /S/L/E. If you have any update for SL that updates AppleHDA.kext, you may reinstall the patched AppleHDA.kext again.

 

 

For SL:

Don't forget to set Kernel Flags --> arch=i386 in com.apple.Boot.plist. This com.apple.Boot.plist is in /Extra.

post-93383-1256860049_thumb.jpg

 

You need to edit layout-id to 0x79, 0x03, 0x00, 0x00 in HDEF section of DSDT.

Share this post


Link to post
Share on other sites
I have the EVGA x58 board w/ ALC889 and I have been trying to find a 64-bit audio solution other than voodoohda for almost two weeks.

 

The codec dump and verbs can be found on airwalks post at the bottom here:

 

http://www.infinitemac.com/f57/guide-how-t...3981/page6.html

 

Any help is appreciated. I have tried porting applehda and modifying my DSDT w/o success

 

Thanks for the information, so I suppose u are voodoohda for e 32-bit snow leopard?

Share this post


Link to post
Share on other sites
Guest Hefisots73

Hello

 

My motherboard has a Intel HDA device, but the sound is low. I also tried with alsa mix to up all the sound parameters and nothing.

 

My mobo is an Asrock Wolfdale 1333 and the sound is a Realtek Intel HDA recognizes Mandriva with audio codec ALC662

 

In OpenSUSE the sound is high but now in Mandriva the sound is low.

 

Any help please.

Share this post


Link to post
Share on other sites
I rememberd that I attempted to make a front mic to be working as External Microphone for SL but it gave me "none" in Sound Preferences. That meant a front mic could not work. I also made a front mic to be acting as Internal Microphone and it failed.

 

If you want to get a front mic, you need to trade off. You got to run 32bit mode and use an old patched 1.5.7a24 AppleHDA.kext as I am thinking.

 

Thanks for the reply and advise.

I tried the patched 1.5.7a24 AppleHDA.kext as well as n3.1.6.2a37 AppleHDA.kext on 4 outs3ins_analog_HDA_headphone in /S/L/E. When I replaced the vanilla SL AppleHDA with the patched, encountered error msg 'System extension cannot be used' :D Went ahead but not working 'input or output device not detected' :( Looks like the patched AppleHDA.kext is not suitable for SL.

On comparing the vanilla SL AppleHDA.kext with the patched, I find that in the plugins, AppleHDAHardwareConfigDriver.kext is missing in the patched AppleHDA.kext.

Is there a patched AppleHDA.kext for SL?

Thanks for your time.

Have a nice day.

Share this post


Link to post
Share on other sites
Thanks for the reply and advise.

I tried the patched 1.5.7a24 AppleHDA.kext as well as n3.1.6.2a37 AppleHDA.kext on 4 outs3ins_analog_HDA_headphone in /S/L/E. When I replaced the vanilla SL AppleHDA with the patched, encountered error msg 'System extension cannot be used' :rolleyes: Went ahead but not working 'input or output device not detected' :( Looks like the patched AppleHDA.kext is not suitable for SL.

On comparing the vanilla SL AppleHDA.kext with the patched, I find that in the plugins, AppleHDAHardwareConfigDriver.kext is missing in the patched AppleHDA.kext.

Is there a patched AppleHDA.kext for SL?

Thanks for your time.

Have a nice day.

 

Try to use Kext Utility for installing the patched kext again. You need to run only 32bit mode. I tested it and it's OK. Also, removing LegacyHDA.kext if you have it.

 

AppleHDAHardwareConfigDriver.kext is found in 10.5.8 update and SL.

Share this post


Link to post
Share on other sites
Try to use Kext Utility for installing the patched kext again. You need to run only 32bit mode. I tested it and it's OK. Also, removing LegacyHDA.kext if you have it.

 

AppleHDAHardwareConfigDriver.kext is found in 10.5.8 update and SL.

tmongkol,

Tks for the prompt response.

Work like a charm :) .

I am still curious why the LegacyHDA can't have 4outs3ins like 1.5.7a24 AppleHDA.kext so there is an extra input of external microphone? :P

Also I check the LegacyHDA.kext for both 3out2in and 4outs2in and both look identical.

What determine whether its 3 or 4 out?

I am trying to learn as much as I can on HDA and that's why the above questions.

Again tks for your time.

Have a nice day.

Share this post


Link to post
Share on other sites
tmongkol,

Tks for the prompt response.

Work like a charm ;) .

I am still curious why the LegacyHDA can't have 4outs3ins like 1.5.7a24 AppleHDA.kext so there is an extra input of external microphone? :)

Also I check the LegacyHDA.kext for both 3out2in and 4outs2in and both look identical.

What determine whether its 3 or 4 out?

I am trying to learn as much as I can on HDA and that's why the above questions.

Again tks for your time.

Have a nice day.

 

Q: What determine whether its 3 or 4 out?

A: AppleHDA can handle maximum four outputs as I think. 3outs has 3 analog ports and 1 digital output. 4outs has 4 analog ports, no digital output.

Share this post


Link to post
Share on other sites
Q: What determine whether its 3 or 4 out?

A: AppleHDA can handle maximum four outputs as I think. 3outs has 3 analog ports and 1 digital output. 4outs has 4 analog ports, no digital output.

 

 

I am still curious why the LegacyHDA has only 2inputs. Can one be created with 4outs3ins like 1.5.7a24 AppleHDA.kext so there is an extra input of external microphone? :P

Tks

Share this post


Link to post
Share on other sites

Now it works for me, I made a simple mistake. I put the whole folder into /Extra/Extensions/. The right way is that choose one of the series LegacyHDA.kext and put it into the /Extra/Extensions.

 

Hope it's helpful for others.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.



×