Jump to content
InsanelyMac Forum
VCH888

ALC889A, Gigabyte (Intel): now having a working front mic

Recommended Posts

My Sound chip is ALC889(10ec0889).

NOT ALC889a(10ec0885)

 

I tried AppleHDA Patcher 1.20, but it said "* Detected unsupported Realtek Codec"

 

Could someone make a working Legacy kext & DSDT Code with this?

My MainBoard is MSI X58 Pro-E.

Share this post


Link to post
Share on other sites
Advertisement
My Sound chip is ALC889(10ec0889).

NOT ALC889a(10ec0885)

 

I tried AppleHDA Patcher 1.20, but it said "* Detected unsupported Realtek Codec"

 

Could someone make a working Legacy kext & DSDT Code with this?

My MainBoard is MSI X58 Pro-E.

 

Just try removed

I only changed CodecID and LayouID for ALC889.

Share this post


Link to post
Share on other sites
Just try

I only changed CodecID and LayouID for ALC889.

 

 

Very thank you for your works!

 

I tried this patched Kexts.

but It's not working. ;)

I'm use Snow Leopard 10.6.1

 

Here is my Consol Log.

-------------------------------------------

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto ExitDSMOS has arrived

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

09. 10. 14. “Ëœ¤í›„ 11:29:24 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

 

------------------------------------

 

I want 3outs3ins w/digital out & HDA front audio.

 

I'm confused.

;)

 

What can i do for next?

 

Best regard.

post-68361-1255531051_thumb.png

post-68361-1255531982_thumb.png

Share this post


Link to post
Share on other sites
Hello tmongkol.

 

I use HDAU Util.

and codecs found.

parse and Save file.

 

and Attached screen shot.

 

 

Very thanks to your concern & attendance.

 

Best Regard.

 

@moonmage

 

removed

I removed SPDIF In from PathMapRef.

Share this post


Link to post
Share on other sites
@moonmage

 

Please try

I removed SPDIF In from PathMapRef.

 

Sadly It's not working. :angel:

 

 

Could you remove SPDIF instead Gray sound port? (Side Speaker)

 

 

What can I do for next? :moil:

 

 

:thanks_speechbubble:

 

Regards.

post-68361-1255754957_thumb.jpg

post-68361-1255754971_thumb.jpg

Share this post


Link to post
Share on other sites
Sadly It's not working. :angel:

 

 

Could you remove SPDIF instead Gray sound port? (Side Speaker)

 

 

What can I do for next? :moil:

 

 

:)

 

Regards.

 

@moonmage

 

removed

This one I added PreservePinconfigurations = true in HDAConfigDefault. And, please post a few of sound assertions if having them.

Share this post


Link to post
Share on other sites

Still not working.

 

Console Massage ----------

 

6:32:43 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

6:32:43 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

6:32:43 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

6:32:43 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

6:32:43 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

6:32:43 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

6:32:43 kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto ExitDSMOS has arrived

6:32:43 kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

 

 

and. profiler audio (Built In) info -----

 

 

Intel High Definition Audio:

 

Device ID: 0x14627522

Audio ID: 12

Available Devices:

Line Out:

Connection: 1/8-Inch Jack

External Microphone:

Connection: 1/8-Inch Jack

External Microphone:

Connection: 1/8-Inch Jack

S/P-DIF Out:

Connection: Optical

Share this post


Link to post
Share on other sites

My audio codec is ALC885 as you know it is very similar to the 889a codec. Which values must I change to get a working LegacyHDA for a EVGA nForce 680i MOBO?

CodecDump: ALC_885_Codec.txt

Regards

iLeopod

Share this post


Link to post
Share on other sites

Hello,

 

How can I read my layout id?

In the first post I see 12 and 889.

But I don't know what is the right for me.

Share this post


Link to post
Share on other sites
Still not working.

 

try for_testing_MSI_ALC889_4.zip

 

Please post your results. I hope this one will work for you. I thought the problem was PathMapRef.

 

Hello,

 

How can I read my layout id?

In the first post I see 12 and 889.

But I don't know what is the right for me.

 

@ tlac

 

What is your motherboard? I hope it should be Gigabyte.

 

My audio codec is ALC885 as you know it is very similar to the 889a codec. Which values must I change to get a working LegacyHDA for a EVGA nForce 680i MOBO?

CodecDump: ALC_885_Codec.txt

Regards

iLeopod

 

@iLeopod

 

I used to help Wintikler's EVGA nForce 730i and it failed. Sorry, I could not help you.

Share this post


Link to post
Share on other sites
@ tlac

 

What is your motherboard? I hope it should be Gigabyte.

 

I have Gigabyte ep45-ud3p rev1.1 + vanilla Snow Leopard + pc-efi 10.4.1 + fakesmc.

I tried to fix dsdt:

		 Method (_L0D, 0, NotSerialized)
	 {
		 Notify (\_SB.PCI0.USBE, 0x02)
		 Notify (\_SB.PCI0.USE2, 0x02)
		 Notify (\_SB.PWRB, 0x02)
Notify (\_SB.PCI0.HDEF, 0x02)
		 Notify (\_SB.PCI0.IGBE, 0x02)
	 }
...

Device (HDEF)
{
Name (_ADR, 0x001B0000)
Method (_PRW, 0, NotSerialized)
{
Return (Package (0x02)
{
0x0D,
0x05
})
}

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x08)
{
"codec-id",
Buffer (0x04)
{
0x85, 0x08, 0xEC, 0x10
},

"layout-id",
Buffer (0x04)
{
0x75, 0x03, 0x00, 0x00
},

"device-type",
Buffer (0x10)
{
"Realtek ALC889A"
},

"PinConfigurations",
Buffer (0x01)
{
0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
Method (DTGP, 5, NotSerialized)
{
If (LEqual (Arg0, Buffer (0x10)
{
/* 0000 */ 0xC6, 0xB7, 0xB5, 0xA0, 0x18, 0x13, 0x1C, 0x44,
/* 0008 */ 0xB0, 0xC9, 0xFE, 0x69, 0x5E, 0xAF, 0x94, 0x9B
}))
{
If (LEqual (Arg1, One))
{
If (LEqual (Arg2, Zero))
{
Store (Buffer (One)
{
0x03
}, Arg4)
Return (One)
}

If (LEqual (Arg2, One))
{
Return (One)
}
}
}

Store (Buffer (One)
{
0x00
}, Arg4)
Return (Zero)
}
}

 

and I installed LegacyHDA from Series_of_LegacyHDA.zip / Series of LegacyHDA / series of LegacyHDA 889 (ALC889a) / 4outs2ins regular headphone.

but no sound.

 

Maybe the problem is the layout id.

Is there any application to detect?

 

other:

I saw in your singal. You are using LAN patch in dsdt for ep45-ud3r. Why?

It works for me without any hack.

Share this post


Link to post
Share on other sites
I have Gigabyte ep45-ud3p rev1.1 + vanilla Snow Leopard + pc-efi 10.4.1 + fakesmc.

I tried to fix dsdt:

		 Method (_L0D, 0, NotSerialized)
	 {
		 Notify (\_SB.PCI0.USBE, 0x02)
		 Notify (\_SB.PCI0.USE2, 0x02)
		 Notify (\_SB.PWRB, 0x02)
Notify (\_SB.PCI0.HDEF, 0x02)
		 Notify (\_SB.PCI0.IGBE, 0x02)
	 }
...

Device (HDEF)
{
Name (_ADR, 0x001B0000)
Method (_PRW, 0, NotSerialized)
{
Return (Package (0x02)
{
0x0D,
0x05
})
}

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x08)
{
"codec-id",
Buffer (0x04)
{
0x85, 0x08, 0xEC, 0x10
},

"layout-id",
Buffer (0x04)
{
0x75, 0x03, 0x00, 0x00
},

"device-type",
Buffer (0x10)
{
"Realtek ALC889A"
},

"PinConfigurations",
Buffer (0x01)
{
0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
Method (DTGP, 5, NotSerialized)
{
If (LEqual (Arg0, Buffer (0x10)
{
/* 0000 */ 0xC6, 0xB7, 0xB5, 0xA0, 0x18, 0x13, 0x1C, 0x44,
/* 0008 */ 0xB0, 0xC9, 0xFE, 0x69, 0x5E, 0xAF, 0x94, 0x9B
}))
{
If (LEqual (Arg1, One))
{
If (LEqual (Arg2, Zero))
{
Store (Buffer (One)
{
0x03
}, Arg4)
Return (One)
}

If (LEqual (Arg2, One))
{
Return (One)
}
}
}

Store (Buffer (One)
{
0x00
}, Arg4)
Return (Zero)
}
}

 

and I installed LegacyHDA from Series_of_LegacyHDA.zip / Series of LegacyHDA / series of LegacyHDA 889 (ALC889a) / 4outs2ins regular headphone.

but no sound.

 

Maybe the problem is the layout id.

Is there any application to detect?

 

other:

I saw in your singal. You are using LAN patch in dsdt for ep45-ud3r. Why?

It works for me without any hack.

 

I used to patch DSDT for LAN but now I use netkas' boot 10.4.1 for Time Machine working properly.

 

"layout-id",
Buffer (0x04)
{
0x75, 0x03, 0x00, 0x00	 ==> layout-id is 885.
},

 

You use layout-id = 885 so you need to use LegacyHDA.kext from series of LegacyHDA 885 (ALC889a).

Share this post


Link to post
Share on other sites
"layout-id",
 Buffer (0x04)
 {
 0x75, 0x03, 0x00, 0x00	 ==> layout-id is 885.
 },

 

You use layout-id = 885 so you need to use LegacyHDA.kext from series of LegacyHDA 885 (ALC889a).

 

Thank you!

I ony changed 0x75, 0x03, 0x00, 0x00 -> 0x79, 0x03, 0x00, 0x00 in dsdt and it works.

 

So, the layout-id is not fixed and changeable?

I think it can work with your solution.

(Sorry, I'm in interested in details.)

Share this post


Link to post
Share on other sites
Thank you!

I ony changed 0x75, 0x03, 0x00, 0x00 -> 0x79, 0x03, 0x00, 0x00 in dsdt and it works.

 

So, the layout-id is not fixed and changeable?

 

Answer: A layout-id (& LayoutID in info.plist) can be any number. Also, an important thing is CodecID in info.plist that must be matched to your Audio Device. For example, Gigabyte 945GCM-S2L has ALC662, 0x10EC0662. CodecID is 283903586.

 

I think it can work with your solution.

(Sorry, I'm in interested in details.)

Share this post


Link to post
Share on other sites
try for_testing_MSI_ALC889_4.zip

 

Please post your results. I hope this one will work for you. I thought the problem was PathMapRef.

 

@tmongkol

 

It's Still not working sadly.

 

 

------------------

 

Intel High Definition Audio:

 

Device ID: 0x14627522

Audio ID: 12

Available Devices:

Line Out:

Connection: 1/8-Inch Jack

External Microphone:

Connection: 1/8-Inch Jack

External Microphone:

Connection: 1/8-Inch Jack

S/P-DIF Out:

Connection: Optical

 

 

-------------------

 

 

 

kernel netkas presents fakesmc, a kext which emulates smc deviceHDAEnabler: Copyright © 2008 by Kabyl

kernel HDAEnabler: 05/05/2008 Added SP-Audio support by Taruga

kernel HDAEnabler: 03/07/2009 Compiled for 32/64-bit by Taruga

kernel FireWire runtime power conservation disabled. (2)

kernel From path: "uuid",

kernel Waiting for boot volume with UUID 197871D1-16B4-3458-B777-FF2017C67588

kernel com.apple.AppleFSCompressionTypeZlib load succeeded

kernel Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>AppleIntelCPUPowerManagementClient: ready

kernel Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/CHN0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/WDC WD740ADFD-00NLR5 Media/IOGUIDPartitionScheme/SN@2

kernel BSD root: disk1s2, major 14, minor 6

kernel FireWire (OHCI) VendorID 197b ID 2380 PCI now active, GUID 0010dc00019625cf; max speed s400.

kernel USBMSC Identifier (non-unique): 920321111113 0x58f 0x6377 0x100

kernel AppleIntelCPUPowerManagement: Turbo Ratios 1112

kernel AppleIntelCPUPowerManagement: initialization complete

com.apple.launchd[1] *** launchd[1] has started up. ***

com.apple.launchd[1] *** Verbose boot, will log to /dev/console. ***

bootlog[37] BOOT_TIME: 1255854585 0

blued[38] Apple Bluetooth daemon started

com.apple.SecurityServer[23] Session 0x5fbff962 created

com.apple.SecurityServer[23] Entering service

mDNSResponder[26] mDNSResponder mDNSResponder-212.1 (Jul 24 2009 22:34:12) starting

com.apple.usbmuxd[19] usbmuxd-176 built for iTunesNine on Jul 20 2009 at 13:06:53, running 32 bit

kernel Waiting for DSMOS...

kernel systemShutdown false

configd[13] network configuration changed.

configd[13] setting hostname to "owonjuui-Mac-Pro.local"

kernel NTFS driver 3.0 [Flags: R/W].

kernel ** AppleSMBusPCI::start failed to get acpi path for provider

kernel NTFS volume name 시스템 예약, version 3.1.

kernel NTFS volume name .Win7, version 3.1.

kernel HDAEnabler: Copyright © 2008 by Kabyl

kernel HDAEnabler: 05/05/2008 Added SP-Audio support by Taruga

kernel HDAEnabler: 03/07/2009 Compiled for 32/64-bit by Taruga

kernel Previous Shutdown Cause: 3

kernel NVDANV50HAL loaded and registered.

kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

/System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow[27] Login Window Application Started

com.apple.kextd[10] /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/InternalModemSupport.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

com.apple.kextd[10] /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/InternalModemSupport.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto ExitDSMOS has arrived

 

 

 

----------------------------

 

HDAenabler is twice notice.

;)

Share this post


Link to post
Share on other sites
@tmongkol

 

It's Still not working sadly.

 

 

------------------

 

Intel High Definition Audio:

 

Device ID: 0x14627522

Audio ID: 12

Available Devices:

Line Out:

Connection: 1/8-Inch Jack

External Microphone:

Connection: 1/8-Inch Jack

External Microphone:

Connection: 1/8-Inch Jack

S/P-DIF Out:

Connection: Optical

 

 

-------------------

 

 

 

kernel netkas presents fakesmc, a kext which emulates smc deviceHDAEnabler: Copyright � 2008 by Kabyl

kernel HDAEnabler: 05/05/2008 Added SP-Audio support by Taruga

kernel HDAEnabler: 03/07/2009 Compiled for 32/64-bit by Taruga

kernel FireWire runtime power conservation disabled. (2)

kernel From path: "uuid",

kernel Waiting for boot volume with UUID 197871D1-16B4-3458-B777-FF2017C67588

kernel com.apple.AppleFSCompressionTypeZlib load succeeded

kernel Waiting on <dict ID="0"><key>IOProviderClass</key><string ID="1">IOResources</string><key>IOResourceMatch</key><string ID="2">boot-uuid-media</string></dict>AppleIntelCPUPowerManagementClient: ready

kernel Got boot device = IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/SATA@1F,2/AppleAHCI/CHN0@0/IOAHCIDevice@0/AppleAHCIDiskDriver/IOAHCIBlockStorageDevice/IOBlockStorageDriver/WDC WD740ADFD-00NLR5 Media/IOGUIDPartitionScheme/SN@2

kernel BSD root: disk1s2, major 14, minor 6

kernel FireWire (OHCI) VendorID 197b ID 2380 PCI now active, GUID 0010dc00019625cf; max speed s400.

kernel USBMSC Identifier (non-unique): 920321111113 0x58f 0x6377 0x100

kernel AppleIntelCPUPowerManagement: Turbo Ratios 1112

kernel AppleIntelCPUPowerManagement: initialization complete

com.apple.launchd[1] *** launchd[1] has started up. ***

com.apple.launchd[1] *** Verbose boot, will log to /dev/console. ***

bootlog[37] BOOT_TIME: 1255854585 0

blued[38] Apple Bluetooth daemon started

com.apple.SecurityServer[23] Session 0x5fbff962 created

com.apple.SecurityServer[23] Entering service

mDNSResponder[26] mDNSResponder mDNSResponder-212.1 (Jul 24 2009 22:34:12) starting

com.apple.usbmuxd[19] usbmuxd-176 built for iTunesNine on Jul 20 2009 at 13:06:53, running 32 bit

kernel Waiting for DSMOS...

kernel systemShutdown false

configd[13] network configuration changed.

configd[13] setting hostname to "owonjuui-Mac-Pro.local"

kernel NTFS driver 3.0 [Flags: R/W].

kernel ** AppleSMBusPCI::start failed to get acpi path for provider

kernel NTFS volume name �‹œ�Š��…œ �˜ˆ�•�, version 3.1.

kernel NTFS volume name .Win7, version 3.1.

kernel HDAEnabler: Copyright � 2008 by Kabyl

kernel HDAEnabler: 05/05/2008 Added SP-Audio support by Taruga

kernel HDAEnabler: 03/07/2009 Compiled for 32/64-bit by Taruga

kernel Previous Shutdown Cause: 3

kernel NVDANV50HAL loaded and registered.

kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

/System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow[27] Login Window Application Started

com.apple.kextd[10] /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/InternalModemSupport.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

com.apple.kextd[10] /System/Library/Extensions/IOSerialFamily.kext/Contents/PlugIns/InternalModemSupport.kext does not declare a kernel dependency; using com.apple.kernel.6.0.

kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exit

kernel Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit

kernel Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto ExitDSMOS has arrived

 

 

 

----------------------------

 

HDAenabler is twice notice.

;)

 

@tmongkol

 

I have exactly the same problem with my ALC889 in MSI X58 mobo. For some reason the PinConfiguration is not being injected/overridden, what appears in IORegistryExplorer under HDEF is always the pinconfigs exactly as they are in Windows Vista. What shows up in system profiler are only the inputs/outputs that AppleHDA can make sense of from this pinconfig. I've tried DSDT, EFI strings and HDAEnabler, all with the same result! If you can solve this one then you're a genius! If you need more information let me know.

Share this post


Link to post
Share on other sites

@ moonmage & dgsga

 

For testing my EP35-DS3P, ALC889a (0x10EC0885, 283904133)

 

I set up the condition of wrong CodecID of LegacyHDA.kext. I set CodecID in info.plist of AppleHDAPlatformdriver to 283904137. After installation and reboot, I got the same sound assertions as you posted. Also, in IORegistryExplorer, PinConfigurations got the same as Windows, like dgsga said.

 

Oct 18 19:39:34 2 kernel[0]: Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 1459 goto Exit
Oct 18 19:39:34 2 kernel[0]: Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-174.1.1/AppleHDA/AppleHDADriver.cpp" at line 172 goto Exi

 

 

Now, what I am thinking? My question, may it be wrong CodecID for your MOBO? It's weird.

 

 

 

removed

use Kext Utility for installing into /S/L/E. Remove LegacyHDA.kext.

This should be the last one I can do because I have no idea now. If it's not working, please try VoodooHDA.kext.

Share this post


Link to post
Share on other sites

I lost it.. too much information and what not. it's not always a bless.

Having the GA-EP35-DS3P rev2.1 with ALC889a I patched my DSDT and used the LegacyHDA (for my 889a) in E/E

This is what I should be doing, right? If not, then O Thee Masters of sanity, correct me..

 

My DSDT:

Device (HDEF)

{

Name (_ADR, 0x001B0000)

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x0A)

{

 

"built-in",

Buffer (0x01)

{

0x01

},

 

"codec-id",

Buffer (0x04)

{

0x85, 0x08, 0xEC, 0x10

},

 

"layout-id",

Buffer (0x04)

{

0x75, 0x03, 0x00, 0x00

},

 

"device-type",

Buffer (0x10)

{

"Realtek ALC889A"

},

 

"PinConfigurations",

Buffer (0x28)

{

/* 0000 */ 0x10, 0x90, 0xA1, 0x01, 0x20, 0x90, 0xA1, 0x02,

/* 0008 */ 0x80, 0x30, 0x81, 0x01, 0x90, 0x40, 0x21, 0x02,

/* 0010 */ 0x30, 0x40, 0x11, 0x01, 0x40, 0x40, 0x01, 0x01,

/* 0018 */ 0x50, 0x60, 0x01, 0x01, 0x60, 0x20, 0x01, 0x01,

/* 0020 */ 0x70, 0x61, 0x4B, 0x01, 0xA0, 0x01, 0xCB, 0x01

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

 

Profiler says:

 

post-39930-1256070093_thumb.png

 

Yet I have no input/output devices..

 

Thanks many..

Share this post


Link to post
Share on other sites
I lost it.. too much information and what not. it's not always a bless.

Having the GA-EP35-DS3P rev2.1 with ALC889a I patched my DSDT and used the LegacyHDA (for my 889a) in E/E

This is what I should be doing, right? If not, then O Thee Masters of sanity, correct me..

 

My DSDT:

 

 

Profiler says:

 

post-39930-1256070093_thumb.png

 

Yet I have no input/output devices..

 

Thanks many..

 

Which OS X are you using? I am not sure whether your sig. is up to date or not.

 

If you're gonna use DSDT w/ HDEF, you need to remove HDAEnabler or Audio String, for example.

Share this post


Link to post
Share on other sites
Which OS X are you using? I am not sure whether your sig. is up to date or not.

 

If you're gonna use DSDT w/ HDEF, you need to remove HDAEnabler or Audio String, for example.

 

 

Hi tmongkol, my sig is indeed outdated. I run 10.6.1, but hardware is still the same.

Do not have hdaenabler, nor efi strings (guess you mean those strings in com.apple.boot.plist)

 

thanks.

 

btw, what revision is your board? do you have the latest BIOS version F6?

maybe I could check your dsdt.aml and use the legcay kext you are using (if we share the same board).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • HWMonitor2 v2.1.0rc3:  
    • There are new Bios updates that came out. I think these were to address the security defects in the kernel?   I updated both my 790 and 990 without issue.
    • Crack download software petromod v2016.2 GeoTeric v2017 paleoscan v2016.1 Leica CloudWorx v6.2 techlog v2016.1
      ttmeps#gmail.com ----- change "#" to "@"
      Anything you need,You can also check here: ctrl + f
        midas civil 2018 v1.2
      symmetre r410
      CP-Studio
      kepware 5.20
      saia PG5 2.1
      Motocom32 dx200 plus
      procon-win 3.5
      midas soilworks 3.5
      geostudio 2012
      technet GMbH PreDesigner 2017
      framecad structure v8
      csi preform 3d v6
      geogiga seismic pro 8.3
      citect 7.2
      3dbody 7.0
      3shape convince
      plastycad
      hypermill 2018
      deswik suite 2017.1
      Scania XCom 2.30
      tebis 4.0
      3shape implant studio 2017
      Cape pack V2.15
      Prinect Signa Station 2017
      exoplan 2017.03
      MagiCAD 2018 
      ExoCad 2017.12
      MillBox 2016
      GOM ARAMIS 6.15
      Blue Sky Plan v3 x64
      Maestro 3D Dental Studio 4
      Sirona InLab 4.2.5
      Maestro Ortho Studio Build 2.8
      Zirkonzahn 2017
      Dolphin Imaging 11.9
      Digital Smile System 1.9.8
      PlastyCAD 1.7
      3Diagnosys 4.1
      ArKaos MediaMaster 5.0.3
      smile designer pro v2.6.1 
      GEO5 2017
      TRUSS4 v10
      exocad Partial Framework 2017
      OnDemand3D Application 1.0.10.5385
      Dental Master 2016 
      Dental Wings (DWOS) 2016
      Ekahau Site Survey 8.6.1
      HYPACK 2016
      Dental Shaper
      Orcaflex 10.0e
      AQWA
      MOSES
      NAPA 2017
      offpipe
      maxsurf
      DNV GL AS PHAST
      DNV safty offshore 7.2
      aveva bocad suite 2.2.0.3
      AVEVA Engineering v14.1 SP1
      Aveva everything3D (E3D) v2.1
      napa ship designer
      numeca fine
      marine 3.1
      Veristar Hull, Stability, Homer, Optimise
      Hydrostar, ariane7
      AVEVA Marine 12.1 SP4.29
      sacs 11.0
      DNV Sesam all moduels
      Leica GEOMOS v5.0
      Rocscience RS3
      3shape orthodontic 2017
      Onyx ProductionHouse v12.1
      pc-dmis 2018
      exocad DentalCAD 2.2 Valletta
      exocad 2018
      frontline genflex 3.2c1
      frontline genesis 10.02
      ez-fixture 9.6.4
      ezgrid 9.5
      ucam 10.2
      em-test expert v8
      3shape design system 2017 2.17.3.0
      PC-DMIS 2018R1 x64
      Motor-CAD/Motorcad 11.1.5
      Synopsys Synplify FPGA 2017.09 Win&Linux FPGA
      Golden Software Strater 5.4.948
      Golden Software MapViewer 8.6.651
      Waterloo Visual MODFLOW Flex 2018.v5.1
      Cype 2017m
      Intergraph SmartPlant Spoolgen Isometrics 2014.v08
      Intergraph SmartSketch 2014.v08.00.00 R1
      Intergraph CAESAR II 2018 v10.00.00 x64
      Intergraph SmartPlant P&ID 2014 R1
      IHS QUE$TOR 2017 Q1
      Intergraph SmartPlant Review 2017 v12.00.00.0501
      ANSYS Apache Totem 14.1 Linux64
      Crosslight Csuprem 2018 x64
      Ensoft LPile 2018.10.02
      AnyBody Modeling System 7.1
      Antenna Magus 2018.0.v8.0 x64
      CGERisk BowTieXP 9.0.1
      PDI GRLWEAP Offshore Wave 2010-7
      NI AWR Design Environment with Analyst 13.03 x64
      Rock Flow Dynamics RFD tNavigator 2017.v17.3 x64
      CMG (Computer Modelling Group) Suite 2017.10
      PHDwin2.10.3
      meyer 12 2017.12
      Schlumberger petrel 2017
      HampsonRussell Suite 10.3 
      geoview 10.3 HRS 10.3
      Midland Valley move 2018.1
      jason 9.7
      Schlumberger CoilCADE 6.0
      Schlumberger StimCADE 4.0
      crystal 2018.1
      gohfer 9.0.1.6
      omni 2017.1
      tesseral pro 5.0.3b
      ERDAS IMAGINE 2018
      Waypoint Inertial Explorer 8.7
      Deswik suite 2017
      FAROBox PointSense plant 18.5
      EyeRadar 2.0
      Leica Xpro 6.4
      Trimble EdgeWise_v5.0.2SP1
      Trimble Business Center 4.0
      3DReshaper 2017 x64
      Amberg Tunnel 2
      virtual surveyor 3.6
      cloudworx for revit
      socet set 5.6
      socet GXP 4.1
      OrbitGT
      Riscan PRO 2.0 x64
      JAR reconstrucer 3.3.0 x64
      Materialise E-stage v6.6
      Virtual Surveyor 3.5
      CARIS HIPS and SIPS 10.2
      DP-moderler
      APS 7.6
      Imagestation SSK 2015
      Deswik 2017.2.1234
      EnterVol 2017.4 for ArcGis
      Geochemist Workbench 11.0.8
      Maptek Vulcan 10.1.4
      Tesseral Pro 5.0.3
      Tesseral 2D 7.2.8
      Global Mapper 19.0.2
      GEOVIA Surpac 6.8
      Ventsim 4.8
      MineSched 9.1.0 x64
      Paradigm 17
      VUMA3D-NETWORK 2018
      MineSight 12.0
      Maptek Eureka 4.1
      whittle 4.7.0.1
      Leapfrog Geo 4.0
      Leapfrog Geothermal 3.2
      Leapfrog Hydro 2.6
      OptiSPICE 5.2
      VPI transmission maker 9.8 x64
      VPI photonics Analyzer 9.8 x64
      VPI componentMaker 9.8 x64
      socet gxp 4.3
      GEOVIA GEMS 6.8.1
      GamaPrintPro
      PosterShop
      RipCente
      ProductionHouse 12
      neoStampa 8.1.5
      Fiery XF v6.5
      ORIS COLOR TUNER WEB 3.1
      ORIS PRESS MATCHER WEB 1.4
      FlexiSIGN & PRINT 12
      PhotoPrint 12 Cloud
      ColorGate V10
      neo Textil
      ACRORIP 9.03
      ErgoSoft RIP 15
      3shape trios 1.4.7.4
      OptiSystem 15
      plaxis 2D 2017
      plaxis 3D 2017
      Rocscience SLIDE3 V2017.010
      Rocscience SLIDE V7.029
      Rocscience RocData v5.008
      Rocscience RS3 v2.005
      Rocscience RS2 phase2 v9.023
      ITASCA 3DEC v5.20.250
      ITASCA Griddle v1.0.1
      ITASCA UDEC v6.0.323
      ITASCA PFC v5.0.32
      ITASCA Flac3D V6.0.48
      ITASCA Flac v8.0.443


×