Jump to content
mackerintel

Hope for AR5007EG?

81 posts in this topic

Recommended Posts

Hello. I was comparing linux drivers for AR5006 and AR5007EG. Then I applied the same changes to AirportAtheros. I changed:

-Removed card revision check

-Replaced RfBanks and registry tables

-Changed default radio revision

-Modified channel changing routine

-Never reset PCI Express-core fix

-Removed EEPROM size check

With this fixes driver now loads, I have Airport icon but no scanning or associating.

 

since airport aint scanning by itself and since people who rebrands their cards can work directly without mods AND WITHOUT KISMAC, i guess that maybe the actual way the thing are being made is not ideal, by the kind of errors syslog tell us (like it cant reset channel, or cant perform scan) i guess that we would needa less modified kext that only bypasses the revision and eeprom checks.

Aditionally it would be reeally better to have various kexts with different modifications...

From the things changed in the list maybe replacing Rfbanks , adding never reset and and MODIFIED CHANNEL CHANGING ROUTINES could be causing problems in mac OS that it wouldnt cause on linux.

 

Im just being hipotetic on this, not affirming.

 

I only see the kind of problems the actual way of modifications causes on the debug files and that it does not occur to people who has rebranded cards with original kexts (who uses the natural apple way to change channels and reset hardware)

 

Could it be possible to make differente versions only for betatesting? I guess maybe a kext with only the check bypasses and all the normal way of work of the default airport kexts (wich are already natrally made for 168c 001c) could work!

 

sorry about the terrible english :unsure:

waiting for answers

Share this post


Link to post
Share on other sites
Advertisement
since airport aint scanning by itself and since people who rebrands their cards can work directly without mods AND WITHOUT KISMAC, i guess that maybe the actual way the thing are being made is not ideal, by the kind of errors syslog tell us (like it cant reset channel, or cant perform scan) i guess that we would needa less modified kext that only bypasses the revision and eeprom checks.

Aditionally it would be reeally better to have various kexts with different modifications...

From the things changed in the list maybe replacing Rfbanks , adding never reset and and MODIFIED CHANNEL CHANGING ROUTINES could be causing problems in mac OS that it wouldnt cause on linux.

 

Im just being hipotetic on this, not affirming.

 

I only see the kind of problems the actual way of modifications causes on the debug files and that it does not occur to people who has rebranded cards with original kexts (who uses the natural apple way to change channels and reset hardware)

 

Could it be possible to make differente versions only for betatesting? I guess maybe a kext with only the check bypasses and all the normal way of work of the default airport kexts (wich are already natrally made for 168c 001c) could work!

 

sorry about the terrible english :)

waiting for answers

Probably you confuse two similar cards: AR5006 and AR5007. AFAIK the first one can be rebranded whereas the second can't. About just bypassing the checks it was the first thing I changed nad it failed then with another error (I/O error if I remember correctly). Making different versions would take a huge amount of time which unfortunately is a scarce resource for me now. What I could do is to release all the intermediary binaries I had. But I fear it would add even more confusion. As whole AR5007 never worked and if you want to continue the work and need the source just use otool -t -v: it's the only source I ever had. I could also release the code I used to inject additional data in sections but this code is ugly and unreadable. Now I happily use AR5008 which needs no modifications, is recognised as Airport, works under all OSes supporting wireless and has opensource drivers. So I would recommend to buy AR5008. AR5007 is somewhat a dead end. I don't say it's impossible but you need to spend a lot of time to make it work. Last sentence may however reveal to be wrong

Share this post


Link to post
Share on other sites

Anyway nice guide and cheers for putting up a good work on the kext

 

Just want to add a note - AR5006EXS (Super AG+) doesn't work with OSX at all. All it throws are HAL error 3. This card isn't supported. However the one without A works well under OSX !

Share this post


Link to post
Share on other sites
Hello. I was comparing linux drivers for AR5006 and AR5007EG. Then I applied the same changes to AirportAtheros. I changed:

-Removed card revision check

-Replaced RfBanks and registry tables

-Changed default radio revision

-Modified channel changing routine

-Never reset PCI Express-core fix

-Removed EEPROM size check

With this fixes driver now loads, I have Airport icon but no scanning or associating. But my card also bugs under linux. So it's possible it has some defect or is buggy. Additionally for me 802.11a would represent some advantages so tomorrow I go to the local stor to buy AR5008E-based abgn card (they work very well according to reports). So I post this work as is and probably won't continue it. But if someone is interested he can continue it.

P.S. @developpers: I wrote a helper application that allows to add data to __DATA__ section. It's ugly but if it could be useful for you say it here.

 

How did you make changes to the AirportAtheros.kext, because it closed source as fair as i know

Share this post


Link to post
Share on other sites

Could someone post an commented source or a basic guide so other people could work on this? Are these teh same methods of the 5005G (i know, different cards) ?

Even if so, id love to read some type of guide or commented source so other ideas could be tested.

:D:(

 

EDIT: Could you also make a patched version from 10.5.7 IO80211Family and its plugins?

QUESTION: I use a 5005G on a desktop, and the 5007EG on a Acer Laptop, the same kext would work on both?

 

EDIT2: Have already seen other drivers for atheros cards? i found 2, but they seem tiger-only:

http://wirelessdriver.sourceforge.net/

and the famous orangeware driver:

http://www.orangeware.com/endusers/wirelessformac.html

These links could help somehow on how they did it work? (Sorry i dont even know if they work on the 5007, but they could be a base for a new external kext couldnt?)

 

EDIT3: what the hell is hal status 67? (the error most people get on non-working kismacs: unable to reset hardware; hal status 67). I already searched for definitions of that everywhere with no success, even on the ah.h file from various revisions of linux drivrs. I guess that all the problems we have has to do with correctly reseting the hardware and the ath channels, may it be connected to the "never reset" mentioned in this thread? sorry about my english.

Share this post


Link to post
Share on other sites
OK here is my attempt at a guide:

 

First, make sure the card is on in another OS and restart. Those of you hoping to not have to dual boot are out of luck right now.

 

1. Starting from 10.5.5 and a vanilla kernel.

 

2. Download and install the Airport Update 2008-004. Reboot.

 

3. Download and install the IO8211Family.kext at the beginning of this thread with Kexthelper unless you feel like doing all of the prermission repairs and stuff.

 

4. Download and install Kismac trunk r319.

 

5. Reboot. You have a 40% chance of getting a boot without a kernel panic. Just retry, it will eventually reboot fine.

 

6. Open Kismac before you do anything. Go to prefererences and find the tab for drivers. Add the Airport Extreme Passive mode one. Active mode does not work. Exit that menu and then click start scan. You will start to see networks. Once you see networks quit Kismac.

 

7. Now go the airport icon in the top bar and click on Join Other Network. (if the icon is not there you need to go to network preferences and enable the icon.) Then click on show networks. Your network will come up. Click on it, click join and then it will ask you for your network password. Enter that and then it will connect to your network and be stable. You will have to set up a network in the networking preference panel for the airport card just like normal.

 

On my Presario C771 the WIFI lights are not on blue but the card still works.

 

When you restart you will sometimes get a kernel error. Just try again. When you restart you will only have to do steps 6 and 7 and will not have to reenter you network password if you put it in your keychain when prompted.

 

It works everytime I boot now as long as the hardware button on the notebook is not pressed. The network stays on all the time and is fast.

 

This worked for me!!! I can't believe it people! It really works! I am on an ACER Aspire one a150 with the "dreaded"ORIGINAL STOCK ATHEROS wireless card!

 

I installed OSX with IPC UNIVERSAL OSX86 Final,

 

And yes I included the atheros wireless on Install. but that just showed me that i had a wireless card and would scan but not show ANY available networks.

 

I tried this tutorial and worked like a charm AND I am connected via WPA!!!! not WEP!!!

 

This worked for me!!! I can't believe it people! It really works! I am on an ACER Aspire one a150 with the "dreaded"ORIGINAL STOCK ATHEROS wireless card!

 

I installed OSX with IPC UNIVERSAL OSX86 Final,

 

And yes I included the atheros wireless on Install. but that just showed me that i had a wireless card and would scan but not show ANY available networks.

 

I tried this tutorial and worked like a charm AND I am connected via WPA!!!! not WEP!!!

 

Just for you Aspire One A150 people,

 

I installed with Voodoo Kernal NOT Vanila!!!

 

Voodoo is better for the ATOM because it takes advantage of the Hyperthreading!!

 

Basically Hyperthreading is kind of like having a dual core versus Single Core!!!

 

And YES!!! My Atheros Card is still working!!! Just downloaded Firefox and in network settings of FIREFOX i picked auto-detect proxy settings for this Networked and works great as well!!!

Share this post


Link to post
Share on other sites

Hmm ... I got it working once but it caused a kernel panic ( i think i forgot to close kismac in all the excitement!! ) .

Now I cannot get it working again. I have the AR5007EG by the way.

 

I thought about taping pin20 but have no idea where the wifi card is on my Toshiba P200-RT108C lappy.

I looked at the manual and it doesn't mention its placement and googling hasn't turned up anything.

 

Can anyone help on this front ...coz even if i buy a replacement i need to know where/how to do it ..

 

 

thx

Share this post


Link to post
Share on other sites

also trying hard to get that card working

 

running ipc 10.5.6

 

tried pretty much everything i found here @ the forum

pretty much everything screwed my hackintosh up

 

last try was that (http://www.insanelymac.com/forum/index.php?s=&showtopic=135572&view=findpost&p=1051305) kext file

 

still everything is working fine not finding any networks with kismac though or no network is shown (@ settings -> networks)

 

would be really awesome if anyone could help me

i'm totally desperate about my wlan

 

thanks a lot

Share this post


Link to post
Share on other sites

Could we make AirPort scan by it self

without using KisMAC

 

it works but its boring.

 

KisMAC loads.

WLanDriver.kext

AtheroJack.kext

 

could we make a startup script??

Share this post


Link to post
Share on other sites
AR5007EG network is looking for nothing kicmac also does not help :)

hope that a normal kext

 

 

yes if some one make it scan that would be great

Share this post


Link to post
Share on other sites

Anyone get this working for 10.5.7?

 

I show the Airport connection in the Network properties but the Status remains as Off and won't turn on. I have a 001c adapter. and followed oldmaclover's how-to.

Share this post


Link to post
Share on other sites

Hey could you help me out I followed you're instructions but everytime I try to join the connection but it says the connection timesout.So could you prbably leave a reply or PM me thanks smile.gif

Share this post


Link to post
Share on other sites
Hey could you help me out I followed you're instructions but everytime I try to join the connection but it says the connection timesout.So could you prbably leave a reply or PM me thanks smile.gif

 

You have to close KisMac before you attempt to connect to a network.

Share this post


Link to post
Share on other sites

No thats not the problem the kismac scan works it finds the wireless network but when I go to join other networks to connect to it, it doesn't see anything.By the way i'm using iPC 10.5.6 Universal, so I picked the driver before installing.

Share this post


Link to post
Share on other sites
Guest Mr.Vaughn
Could we make AirPort scan by it self

without using KisMAC

 

it works but its boring.

 

KisMAC loads.

WLanDriver.kext

AtheroJack.kext

 

could we make a startup script??

 

Do you think you can attach those kexts?

Share this post


Link to post
Share on other sites
Here is what I do to resolve the stability issue on my Acer 5570z using the Atheros 5007eg wireless and the previous steps in this guide to get the card recognized:

 

1. Scan for wireless networks with KisMac

 

2. Stop KisMac once it sees networks

 

4. Connect to the network of your choice

 

5. LOG OFF (do NOT reboot)

 

6. Log back on using the SAME id/name you were logged in with before

 

7. The wireless network you were connected to before should connect automatically and stay connected with no drops!

 

I've done this multiple times this week, and it works everytime! I've stayed connected for over 12 hours at a time with great connection signal/strength and speed! Not a true "solution", but for now it works! I also used the tape trick on pin 20 of the Atheros card (detailed on other posts), so I don't need to boot into another OS first. The card always has power, and you don't have to worry about kill switch!!!

 

 

OK people this guide is just perfect

 

Running MSIWindosx86.iso with all the paches i need for my viewsonic vnb100 and it fully stable and everythig works great!! Everything!!!!!

 

So atheros5007EG works on OS x and it works perfect

 

BUT some steps are missing

an other day a will post the step ok?

 

Good luck to everybody....

Share this post


Link to post
Share on other sites
OK people this guide is just perfect

 

Running MSIWindosx86.iso with all the paches i need for my viewsonic vnb100 and it fully stable and everythig works great!! Everything!!!!!

 

So atheros5007EG works on OS x and it works perfect

 

BUT some steps are missing

an other day a will post the step ok?

 

Good luck to everybody....

 

Please post it quickly!!!!!

Well, the good news is it works on OS X, but to make it work propely at first, :s I need to reboot,reboot,reboot,reboot,reboot,reboot,reboot, and reboot. Any Fix to this

 

Thanks!

 

Macgeek

Share this post


Link to post
Share on other sites

ar5b91, thats my atheros card. I cant get it working. The PID/VID is 168c,002b. I replaced that on AtherosFix.kext and no luck. Airport wont pick it up.

 

I'm going crazy. I'm even gonna buy a wireless usb broadcom :).

Share this post


Link to post
Share on other sites
Hello. I was comparing linux drivers for AR5006 and AR5007EG. Then I applied the same changes to AirportAtheros. I changed:

-Removed card revision check

-Replaced RfBanks and registry tables

-Changed default radio revision

-Modified channel changing routine

-Never reset PCI Express-core fix

-Removed EEPROM size check

With this fixes driver now loads, I have Airport icon but no scanning or associating. But my card also bugs under linux. So it's possible it has some defect or is buggy. Additionally for me 802.11a would represent some advantages so tomorrow I go to the local stor to buy AR5008E-based abgn card (they work very well according to reports). So I post this work as is and probably won't continue it. But if someone is interested he can continue it.

P.S. @developpers: I wrote a helper application that allows to add data to __DATA__ section. It's ugly but if it could be useful for you say it here.

 

Is your wireless card vendor ID 168c,001c??? i can edit the file correctly because if you are using 10.6.2 with latest updates AirportAtheros.kext is no longer used with the new airport update, AirportAtheros21.kext is now being used.

 

IO80211Family.kext has 1 dependency which is IONetworking Family.kext which does not need to be edited.

 

If your vendorID matches the above i have edited the kext for you, just place those 2 kexts inside your /Extra's folder.

 

I cannot say my files work, i know i edited my own files to get AR5005 working under latest Airport update, works both in 32bit and 64bit. I have updated the file with the above vendor ID, just check and let me know ok. Or if you give me the correct vendor ID i can re-edit.

 

Apparently from searching AR5006 and AR5007 has same vendor ID, not to positive though.

 

http://www.mediafire.com/?qngyjxgtdzg

Share this post


Link to post
Share on other sites

Can you please give detailed steps?! Cause i have 168c,001c do I need to place it just like copy paste into /Extra ? Or do I also need to remove extensions.mkext etc?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×