Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
aqua-mac

8800 GT to Quadro FX 3700

127 posts in this topic

Recommended Posts

aqua-mac, thanks for all the help and documentation on this.

 

i've flashed my MSI 9800GT OC to a 3700, and after installing the GFX string in Leopard, everything seems to be working swimmingly. I didn't run any benches, but everything seemed to be working properly. So i rebooted my system and let it boot in to windows (XP 64-bit) so i could grab the quadro drivers. got all those installed, and as soon as i got the drivers and tried to up the resolution on my display, I lost signal over DVI. I tried a lot of different things, but when i swapped out for a VGA cable (plugged in to the same DVI port through an adapter) i got picture back. So i can only get picture in windows over VGA with the card flashed as a quadro.

 

Just wanted to see if anyone else had encountered this problem or if anyone had any ideas. I'm amazed that it seems to work flawlessly on my hackintosh partition, but it's all screwy in windows. I'm starting to think it might just be bad XP x64 drivers, but i don't really feel like installing a new OS to test that theory. Any ides would be much appreciated. Thanks everyone.

jdazzle34, what rom file did you use for the 9800gt? Did you use one of aqua-mac's or another?

Can I get a copy?

Thanks

Share this post


Link to post
Share on other sites

Dear Members!,

 

I am facing very strange problem with my 8800GT.

 

Sometime when I scroll big content page in any browser like (Safari, Firefox, Opera) the screen blinks 1 to 2 time and then system hangs. The problem only occurred with 8800GT display card.

 

I have another system with 7600LE and that work fine.

 

--------------

Jogi

http://www.techbabu.com

Share this post


Link to post
Share on other sites

Hi everry body I tried that evga card from geeks.com and it seams to of went good had to press y

three times the machine booted nicely and i loaded some quatro fx drivers from nvidia and that went smooth and the machine rebooted. the log on was full res but i had no icons no program manager

and no adminivstrative previliges. how do you get drivers for xp pro 32, vista 64, mac osx86 10.5.6

and up leo4allv3 10.5.2 i have been looking and fond nothing. please help.

Share this post


Link to post
Share on other sites

Yeaa the card works with the real nvidia drivers in xp thank you Aqua-mac, I want to grow up to be like you.

I think I still need kext for Osx86 I never see Quadro Fx 3700 in none of the releases. I would like to use iatkos 5 how

should i do this PS. i am not to good with the terminal.

Share this post


Link to post
Share on other sites

Hey aqua-mac, I have a nVidia Quadro FX 570m, the total VRAM is not detected and QE/CI is not supported in mac. The 570m uses the exact same GPU (G84) as the nVidia GeForce 8600m which is in MacBook Pro's, would it be possible to flash a Quadro FX 570m to a GeForce 8600m?

 

Let me know if you need my graphics card rom or something else to answer my question.

 

Thanks!

Mike

Share this post


Link to post
Share on other sites

hello aqua, i flashed succesfully my 8800GT to 3700

this is what i get:

 

hipset Model: Quadro FX 3700

Type: GPU

Bus: PCIe

Slot: Slot-1

PCIe Lane Width: x16

VRAM (Total): 512 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x061a

Revision ID: 0x00a2

ROM Revision: xx.xx.xx - NVIDIA.ROM

Displays:

Philips 190X:

Resolution: 1280 x 1024 @ 75 Hz

Pixel Depth: 32-Bit Color (ARGB8888)

Main Display: Yes

Mirror: Off

Online: Yes

Rotation: Supported

Display Connector:

Status: No Display Connected

 

I couldn't get it to work with EFI Strings (nor yours or mine), so now it works with chameleon's boot:GraphicsEnabler=Yes option

Didnt try dsdt adding, cause i get QE/CI with boot method so it's ok

 

Thing is that i see no difference, tried a lot of benchmarks and the results are the same as with 8800GT before

hmmm are u sure that quadro's drivers have better support than 8800GT's?

 

of course i'll test more and i'll decide if i go back or keep it Quadro

thanks for your work :)

 

EDIT: After some hours i left the monitor on power management: Display off , when i returned the screen was only "noise" like old TV!

istockphoto_4783663_tv_static.jpg

:)

i had to reboot, but i flashed back to 8800GT (a 64EFI rom)

Share this post


Link to post
Share on other sites

Hi there aqua. I would like to know what's the exact method you're using to change one card's bios from 9800GT to the FX3700 equivalent. Obviously changing the ID number(s) alone does not work (I've tried it). Do you also mess with timings, what about fan speeds (mine is stuck at 100% when I tried to use one of your bios).

 

No matter what I tried I can't change *my* 9800GT's bios to FX3700 equivalents, only your bios work but since they are of different models they have many bugs in my system (recognize half the VRAM, full fan speed, only windows recognizes the card, etc, etc).

Share this post


Link to post
Share on other sites

Steven 185,

 

If you have a look at the roms in my download, you can see the code that I changed and I got this code from an actual Quadro FX 3700 (compare with Hexedit). It would be much more difficult to change a 9800 GT as the chip is slightly different to the Quadro's. I daresay I could do it if I had a card, but there is a certain amount of trial and error involved. The advantage of the Quadro drivers is only in a few programs such as Maya etc.

 

Mike2732,

 

What is the device id of your card? The card can only be softstrapped if the last digits are different. The first 3 digits must be the same. Also if your card has a similar device id then it should be able to be got working without flashing.

Share this post


Link to post
Share on other sites

aqua-mac,

 

Great stuff! I've got an FX3700 from an unused PC workstation that I'd like to run in my MacPro3,1 and I'm not quite sure what needs to be done for OSX to recognize it. I recently upgraded to SL, and I've got Win7 x64 running in BootCamp. When I swapped my existing 88000GT for the FX3700 card, the machine will boot just fine into Win7, but when I hold down Option to try to boot into OSX, the monitor just stays black. I tried parsing through your instructions and the many posts here, but couldn't quite figure out what needs to be done to get OSX to see the card. I would be extremely grateful for any help you could provide.

 

Thanks, -Profiene

Share this post


Link to post
Share on other sites

Hi profiene,

 

To put a card like that in a real mac, you will have to put it in slot 2 and leave your mac card in slot 1. Your PC card lacks the EFI firmware to boot your mac on it's own. If you connect your monitor to it, you won't get a picture untill you get to the desktop.

Share this post


Link to post
Share on other sites
Booim,

 

The artifacts are no doubt caused by a slight mismatch between your card and my rom that is from point of view. I suspect it is a memory register mismatch. I will take a look.

 

Booim, I took a look at your rom, you could try this:

 

http://rapidshare.com/files/262751056/booim3700.rom.zip

 

 

Thanks a lot aqua-mac. :(

 

I will certainly try this one and report the result soon (I'm still in the middle of a project at this moment, so I will give it a try sometime next week).

Share this post


Link to post
Share on other sites
s2n117,

 

Yes that looks like the original type of 8800 GT.

 

Georgio,

 

As I don't have a 8800 GTS it is unlikely to happen from me.

 

Booim,

 

The artifacts are no doubt caused by a slight mismatch between your card and my rom that is from point of view. I suspect it is a memory register mismatch. I will take a look.

 

Booim, I took a look at your rom, you could try this:

 

http://rapidshare.com/files/262751056/booim3700.rom.zip

 

Hy Aqua,

 

I own two Gigabyte 8800GT, model name gv-nx88t512hp rev.1.0 and i tried your bios- on each card separately-(512 MB version) with the frequencies changed to the ones of my card and i got annoing artefacts in bios and when the system loads the os, even strange pixels when I work in After Effects and load OpenGl acceleration.Seems there are the same problems like Booim encountered, and like you said is an memory register mismatch problem, or something else rather that too high frequencies.

I even tried Booim's bios and I had to reflash the card blindly :D .Can you please take a look at my bios?I have two similar video cards and I'd be very, very happy that I could use them in sli mode (i didn't tried them to sli, bc. of the artefacts).

This is the link of my original bios: http://rapidshare.com/files/319723906/clim...8800gt.rar.html

Maybe you could take a look when you have the time.Thanks a lot, you made one big leap ahead with your work !

Share this post


Link to post
Share on other sites

Hi AquaMac,

 

I flashed your Quadro 4500fx rom fix to my fx4500 and it worked great under Leopard, I used NVinject to get the system to see the card and all functionality was enabled. I've since installed snow Leopard, and once again I now have just a 512mb frame buffer again ;)

 

Have you found a way to remedy this in SL as I understand that NVinject doesn't work in Snow Leopard.

 

One thig that interests me is that on your website, you have your new Hackintosh running with 3x 280gtx cards; did you have to mod the roms on these as well, or did they drop straight in?

 

Many thanks in advance. :)

Share this post


Link to post
Share on other sites

Hi Aquamac,

 

Just tested your QuadroFX3700 rom and it works flawlessly in my Win7 64 bit. I used the latest Quadro performance driver (191.78). In Maya 2009, the performance gain was very noticeable. From an average 14 fps (8800GT) to 20 fps (QFX3700) even by enabling the smooth wireframe option.

 

The performance advantage in OpenGL Extensions Viewer 3.0 was even greater (at least before it crash due to the unsupported Win7 64bit platform, not the softmod or driver issue). It leaps from an average 170 over 1000 fps... When they release the new Win7 version, I'll post the real results.

 

These are the list of 64bit (pro) apps I tested: Maya2009, Mudbox 2009 SP2, RealFlow 4.3.8, Nuke 5.1v5 & 3D Studio Max 2009.

 

On the gaming side, the softmod performance is just about the same as 8800GT (tested using the latest 195.62 WHQL driver). These are the games I already tested: HawX, COD MW2, Torchlight, PES 2010, Far Cry 2, Crysis Warhead, NBA 2009 & GRID.

 

I'll post the result in my Hacintosh 10.5.8 soon...

 

Anyway, thank you for your time and excellent work with the softmod ROM. :)

 

These are the screenshot I took using Maya 2009.

 

8800GT - smooth wireframe: OFF

post-222445-1261702490_thumb.jpg

 

QFX3700 - Smooth wireframe: ON

post-222445-1261702532_thumb.jpg

Share this post


Link to post
Share on other sites

Hehe thats my bike :D . I'm am Maryus3D from Guru3D. http://forums.guru3d.com/showthread.php?t=264654&page=7

 

Well aqua-mac you are a genius guy... godlike. But there are some problems. This is for every one. If you read the nvsoftquadrox thread from Guru3D you'll find that the bios mod is not enough. The driver needs to be patched too otherwise there will be no performance. Booim I get the same performance in XP with the geforce driver :) . That is not the true performance. The true performance come only with a patched driver and I don't know why. If you mod a 8800GT and install a regul Quadro driver and you'll enter in Nvidia control panel (no matter if is vista\xp\7) the workstation function is missing and there are no pro software in profile menus only games even if is a Quadro driver installed. As you can see in the image below there is a comparison between a regular geforce driver and a patched Quadro driver.

 

fx3700.th.jpg

 

Now there are some true differences and would be more if Maya uses more cores from CPU. Maya currently use only one core in viewport :) so the GPU is CPU limited.

 

Here are some differences between a patched driver ( 182.08 is the latest) and a regular Quadro one.

 

111111uh.th.jpg and 5555gh.th.jpg

 

As you can see clearly in windows 7 the workstation function and pro apps are missing (CoD4 instead of pro apps) and in winxp with patched driver there is a workstation function and pro apps.

 

Now my questions are:

 

Why is like that?

Aqua-mac can you make a stringer bios-mod or is not depend on that? The patched driver stuff is very stressful we are limited to XP 64 and old versions of 3D max, because new versions of 3D max needs the 3DS max performance driver support thing from newer driver.

Can 9600GT and 9500GT be modded? The Quadro equivalence are FX 1800 and FX 580.

What about GT200 cards?

 

BTW:

I also did some tests in iDeneb 10.5.8

mac2j.th.jpg

 

I'v got even worse performance then a regular geforce driver :( . I use GFX string, nvdarwin and nvinject there were all the same. Maybe is 5.8 fault now I'm downloading Snow OSX 10.6.2. Hope I'll be more lucky :) .

 

Sorry for my bad english is not my native language.

 

 

EDIT:

OK!!!

 

I finally installed Snow Leopard 10.6.2. I use NVenabler for the card. I get same performance in windows 7. Well is not bad but it could be better. In 10.5.8 was horrible. I wish I have the true performance from XP with 182.08 patched in OSX SL. Windows sucks so bad and I'm relay bored about XP. :(

sleo1.th.jpg

 

BTW: I don't know how my Q6600 became a Xeon and DDR2 became DDR3 :) .

Cheers

Share this post


Link to post
Share on other sites
If you mod a 8800GT and install a regul Quadro driver and you'll enter in Nvidia control panel (no matter if is vista\xp\7) the workstation function is missing and there are no pro software in profile menus only games even if is a Quadro driver installed.

 

Now I've successfully patch the Vista x64 driver, use it in my Win7 x64 and IT WORKS.....

(I need ReadyDriver Plus 1.1 to disable Windows driver signing enforcement.)

Eventhough I haven't make an extensive test, but Maya 2009 & 3D StudioMax 2009 works like a charm :D 3D StudioMax even use the real "Performance Driver" provided by nVidia instead its own Direct3D or OpenGL driver.

 

I'm talking about almost 4x faster viewport rendering performance compare to the unmodded 8800GT and 2,5x faster than softmodded QFX3700 without the patched driver, but sadly Redway3D benchmark crashed... ;)

not that it matters...

 

Bike scene:

8800GT: 14 fps

QFX3700 (Quadro 191.78 driver): 20 fps

QFX3700 (patched 182.08 driver): 54 fps

 

TextBench scene:

8800GT: 11 fps

QFX3700 (Quadro 191.78 driver): 13 fps

QFX3700 (patched 182.08 driver): 42 fps

 

Tested @1680x1050

 

This is the real Quadro control panel :D

post-222445-1261877743_thumb.jpg

 

post-222445-1261877921_thumb.jpg

Share this post


Link to post
Share on other sites

Hi Maryuosx,

 

Here's how I did it:

 

1. Install ReadyDriver Plus 1.1:

http://www.citadelindustries.net/readydriverplus/.

 

2. Install the latest RivaTuner:

http://downloads.guru3d.com/download.php?det=163

(if you don't have ReadyPlus installed, RivaTuner will not be installed properly).

 

3. Install DriverCleaner Pro 1.5:

http://downloads.guru3d.com/download.php?det=745.

 

4. Download the appropriate driver at:

http://www.nvidia.com/object/winvista_x64_182.08.html.

 

5. Run the driver but DO NOT install it just yet or you can just extract it and move the driver to other place than the default installation folder (IT'S A MUST).

 

6. Because I don't know the file extension for the script, I just copy the one available in C:\Program Files (x86)\RivaTuner v2.24\PatchScripts\NVIDIA\SoftQuadro4 (any script will do) and rename it to NVSoftQuadroX (or anything you like).

 

7. Open the script in Notepad, erase everything and replace it with the following:

; NVSoftQuadroX patchscript by Styler - for XP 64bit Quadro softmods
 ; based on gellmaR (gellmar@yahoo.com) patchscript
 ; vista fix - ultrapregnant dog (for 182.08)
	  ;date 07.04.2009

  [Common]
  SrcFile	= nvlddmkm.sys
  BakFile = nvlddmkm.old
  HlpFile = NVSoftQuadroX.rth
  MakeCRC = 1
  Packed	= 1

  ; common sequence for AntiProtect (64-bit)
  Src0	= FF 96 60 08 00 00 BA 00 10 10 00 48 8B CE 0F BA F0 1F 44 8B C0
  SCM0	= FF FF 00 00 FF FF FF FF FF FF FF FF FF 00 FF FF FF FF FF FF FF
  Dst0	= FF 96 60 08 00 00 BA 00 10 10 00 48 8B CE f9 90 90 90 44 8B c0
  DCM0	= 00 00 FF FF 00 00 00 00 00 00 00 00 00 FF 00 00 00 00 00 00 00
  Num0	= 0

  Src1	= BA 00 10 10 00 0F BA F0 1F
  Dst1	= BA 00 10 10 00 F9 90 90 90
  Num1	= 0


  ; common sequences for SoftQuadro & NVRC unlocks
  Src2	= BA 84 10 00 00 FF 93 20 0A 00 00 0F BA E0 10 
  SCM2	= FF FF FF FF FF FF FF 00 00 FF FF FF FF FF FF
  Dst2	= BA 84 10 00 00 FF 93 20 0A 00 00 F9 90 90 90
  DCM2	= 00 00 00 00 00 00 00 FF FF 00 00 00 00 00 00
  Num2	= 3

 

8. Close, save the file and run it (there supposed to be no error messages, if you encounter some error messages, please ask the guy who created this script) This is the link:

http://forums.guru3d.com/showthread.php?t=264654&page=7.

 

9. The script will ask for the location of nvlddmkm.sy_ or nvlddmkm.sys, so just point it at the driver location.

 

10. After finish patching the driver, uninstall nVidia driver and reboot the computer in safe mode.

 

11. In safe mode, run the DriverCleaner Pro and add multiple filter (nVidia + nVidia Stereo + nVidia WDM) just to be sure that all nVidia related files and registry entries will be gone.

This is the reason that you MUST place the patched nVidia driver in some place other than the default location, because this utility will erase everything (files and registry) related to nVidia.

 

12. Reboot the computer again (normal mode) and if you have that ugly screen resolution, you have done right so far (otherwise just run step 10-11 all over again).

 

13. Make sure you wait a little while for Windows to finish installing the default VGA compatible driver for your display (you can check it in the device manager if the device exist, otherwise you will need to wait for it to appear).

 

14. Once the Windows finish installing the default driver, you can go ahead and install the patch driver and WHOILA....!!

 

15. You now have the REAL QUADRO in Windows.

Share this post


Link to post
Share on other sites

Because the Win version of this softmod gives such a huge performance impact on those pro apps, I'm curious if the Hacintosh could have the same kind of improvements. At this moment, it still have the exact same performance before the softmod.

 

I guess it needs some sort of kext patching to make this OS recognize and take advantage the true potential of quadro. Just like its Windows counterpart which still needs driver patching before it can run like a real quadro. I'll be researching to find out what is the real quadro performance on a real macpro and post the result to some genius guy like Aquamac who I'm pretty sure can figure out this sort of things...

Share this post


Link to post
Share on other sites

Agree! OSX need a special gfx strings or a special injector wich must include something similar to that patch script to unlock the pro features from the driver otherwise is useless just to have the Quadro name and geforce boost. I think OSX would be faster than windoes in maya because of native OpenGL + it is UNIX based. I,v tested maya on linux long time ago and it was a lot faster and stable then windows. I'm sure that in OSX it would be the same thing. I hope Autodesk release a 64bit version of maya for SnowOSX and then it will kill windows for good.

Share this post


Link to post
Share on other sites
Agree! OSX need a special gfx strings or a special injector wich must include something similar to that patch script to unlock the pro features from the driver otherwise is useless just to have the Quadro name and geforce boost.

 

Sadly, according to Aquamac who once used real QFX 4500 on a real mac, the performance improvement over regular geforce on mac was neglectible, even on 3D apps. And after searching the net, I also found similar result...

 

Maybe someday when nVidia or Apple develop special quadro kext/driver to boost the OpenGL performance on workstation apps, we'll have the real quadro performance on OSX...

Share this post


Link to post
Share on other sites

Wow Booim, I stumbled on this thread while researching how to mod my GeForce 9800GT to a Quadro FX3700. I assume before I attempt to patch any drivers I need to actually mod the BIOS. I see the one from aqua-mac is for the 8800GT which I assume I cannot use.

 

Can either you or aqua-mac tell me the steps I need to perform? I assume that I have to use NVFlash to get a copy of my BIOS. What do I look for after that?

 

Here are the specs on both cards from the nv4_disp.inf file:

 

NVIDIA_G92.DEV_0614.1 = "NVIDIA GeForce 9800 GT "

NVIDIA_G92.DEV_061A.1 = "NVIDIA Quadro FX 3700"

 

It seems like I just need to change the last digit of the device id from 4 to A. Is this possible? I'm a software developer but I've never modded hardware before. Any help you can give would be greatly appreciated.

 

Thanks,

 

~jr

Share this post


Link to post
Share on other sites
Sadly, according to Aquamac who once used real QFX 4500 on a real mac, the performance improvement over regular geforce on mac was neglectible, even on 3D apps. And after searching the net, I also found similar result...

 

Maybe someday when nVidia or Apple develop special quadro kext/driver to boost the OpenGL performance on workstation apps, we'll have the real quadro performance on OSX...

 

 

So let me get this right! If some body buy a Mac Pro with a 1,699.95 $ Quadro FX 4800, he will have the same performance as a GTX260 in windows? Thats crazy :D:blink: !!! Is very hard to believe that :(.

 

 

BTW: Apparently 9800GT has the same hardware as a 8800GT. Some of my friends tried the mod in 9800GT and it works but some of them had problems. Maybe because they don't use a reference model :)

Share this post


Link to post
Share on other sites
So let me get this right! If some body buy a Mac Pro with a 1,699.95 $ Quadro FX 4800, he will have the same performance as a GTX260 in windows? Thats crazy :):) !!! Is very hard to believe that :) .

 

Sadly it's true.... Unless the apps you use has specialized quadro accelerated plugins, such as Elemental.

 

But on the bright side, if you have CUDA enabled apps which might be available on the next version of every major 3D apps, it will run way faster than any consumer level card (after installing the latest CUDA runtime which can only be installed if you have this QFX4800 and perhaps the next gen of quadro).

 

@JohnnyRoy:

The softmod bios I used was built by Aquamac, he's the genius behind this successful softmod...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×