Jump to content
VooD

Acer 5920G + Leopard 10.5.5 Vanilla Retail GUIDE 2.0

443 posts in this topic

Recommended Posts

Hello Vood

 

You have made a lot of people a little bit happier with your instructions, I hope you can make me happier too ;)

I have a 5920g, the original leo 10.5.0 disk, an 80gig usb drive, a usb mouse and a usb keyboard.

 

My laptop says on the sticker on the lower right corner “Up to 1024MB nvidia GeForce 8600m GT TurboCache”, on a sticker on the left corner it says 256mb 8600m GT and GPUz says it has 256mb vram.

When I boot osX or try to install it, it says VESA3 14mb

 

When I do install nvinject, everything turns to {censored}...

the os installs and boots ok but it becomes totally unresponsive clearly due to graphics card issues because while windows do open, it takes a lot of time to do so...

As long as I don't install nvinject it works ok but with crappy graphics...

I guess I can't do anything about it, rigt VooD

 

Turbocache nvidias can't work in os x as far as I know, because they use shared memory. I know this notebook has a detachable vga card, so maybe you can find a not turbocache card somewhere and swap in.

Share this post


Link to post
Share on other sites
Advertisement

Wow!!

 

I didn't expect such a fast reply.

 

I understand what you are saying but buying a new card is not possible for me.

 

In essence, my question was if my card is a turbocache or not, since it has it's own memory.

 

Thank you again VooD, keep up the good work!!!

 

I might keep it without QE, CI as a desperate solution...

Share this post


Link to post
Share on other sites

Hey !

That is awsome work Vood !

Though I haven't yet been able to get hold of a Vanilla DVD of the Leopard MAC OS X yet. So I'm currently using Iatkosvi5. I know I should use your guide... but without a retail DVD... I can't really use it...

 

Anyways, here is my problem (I'm on an acer 5920g btw):

 

1.Installed the Iatkosi5 (which is the leopard 10.5.5 version of MAC OS X)

2.I Found your guide and so installed most of your drivers (I then later replaced the disabler and Smbios Iatkos system kexts with your ones) and everything worked perfectly (including my internal microhpone for some reason)!!!

3.I Updated to 10.5.6.... and everything went wrong...

 

First of all my battery metre seems to decide for itself when it should appear... sometimes I start my mac up and I see it... some other times it decidesnot to show up....

Secondly, all my sound drivers dont show up in system preferences anymore !

I mean if I go to the Sound Pane... I only see HD Audio output which seems to be my laptop speakers as they work... so the jacks in the front and all that disapeared since the update... I have replaced the appleHDA kext... but I have not got any progress... still the same things...

 

It's like the OS isn't starting up the extensions properly...

You know the way the battery metre doesn't always startup and my audio drivers don't work... it's kind of annoying... Would you be able to help me please?

 

Thanks in advance,

regards

 

RESOLVED !

 

I just installed all the drivers again and the new applhda and ALCinject...

Everything works near perfect... the only problem now is that my 3rd partition (one is mac one is vista and the other is basic storage) disapeared...

I used it as a partitions to exchange files and store files between my mac and vista OS. It is still there... cause I see it in Vista... yet when I open up mac... I only see my Vista and Mac hard drives... quite irritating !!!

Share this post


Link to post
Share on other sites

Hi!

I have perfectly working deep sleep!!!!

Who also wants this function must install PC_Efi 9. by Netkas (it suports sleep mode) and DeepSleep widget. You can get deep sleep only with disconected all usb (with batery working) and disconnected AC adapter.

Think it will help to get deep sleep.

Share this post


Link to post
Share on other sites

thanks alot for this guide VooD! used with a combination of this and iatkos5i as the main system with your filepack. great stuff. also running pc efi9 but i get bad sleep image/sleep image has garbage message so no deep sleep for me yet. maybe when i get my retail copy next month i'll give it another shot. anyway thanks again!

Share this post


Link to post
Share on other sites

Hello VooD,

 

You are awesome!! Thanks for this great tutorial.

 

I have the same SPEC 5920G as you have and was trying to use 10.5.6 Retail DVD to install in this machine. Guess what!!

 

It did not work out.

 

Everything was fine until to the steps that I repeated to install the other drivers(Ethernet, PCI, Adudio etc) and I found that once I installed PCI driver, it was the root casue for booting failure. When I use F8 with -v to boot, I saw something like "fail to load AppleICPCI" then stop. I wonder if this driver is not comaptible. How can I fix it.

 

Tried at least ten time installation(couldnt take more). To see if I can get any luck here.

 

Highly appreciated any input or you need any information from me.

 

Cheers,

 

Kaihoo,(sorry for my English0

Share this post


Link to post
Share on other sites

You should read the whole tutorial

 

Update 3, UPGRADING TO 10.5.6: dobry_kamil found that updating to 10.5.6 makes the ethernet and wifi cards no longer work because an incompatibility with the hacked IOPCMCIAFamily.kext. Here's an alternate file he found which should make both network adapters back to workAttached File IOPCMCIAFamily.b2.zip ( 140.25K ) Number of downloads: 156

Share this post


Link to post
Share on other sites
You should read the whole tutorial

 

Hi VooD,

 

Yes, I followed your tutorial again, use 10.5.4 retail DVD, upgrade to 10.5.6. Everything is working great. YOU ARE MAN, thanks!!

 

But, only problem was I got the Dell 1490 and installed in my ACER 5920G which is the same SPEC as you have. It didnt work. I also installed the kext for 10.5.6 version. No luck.

 

I saw Airport in the network performance but I could not turn it on. Is this wireless card working out of box. Or do I need to do some extra steps to active.

 

Thank you for your help.

 

Cheers!!

Share this post


Link to post
Share on other sites
Hi VooD,

 

Yes, I followed your tutorial again, use 10.5.4 retail DVD, upgrade to 10.5.6. Everything is working great. YOU ARE MAN, thanks!!

 

But, only problem was I got the Dell 1490 and installed in my ACER 5920G which is the same SPEC as you have. It didnt work. I also installed the kext for 10.5.6 version. No luck.

 

I saw Airport in the network performance but I could not turn it on. Is this wireless card working out of box. Or do I need to do some extra steps to active.

 

Thank you for your help.

 

Cheers!!

 

I think I wrote somewhere in this topic the card needs to be turned on at least once in windows. (and you shouldn't turn it off from os x because you would have to turn it on again from windows)

Share this post


Link to post
Share on other sites
I think I wrote somewhere in this topic the card needs to be turned on at least once in windows. (and you shouldn't turn it off from os x because you would have to turn it on again from windows)

 

 

Highly appriciated your fast reply.

 

I will give a try and report the result. Thank you very much!!

 

Cheers.

Share this post


Link to post
Share on other sites

Hello again! :)

 

I've been using Chameleon 2.0RC1 boot manager since it became public, along with the official 10.5.6 update. What I have noticed is that using boot flag USBBusFix=Yes makes system bootable on every restart/power without any kind of hanging during booting. I made it fixed inside com.apple.Boot.plist as Kernel Flag. ;)

 

For those who wish internal Mic to work, here is one "Legacy" driver, ALC888STNotebook.kext.zip found at http://www.insanelymac.com/forum/index.php?showtopic=127819 . With this you have working InternalMic, LineOut and InternalSpeakers, maybe even SPDIF out but I do not have possibility to try that one....drawback is that there is no Line In and external microphone input and no jack sensing (or jack autoswitching) whatsoever. This kext is meant to be used in pair with vanilla AppleHDA.kext. I am also using DSDT patch, and maybe it is possible that patching is needeed for using this kext. Here is mine DSDT.aml, just in case if it is needeed DSDT.aml.zip

 

For users of Acer5920G laptop with nVidia GeForce 8600M GT 512MB, here is NVinjectGo512MB.kext.zip for fully working 512MB with QE/CI.

Share this post


Link to post
Share on other sites
Hello again! :)

 

I've been using Chameleon 2.0RC1 boot manager since it became public, along with the official 10.5.6 update. What I have noticed is that using boot flag USBBusFix=Yes makes system bootable on every restart/power without any kind of hanging during booting. I made it fixed inside com.apple.Boot.plist as Kernel Flag. ;)

 

For those who wish internal Mic to work, here is one "Legacy" driver, ALC888STNotebook.kext.zip found at http://www.insanelymac.com/forum/index.php?showtopic=127819 . With this you have working InternalMic, LineOut and InternalSpeakers, maybe even SPDIF out but I do not have possibility to try that one....drawback is that there is no Line In and external microphone input and no jack sensing (or jack autoswitching) whatsoever. This kext is meant to be used in pair with vanilla AppleHDA.kext. I am also using DSDT patch, and maybe it is possible that patching is needeed for using this kext. Here is mine DSDT.aml, just in case if it is needeed DSDT.aml.zip

 

For users of Acer5920G laptop with nVidia GeForce 8600M GT 512MB, here is NVinjectGo512MB.kext.zip for fully working 512MB with QE/CI.

 

Did you already try the new VoodooHDA.kext?

 

I don't have the laptop with me at the moment so I can't make all the testing I'd wish. But yes, DSDT + Chameleon is definetively something I was planning to add to the tutorial.

Share this post


Link to post
Share on other sites

Hi Vood!

I try to use DSDT patcher but have no luck :( ! Do you know something about it? What about manual from you? Could you do this for all acer users ;) ?

Share this post


Link to post
Share on other sites
Hi Vood!

I try to use DSDT patcher but have no luck :( ! Do you know something about it? What about manual from you? Could you do this for all acer users ;) ?

 

I'm sorry but I don't have this notebook any longer with me. It's owned by a relative of mine now and I only can make experiments with it from time to time.

About DSDT there's lots of manuals about. Anyway, you probably should take a look at DSDT Patcher included documentation.

Share this post


Link to post
Share on other sites
Did you already try the new VoodooHDA.kext?

 

I don't have the laptop with me at the moment so I can't make all the testing I'd wish. But yes, DSDT + Chameleon is definetively something I was planning to add to the tutorial.

VoodooHDA.kext? Nope...didn't even knew for that one :( But shure, I will try it in next few days and I will report the results here. From what I have read, it seems promissing. Thanks for the tip ;)

Share this post


Link to post
Share on other sites

hey, i turned on "Boot with LAN" and put that as my first boot priority.

after that i don't need windows to turn the wifi on or off. (ahteros 5006 works oob)

 

idk, if anyone fixed that, or was fixed in 10.5.6, but it works for me. ( i dont have windows installed in this machine).

 

also, can anyone tell me how i can enable sleep with the altered kext?

Share this post


Link to post
Share on other sites

Hello again!

I haven't been here for a long time. In the meantime i had to work with Micro§hit again 'cause of my work.

 

But thx 2 carbon-copy-??? i had my working leopard-partition copied on my external HD :-)

 

Now I have some questions:

 

1.) I am going to boot Leopard from my external-USB-HD with the help of the boot-cd that Vood offered...

 

2.) ... then copy the USB-HD on a partition with cabon-copy ...

 

3.) ... and now wanna keep my Vista and be able to boot both (Vista & Leopard)

 

since my vista-sp1 is far more stable and more compatible with our Acer-5920G-Hardware (unfortunately) :-( then Leopard ... i would prefer to be able to boot Leo from within the "Vista"-Boot-Loader (whatever it's exact name is) ...

 

can someone help me to get that done (remember, I have no Vista-Repair-Disk)

 

thx a lot guys

Share this post


Link to post
Share on other sites
since my vista-sp1 is far more stable and more compatible with our Acer-5920G-Hardware (unfortunately)
I REALLY REALLY REALLY wish Vista or even Windows 7 were half as fast as Mac OS X runs in this computer...

 

Really, using my instructions the new info in the edits, chameleon rc 2.0, and dsdt patching this laptop runs GREAT.

Never had this laptop crash in osx, and everything runs as intended.

 

Btw if you really want to use Windows PLEASE use XP SP3...the difference between Vista's performance (even sp1) and XP SP3 is simply huge.

Share this post


Link to post
Share on other sites
I REALLY REALLY REALLY wish Vista or even Windows 7 were half as fast as Mac OS X runs in this computer...

 

Really, using my instructions the new info in the edits, chameleon rc 2.0, and dsdt patching this laptop runs GREAT.

Never had this laptop crash in osx, and everything runs as intended.

 

Btw if you really want to use Windows PLEASE use XP SP3...the difference between Vista's performance (even sp1) and XP SP3 is simply huge.

 

"the new info in the edits" --> which files/drivers have been edited?

 

I will give it a shot again,

the only reason i changed back to windows, were my cashes-on-boot and sometimes craches-within-osx (especially when loading torrents) and of course the skype-issue.

 

i will give the USBBusFix=Yes hint a chance, too.

 

see you VooD

Share this post


Link to post
Share on other sites
"the new info in the edits" --> which files/drivers have been edited?

 

I will give it a shot again,

the only reason i changed back to windows, were my cashes-on-boot and sometimes craches-within-osx (especially when loading torrents) and of course the skype-issue.

 

i will give the USBBusFix=Yes hint a chance, too.

 

see you VooD

 

 

Look at the bottom of my first post. Skype seems to work with the new audio driver. And about crashes-within-osx, I never had one.

Share this post


Link to post
Share on other sites

Hello again :D

 

Here is new HDA driver based on previous ALC888STNotebook.kext. The diference is that all I/O ports are fully working (Line In, Ext Mic & Internal Mic autoswitching, Internal Speaker & HP Out autoswitching). Instructions are inside archive.

 

Enjoy. :)

 

Acer5920GHDAv1.0.zip

 

Edit: Use this driver with stock (aka vanilla) AppleHDA.kext, without ALCInject or HDAEnabler kexts.

Share this post


Link to post
Share on other sites
Hello again :)

 

Here is new HDA driver based on previous ALC888STNotebook.kext. The diference is that all I/O ports are fully working (Line In, Ext Mic & Internal Mic autoswitching, Internal Speaker & HP Out autoswitching). Instructions are inside archive.

 

Enjoy. :D

 

Acer5920GHDAv1.0.zip

 

Great :)

Share this post


Link to post
Share on other sites

VooD, about that VoodooHDA.kext....I tried that and found it too buggy to use it. Depending on version, sound output is working, but inputs are mostly unusable...or with working inputs there are periodic ticks on output...that driver is still not for general use, but it seems that it could work in near future :) v1.0 would be a way to go :)

Share this post


Link to post
Share on other sites

Hi Vood!

Maybe you can help me with DSDT Patcher? I'm using 1.0.1e. So in final log I have next:

Intel ACPI Component Architecture

ASL Optimizing Compiler version 20080926 [Oct 4 2008]

Copyright © 2000 - 2008 Intel Corporation

Supports ACPI Specification Revision 3.0a

 

./dsdt_fixed.txt 7437: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 7548: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 7613: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 7824: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8038: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8281: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8320: Method (WMBD, 3, NotSerialized)

Warning 1087 - ^ Not all control paths return a value (WMBD)

 

./dsdt_fixed.txt 8324: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8426: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8544: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8589: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

ASL Input: ./dsdt_fixed.txt - 8622 lines, 303301 bytes, 3641 keywords

Compilation complete. 10 Errors, 1 Warnings, 0 Remarks, 1255 Optimizations

 

 

 

Compiling done, if it worked, you have now a patched DSDT in dsdt.aml

If the compiling went wrong, you could force to build it with ./DSDT\ Patcher -f (try this DSDT at your own risk)

 

 

logout

 

What do you think I have to do with this error? As a result I don't have dsdt.aml file

Share this post


Link to post
Share on other sites
Hi Vood!

Maybe you can help me with DSDT Patcher? I'm using 1.0.1e. So in final log I have next:

Intel ACPI Component Architecture

ASL Optimizing Compiler version 20080926 [Oct 4 2008]

Copyright © 2000 - 2008 Intel Corporation

Supports ACPI Specification Revision 3.0a

 

./dsdt_fixed.txt 7437: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 7548: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 7613: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 7824: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8038: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8281: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8320: Method (WMBD, 3, NotSerialized)

Warning 1087 - ^ Not all control paths return a value (WMBD)

 

./dsdt_fixed.txt 8324: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8426: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8544: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

./dsdt_fixed.txt 8589: Name (T0_0, 0x00)

Error 4111 - Creating a named object in a While loop ^

 

ASL Input: ./dsdt_fixed.txt - 8622 lines, 303301 bytes, 3641 keywords

Compilation complete. 10 Errors, 1 Warnings, 0 Remarks, 1255 Optimizations

Compiling done, if it worked, you have now a patched DSDT in dsdt.aml

If the compiling went wrong, you could force to build it with ./DSDT\ Patcher -f (try this DSDT at your own risk)

logout

 

What do you think I have to do with this error? As a result I don't have dsdt.aml file

 

Try -newHPET or/and different emulation

If that still doesn't work try http://www.insanelymac.com/forum/index.php?showtopic=142434

 

I don't the laptop with me so I can't don tests right now, tough I think I had already installed a patched DSDT.aml on it some months ago with no issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×