Jump to content

HP 6720s and Ideneb 10.5.5 Wlan


anubis80
 Share

2 posts in this topic

Recommended Posts

Hi There

 

I have a Problem. I downloaded and Install Ideneb 10.5.5 on my HP 6720s. Everything is ok,but only my Wlan Broadcom Card doesn´t run. I have installed a Programm and use this in Terminal:lspci -nn

 

Thats the Answer:

 

Last login: Thu Oct 30 08:24:03 on console

localhost:~ root# lspci -nn

00:00.0 Host bridge [0600]: Intel Corporation Unknown device [8086:2a10] (rev 0c)

00:02.0 VGA compatible controller [0300]: Intel Corporation Unknown device [8086:2a12] (rev 0c)

00:02.1 Display controller [0380]: Intel Corporation Unknown device [8086:2a13] (rev 0c)

00:19.0 Ethernet controller [0200]: Intel Corporation 82562GT 10/100 Network Connection [8086:10c4] (rev 03)

00:1a.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 [8086:2834] (rev 03)

00:1a.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 [8086:283a] (rev 03)

00:1b.0 Audio device [0403]: Intel Corporation 82801H (ICH8 Family) HD Audio Controller [8086:284b] (rev 03)

00:1c.0 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 [8086:283f] (rev 03)

00:1c.1 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 [8086:2841] (rev 03)

00:1c.4 PCI bridge [0604]: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 [8086:2847] (rev 03)

00:1d.0 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 [8086:2830] (rev 03)

00:1d.1 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 [8086:2831] (rev 03)

00:1d.2 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 [8086:2832] (rev 03)

00:1d.7 USB Controller [0c03]: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 [8086:2836] (rev 03)

00:1e.0 PCI bridge [0604]: Intel Corporation 82801 Mobile PCI Bridge [8086:2448] (rev f3)

00:1f.0 ISA bridge [0601]: Intel Corporation Mobile LPC Interface Controller [8086:2815] (rev 03)

00:1f.1 IDE interface [0101]: Intel Corporation Mobile IDE Controller [8086:2850] (rev 03)

00:1f.2 SATA controller [0106]: Intel Corporation Mobile SATA AHCI Controller [8086:2829] (rev 03)

10:00.0 Network controller [0280]: Broadcom Corporation BCM4310 USB Controller [14e4:4315] (rev 01)

localhost:~ root#

 

I think the Wlan Controller is running, but i dont find any networks. Is the driver false or anything else?

 

Sorry for my bad english,im from germany

 

greetz

Link to comment
Share on other sites

  • 4 weeks later...

I got it working, you have to do this

 

Press the button in the laptop that turns on the wifi, it's the one to the left of the power button, make sure it lights up blue

 

open a terminal and do

 

sudo vi /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AppleAirPortBrcm4311.kext/Contents/Info.plist

 

search for this section

 

		<key>IONameMatch</key>
		<array>
			<string>pci106b,4e</string>
			<string>pci14e4,4311</string>
			<string>pci14e4,4312</string>
			<string>pci14e4,4313</string>
			<string>pci14e4,4318</string>
			<string>pci14e4,4319</string>
			<string>pci14e4,431a</string>
			<string>pci14e4,4320</string>
			<string>pci14e4,4324</string>
			<string>pci14e4,4325</string>
			<string>pci14e4,4328</string>
			<string>pci14e4,432b</string>
			<string>pci14e4,432c</string>
			<string>pci14e4,432d</string>
		</array>

 

 

and add this

				<string>pci14e4,4315</string>

 

then do the next in the terminal

 

# sudo kextcache -k /System/Library/Extensions

 

and finally, reboot. The wireless card will be detected as an airport card and work normally. This is how I am posting now!!

Link to comment
Share on other sites

 Share

×
×
  • Create New...