Jump to content

Toshiba Qosmio F55


3 posts in this topic

Recommended Posts

So I'm guessing the reason I can't find any info on this is due to the fact that the laptop is only a couple months old now, but I'm curious if anyone has ever successfully installed any version of OS X on one before.

 

I've only tried iDeneb 10.5.5 so far and it's hanging at the following line:

IOAPIC: Version 0x20 Vectors 0:23

 

I think I saw some mention of a similar hang on a certain Dell laptop, but no solutions for it.

If anyone has any info on this, I'd appreciate the feedback... I do believe the F50 is a similar laptop, so any information regarding that would be useful as well.

If it helps, here's a little info on the motherboard/CPU...

Model: Toshiba JSKAA

Chipset: Intel PM45 (Rev. 7)

Southbridge: ICH9M (82801IM).

CPU: Core 2 Duo P7350 (Penryn).

The BIOS has been updated to the latest, 1.30.

Link to comment
Share on other sites

After putting in a fair bit of time into figuring this problem out, I'm fairly confident that the OS doesn't like the optical drive on the F55, at least for installation.

I've successfully installed 10.5.5 using the iDeneb disc by doing a hard disk swap into an HP dv5, running the installer, then swapping it back into the F55.

You might be able to use a USB DVD drive instead of resorting to such ridiculous measures.

Just a note... the video card in this laptop is too new, so you will have to boot into safe mode to do any work prior to video driver installation.

 

Video: Supported - Use aqua-mac's driver pack.

Audio: As far as I can tell, there's no support for the ALC272 codec at this time. I've dumped the codec, but HDAPatcher will inform you that it's unrecognized... but then I'm not entirely sure I know what I'm doing with the patcher anyway. :)

Wired networking: Use the Realtek wired networking support included in the iDeneb installer, or do a quick search - support is there!

Wireless networking: The wireless on this laptop is a new Atheros 9000-series unit... as far as I can tell, the word is that there is no driver.

GPS: Fairly confident this works out of the box, will verify later.

Camera: Might work out of the box... blue 'recording' light illuminates, but I get no picture. Will update this later.

Link to comment
Share on other sites

  • 1 month later...

I have the same laptop and have been working on this too for the last week or so and have finally installed iDeneb 10.5.5. I too was getting the same error message when trying to boot into the install disk as I got: IOAPIC: Version 0x20 Vectors 0:23

 

 

 

I was finally able to install it using the "-V CPUS=2" (without the quotes)

 

I also used the aqua-mac's video driver pack which worked fine (Thanks Aqua mac !!! :) )

 

Still working on the wired network card.

 

 

For the Wireless, I am going to replace it with the BroadCom card I have which I have used on other OSX86 laptops that I have done so I know it works fine. Might have to pick another one up on EBAY, they usually go for about $10 each.

Link to comment
Share on other sites

 Share

×
×
  • Create New...