Jump to content
InsanelyMac Forum
quinielascom

Driver for Laptop Card-Readers (Internal PCI Bus)

Recommended Posts

@wingrunr21 The kext you attach in post #74 did work, thanks. So what was the difference with others?

 

This one freezes too :P This time tested with last versions Chunnans' b2 of iopcmciafamily, because of my 3g pcmcia card...

 

Anybody succesfully tested card reader driver with chunnans' iopcifamily/iopcmciafamily?

Share this post


Link to post
Share on other sites
Advertisement
This one freezes too :) This time tested with last versions Chunnans' b2 of iopcmciafamily, because of my 3g pcmcia card...

 

Anybody succesfully tested card reader driver with chunnans' iopcifamily/iopcmciafamily?

 

 

I did but got IOKIT timeout errors and very slow bootup.

Share this post


Link to post
Share on other sites

Lastests version (since the one for macgirl) load successfully without freezing for me, but sd card doesn't mount, never...

 

10/01/09 13:15:48 kernel SDHCI: BaseClock = 33MHz 
10/01/09 13:15:48 kernel SDHCI: SD Clock = 257KHz 
10/01/09 13:15:48 kernel powerSD:  0x1f021a1 
10/01/09 13:15:49 kernel SDHCI: No Response from CMD8 
10/01/09 13:15:49 kernel SDHCI: No Response from CMD8 
10/01/09 13:15:50 kernel SDHCI: BaseClock = 33MHz 
10/01/09 13:15:50 kernel SDHCI: SD Clock = 16500KHz 
10/01/09 13:15:50 kernel SDHCI: RCA 0x00001234 
10/01/09 13:15:50 kernel SDHCI: RCA 0x00001234 
10/01/09 13:15:52 kernel SDHCI: Response: 0x00004F00 0x325F5983 0xCBF6DBFF 0x8F8A4000 
10/01/09 13:15:52 kernel SDHCI: Response: 0x00004F00 0x325F5983 0xCBF6DBFF 0x8F8A4000

 

----> kext loaded without card in

 

And sometimes it talk about 4 bit mode... when i load kext without card in and i plug it later...

Oh, and in this case i can see AppleXsanFilter loaded to the end of the IORegistry tree of

IOService:/AppleACPIPlatformExpert/PCI0@0/AppleACPIPCI/P0P9@1E/IOPCI2PCIBridge/pci1180,822@3,1

...

 

I use IOPCIfamily vanilla and tested with ChunNan one... no change.

 

It's strange, because i have an Asus A8sc motherboard, sister of the A8sr one...

 

Many thanks for your work man, it's pretty cool to think that my HAck will be 100% operational after more than one year of *****...

Share this post


Link to post
Share on other sites

I use my own version of IOPCIFamily 2.5.4. (see signature).

 

Funny result:

WindowsXP can't read SD SanDisk 16Gb.

MacOSX with driver fc1 from sf.net read this card without any problem. :P

Share this post


Link to post
Share on other sites

Didn't work for me (Asus A8Sc), caused troubles like other people :

- Disconnect the mouses (trackpad and bluetooth mouse) BUT the trackpad buttons work.

- Massively slowdown the computer.

- Doesn't read any SD card.

- Made the computer stop not to work.

 

This is a Ricoh standard card reader :P

 

Good luck !

Share this post


Link to post
Share on other sites

I have a Dell Inspiron 1525 and would like to know if my Card Reader will work...

 

My Hardware Card Reader is:

 

Ricoh RL5c592 Memory Stick Bus Host Adapter

Ricoh RL5c822 Bus Host Adapter

Ricoh RL5c832 IEEE1394 Controller

Ricoh RL5c843 MMC Host Controller

Ricoh RL5c852 xD-Picture Card Controller

 

well, I do not know what is right, but when you see the description of computer hardware appears all these above. If I download this driver that is available in the 1st post, will work my card reader normaly?

 

I await answers...=)

 

Thanks

 

Bye

Share this post


Link to post
Share on other sites
you are fast! :D

I can install that will be 100% functionality?

 

Thanks for the fast-answer!! :P

 

The only way to see if it's going to be 100% functional is to install and test! Remember to repair permissions after installing the kext. Please, post your results here!

Share this post


Link to post
Share on other sites
Sorry to do this stupid question, but ... How to install the kext? :D

 

I am totally new, I ask a lot of patience with me! :(

 

Bye

 

Kexthelper. You can search a little....

 

I've tested a verbose version of fc1, this is what i get when i insert SD card :

 

16/01/09 16:25:38 kernel SDHCI: BaseClock = 33MHz 
16/01/09 16:25:38 kernel SDHCI: SD Clock = 257KHz 
16/01/09 16:25:38 kernel powerSD:  0x1f021a1 
16/01/09 16:25:39 kernel SDHCI: [b]No Response from CMD8[/b] 
16/01/09 16:25:39 kernel SDHCI: BaseClock = 33MHz

 

Then mouse block... Any idea ? Ricoh one...

Share this post


Link to post
Share on other sites
Sorry to do this stupid question, but ... How to install the kext? :D

 

I am totally new, I ask a lot of patience with me! :)

 

Bye

 

You can use OSX86Tools to install kexts, repair permissions and clean cache... do a search for download it!

Share this post


Link to post
Share on other sites
I have a Dell Inspiron 1525 and would like to know if my Card Reader will work...

 

My Hardware Card Reader is:

 

Ricoh RL5c592 Memory Stick Bus Host Adapter

Ricoh RL5c822 Bus Host Adapter

Ricoh RL5c832 IEEE1394 Controller

Ricoh RL5c843 MMC Host Controller

Ricoh RL5c852 xD-Picture Card Controller

 

well, I do not know what is right, but when you see the description of computer hardware appears all these above. If I download this driver that is available in the 1st post, will work my card reader normaly?

 

I await answers...=)

 

Thanks

 

Bye

 

Yes it works, read the other post and what others have to say about it. I also have a Dell Inspiron 1525 and SD/SH~ SD Cards work great. You have to unmount it before you remove the card or it will crash your system. But other than that it works perfectly.

 

Also is there a way to keep proper revisions and info so that we know whats going on and when a new version comes out. As far as I know I have the lastest version, but then again I am not sure, cause I downloaded it from the Dell Driver Package 1.4.

Share this post


Link to post
Share on other sites
Yes it works, read the other post and what others have to say about it. I also have a Dell Inspiron 1525 and SD/SH~ SD Cards work great. You have to unmount it before you remove the card or it will crash your system. But other than that it works perfectly.

 

Also is there a way to keep proper revisions and info so that we know whats going on and when a new version comes out. As far as I know I have the lastest version, but then again I am not sure, cause I downloaded it from the Dell Driver Package 1.4.

 

You don't have the latest version because the last update of Sonotone's Dell laptops Post-Installer (V1.4.1) is dated 12/26/2008 whereas latest SD card Reader update dated 05/01/2009 (Final Candidate V1), you can check news at Sourceforge's developpement page, as mentioned on the first page of the thread...

Share this post


Link to post
Share on other sites

Incredible!

It works perfect with my thinkpad x60s!

Not only support SD (2G fat) but also support SDHC (4G fat32) which can't be recognized under windows system!

Share this post


Link to post
Share on other sites

Hi. I've used this kext with an Asus F3Jc. And it works great. Now, the only thing that doesn't work on my hackie is the webcam. :censored2:

 

Could you please update the first post to include my laptop model and make? Thanks :censored2:

Share this post


Link to post
Share on other sites

Works, but unfortunately crashes finder after a short time. Dell Inspiron 1525, 10.5.5.

Share this post


Link to post
Share on other sites
Incredible!

It works perfect with my thinkpad x60s!

Not only support SD (2G fat) but also support SDHC (4G fat32) which can't be recognized under windows system!

Yes, the MacOSX driver is better then Windows's one ;)

 

Works, but unfortunately crashes finder after a short time. Dell Inspiron 1525, 10.5.5.

Dell Inspiron 1525 - works perfect.

 

is it possible if you can support for Texas Instruments PCIxx12 card reader dev id 104c 803b?

No, hardcoded differently.

Share this post


Link to post
Share on other sites

:angel: something very strange is happening . i have HP dv2700 . the first time i installed the kext it worked perfect . but after a couple of days it stopped working . so i tried anything u can imagin. from IOPCIFamily.kext to IOUSBFamily.kext and a lot of other stuff . and different IOSDHCIBlockDevice.kext . but it did not work anymore . i tired it inside vista it works still so it's not the SD card nor the card reader.

 

so i gave up and i did a fresh install . and installed the driver . and it didn't work . once i insert the SD card it freezes . that's all i get and it's very strange cus the first time it worked very nice . but now it's not working anymore. i'm sure the problem is not the IOSDHCIBlockDevice.kext . it should be from somewhere else . please help anyone.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • @Gengik84  i kext sono aggiornati e messi nella partizione efi per il BT ho cercato in rete e come detto nei precedenti post 2 sono in efi ed uno in l/e.  Potresti dare un'occhiata alla mia efi  e le varie patch dsdt magari c'è qualcosa che non va... https://drive.google.com/open?id=1d7qfHs3KYEWANjtSlKyR29aEbgTFsytd   Grazieeee
    • Hi,  as per your guide, I have purchased the Wifi+bluetooth card you recommend twice! i can't get bluetooth to show up or work. Wifi is working though. I can assure you that i have my USBs fixed properly. still no luck with bluetooth. doesn't even show up in system pref.    "I'm using an original >> Apple BCM943602CS WIFI+bluetooth module and adapter, this has native support in macOS High Sierra and needs no kexts / drivers. It works out of the box!"   My setup is very similar to yours:  mobo: asus z370 F gaming  i7 8700k  gtx 1080ti    please advise me further!    much appreciated 
    • I had it working without any kext or inject when I installed sierra but my Geekbench scores where low and had some video playback issues. I'll try giving it a shot again without any frame buffers or kext and see if I can get it to work.    Also do you know if my MB has CSM? I don't see it on the MB website. 
    • @AceMcLoven R9 270X and R9 280X don't need anything to work in a Hackintosh, I have a MSI R9 270X and it works 100% OOB without any injection or selecting the framebuffer if I set InjectATI=True or select a framebuffer Futomaki it will go to black screen. Don't inject anything in the Graphics section. You don't even need the RadeonDeInit either, just make sure that the CSM is disabled in BIOS/UEFI. I've been using HDMI and DP ports and both work ok.
    • risolto!!! Fatto un'installazione pulita e poi ho seguito questo post  ...l'installazione deve essere pulita..senza kexts aggiuntivi di precedenti prove


×