Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
lovedahackintosh

slow performance on hp dv4000 with xnu 9.5 and speedstep

9 posts in this topic

Recommended Posts

ok, i am having some issues with this setup.

 

after a long absence from the osx86 community i am trying once again to get my hp dv4000 working properly. so far things are going well. it is a 1.6ghz pentium m processor and i am running xnu 9.5 kernel with chameleon efi and intelenhanced speedstep.

 

the speedstep app shows all the available frequencies but i am unable to change them and if i select the fastest one, my system locks up.

 

the system clock seems to be running very fast and the seconds fly by at twice normal speed. i have tried booting with busratio=16 but it does nothing. using fsb=100 causes a kernel panic.

 

here is my output from speedstep:

 

sudo dmesg | grep Speed

IntelEnhancedSpeedStep: INFO Initializing version 1.3.2 © Prashant Vaibhav <mercurysquad@yahoo.com>

IntelEnhancedSpeedStep: INFO Your processor doesn't support constant_tsc, but you have a kernel which can compensate for it.

IntelEnhancedSpeedStep: INFO On your processor, voltages can be changed in 16 mV steps

IntelEnhancedSpeedStep: INFO Using 6 PStates.

 

and this command: sysctl hw | grep EST

does nothing

Share this post


Link to post
Share on other sites

Hi,

Pentium M is fully supported so it will work with a little tweaking.

 

First, I'm wondering where you read about the fsb flag? Because wherever I have mentioned it, I've made it clear that it is specified in Hz, not MHz :D When it panics, it prints out the busFreq and you could probably see it listed as 0.000100 MHz.

 

Second, which kernel are you using exactly? You can try uname -v in terminal.

 

Third, it should be sysctl machdep | grep EST, not hw.

 

Fourth, could you edit the kext's Info.plist file, and set DebugMessages to true. Then delete Extensions.mkext and reboot. Then you can see the kext's debug messages by using sudo dmesg | grep IntelEnhanced

 

Fifth, please post the output of sysctl kern | grep throttle - want to make sure your ACPI is reporting proper voltage (common problem).

 

And lastly, post a photo of the kernel panic. If it just hard freeezes, boot with flag debug=0x100 to get it show the KP message over the gui.

Share this post


Link to post
Share on other sites

1. i actually used both and they resulted in the same issue. an rtc granularity error. i attached a blurry image. :-)

 

2. uname -v

Darwin Kernel Version 9.5.0: Tue Oct 14 07:39:11 IST 2008; Voodoo; Beta 2c :xnu-1228.7.58/BUILD/obj/RELEASE_I386

 

3. sysctl machdep | grep EST

machdep.cpu.features: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT CLFSH DS ACPI MMX FXSR SSE SSE2 SS TM EST TM2

 

4. sudo dmesg | grep IntelEnhanced

IntelEnhancedSpeedStep: INFO Initializing version 1.3.2 © Prashant Vaibhav <mercurysquad@yahoo.com>

IntelEnhancedSpeedStep: INFO Your processor doesn't support constant_tsc, but you have a kernel which can compensate for it.

IntelEnhancedSpeedStep: INFO On your processor, voltages can be changed in 16 mV steps

IntelEnhancedSpeedStep: INFO Using 6 PStates.

 

5. sysctl kern | grep throttle

kern.exec: unknown type returned

kern.cputhrottle_curfreq: 600

kern.cputhrottle_curvolt: 748

kern.cputhrottle_freqs: 600 800 1000 1200 1400 1600

kern.cputhrottle_factoryvolts: 2796 2796 2796 2796 2796 2796

kern.cputhrottle_ctl: 1539

post-122434-1224644677_thumb.jpg

Share this post


Link to post
Share on other sites
5. sysctl kern | grep throttle

kern.exec: unknown type returned

kern.cputhrottle_curfreq: 600

kern.cputhrottle_curvolt: 748

kern.cputhrottle_freqs: 600 800 1000 1200 1400 1600

kern.cputhrottle_factoryvolts: 2796 2796 2796 2796 2796 2796

kern.cputhrottle_ctl: 1539

 

That's your problem. Broken ACPI reports ~2.8 Volts! That's clearly too large. Just see how your actual current voltage (at 600 MHz) is 748 mV, not 2796 mV as your ACPI is trying to have us believe.

 

I'm trying to find a workaround to this. Intel keeps the algorithm to calculate the voltage 'secret' ...

Share this post


Link to post
Share on other sites

ok, i finally have proper throttling back on this thing. here is a copy of my pstate table. do you see any issues with these? i wasnt really sure how much voltage to use.

 

<key>PStateTable</key>

<array>

<array>

<integer>1600</integer>

<integer>1100</integer>

</array>

<array>

<integer>1400</integer>

<integer>1100</integer>

</array>

<array>

<integer>1200</integer>

<integer>1100</integer>

</array>

<array>

<integer>1000</integer>

<integer>860</integer>

</array>

<array>

<integer>800</integer>

<integer>780</integer>

</array>

<array>

<integer>600</integer>

<integer>748</integer>

</array>

Share this post


Link to post
Share on other sites

Superhai's version, even though it has Pentium M support, is incomplete and not really usable right now.

 

Voltages look ok. For your 1400 and 1200 MHz voltages, you can use maybe 1000 and 920 though.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×