Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


How to Mount Airport Extreme External Hard Drive on to Desktop

5 posts in this topic

Recommended Posts

I'm trying to access my External Disk plugged in via Airport Extreme Base Station from the desktop, however it seems not mount on the desktop like it would when plugging an external drive in via usb or firewire. I can certainly access it through the "Shared" tab of the MenuBar in Finder, however, it should be on my desktop as it would appear like the orange icon with external drives plugged in.




Essentially, the icon should look like this on the desktop:








I did a little research on this topic and found an unresolved discussion: http://discussions.apple.com/message.jspa?messageID=6882194




A few excerpts:


With the last update to the AirPort Utility my USB drive does not auto mount any longer... 




I have a similar problem, I have just set up my AEBS with an external HD. I do see the AEBS in shared after startup but how to I auto mount the partitions on the drive ?




Thanks for your time, I hope this is not completely new to everyone as these settings changed after updates, looks like its still being reported from the above posting October 2008.

Share this post

Link to post
Share on other sites
Can't you make a shortcut?

Thanks for the quick reply! :wacko: I can't really do much, I've though of that idea, so when I tried dragging it over, it wasn't allowed to be moved. When I 'command+click' or right-click, I only have 2 options, to "open" or to  "get info"




I researched on this a little bit more, it seems like it's still an existing issue. I forgot to mention I'm running on the latest firmware update 7.3.2.


I was able to get my external to mount doing this: open Finder. Click on Finder>Preferences and click 'connected servers' check box. Command F to bring up a finder window and on the left side under 'shared' my AEBS shows up. Click once on the base station and the external hard drive shows up. Click on the external hard drive icon and it mounts to the desktop and stays there. I imagine I'll have to repeat this everytime I disconnect from my AEBS rather than it automatically mounting.


I think I'll need further help with this one, Does "Finder > Preferences" mean "System Preferences?"



Here are some more findings, a pretty active discussion found here: http://discussions.apple.com/thread.jspa?threadID=1106671


Some excerpts:


I also switched back to the firmware update 7.1.1. When I reconnected the airport disk (just 500 gig storage drive – mines a lacie) via the usb terminal, I finally saw it show up on my desktop again. Big smiles.


Just on the phone with the Tech guy, He stated he had not heard of this issue. I told him my story and he quickly filed the report for me to talk to an engineer. The engineer asked me to tell him my story and I did. He then asked for me to go to my desktop and go to my "go" and click on "Go to folder" After that, he told me to type in "/volumes" in the blank bar. It open up a window and showed all my drives including my external hard drive account drives. He has asked me if I saw any folder named with 1234 at the end of title. I said no. He then said that Apple has been getting reports of this issue and suggest for us to downgrade until Apple releases a new update.
< this posting was from  Oct '07


Eventually, the Airdisk will reconnect OR go to 'Finder'-->'Network' and you should see your AEBS by it's assigned name (in my case I've named it "Bedroom Airport"). Connect to it and you'll see the AirDisk will mount to your desktop.


after having all the trouble described here, I switched over to SMB-Connection as described earlier in this thread and Voila! - Reconnecting works just fine for me too!


What I have done to make things easier:

1.) In a terminal window become root and add a line to your /etc/hosts with the name and IP-address of your Airport Extreme.

2.) Connect to the SMB-Share using the name of the station in the finder and store the password in the keychain.

3.) When the shared drive appears on the desktop, make an alias and place it on the desktop.




From other sources:


Finder>Preferences>Show connected servers on desktop




System Preferences>Accounts>Login Items>+Airdisk



In Finder->Preferences is an option to display network drive icons. I clicked the box and "Voila".




Again, where can this be found?



Finder → Preferences → General → "Show these items on the Desktop


Go to your user preferences and drag the mounted drive to your login items. It works great for reconnecting every time you login.



Where's "General"?



Any further thoughts? Thanks for your time.

Share this post

Link to post
Share on other sites

Gramarye, the hints in your post helped me solve this issue that has been nagging me for over a year! Here are the steps I took to resolve:


1. Click the finder icon in your dock

2. Press command-, (comma) or click on the word "Finder" in the menu bar and click preferences

3. Click on the General tab

4. Make sure there is a check mark in the box next to "Connected servers"

5. Verify that your airport disk now appears on your desktop. If not, connect to it manually the way you normally do.

6. Click on the Apple logo in the menu bar

7. Click on "System Preferences"

8. Click on "Accounts"

9. Click on your account

10. Click on "Login Item", to the right

11. Look at the lock in the bottom left of the window—if it is locked, click it and enter your credentials to unlock.

12. Drag your airport disk from the desktop into the space where login items appear (you may already have stuff there, which is okay)

13. Put a check mark into hide box next to your airport disk

14. Close System Preferences

15. Restart your computer

16. Once it is done rebooting, you will see your airport disk appear on your desktop

17. Start a program that needs to access files on your airport disk (e.g. iTunes, EyeTV, Plex, etc.)

18. The program in step 17 will start without giving you an error that it cannot find the needed file

19. Jump around giddily and/or laugh maniacally :)


Gramarye, know that I could not have figured this out without your tips, so THANK YOU!



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.