Jump to content

iDeneb / XP Dualboot


mogster
 Share

12 posts in this topic

Recommended Posts

Anyway, I'm about to install OS X (iDeneb 10.5.5), but I'm getting a "still waiting for root device" error. And I think I know why.

 

I haven't yet made the partition I want to use active yet. I have a blank FAT32 partition that I was gonna make HFS+ using the disk utility during the OS X set-up. I have lots of sensitive information on other partitions, so I don't want to do anything silly, hence I'm posting before I fiddle with diskpart...

 

So with diskpart, I want to make the partition active with the id=af thingy, without doing any damage (the partition can be formatted, but I don't want the entire disk being formatted). What do I need to type to do this if it's on disk 0, partition 2? Last time I tried that id=af thing, I remember not being able to boot Windows again... then I can't remember what happened between then... but I remember getting OS X installed shortly after, so that must be what I should do =P

 

Some input before I do something potentially silly?

Link to comment
Share on other sites

Don't know much about diskpart, only used it once myself but for me it was too much work and too much that could go wrong, so I've reverted to using a completely physically separate hd for OSX on both my two pcs (one is AMD Ahtlon64 X2, having iDeneb 1.3 Leopard 10.5.5 on one hd, then XP Pro SP3 and Vista x64 on another hd, the other pc runs JaS 10.5.4 on a Intel Core 2 Duo processor).

 

Imho, if you're really worried about stuff on the other partitions, you should really look into just getting a separate hd to install OSX on, much easier and way less hassle.

All you need to do when having OSX installed on the separate hd is to use the built-in bios selector for boot-device.

On this AMD PC I press F11 to get to the list of harddrives etc to boot from. Then just choosing the hd OSX is on and it will boot that instead of the normal XP hd.

 

Edit: The error I didn't even notice that it was written in the post :rolleyes:, but as Hugo Guerreiro wrote, it's because of no drivers being there for the SATA/ATA-controller on the dvd.

I guess it would be possible to inject drivers somehow, but that I don't know anything about myself.

Link to comment
Share on other sites

It's a JMicron JMB363 controller... I think the iDeneb DVD comes with that already, said a lot of {censored} about JMicron (other people have this release working with a P5K)... I still have an inkling it's do with making the partition active with id=af, but I know I won't be able to boot after that...

Link to comment
Share on other sites

It's a JMicron JMB363 controller... I think the iDeneb DVD comes with that already,

 

Well..thats a comon error for everyone that wants to boot a dvd and it doesnt goes further from that error...

the fact that a release as the driver for installation doesnt mean that it as it inserted on the dvd kexts at boot.

wich means that sometimes the extensions folder that the dvd uses to boot doesnt have the kext for your specific controller there,

and so you get the "still waiting for root device" error, that nothing is but the kext that controles your jmicron device not being putted into the extensions folder that the dvd uses to boot. Even if the kext is actually there maybe for some reason it might not have your Device Id on the info.plist file making it not loadable at boot.

It as nothing to do with you having done already your partition or not. it simply is a kext not being loaded at DVD boot.

Link to comment
Share on other sites

I'm booting from an IDE DVD, BUT I've done a lot of googling and read:

 

"Got it fully functional, with all bells and whistles on Asus P5K Pro. Only AppleVIAATA.kext had to be added, coz otherwise my IDE DVD wasn't visible for OSX"

 

*edit* Hmm... seems the pro version has a different ATA controller, worth a try anyway, riiiight?

 

(last time I had to borrow my friend's SATA DVD drive to install OS X... hoping I can avoid this)

Link to comment
Share on other sites

  • 2 weeks later...

Any updates on this?

 

I have a P5K Deluxe, I'm using all SATA drives and SATA DVD on the ICH9R controller, I'm not using the JMicron (turned off in BIOS). The iDeneb v1.3 (10.5.5) DVD boots fine, I'm able to install everything (I chose the ICHx option in the installer), but then when I try to boot the new installation from hard drive, I get the "still waiting for root device" problem. I'm using MBR type partition with MAC Extended Journaled FS.

Link to comment
Share on other sites

 Share

×
×
  • Create New...