Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Jeffrey T

InputRemapper on new Aluminum Macbooks

10 posts in this topic

Recommended Posts

I'm having weird problems under Windows XP on my new MB (Al case, 2.4Ghz) with 1.0.04

 

The 'macbook keyboard settings' option doesn't appear, and when I load the 'macbook settings', the laptop appears to freeze up.

 

Is anybody else seeing this?

 

---UPDATE---

 

Found out some of the BootCamp drivers hadn't left the room, working better now.

 

Fan control doesn't seem to do anything, and it doesn't appear to be reading the light sensor.

 

Screen and Keyboard backlight control works though. Nuts, would be nice to be able to control automatically.

Share this post


Link to post
Share on other sites

Hi Jeffrey-

 

Can you explain how you got those bootcamp drivers to "leave the room"?

 

I have installed inputremapper on my new Aluminum MBP in order to control the fan speed and I'm likewise experiencing random 10 second freezes.

 

Please let me know what I can do.

 

All the best,

 

~M

Share this post


Link to post
Share on other sites

i have the same "freeze" problem, i think need to wait for the next release to fix this coz more aluminum macbook user will face the heat problem....

i also need it to turn on the fan when i am in bootcamp.

i found it is the only app that can manually turn the fan on.

 

Speedfan won't work....

Share this post


Link to post
Share on other sites
i have the same "freeze" problem, i think need to wait for the next release to fix this coz more aluminum macbook user will face the heat problem....

i also need it to turn on the fan when i am in bootcamp.

i found it is the only app that can manually turn the fan on.

 

Speedfan won't work....

 

I concur. I e-mailed one of the Speedfan developers, and he said he's working on a Speedfan profile for the new MacBook and Pro. As far as input remapper, I haven't experienced the freeze problem yet, but my light sensor doesn't seem to be registering. For instance, in the configuration screen, the slider for the light sensor INPUT jumps from far left to only an increment right of it, and then back continuously -- suggesting that there is little to no light, and it's sporadic -- regardless of the amount of light in the room. This is in whichever mode that allows you to control the parameters, and since it's either detecting no light or very little, and additionally because it's skittish between the two, setting the min max to that range causes the screen to turn off then on at the darkest of settings over and over again. Unless I misunderstand how it works, I believe this also affects the keyboard lighting.

 

My other question is about the fan control, and I'm hoping that i just don't understand how it works. Is it possible to have the fan(s) adjust themselves depending on temperature inputs, or is the only option that we set a fixed speed for each and adjust it later if needed?

 

Thanks, Adam.

Share this post


Link to post
Share on other sites

I can't get it to work on the new alu macbook pro either. I am experiencing the freezes like every 10 seconds, and I can't get it to recognize my Fn key. I just want to swap my Fn and Ctrl keys so I can play games.

Share this post


Link to post
Share on other sites

I Have Aluminium MacBook MB467LL/A

After I installed BootCamp and InputRemapper It was same problem.

The "freeze" comes becouse InputRemapper and BootCamp services runs at same time.

Solution:

1 way) For work with rigth click you mast onse run process KbdMgr.exe and kill it after initialization this service, after that you can run InputRemapper and it will be no "freeze" and sussesfull work.

 

2 way) I have wrote program what will do this automaticly, you can download and test it from: http://ighor.info/BootCampToInputRemapper.rar

You mast:

1) install BootCamp

2) install my program (BootCampToInputRemapper.rar)

3) install InputRemapper

4) reboot computer

Enjoy!

 

PS: I waiting for multitouch version of InputRemapper and I can help with programming. Who can give me some event code ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    •   Thank you Baio77. Here is my CLOVER folder and the Hack info. 
            For Some Reason I can't upload my CLOVER folder. But here you can download...
      https://www.dropbox.com/s/vjprxs1idtj9pt7/CLOVER.zip?dl=0     Thank you again!!!   HackInfo_Report.zip
    • The brightness is NOT from Sierra, in my signature you find tools with which to give info on your system .....
      Post Hack Info and the clover folder ......
      Only in this way can I help you ......
    • Few more minutes to go before going live again with https://OSXLatitude.com
          So you can lock this topic again @Allan Hopefully for a bit longer than a couple of weeks this time hehe.
    • ok, I am having a weird glitch with my Primary bios after modding it myself. can I get some help getting a Clean osmosis modded (for High Sierra and beyond) Bios Image?   https://www.gigabyte.com/us/Motherboard/GA-Z87X-UD5-TH-rev-1x#support-dl   the version I have always stuck with was F4, because the F5d.  I use a custom iMac 14,2 configuration that has been stable, the issues I have with stability come from not being able to get Access to the Bios, and prior to my attempt to mod it has been stable with up to High Sierra using clover, and up to Sierra with my very very old Ozmosis 894m F4 rom. I am not opposed to installing Ozmosis on the EFI Partition, But Gigabyte locked the Bios loading .efi Files, there is no shell to Force it to load HFS+ or APFS drivers.   so what I am asking for is assistance ether unlocking a Shell for my Bios, or getting a bios with the APFS, HFS+, and Ozmosis related files in it.   thanks again for everyones assistance. HBP
    •     Install from fresh again. This time without Tony Tools, follow some guide in this topic. Install IntelHD kexts as usual in S/L/E and thats it. Everything works again, except for backlight, I never could have this work, also got heating problem and when boots apple logo dissapears from like 5 seconds and then appear the login window... Any ideas on any of this????  


×