Jump to content

PCGenUSBEHCI failed to load (Kalyway 10.5.3) / Autochk.exe is missing (winxp pro)


2 posts in this topic

Recommended Posts


I installed Kalyway 10.5.2 just greta on my system, it took me a bit to find out how to get rid of the error loading operating system by using gparted to set the boot flag to my other OS, but now i have a fe wmore problems. I know mac OSX is compatible with my system, but i think that it messed up windows xp pro (32 bit) and when i installed the Kalyway combo update 10.5.3 and applied the kernel patch before restarting i got the dreaded "com.orByte.driver.PCGenUSBEHCI; destroying kmod" error in yellow when booting with the -v paremeter. I tried using update -v, but it hangs on failed to find security or something for firewire or something similar, it always did that so its not a real problem. I also tried -v -x which is safe boot, it worked then. I could access usb devices and storage and SD cards so i dont know what happened.

I have windows xp pro 32 bit, and vista 64 bit install, i have my partitions like this (recovery partition, mac osx, vista, windows xp) and my vista partition is my main, and i have it set up to boot using the chain0 method. It boots fine from that.

What is the PCGenUSBEHCI error and what does it actually mean? Why would it stop booting in regular mode but still show the rropr in yellow and continue in safe boot?


On my windows xp partition after i installed mac osx it gave me a strange error.

It has a boot loop with "autochk.exe missing or corrupt - skipping autocheck" and it skips and goes to a BSOD for about 1/4 of a second then it restarts. The autochk.exe is in the correct spot, and ive ran chkdsk /f /r on the drive and chkntfs /x pointing to the drive but it still shows the error. The drive doesnt have a dirty bit and partition manager 8.5 and ghost 14 and gparted show the partition as ntfs and is not hidden.

Would this be a prtition table error? Ive ran the recovery console and tried fixboot and fixmbr but it doesnt do anything. I even replaced autochk.exe with a new one to make sure it wasnt corrupted, still nothing.


I can view the contents of this drive fine and access the files on it. I dont wnat to have to do a repair install and re-install a bunch of programs and updates so is there a way to fix this error with an in-place upgrade?


How would i repair my partition table aswell if that would work?

I just nmeed to know what the OSX error means and y i would get it, ive even replaced the kext with a backup and tried a dif kernel for boot.

What would cause the autochk thing?

And how would i load the registry from that win xp install to be able to modify session to be autochk autochk* if its not that already?


I know alot on computers but not so much on mac osx even tho i know about kexts, file structure, booting, filesystem, file types and etc. so what could be the problem with these?


Link to comment
Share on other sites

  • 2 weeks later...

  • Create New...