Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
ShadowBandit

HELP with Asus N10 OS X install.....

Recommended Posts

Good afternoon everyone so i picked up one of these machines in the hopes to install OSX. I first did a lot of reading and what not on installing OSX, i was successful on 2 machines(Inspiron 1505, and Sony CR series notebook) I only really did the installs and nothing more bc it was mostly a learning experience. I searched around before I bought this notebook for Chipset, Sound, Video, and Network and all seemed to match some kind of system or another. For the most part this system is similar to most of the Netbooks out there that have OSX installed and running. ie. EeePC 1000h or 901, MSI Wind, and Lenovo S10. This lead me to the conclusion that the hardware would be supported but i apperantly missed something in my readings(maybe i was up too late lol). I am basically tried 4 diff install methods:

 

iDeneb v1.3 10.5.5: Hangs at the apple screen just like the rest with pretty much the same verbose screen as below....

 

JAS 10.4.8 universal: Reboots as soon as darwin starts to load,

 

Kalyway 10.5.2: Gives me a kernel panic on 4counts i believe they were all related to ACPI issues,

 

Boot 132 method with Retail 10.5.4: Used Generic ISO found on here and then swapped out to Retail Leo. makes it to the grey apple screen but never starts loading anything. If i use -v it will show loading all the kext, but it then hangs once it gets to dmos: starting....

 

I would greatly appreciate any help to get this machine up and running i know i might be missing some kind of kext to get it to work propperly but being that i am new at this i just need a little guidance. I feel like i have confused myself from reading so many post and different methods of installing OSX lol..

 

thanks again....

 

 

Specs:

 

CPU: N270 Atom 1.6ghz with HT

Chipset: 945GSE Express North and ICH7 south

Sound: Azalia Realtek HD audio

GPU: GMA950, and Nvidia 9300(tried install with GMA and then with 9300)

LAN/WLAN: Realtek RTL8168/Atheros AR928x

 

If you guys need anymore information please ask i will open up the bottom and check out the ID's on the WIFI, i did last night but did not write em down but i know it had diff numbers from what is posted int he device manager.

 

Update: 2008/10/24

Standard timesplicing quatum is 10000 us
Vm_page_bootstrap: 510042 free pages and 14246 wired pages
Mig_table_max_displ = 79
HTT: 1 core per package; 2 logical cpus per package
ACPI CA 20051117 [debug level=0 layer=0]
appleACPICPU: ProcessorApicId=1 LocalApicid=0 enabled
appleACPICPU: ProcessorApicId=2 LocalApicId=1 enabled
Loading security extension com.apple.nke.applicationfirewall
Loading security extension com.apple.security.seatbelt
Calling mpo_policy_init for mb
Seatbelt MACF policy initialized
Security policy loaded: seatbelt policy (mb)
Loading security extension com.apple.security.TMSafetyNet
Calling mpo_policy_init for TMSafetyNet
Security plicy loaded: safety net for time machine (TMSafetyNet)
Copyright © 1982, 1986, 1991, 1993
The regents of the university of California. All rights reserved.

MAC Framework successfully initialized 
Using 10485 buffer headers and 4096 cluster IO buffer headers
IOAPIC: version 0x20 Vectors 0:23
ACPI: System State [s0 s3 s4 s5] (s3)
Extension ‘com.apple.driver.applePCIconfigurator’ has immediate depndencies on both com.apple.kernel and com.apple.kpi components; use only style.
Mbinit: done
Security auditing service present
bSM auditing present
From path: “uuid”,
Waiting for boot volume with UUID 804603d3-83e9-36b8-ab8e-11501d1805d6
Waiting on <dict ID=”0”>IOProviderClass</Key><string ID=”1”>IOResources</sting><key>IOresource
Match</key><string ID=”2”>boot-uuid-media</string></dict>

 

Thanks again.

Share this post


Link to post
Share on other sites
Advertisement

i paid 675, but it can be had for about 500 after rebates from the Live.com program which i did not know about until after i bought mine :D oh well... i mean if i were to buy the 1000H I would be stuck upgrading the ram and faster HD. so i would spend more anyways so the way i look at it is i paid another 100bux for the GPU.

 

I am thinking it will work with osx since it has the same chipset as the Eee and msi but i dont think the wifi is compatible. Hopefully it is removable and i can swap it out for one of the dell oem ones.

 

We shal see.....

Share this post


Link to post
Share on other sites

Alright ladies and gents, looks like fedex screwed me :) was set to arrive today but it didnt. So i am going to call in a few minutes and just pick up the package tomorrow morning, I am going to try the Boot 132 method to install osx hopefully i can find the right kext to install and 10.5.5 updates will hopefully take care of my Nvidia 9300m GS. I will keep everyone updated and will change around the first post to reflect since i already bought the net/notebook.

 

Thanks.

Share this post


Link to post
Share on other sites

Got my N10J today, but so far no luck with installing :unsure:.....

 

Boot 132 will get stuck on the grey apple screen, i also tried Kalway 10.5.2 and i get kernel panics for both....

 

I would appreciate some help if anyone could post :D I tried the 132 from the MSI, Generic, and a couple of others.... I just am not sure what what the kernel panic is all about. I do believe it might be possible to install osx its just a matter of figuring what the problem is and i am no expert unfortunately.

 

I would appreciate any help you guys can offer,

 

Thanks.

Share this post


Link to post
Share on other sites

I assume you already tried this

 

http://uneasysilence.com/archive/2008/10/13519/

 

and this

 

http://wiki.osx86project.org/wiki/index.ph...Inspiron/mini_9

 

 

Should work, looks like the same basic internals aside from your graphics card which should be a plus in any case. The again, Asus does tend to put out some buggy BIOS... at least when it comes to working with stuff other than Windows.

Share this post


Link to post
Share on other sites

dies thank you for the post, I am no longer getting kernel panic after a bios update i got from kabyl but the installs are now hanging at the grey apple screen without a rotating wheel. here is the code:

 

Standard timesplicing quatum is 10000 us
Vm_page_bootstrap: 510042 free pages and 14246 wired pages
Mig_table_max_displ = 79
HTT: 1 core per package; 2 logical cpus per package
ACPI CA 20051117 [debug level=0 layer=0]
appleACPICPU: ProcessorApicId=1 LocalApicid=0 enabled
appleACPICPU: ProcessorApicId=2 LocalApicId=1 enabled
Loading security extension com.apple.nke.applicationfirewall
Loading security extension com.apple.security.seatbelt
Calling mpo_policy_init for mb
Seatbelt MACF policy initialized
Security policy loaded: seatbelt policy (mb)
Loading security extension com.apple.security.TMSafetyNet
Calling mpo_policy_init for TMSafetyNet
Security plicy loaded: safety net for time machine (TMSafetyNet)
Copyright © 1982, 1986, 1991, 1993
The regents of the university of California. All rights reserved.

MAC Framework successfully initialized 
Using 10485 buffer headers and 4096 cluster IO buffer headers
IOAPIC: version 0x20 Vectors 0:23
ACPI: System State [s0 s3 s4 s5] (s3)
Extension ‘com.apple.driver.applePCIconfigurator’ has immediate depndencies on both com.apple.kernel and com.apple.kpi components; use only style.
Mbinit: done
Security auditing service present
bSM auditing present
From path: “uuid”,
Waiting for boot volume with UUID 804603d3-83e9-36b8-ab8e-11501d1805d6
Waiting on <dict ID=”0”>IOProviderClass</Key><string ID=”1”>IOResources</sting><key>IOresource
Match</key><string ID=”2”>boot-uuid-media</string></dict>

 

every method, and dvd that i try gives me the same result..... the hdd does nothing, and the dvd player quiets down so i am assuming this is a hang? although i see no panics??

 

I am going to aquire the msiwindosx dvd and see if i have any luck with that, i would like to do the boot 132 or efi method but i feel like you really need a previous install of osx to build yourself a nice .img file to house all your kext, kernel, and dsmos....... if someone could make one for me i would appreciate it greatly!!! I do believe i downloaded the msi iso before for boot 132 and had no luck with it.

 

Thanks

Share this post


Link to post
Share on other sites

I too have an n10j and asus got us this time. with current bios there is no way to shut off the on board hardware to install mac os. what did you use to flash to the modded bios? You have to be able to turn off all on board hardware (like you could on the 1000h. No option for that in the N10 bios currently. I wonder what the sound card is on the n10. I already bought an apple wifi card in hopes we will be able to install mac os. Keep us posted and good luck.

Share this post


Link to post
Share on other sites

yea man, i can shut off the lan, wifi, and sound, usb, and the touchpad but even when i shut off all but the usb(to run the dvd obviously) it gets stuck :D...... i flashed the bios after i requested it to be modified by osrom. I have looked up the componenets, and for the most part they are all the same as the eee1000. I wonder what could happen if the n10 was modded with Eee1000 bios mod to allow the install........ and if it would be possible to return to the regulard bios afterwards? I dont know i have even tried native installs, modded os-x dvd's and i even got vmware all with no luck!!!

 

tried dvds:

Kalyway 10.5.2 intel/amd

iDeneb 1.3 10.5.5 intel/amd

Jas 10.4.8

wondosx DVD

and Retail DVD 10.5.4 with boot 132 from many diff systems, msiwind, lenovo, generic, and couple of others.... to no luck.

 

So i guess unti lsomeone figures out a way to modify a DVD to work with our systems specs i guess we are SOL :( unless it is possible to mod the bios with eee 1000h bios....

 

Until then, to speed up your vista just restore with vista dvd that came with your system and once it is finished dont put in the app and driver dvd when it tells you. Instead just reboot the system and when it comes to the desktop you can put in the dvd to install only the needed items! trust me it made a huge diff in boot times and starting up apps!

 

or do what i did after the re-install if you are not happy with the vista hogging your ram just install XP ;)

 

Good luck and i hope someone chimes in with an idea to install osx :)

Share this post


Link to post
Share on other sites

I actually did it from the bios screen..... i could nto do it through windows bc it was the same date and version, so it kept giving me an error but it will work if you do it from the actual bios screen :)

 

have you had any progress?? if you are successful please update this thread. I just tried another cd and i still get the exact same error.

 

Jas 10.48

Kalyway 10.5.2

Kalyway 10.5.1(intell only, still no dice :D )

Ideneb 10.5.5

WindOSX cd

Retail DVD with boot 132, generic, msi wind, lenovo, mini9, and others....

 

Every install gives me the same exact error :) If i dont use the -v it will boot to the grey screen but without the rotating wheel, and if i use -v i see the waiting for uuid blah blah.... see the code above.

 

Hope someone figures this mess out :)

Share this post


Link to post
Share on other sites
bump!!!

 

oh and i am using an external DVD DL Drive.... it is IDE not sure if this might be a cause of the problem as well?

 

Did you try in the BIOS under the SATA configuration to change it from Enhanced to Compatible? I had to do this to install XP on it.

Share this post


Link to post
Share on other sites

This is just a shot in the dark but maybe if you already have a vanilla hackingtosh lying around try installing to an usb drive using the boot-123(usb key) method on that hack(leaving it on touched) than see if the usb boot-123 key boots the externel usb Vanilla drive on your n10. *remember to add cpus=1 flag to the boot.plist.

 

I did this method on the aspire one(though it is not necessary on the aspire one) I just like having an osx86 installed on an external USB that I can switch between my desktop hack,my aspire one and my brother real mac!

 

downside of this method is the slow usb2 drive speeds.

Share this post


Link to post
Share on other sites

at this point that might be worth giving it a shot, I would just like to figure out why the hell it hangs lol.... but i guess no one has ran into a problem like this yet.

 

I appreciate your input and will do that.

Share this post


Link to post
Share on other sites

Not that it will necessarily make you feel any better but I am having similar results on my N10j.

 

I've tried most of the various builds and haven't had any luck yet either. I'm open to suggestions or bouncing ideas back and forth if you want Shadow... I'm sort of surprised that there isn't more discussion about this machine. Maybe in time...

 

What method / build are you concentrating on using?

 

My *guess* is right now that there are some very specific PCI vendor and device IDs that the N10 uses that aren't in any of the kexts packaged with the various builds. That's a guess at best but the hardware seems to be mostly common with a couple of other netbooks that people seem to have running (wind, aspire one, etc.).

 

I haven't had a chance to try iDeneb yet but I believe you have with no joy.

 

I plan on taking a look through one of the builds (haven't decided which yet) to see what type of drivers are packaged / included. Hoping it's not a lack of BIOS functionality that's causing it...

 

Would love to see this machine working!!!

 

Cheers.

Share this post


Link to post
Share on other sites

if you have an USB and a extra hackingtosh lying around try the method i mentioned a few post back and see what you get. If this method works then we know the error has something to do with the internal hard drive.

 

Not that it will necessarily make you feel any better but I am having similar results on my N10j.

 

I've tried most of the various builds and haven't had any luck yet either. I'm open to suggestions or bouncing ideas back and forth if you want Shadow... I'm sort of surprised that there isn't more discussion about this machine. Maybe in time...

 

What method / build are you concentrating on using?

 

My *guess* is right now that there are some very specific PCI vendor and device IDs that the N10 uses that aren't in any of the kexts packaged with the various builds. That's a guess at best but the hardware seems to be mostly common with a couple of other netbooks that people seem to have running (wind, aspire one, etc.).

 

I haven't had a chance to try iDeneb yet but I believe you have with no joy.

 

I plan on taking a look through one of the builds (haven't decided which yet) to see what type of drivers are packaged / included. Hoping it's not a lack of BIOS functionality that's causing it...

 

Would love to see this machine working!!!

 

 

 

 

Cheers.

Share this post


Link to post
Share on other sites

Riker, atleast now i know i am not the only one..... I was mostly focusing on the Boot132 bc you could compile your own kext but i dont have a hackintosh right now :D the one i gave to my kid sis is windows notebook again.

 

Hughson: i have been meaning to try this method but like i said i need to see if i can aquire her notebook for a couple of days without it being an issue lol.... I was not aware that an HD could cause a problem with the install. If this is the case i am actually swapping my HD in the next couple of days to a Seagate Momentus 7200.3 which i read alot of people use for macbooks?

 

Thanks for the input guys I feel like someone will have osx installed soon :D

Share this post


Link to post
Share on other sites

Well, sounds like we're both in the same boat and I'm willing to give it a go. Better when you aren't in it alone! :)

 

@Hughson: Read your post and I'm still sort of new to the Hackintosh scene so I think I understand what you are saying to do. Problem is I don't have a spare, working hackintosh laying around - this was sort of my first go. I do have a Macbook but I don't think that will do the job will it?

 

I'm also surprised that it's possible for it to be hanging because of the drive but I guess anything's possible and I certainly can't say any different since I have little to no experience with Hackintosh. :blink:

 

On the hard drive side, I happen to have a spare 320GB 7200.3 Momentus drive laying around. I'll snap it in and see if we have joy on any of the builds. If only it was that simple! *Crosses fingers, toes and various other appendages* :P

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×