Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
aldo77

GMA X4500

1,615 posts in this topic

Recommended Posts

Neither do i , i cant see why i cant set it into correct resolution, no option to allowed me choose 1280x800 in my lifebook fujitsu. That is my problem till now

Share this post


Link to post
Share on other sites

Try setting it manually while booting as : "Graphics Mode" = 1280x800x32

if worked correctly put it in boot.plist file.

Share this post


Link to post
Share on other sites
Try setting it manually while booting as : "Graphics Mode" = 1280x800x32

if worked correctly put it in boot.plist file.

Already did it :D

Custom chameleon boot.plist, com.apple.Boot.plist, tried that all

Share this post


Link to post
Share on other sites

if worked correctly put it in boot.plist file.

 

how to put an option in boot.plist file?

 

i tried this kext and while booting i entered "arch=i386"

and it works.. it opened native 1680x1050 with no problem..

but i have to boot with this command every time..

also i did a search and found only chameleon boot.plist.

what should i do?

thanks in advance..

 

edit: thinkpad t500, c2duo p8400 2.26, 8gb ddr3, intel x4500hd, 160gb hitachi hdd

Share this post


Link to post
Share on other sites

hello

 

in org.chameleon.boot.plist or apple.com.boot.plist located in Extra

 

edit with text editor

 

key>kernel flag

 

string>arch=i386

 

puth there

 

good hack

Share this post


Link to post
Share on other sites

hello

 

in org.chameleon.boot.plist or apple.com.boot.plist located in Extra

 

edit with text editor

 

key>kernel flag

 

string>arch=i386

 

puth there

 

good hack

does that only make it boot with the kext or is that for qe as well? ive been waiting a long time and have almost given up.

Share this post


Link to post
Share on other sites

solved:

 

org.chameleon.Boot.plist

<key>Graphics Mode</key>

<string>1680x1050x32</string>

 

artur-pt, thank you.. will try your solution too..

Share this post


Link to post
Share on other sites
hello in org.chameleon.boot.plist or apple.com.boot.plist located in Extra edit with text editor key>kernel flag string>arch=i386 puth there good hack

 

I can't recall it now, but I do remember I had an issue with Chameleon v166x where it didn't recognize this flag on org.chameleon.boot and it worked only in com.apple.boot.

 

I didn't check whether it's solved in later versions or not.

 

does that only make it boot with the kext or is that for qe as well? ive been waiting a long time and have almost given up.

No QE/CI for this chip afai :(

Share this post


Link to post
Share on other sites

I'm going to just be straight up here--after searching this site and others, I've tried several different tricks, various kexts etc. and nothing is working for me. I *have* achieved 1440x900 resolution, however, though at boot I specifically set "Graphics Mode"="1920x1080x32@60" as my monitor is 1920x1080. Anyone know how I can actually get the proper resolution going? I'm not concerned about qe/cl at the moment.

 

I have the G45 chipset with X4500HD in a desktop (Hardware ID 2E22) and I am in a 64-bit environment, thus 32-bit patches will not work for my system.

 

Thank you!

 

EDIT: I'm an experienced Windows and Linux administrator so I have no qualms about jumping in and getting my hands dirty if need be. I'm very comfortable with the command line.

Share this post


Link to post
Share on other sites

I have the G45 chipset with X4500HD in a desktop (Hardware ID 2E22) and I am in a 64-bit environment, thus 32-bit patches will not work for my system.

 

But we all here know that there is no 64-bit kext for this chip .. how do you expect to get it working let alone changing the resolution ???

Share this post


Link to post
Share on other sites

I also have a Dell Latitude E6400 with Intel GMAX3100. Anyone have any sort of workaround or partial solution to this problem yet ? Also, I have hazard's 10.6.6i disk and I tried to install this in this laptop (Dell latutide E6400) but it failed... snow leopard set up gives a kernel panic when I boot from ######. However installing snow leopard 10.6.3 on this laptop works perfectly with the retail version. The reason i say this is because when I used Hazard's disk in my old laptop (Dell Studio 1555) i can see a kext for Intel GM45/X3100 graphics. But when i try to install hazard 10.6.6i to this laptop (Dell Latitude E6400) it gives a kernel panic so I can't install it. Anyone know how to make Hazard's 10.6.6i work on this latitude E6400 because hazard's 10.6.6i disk has that GMAX3100 driver.

Share this post


Link to post
Share on other sites

Anyone got this card to work in ML ?

 

we need 64bit version for X3100FP kext modified to device code 2a42

 

Update: I patched the X3100FB next from SL and it works perfectly (kext attached).

Thx. Work, but I have "black screen" Screen backlight switch to off mode.

Share this post


Link to post
Share on other sites

Anyone got this card to work in ML ?

 

we need 64bit version for X3100FP kext modified to device code 2a42

 

Update: I patched the X3100FB next from SL and it works perfectly (kext attached).

 

 

hello

 

u patched with what ?

 

thanks

 

good hack

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×