Jump to content

BCM 4310(SOLVED in a extrange way)


yoplaid
 Share

2 posts in this topic

Recommended Posts

Hi, first of all, congratulations for this awesome forum, I've learned a lot here! I also have to apologise for my english (I'm spanish)

 

Well, I've installed kalyway 10.5.2 on my hp dv6835es. It works smooth BUT I don't have neither power management nor wifi. When I installed LEO4all I had power management(but the DVD drive didn't work).

My wifi card is a BCM 4310 or at least this is waht OSx86Tools said. I've runned 43xx enabler, i've also changed the id by hand (in info.plist i added <string>14e4,4315</string> that someone in the forum said that worked) and finaly I changed NetworkConfiguration or something like this putting en1 instead of en0 and changing the 0 for a 1. Anything worked, it's like if the wifi doesn't existed.

Finally the wifi swith ALWAYS appears as OFF, so maybe this is the problem.

Do you know any way to fix my wifi??

 

Thank you very.

Link to comment
Share on other sites

Well, I really don,t know why but I have the wifi working. Lets explain this extrange method that could be usefull to anyone like me.

 

-first I used the script bcm43xx_enabler.sh were I added <string>pci14e4,4315</string>

-then sudo ./script bcm43xx_enabler.sh

-then i downloaded OSx86 tools

-open OSx86Tools and click on ViewPci device/vendorid

-it says something abaut installing something and then the airport apears.

 

I really don't know what happened but works!!!

I hope that this would help someone with my problem.

Good luck!

Link to comment
Share on other sites

 Share

×
×
  • Create New...