Jump to content

Lenovo s10


8 posts in this topic

Recommended Posts



I decided to start up a thread for all news relating to the Lenovo s10.


Some people began receiving the first shipments, so we can finally give OSx86 a run on these netbooks!


So what's the latest news?


- No bluetooth! At least not with the first shipments sent out. (Hopefully we can expect a bluetooth option at a later time)

- There IS a 512mb ram soldered into the board. The s10 CAN accept up to 2gb ram. It just disables the onboard card. (NICE)


In terms of installing osx...

One person posted results using the windosx86 install (used for the MSI Wind). He reported a non-working wifi card, lan and sound. As expected, the 950 gma works.


I assume it is because of a lack of compatible kexts. The person used the wind installation which was custom made for the msi wind.


When more experienced osx86 users finally get their lenovo s10s, maybe we can get a better idea of what is working and what is not.


When I know what is working, I plan to make a custom installation! (Similar to the windosx86 distro).


So, if you have a lenovo s10, please post your results!

Link to comment
Share on other sites

there's a post at www.s10lenovo.com that says the s10 has the following troublesome hardware:


sound: ALC269

wlan: BCM4312

lan: BCM5906


searching around here, it would seem that there's no driver for the ALC269. but then again one person on s10lenovo.com said that he installed the msiwind OSX and audio works, so who knows.

wlan seems like it can be fixed by following the instructions here: http://www.insanelymac.com/lofiversion/ind...hp/t120144.html. this involves flashing the wlan chip to give it a device id/vendor id that OSX likes.

finally it looks like the BCM5906 is a lost cause until someone ports the linux driver to OSX.

Link to comment
Share on other sites

I'm a newbie at this osx86 stuff, but I just got my s10 in today and tried using the msiWindOsx86 instal disc and everything seems to go smoothly until it restarts and goes to the section that says "Do you already have a mac" and I tell it to skip the transfer. It freezes for a little then goes back to the intro video for Leopard. I need help. I unchecked the kernal box too.

Any ideas?

Link to comment
Share on other sites

  • 2 months later...

hi guys!


1st of all...u all are my precious friends,coz i can't do all these crazy things without u all!thanx again!


i've done my trial installation to see it works or not.it works guys,but not perfect.i'll give the 'work' and the 'not'... :D

this machine i bought for my sister last week,it was s10 (white).

i use leo4allv3 by eddie11c...


processor: detected as Intel Core Solo 1.6ghz

graphic adapter: detected as Intel (0x27ae8086) but no QE/CI.it is intel gma945 i think,follow all the instructions from others,but nothing works.

wireless: not detected

bluetooth: detected like charm,work OOTB,my mighty mouse works!

lan: not detected


not bad for a small machine... :D

Link to comment
Share on other sites

  • 2 months later...
  • 10 months later...

I installed my lenovo s10-2 with the original Retail DVD of snow leopard with the help of usb drivers, 1 with NBE bootloader and other with the image that i restored from the DVD. I did not got any issues except Sound and ethernet not working. Wi-fi , bluetooth, display worked out of the box. I am searching a solution to increase the resolution to the maximum supported on s10-2 as its currently running 1024 X 600. Can any one help me on this.




Link to comment
Share on other sites


  • Create New...