Jump to content
nobb1x

Broadcom BCM5787M/BCM5784M - A solution

246 posts in this topic

Recommended Posts

Advertisement

Damn, I catch a glimpse of the devices here in my Broadcom network card and saw that is the same friend nobb1x, only that mine is "5787 14e4: 169b" ... I installed the kext for Snow Leopard, but not resulted in anything ...

Share this post


Link to post
Share on other sites

I modified the kext in "update 2" before I put it into the plugins folder because my card is a BCM57780 14e4:1692. But when I watch my system (10.6.3) boot, I see an error along the lines of "1692 Device Unknown"

 

What I did to modify the kext was

 

Info.plist (IONameMatch): Replace the string 'pci14e4,1693' with 'pci14e4,1692'

 

and

 

/contents/MacOS/AppleBCM5701Ethernet (hexedited): replaced all "66 81 FA 93 16" with "66 81 FA 92 16". There was a few of them.

 

Did I miss something or do it entirely wrong?

Share this post


Link to post
Share on other sites

Hello

I have Snow 10.6.5 and BCM5784M& It works only if i type:

sudo tcpdump -i en0

 

I've done this:

Start_Promisc copy it in /Library/StartupItems then Edit start_promisc,

INTF="en0"

KEXTPATH where is AppleBCM5787.kext

Then type:

sudo chmod -R 755 /Library/StartupItems/Start_Promisc

sudo chown -R root:wheel /Library/StartupItems/Start_Promisc

 

After restart it doesn't work.

 

What should I do?

Share this post


Link to post
Share on other sites
Anyone know if it works on OSx version 10.6.6 ??

 

Works very well with a 5787M (:1693)!

Share this post


Link to post
Share on other sites

Hi everybody,

I've installed some time ago a kext from update 2 on my iAtkos S3, Acer Aspire 2920z (repalced wifi card with compatible one). Now I've updated to 10.6.7 (oh yeah, with just normal update!), everything's almost fine, but wifi doesn't connect automatically to my home wifi at system logon. By the way, my old wifi problem still here too - sometimes it disconnects and can't reconnect until reboot. Got any solutions for these issues? Thanks

Share this post


Link to post
Share on other sites
Hi,My card is BCM57780, Broadcom NetLink Gigabit Ethernet 14e4:1692

I've already installed snow leopard 10.6.3,but my card just doesn't work.I used many ways.but my problem is still there. Can you please help me out?

I have the same LAN card,10.6.7 hera on Acer 5742G, but not working Ethernet

Did someone manage to get this card working

Share this post


Link to post
Share on other sites

Hi!

 

Can someone add this link into the beginpost? (http://www.kexts.com/downloads.php?do=file&id=1115).

 

Now this is added into the beginpost: http://www.insanelymac.com/forum/index.php...mp;#entry963461 But my kextlink is much better, you don't need to edit the kext for the Macadress and do a TCP dump.

 

This is the BCM5722D kext, made by Adlan (LINK)

 

Nawcom added the device id for the BCM5784M (14e4 1698). This is the netwerkchip that is inside the Dell Studio 1555 and much more laptops.

 

When you add your device ID, it works (maybe) with this models to:

It should support the following models:

BCM5754

BCM5754M

BCM5755

BCM5755M

BCM5787

BCM5787M #

BCM5906 #

BCM5906M #

Share this post


Link to post
Share on other sites

Got this working on Snow Leopard, with comboupdate 10.6.7, running a Dell Latitude e5400.

 

My DEV_ID is DEV_1680 under Windows (since my NIC is a BCM5761E). I just changed 1693 to 1680 rebooted, and it worked. Flawless.

 

Two problems I have though, I can't seem to find that startup script in the archive?!?

Second is, can't seem to find thoose lines using the HexEditor, to change my MAC Address.. annoying.. besides that, the NIC is working I guess.. but I can't test it.. lol ;)

 

Take a look at, http://www.broadcom.com/support/ethernet_n...mine_driver.php

Scroll down a bit, and you'll se the DEV_ID's.

Share this post


Link to post
Share on other sites
Lion's patched kext for 1693

 

works fine, sleep works but adapter doesnt work after sleep.

 

if you wanna use it with other card, change every 93 16 bytes to your devid.

 

Many thanks netkas,

 

works perfectly!!!! :wacko:

Share this post


Link to post
Share on other sites
Many thanks netkas,

 

works perfectly!!!! :D

 

Also worked for me with lion - even after sleep! Put it into E/E, made an extensions.mkext and repaired permissions with kext wizard.

 

Thank you netkas :)

Share this post


Link to post
Share on other sites

Hey Guys, thanks for the Kext! I have a quick question though, I am hex editing and was unsure about the procedure.

 

Do I simply do a find and replace for 93 16 bytes and replace all instances with my device id (I am assuming it is going to be 1680 in hex as 1680 is my devid) ?

Share this post


Link to post
Share on other sites
Lion's patched kext for 1693

 

works fine, sleep works but adapter doesnt work after sleep.

 

if you wanna use it with other card, change every 93 16 bytes to your devid.

 

Works perfectly.

Mine is 14e4:1698

i just added it to the list and it works great

(I tried very hard to find this thread again to Thank You)

Thanks a lot

Share this post


Link to post
Share on other sites

Can anybody make "Adding BCM5784M kext to Lion for Dummies"? :) I'm completely lost, tried 5 ways... Acer Aspire 8735G, Lion 10.7.2.

Share this post


Link to post
Share on other sites

Can anybody make "Adding BCM5784M kext to Lion for Dummies"? :) I'm completely lost, tried 5 ways... Acer Aspire 8735G, Lion 10.7.2.

right click, show package contents.

then

drag drop file on desktop (info.plist) edit there. save. drag n drop back to kext.

repair permissions.

 

or edit the kext on desktop. then install with kext wizard

Share this post


Link to post
Share on other sites

Cheers pal! Some more dummy questions:

right click, show package contents.

Which file? From update 3 in first post?

drag drop file on desktop (info.plist) edit there. save.

What exactly I have to edit? Just a small example, and I'll get it.

then install with kext wizard

Can I use Kext Utility as well?

Share this post


Link to post
Share on other sites

Lion's patched kext for 1693

 

works fine, sleep works but adapter doesnt work after sleep.

 

if you wanna use it with other card, change every 93 16 bytes to your devid.

Hate to revive an old topic, I would have sent a pm, but it said it was not possible...

 

 

Hi, I noticed you'd patched AppleBCM5701 for Lion, to work with 16 93. Can this be made to work with 16 b1? I tried swapping out 93 16 for b1 16 but to no avail, It shows up in the network prefpane and seems to get assigned an ip, but won't connect.

 

I've tried editing the original 10.7 kext *ionetworking>applebcm5701* from scratch but all attempts result in some weird link error during boot...

 

I realize you're a very busy individual but if you ever have the time to check this out it'd be much appreciated, or even just steering me in the right direction would be much appreciated too; I hate to ask for 'freebies' esp since you're not getting paid for your work.

 

Kind regards,

ks

Share this post


Link to post
Share on other sites

Lion's patched kext for 1693

 

works fine, sleep works but adapter doesnt work after sleep.

 

if you wanna use it with other card, change every 93 16 bytes to your devid.

 

Hi Netkas,

 

Would it be possible for you to provide the same Kext for Mountain Lion. Or atleast let me know what all values have you bin-patched..

 

Thanks in advance..

Share this post


Link to post
Share on other sites

Hey guys I have a Dell Latitude E6400 and a Dell Studio 1555. Does anyone know how to make wifi/ethernet work with either models ? Thanks !!

 

Studio 1555

Broadcom NetLink Gigabit Ethernet - Device ID: 1698 Vendor ID: 14E4

Intel® WiFi Link 5100 AGN - Device ID: 4232 Vendor ID: 8086

 

Latitude E6400

Ethernet

Type: Ethernet Controller

Bus: PCI

Vendor ID: 0x8086

Device ID: 0x10f5

Subsystem Vendor ID: 0x1028

Subsystem ID: 0x0233

Revision ID: 0x0003

BSD name: en0

 

Airport

Software Versions:

Manu Extra: 6.2.1 (621.1)

configd plug-in: 6.2 (620.15.1)

System Profiler: 6.0 (600.9)

Network Preference: 6.2.1 (621.1)

AirPort Utility: 5.4.2 (542.23)

IO80211 Family: 3.1 (310.6)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×