Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
MadTux

How to patch AppleHDA.kext from 10.5.2 and above

228 posts in this topic

Recommended Posts

OK. Strip out the junk;

f01c2701 111d2701 111e2701 411f2701 f01c3701 111d3701 111e3701 411f3701 1f1c4701 101d4701 211e4701 021f4701 101c5701 011d5701 131e5701 991f5701 f01c6701111d6701 111e6701411f6701 401c8701981d8701 a11e8701021f8701 411c9701091d9701 a31e9701991f9701 4e1ca701301da701 811ea701021fa701 f01cc701111dc701 111ec701411fc701 2d1cd701951dd701 171ed701401fd701 301ce701111de701 451ee701021fe701

 

then you have to byte flip each double word;

<01271CF0 01271D11 01271E11 01271F41 01371CF0 01371D11 01371E11 01371F41 01471C1F 01471D10 01471E21 01471F02 01571C10 01571D01 01571E13 01571F99 01671D11 01671CF0 01671F41 01671E11 01871D98 01871C40 01871F02 01871EA1 01971D09 01971C41 01971F99 01971EA3 01A71D30 01A71C4E 01A71F02 01A71E81 01C71D11 01C71CF0 01C71F41 01C71E11 01D71D95 01D71C2D 01D71F40 01D71E17 01E71D11 01E71C30 01E71F02 01E71E45>

 

I'd be interested if this has any effect on your system profiler just paste the above into ConfigData of Info.plist of Applecontroller.

Share this post


Link to post
Share on other sites
then you have to byte flip each double word;

<01271CF0 01271D11 01271E11 01271F41 01371CF0 01371D11 01371E11 01371F41 01471C1F 01471D10 01471E21 01471F02 01571C10 01571D01 01571E13 01571F99 01671D11 01671CF0 01671F41 01671E11 01871D98 01871C40 01871F02 01871EA1 01971D09 01971C41 01971F99 01971EA3 01A71D30 01A71C4E 01A71F02 01A71E81 01C71D11 01C71CF0 01C71F41 01C71E11 01D71D95 01D71C2D 01D71F40 01D71E17 01E71D11 01E71C30 01E71F02 01E71E45>

 

I'd be interested if this has any effect on your system profiler just paste the above into ConfigData of Info.plist of Applecontroller.

 

This could work...

Share this post


Link to post
Share on other sites

interresting stuff ... even if i cant handle it myself. this makes me remember the old good amiga-action-replay times where we knocked down protections with some guys ... :)

Share this post


Link to post
Share on other sites
interresting stuff ... even if i cant handle it myself. this makes me remember the old good amiga-action-replay times where we knocked down protections with some guys ... :)

 

I believe this will be interesting story to talk about.

 

Ok i'll give it a go, Do I have to have a working AppleHDA 10.5.5 first?

 

Thanks

 

Ade.

 

U need to have a least patched HDA binary for thing like this, and maybe some code in pathmap

 

But it should show you all your Devices in Profiler

 

AND I LOVE WHEN WE HAVE SOME PROGRESS!!

Share this post


Link to post
Share on other sites

@miglo: the lenovo netbook got that alc269 too? so all the new netbooks have that damn chip. we need to get this working. dell, lenovo, msi, asus and acer use all the 269 in their netbooks. and they run so l33t - except sound. check my other thread here in "sound" for progress ...

 

LINE OUT is working ...

Share this post


Link to post
Share on other sites

Mad Tux,

Might I suggest that you make a patcher if you have enough knowledge and time. Also, if you could contact taruga, maybe you two can work together and make the ultimate patcher and finally fix the sound problems of everyone.

Share this post


Link to post
Share on other sites
Mad Tux,

Might I suggest that you make a patcher if you have enough knowledge and time. Also, if you could contact taruga, maybe you two can work together and make the ultimate patcher and finally fix the sound problems of everyone.

First we have a different aproach. second I believe that he has already built something like "ultimat patch" for sound, but it is not public yet. So what is the point of merging? And I don't have time to build a patcher, I have a exams to take. A lot of uninsanelymac life to cach.

Share this post


Link to post
Share on other sites

MadTux,

Still playing around with the ALC269. AppleHDA loads but I get loads of cool errors in my system.log file and not surprisingly no devices pop up.

Could you please show me what you get under system.log (search HDA) or no errors (hopefully) with your working ALC880 kext.

Could I see your output for ioreg -l -w0 | grep HDA.

Thanks

Steve

Share this post


Link to post
Share on other sites

Ok I cannot get my 10.5.5 kext to load to try the Default Pin Config Overrides you guys suggested.

 

If someone could have a look at this kext to see what i'm doing wrong that would be great. Ive posted a linux dump of my codec and the modified AppleHDA kext i'm trying to load.

 

Thanks

 

Ade.

AppleHDA.kext.zip

268.txt

Share this post


Link to post
Share on other sites

thank you madtux, now i understand how to remap applehda by myself,

 

but with my p35-ds3l ( alc888 - ich9 ), i was unable to activate analog 5.1 output wathever the pin configuration i choose, even if the system profiler and the sound prefpane show me 3 output, only the green jack work :wacko: (coax and optical seems to work but not tested)

 

here is my HDAaudio dump

 

 

any help will be appreciated .

Share this post


Link to post
Share on other sites

Has anyone had any luck getting the ALC888 on ICH7 to work via this method? Taruga's patcher doesn't support this soundcard on this chipset.

Share this post


Link to post
Share on other sites
Anyone help. Please don't let this thread die we are starting to get somewhere

 

Best

 

Ade.

I saw your kext:

1. U didn't patch AppleHDA bin

2. Where is your codec id inside PlatformDriver on Layout 12? U didn't done that ether.

3. And where are your Nodes inside Pathmap that os associated to Layout 12?

Read the first post, do as much U can, then test PinConfig

Share this post


Link to post
Share on other sites

Very good instructions. I do have one problem. My kexts keep opening as _*folders*_ in hexedit or 0xed or any other editor i've tried instead of a binary file. I am not sure what i changed to make this happen (some setting in finder??) or how to change it back. any one have suggestions?

 

Thanks.

Share this post


Link to post
Share on other sites

hi MadTux, thanks for this guide, i'm trying to do one for mine ALC268, because taruga's one (any version) crash the hack on shutdown, i have the modified kext loaded but no input/output peripherals, looking in the system profiler i can see instead it see many IO, even those i've deleted!! spdif,line in/out etc.

 

you say

"Now we have to delete all things in side Layout map that we don't need so if U don't have a InternalSpeakers remove that line or SPDIF and so one, but leave things U need :-)"

ok, i have only internal speakers, mic and headphones

 

"The easy way of knowing what U have and your node numbers is if U use a applehda patcher and copy a result of a found devices with node numbers. The hard way (and a better coz more input/output U can put in Platformdriver, and some codec dumps are not so full with descriptions) is to read a codec dump what is not so hard."

i'm looking on taruga's one,i still need to understand it 100%

 

//"PathMap

there U put a node numbers they are in this order:

0 > Mic > 3 node numbers

1 > Line in > 3 node numbers

2 > SPDIF in > 2 numbers

3 > Speakers > 3 node numbers

4 > Headphones > 3 node numbers

5 > LineOut > 3 node numbers

6 > SPDIF out > 2 node numbers"

Do i need to delete unnecessary items from here too? so if i have mic,speakers and headphones i need to erase 1,2,5,6 ??

 

ATM, the kext load and shutting down the mac it don't crash,i can succeed in kextunloading too,while this is forbidden using taruga's. just i need it emitting some sounds :rolleyes:

 

edit--

i get this error twice in dmesg loading the modified kext, what i'm doing wrong?

 

Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 1653 goto Exit

Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 108 goto Exit

Share this post


Link to post
Share on other sites

Hi all,

 

I've an ALC1200 (p5q pro motherboard)

 

Can you give me the translation in decimal, hex and hexedit ?

I think is

in hex : 0x10ec0888

so hexedit : 8808EC10

 

but in decimal ?

 

thanks vincent

Share this post


Link to post
Share on other sites
Hi all,

 

I've an ALC1200 (p5q pro motherboard)

 

Can you give me the translation in decimal, hex and hexedit ?

I think is

in hex : 0x10ec0888

so hexedit : 8808EC10

 

but in decimal ?

 

thanks vincent

 

 

is 283904136

Share this post


Link to post
Share on other sites
Hi all,

 

I've an ALC1200 (p5q pro motherboard)

 

Can you give me the translation in decimal, hex and hexedit ?

I think is

in hex : 0x10ec0888

so hexedit : 8808EC10

 

but in decimal ?

 

thanks vincent

 

Why don't U use calculator?

 

Nobix can U post "non shutdown" alc268 kext?

 

hi MadTux, thanks for this guide, i'm trying to do one for mine ALC268, because taruga's one (any version) crash the hack on shutdown, i have the modified kext loaded but no input/output peripherals, looking in the system profiler i can see instead it see many IO, even those i've deleted!! spdif,line in/out etc.

 

you say

"Now we have to delete all things in side Layout map that we don't need so if U don't have a InternalSpeakers remove that line or SPDIF and so one, but leave things U need :-)"

ok, i have only internal speakers, mic and headphones

 

"The easy way of knowing what U have and your node numbers is if U use a applehda patcher and copy a result of a found devices with node numbers. The hard way (and a better coz more input/output U can put in Platformdriver, and some codec dumps are not so full with descriptions) is to read a codec dump what is not so hard."

i'm looking on taruga's one,i still need to understand it 100%

 

//"PathMap

there U put a node numbers they are in this order:

0 > Mic > 3 node numbers

1 > Line in > 3 node numbers

2 > SPDIF in > 2 numbers

3 > Speakers > 3 node numbers

4 > Headphones > 3 node numbers

5 > LineOut > 3 node numbers

6 > SPDIF out > 2 node numbers"

Do i need to delete unnecessary items from here too? so if i have mic,speakers and headphones i need to erase 1,2,5,6 ??

 

ATM, the kext load and shutting down the mac it don't crash,i can succeed in kextunloading too,while this is forbidden using taruga's. just i need it emitting some sounds ;)

 

edit--

i get this error twice in dmesg loading the modified kext, what i'm doing wrong?

 

Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 1653 goto Exit

Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-157.1.24/AppleHDA/AppleHDADriver.cpp" at line 108 goto Exit

 

Pinconfig is bigest thing in 268 try to use one in your broken kext

Share this post


Link to post
Share on other sites
Why don't U use calculator?

 

Nobix can U post "non shutdown" alc268 kext?

 

 

 

Pinconfig is bigest thing in 268 try to use one in your broken kext

 

I'm trying pinconfig just right now, i have extracted the infos from the Vista driver

Here is the "non shutdown" alc268 kext, its a common problem, not just on my hack,

Some time ago someone made a fix for it, there is a thread on this forum, but it works

5 out 10 times, i'm sure the crash on shutdown is due the Taruga kext because starting the

system with -v i can see a panic saying "an application releasing the hda audio has caused a corruption in

the register" (about, i'm not sure it say this exactly)

ALC268_Installer2.zip

Share this post


Link to post
Share on other sites

Can anyone tell me if a full reboot is necessary to test a layout, or can I just unload and reload the kexts? (I'm assuming I'd have to unload HDAEnable and AppleHDA kext.

 

Can anyone clarify this?

 

 

EDIT: A few more questions:

 

-Does anyone know what causes the volume slider to be disabled in some cases? Is that a matter of switching codec? Layout?

 

-My codec layout doesn't have the * for the mixer selectors, and the output seems to be connected to multiple mixers. How do I know which to use? My codec is attached. Actually, it does have *, but only for the front connectors, which are off of a motherboard header that I'm not using.

ALC_662_codec2.txt

Share this post


Link to post
Share on other sites
I'm trying pinconfig just right now, i have extracted the infos from the Vista driver

Here is the "non shutdown" alc268 kext, its a common problem, not just on my hack,

Some time ago someone made a fix for it, there is a thread on this forum, but it works

5 out 10 times, i'm sure the crash on shutdown is due the Taruga kext because starting the

system with -v i can see a panic saying "an application releasing the hda audio has caused a corruption in

the register" (about, i'm not sure it say this exactly)

 

try this one, it will not kernel panic. And if U have spare time we can test it to show devices in sysprofiler

Madtux_ALC268.zip

 

And If U maybe have a HDA kext from 10.5.0 or anybody has, please post it, I need for some testing.

Share this post


Link to post
Share on other sites
Can anyone tell me if a full reboot is necessary to test a layout, or can I just unload and reload the kexts? (I'm assuming I'd have to unload HDAEnable and AppleHDA kext.

I always reboot

-Does anyone know what causes the volume slider to be disabled in some cases? Is that a matter of switching codec? Layout?

U can fix volume slider thru Pathmap, but U will lost mute

-My codec layout doesn't have the * for the mixer selectors, and the output seems to be connected to multiple mixers. How do I know which to use? My codec is attached. Actually, it does have *, but only for the front connectors, which are off of a motherboard header that I'm not using.

use the first one, do with some trial end error, or find a better codec dump.

Build latest alsa from source and get the latest one, or learn how to read datasheet from realtek.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×