Jump to content

10.5.5 from Kalyway 10.5.2


jlmusa
 Share

6 posts in this topic

Recommended Posts

hello friends... well i hae too much to ask, and I think many people will be identifies with my problems...

First of all, I have kalyway 10.5.2 installed on a Pentium-D, mother INTEL D101GGC, Nvidia 7200LE, all working, and sound ALC861 working thanks to THIS post, everything is working.. Then, 10.5.5 update is here... and I wanted too try this, backing up my system in Time Machine... This were the results...

 

1. ALWAYS installing with this guide, otherway the system breaks.. well I did it step by step, but on reboot my kernel (SleepKernel) was repleced (i guess) so, I could never boot up again, on a constant reboot of my computer... let's reinstall the system all over again and use time machine...

 

2. SO, the problem was this famous EFI, not well nown for people who are new in this... so... I runned the packcage (COMBO UPDATE, 601 MB) and before restart I copied the kernels and mach_kernel files from time machine to drive of MAC... repaired permissions and rebooted... then, that didn't even worked: I could, yes, boot with the -v flag, and do it twice... but can=t boot onto the system, because it says something about being unable to write on kernel symbols... I tried with -x.. and it started, but neither my MOUSE or my KEYBOARD where ready (and bluetooth were activated, searching for peripherals!!!!

 

PLEASE HELP MEEEEE

what can I do??? Now I'm on 10.5.2 again... what can I do?? how to use OSX86 tools to update without problems my computer??? PLEASE

PLEASE

HELP

 

Thank you everyone.

 

J.

 

PS: Sorry for my english :)

Link to comment
Share on other sites

To update 10.5.5 just follow this guideline ---> http://forum.insanelymac.com/index.php?showtopic=126268 . If you want to update from 10.5.2 please download combo update.

After finishing update always boot with "update -v" otherwise your PC should recurring reboot.

To kick out form booting problem use OSX86 tools to Install modbin kernel. Try Googleing 9.4 modbin kernel if you dont have. I hope to get 10.5.5 modbin very soon...

 

hope this will help.

Link to comment
Share on other sites

I did it from 10.5.2 kalyay toh 9.2 > kalyaway combo update 10.5.3 > combo update 10.5.5

 

to update to 10.5.5:

- backup kext and kernel with osx86tools

- run the console script trick

- run the combo update

-close the console

-restore kext and kernel

- restart

 

Dell gx280 2.8 p4 cpu, works better with kernel modbin 9.4

Link to comment
Share on other sites

There's a way to fix it after upgrading. As you mentioned your kernel is replaced, but there's no need to reinstall everything again, all you gotta do is get your sleepkernel back, which is easy to do (albeit a bit time consuming if you aren't patient).

 

You must boot up from your kalyway DVD, then once you get to the step before installation do the following:

 

1.- Goto Utilities and select Terminal

2.- On Terminal goto /Volumes/Mac/ (replace Mac with the name of your partition. On my case I named it Mac, if you're unsure just do a "ls -Fla /Volumes" to list the available partitions, and check the name of the one where you installed kalyway)

3.- Once in, do a "ls -Fla" and look at the results. There must be a "mach_kernel" file (without extension, watch out cause there's a .ctfsys here) that contains the kernel used to boot. What you wanna do is replace this file with your old "sleepkernel" which is also located in the same directory.

4.- This is optional, but do a backup of the current kernel with "mv mach_kernel kernelbackup1055" (kernelbackup1055 is the name of the backup)

5.- Copy sleepkernel over mach_kernel with "cp sleepkernel mach_kernel"

6.- Reboot, and you're done!

 

With this you'll restore your old sleepkernel to run with the 10.5.5 leopard, and if everything else is running well, you'll be able to boot up as before.

 

If by any chance you get to see the gray background with the apple logo for a second, and then reboot instantly it means the kernel is not working properly. Usually this is fixed by typing "update -v" at the boot screen before going into leopard.

 

If "update -v" doesn't work then something else got screwed up in the upgrade process.

 

I managed to get from 10.5.2 to 10.5.5 (I'm replying from it right now) by doing these steps right after each upgrade. I may have avoided this by replacing the kernel just right before the final restart, however.

 

cheers!

Link to comment
Share on other sites

Is there a way to upgrade straight from 10.5.2 to 10.5.5? or do you have to go incrementally? It seems that nobody has done it.

 

I tried this but for some reason my pre-script didn't work. I left it on but it didn't say anything during the installation, and then it crashed after the installation was done. i never got a response from my script. i may have made a typo.

Link to comment
Share on other sites

There were no Problems with my Updating from 10.5.2 to 10.5.5 (using Kalyway's DVD). First there was only some hanging at the bootscreen, bot later on it worked while booting into safemode (-x) and install an EFIString for my graphic card. After that all, it works like a charm.

 

For specs see my signature. :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...