Jump to content
Sign in to follow this  
Followers 0
vovaz04h

Motherboard MSI MS-7379 G31M

9 posts in this topic

Recommended Posts

Помогите с установкий OSx86 на майкростаровскую мать ms-7379 G31M.

 

Конфигурация системы:

MB: microstar ms-7379 g31m

RAM: 2gb

HDD: sata 80gb

DVD-RW: IDE

Video: Integrated Intell G31

 

Если у кого-то есть варианты (рабочие) по установке - прошу высказываться.

 

P.S. Сменить железо не предлагать

Share this post


Link to post
Share on other sites
Advertisement

С оригинальным биосом для данной матери установка висла и ругалась на ACPI.

Поставил биос из ветки mod_bios_by_Kabyl для своей матери не нашел и по-этому ставил сходный по размерам для матери 7383 - прошилось на ура (все нормально). Установка запустилась.

Завтра буду ставить (пробовать) перекину данные с винта и буду пробовать.

Share this post


Link to post
Share on other sites

В результате.... Ос установил но загрузка идет только если нажать F8 и вписать cpus=1. То-есть только одно ядро работает :D

Нет звука для HDA 82801G. Или я пока не нашел как его зставить работать. Видео только 1024х768 похоже только VESA. Поддержку G33/G31 я тоже пока не нашел.

 

Только что запустил звук с помощью http://forum.insanelymac.com/index.php?showtopic=36520

Ставим AzaliaAudio.pkg should give 2ch output on most High Def Audio chipsets (updated v1.1)

Share this post


Link to post
Share on other sites

А что у вас за проблема с USB? (Так спрашиваю как будто смогу помочь :) Это не так :) ) у меня работает замечательно из коробки. Остался как я и писал только один недостаток cpus=1 не знаю поможет ли cpu-1 fix и что он конкретно делает.

 

И хотелос бы узнать есть ли описание фиксов которые нужно ставить или выбирать при установке. Ну и для какого железа какой фикс.

Share this post


Link to post
Share on other sites

C USB разобрался, кое как работает, время от времени удаляю /System/Library/Extensions/Cache и работает :P

теперь надо разобратся со встроенной видяхой, приложение говорит VRAM а нужно больше. Может VRAM, totalsize где то больше прописать чтоли.

 

cpu-1 fix помоему в boot ему пропишет чтоб всегда был cpus=1.

Share this post


Link to post
Share on other sites

Так в том то и дело что хочется не cpus=1 а что бы ядер было 2 как на проце.

 

Имя процессора: Intel® Pentium® Dual CPU E2160 @

Скорость процессора: 1.8 ГГц

Общее количество ядер: 1

Кэш L2: 1 МБ

Свойства процессора: FPU VME DE PSE TSC MSR PAE MCE CX8 APIC SEP MTRR PGE MCA CMOV PAT PSE36 CLFSH DS ACPI MMX FXSR SSE SSE2 SS HTT TM SSE3 MON DSCPL EST TM2 SSSE3 CX16 TPR PDCM

 

а должно быть 2 ядра ;) Народ!!!! Выручайте!!!!

Share this post


Link to post
Share on other sites

Точно такая же мать (MSI G31 M-F). В биосе поставь Execute Bit Support в Enabled. Поизучай тему DSDT. Проблема решена мной путем стирания в DSDT строчек CPU Alias у всех ядер. Посмотри патчер от koalala: он умеет и автоматически решить эту проблему (правда насколько хорошо не знаю, я ручками удалял) и многое другое, в том числе прописать в DSDT видео, чтоб заработало нативно без стрингов и инжекторов. Правда у тебя карточка патчером не поддерживаемая, неужели нет никакой невстроенной от нвидии или ати?

 

С параметром в биосе и DSDT с удаленными CPU Alias гарантирована работа на всех ядрах.

Share this post


Link to post
Share on other sites
Точно такая же мать (MSI G31 M-F). В биосе поставь Execute Bit Support в Enabled. Поизучай тему DSDT. Проблема решена мной путем стирания в DSDT строчек CPU Alias у всех ядер. Посмотри патчер от koalala: он умеет и автоматически решить эту проблему (правда насколько хорошо не знаю, я ручками удалял) и многое другое, в том числе прописать в DSDT видео, чтоб заработало нативно без стрингов и инжекторов. Правда у тебя карточка патчером не поддерживаемая, неужели нет никакой невстроенной от нвидии или ати?

 

С параметром в биосе и DSDT с удаленными CPU Alias гарантирована работа на всех ядрах.

 

Да после DSDT патча заработали оба ядра. Теперь хочу на этой матери завести родной Intel HDA не Azalia а именно родной. Пробовал Таругу и линуксовый дамп. В результате устройства появились (Линейный выход и наушники и микрофон) но звука через них нет хотя при загрузке щелчок в динамиках есть (я так понимаю при инициализации драйверами звука). Делитесь либо опытом либо готовым драйвером ^_^

 

Вот что написано на сайте у MSI

 

• Аудио-кодек Realtek® ALC888/ 883 (опционально)/ 861 (опционально).

- 7.1-канальное аудио с гибким переназначением разъемов ввода/вывода.

- Совместим со спецификацией Azalia 1.0.

- Соответствует спецификации Microsoft Vista Premium.

 

MSI_7379_realatek_alc888.txt это дамп из линукса

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

×