Jump to content

RT2870: not working

Ren McCourtey

2 posts in this topic

Recommended Posts

Hello everybody,

I'd like to ask for help someone with more Mac exps than I have. Third night when I tried to make RT2870 based dongle running under 10.5.4 is over and I am still on square one.

This is my first contact with Mac world and I have to say, OSX takes your usual fight with computers to whole new level. ;) At least I learned quite a bunch of things about it so far.


My dongle is Cisco/Linksys made with PID 0071&VID 1737. So I:

1) Installed driver (i) Latest official Ralink driver ii) modified version I found around here)

2) Edited Info.plist and added my IDs (i) plist in /Content ii) plist in /Content/Resources iii) both)

3) Rebuilt cache (with kextcache -k /System/Library/Extensions)

4) Repaired permissions (i) with chown ii) with Disk utility)

5) kextload: kext loaded successfully

6) Rebooted

Everything on new iATKOS & JaS, with vanilla & moded kernels, unplug/plug, plug when system running, all in various combinations and....

...big fat nothing. No new device in network settings, NO DEVICE!! in Ralink utility, not even a blink of the LED..By the way, utility never starts automaticaly as it is said it should, if it's relevant.


Am I missing some important step here or do I just have a bad luck? Sleep is not working same as audio but I am not even thinking about fixing those without Internet running.

Do you also hate that feeling when no matter how hard you try there's absolutely no effect, not even negative? Like when you would be just sitting there watching the screen not doing anything with THE ABSOLUTELY SAME result? ;)

Link to comment
Share on other sites


  • Create New...