Jump to content

HP Nc6000/Nc8000 topic


127 posts in this topic

Recommended Posts


NC6000 NC8000

these laptops are one of the best hackingtosh it has an SSE2 prossesor , Ati mobilty 9600 64/128mb ac97 audio and firewire

everything works exept the grafics of leopard no qe/ci becouse ati was to lazy to devolep and i couldn't get the battery to be recongized reason is that the PC thinks it has 2 battery bays maybe an older bios can fix this need someone to try



i recomend the JaS 10.5.4 install disc with StageXnu kernel or the Boot-132 with this topic http://forum.insanelymac.com/index.php?sho...23841&st=80


install guide from Yana209:


2-Installed OSx86:

a- Erased the drive using disk utility

b- customized the installation and chose only: StageXNU, AC97 Audio, ICH and PIIX controller, Artheros Wireless adapter (All thanks to Nick14).

c- Installation took around 25 minutes.

d-Rebooted the computer

e- choose the options -v -f

f- booting took 10 minutes to finish and then the all awaited welcome video started :-D


the wifi fix :IO80211Family.kext.zip just remove the zip from it name and it will ask if you want it as zip or Kext and choose kext


Audio:AppleAC97Audio.kext.zip this just need to unpack


grafic: http://forum.insanelymac.com/index.php?sho...829&hl=9600 use 1280x1024 for less problems with the screen dont install the Frameworks they dont work just the kext




Internal Broadcom :AppleBCM5751Ethernet.kext.zip Just extract it and copy it to /System/Library/Extensions/IONetworkingFamily.kext/Contents/PlugIns and delete the 5701 kext else you wont get a mac adress


keyboard and mouse : http://forum.insanelymac.com/index.php?sho...mp;#entry811362

Link to comment
Share on other sites

Well i managed to install kaliway 10.5.2 on my nc6000. I haven't test everything in the system just yet, but so far audio works, usb sort of works: when i insert usb key it wont detect it, but it detects it after reboot. dvd-rom works, ethernet (haven't test it), wi-fi doesn't work ive got atheros w500 internal card, tried few tutorials but it sort of detects it but can't turn on. Video is sluggish as i expected, mouse leaves small white square in some places.

Link to comment
Share on other sites

The audio works best with the on i uploaded the wifi is the same as mine but wright LSCPI in termail and post it here but everything should work the usb worked on mine the mouse squares come but if you put in in 1280x1024 mode it becouse alot less i got everything working exept the battery and grafic acceleration

Link to comment
Share on other sites

Yes i've tried it on 3 diffrent NC6000 just get JaS 10.5.4 and install it but the boot on the disc take about 15min and first boot about the sametime but after that it works 100% everything exept the grafics no qe/ci the wifi NC6000 has is a intel 2200 so there should be drivers there and after first boot it boots in 7 sec

Link to comment
Share on other sites


Glad to know there's a topic about NC6000 and one of the fellows already successfully installed Kalyway 10.5.2.

I had no problem in the installation and boot selection procedure but once I select the OS X partition, it starts loading and then gets stuck at the following last two lines:


MAC Framework successfully initialized

using 5254 buffer headers and 4096 cluster IO buffer headers



I have waited some 25 minutes, but no activity. I too have NC6000.


Any help is appreciated.





just tried it with option -f and it is showin a grey screen with dark grey apple logo on it and some circular animation...not going beyond it...

Link to comment
Share on other sites

I have re-installed everything again. (i didn't know how to choose a different kernel at the start) so I chose kernel_9.2_sleep, and now I have tried all the kernels, but each time it will get take me to grey apple logo screen and a after a while a dialogue will tell me that I should restart my machine :angel:

I couldn't find stageXNU Kernel in Kalyway 10.5.2 DVD. How to get that?



Link to comment
Share on other sites

It would be so nice if you could elaborate a bit further on how to do the installation.


Which packages in which categories to check, which to uncheck. How long the install takes, how long the first boot takes. So people know they don't have to panic if it freezes or takes a long time. You could also state when something is obviously going wrong... (in case you know).


I always thought the installation was one of the most complicated things to actually get right.


Right now I am sitting in front of my NC6000/NC8000 waiting for it to boot for the first time. I've got a grey screen and I can see my mousepointer and move it around - but that's about it. It's been like this for a good 15 minutes, does that mean I can start worrying, or not?


It would be real nice to see few more details in this thread... thanks in advance!

Link to comment
Share on other sites

First Boot= 15min atleast with JaS 10.5.4 and boot-132 atleast on my and nickhes PC


2 boot after install = 10-20min


3 boot to 1million = 7-10 sec


and choose StageXnu kernel or sleep 9.2 and after that change to Voodoo 9.4 or 9.5 they work alot better and faster then other kernel

Link to comment
Share on other sites

Okay, here is a progress report.


I got my Keyboard & Mouse working after installing the ApplePS2Controller, so thanks for the hint!


Fixed Network is working, Wireless still troubles me. Bootup time is 5 minutes, each and every time!


I don't know what it is with the bootup time, that is really annoying, what also is annoying that X11 doesn't work. I did install it, but when I try to launch it, it immediately fails.


So right now my prio #1 is bootup, then #2 X11. After that I'll try to get the Atheros working. By the way - why did you install that extra audio driver? Audio works for me a-ok after the install and when I install the other package named above my system won't boot...




Any Ideas about anything named above? Would be greatly appreciated...

Link to comment
Share on other sites

Okay, let's see. Another half day of work done.


I learned that it is important to install your drivers, even if you know you're not going to use the devices. I know now why my laptop kept hanging for 5 minutes at this point:


configd[55]: InterfaceNamer: timed out waiting for IOKit to quiesce


I needed to install the Cardbus drivers, which are linked to on the first page.


I also got the Atheros to work, but I needed the old Tiger drivers for this, they can be found here.


Now I'll see if I can find an X11 package and see if I can get it to work - after that I'll try and see what I can do about the QE/CI support for the ATI Mobility Radeon.

Link to comment
Share on other sites


  • Create New...