Jump to content

shutdown_fix problem


schnullimaus
 Share

7 posts in this topic

Recommended Posts

Hi Forum,

 

I am running Leopard 10.5.4 on a Gigabyte GA EP35-DS3P. I am having issues with system shutdown,

as many people have,

 

I have installed the CPU Preference Plane (via onyx), and if I disable one CPU manually

the system shuts down properly. So my problem seems related to the known issue of disabling all

CPU Cores at shutdown...

 

I did then install shutdown_fix, which basically installes a compiled onecore.c as a startupitem,

which calls /sbin/poweroff_fix in the StopService section.

 

While it is working fine from command line (either directly running

 

/Library/StartupItems/shutdownfix/shutdownfix stop

 

or running

 

/sbin/SystemStarter stop shutdownfix

 

disables one CUP as expected.

 

My problem now is that despite all of that I still have shutdown problems and I *assume* that for some

reasons the fix does not get executed on system shutdown.

I did modify the line /sbin/poweroff_fix in /Library/StartupItems/shutdownfix/shutdownfix to

/sbin/poweroff_fix > /shutdownfix.txt,

 

expecting a file beeing visible afer a restart indicating that poweroff_fix was executed, but there is no file,

so that's why I assume the SystemStarter does not execute the shutdownfix / stop at shutdown.

(putting an echo start > /shutdown-start.txt into the StartService section creates a file after boot,

so I know the StartupItem gets executed on Startup)

 

 

My questions are:

 

- are there known issues / configuration tasks which must be considered with the SystemStarter to execute ShutdownScripts ?

- which (probably more accurate) options do I have for troubleshooting =

- am I alone or do others have the same / similar issues?

 

 

Thanks a lot,

best regards,

Stephan

Link to comment
Share on other sites

Try removing all your fixes and install the 9.4.0 StageXNU kernel (don't forget the matching system.kext).

 

http://######.com/blog/?p=239

 

Beerkex'd',

 

It worked for me. I have tried almost everything and Restart, Sleep and Shutdown work! I can't believe it!

 

I have a Asus P5E WS PRO (X38), XFX XXX Alpha Dog 8800 GT OC and a Q6600 cpu.

 

Many, Many thanks!!!

 

Miro

Link to comment
Share on other sites

Hi, I used to have the shutdown problem with a vanila 9.4.0 kernel on an ASUS P5E/C2D E8400.

 

I installed the CHUD dev. package & the shutdown fix. Through the CPU Pref. Pane I realized that my CPU was identified as a PIII with Hyperthreading instead as a dualcore one. I tweaked the BIOS with the following settings:

 

CPU & PCI-e Spreading ENABLED

Speedstep ENABLED

NX ENABLED

Everything else DISABLED

S3 Sleep Mode

 

Then I got 2 Cores showing up on The CPU Pref.Pane and shutdown worked 10 out of 10.

 

PS. The BIOS Version is 0702.

Link to comment
Share on other sites

BTW,

 

Why would my e8400 show up as a Pentium 3 CPU in the CPU Pref. Pane ?

Is there a way to remedy this ?

 

Initially in the "About this Mac" window the CPU was reported as "Unknown" so I had to manually change it.

Link to comment
Share on other sites

 Share

×
×
  • Create New...