Jump to content

Radeon M6 issue


2 posts in this topic

Recommended Posts

Hi guys, sorry for the new topic, but I'v read all related and haven't found any answer to my problem... :)


My system goes sleep perfectly, but there is one issue after wake up, everythings work, hardrive,

ethernet keyboard, mouse, peripherials... but the screen is frozen :(

I can only move mouse (I guess because it is hw accelerated) accross the screen, but that is all I can do...

If I use my keyboard shortcuts, I can shutdown system or whatever, but still the displayd image is that

one just before sleep mode :( Machine is not dead, I can telnet it, but the screen is "frosen" on the last position

before going to sleep (except the mouse, I can move it). Any idea, what should be wrong? Thank You!


My configuration:


8.8.1 SEE2 Intel kernel (haven't found any newer for my Northwood)

Radeon M6 integrated on board, QE enabled (using AgpGart, Radeon 7500 pack and Callisto 006 custom build)

RadeonTool.kext installed, AppleIOACPI and AppleSMBIOS and PowerManagement.bundle from JaS

(also tried hackintosh SMBIOS and moded PowerManagement from this forum)

10.4.8 Jas install (thank You bro!) updated to 10.4.11 (but all kexts are from 10.4.8)

Link to comment
Share on other sites

Untill I will solve this problem I've make some framework mod just to remove Sleep

option from Finder menu. You can also use Mac Pilot to remove it from login screen,

if You want.


1/ set sleep option in Energy saver to Never - http://support.apple.com/kb/HT2412?viewlocale=en_US

2/ replace /System/Library/Frameworks with this file - 20MB - http://leteckaposta.cz/751906003

3/ repair rights / permissions for it

4/ logout or reboot


Works for every 10.4.x systems with English language settings, I can mod also for another languages,

if You cere...


5/ If You are using laptop, You can use Insomniax or Sleeples util prevent your hackintosh sleep when lid is closed,

but it may caused some heating problems, so be aware!!! Some notebooks also support disabling this in bios directly as well.

Link to comment
Share on other sites


  • Create New...