Jump to content

[Solved] Acer, still waiting for root device...


frg6318
 Share

9 posts in this topic

Recommended Posts

Hi

 

I have a big problem with my Acer Aspire 3100, I tried iAtkos v4a and Kalway 10.5.2 and they don't boot, when i start them with -v option they hang at "Waiting for root device...." message, so i tried to install them on Vmware Server, but it fails too, I want to add drivers for ATI IXP SB400 to Extensions.mkext but I can't, so I thought that maybe someone could add this drivers for me to this file, then I will add it to ISO image and maybe then I will be able to install Leopard on my PC.I have found two drivers but I don't know which is correct for my Acer, so I attached both. Btw. sorry for my weak English.

 

I have found a tutorial with the instructions how to do this (add driver to Extensions.mkext) http://forum.insanelymac.com/index.php?showtopic=67713, I would do this by myself but i have no access to working Mac ;)

AppleOnboardPCATA.kext.zip

SATA.zip

Link to comment
Share on other sites

Ok, here is what I did:

1. I downladed transmac v 8 (you must have full version)

2. Opened Kalway 10.5.2 ISO and added both files attached to my previous post to System/Library/Extensions folder using transmac

3. Burned this modified ISO to new DVD disc

4. Restarted system, and during boot I pressed F8 and added -x -v boot options

5. After a while system booted and I was able to install Mac !!!

6. I had two problems in Disk Utility during install

a ) When I have chosen volume format different than Mac OS Extended (Journaled) my partition table was destroyed (but testdisk helped)

b ) I was unable to erase partition when it was a primary partition, so I have created a extended partition and then logical partition in it using gparted, and that solved this problem

7. After that system installed properly

8. Because I already had Vista and Ubuntu, so I had to use "boot_v8" file to be able to start mac using grub.

9. Last thing I had to do, to add drivers to my installed system, so I booted Kalway again, and using terminal I copied files from DVD, to /System/Libary/Extensions.

 

After that I was able to launch Mac, and after little research everything except webcam works !!! ;)

Link to comment
Share on other sites

sorry to bump this but what is the full directory for where the files go? I opened up my ISO in TransMac then i go to "HFS+ Volume">"Install Mac OS X.app">"Contents" I dont't see a System folder or anything like that, and yes it's Kalway 10.5.2 :D

Link to comment
Share on other sites

 Share

×
×
  • Create New...