Jump to content

Power/Sleep button not working (10.5.4)

2 posts in this topic

Recommended Posts

So close to the completion of my Macintoshiba I can taste it!


Basically, using vanilla 10.5.4 and AppleACPIPlatform.kext, I've lost the use of my power buttons for sleep/graceful power down. Under the 10.5.2 patched AppleACPIPlatform.kext, they worked fine.


Doing a quick compare, I see my 10.5.2 AppleACPIPlatform.kext had AppleACPIButtons.kext inside it. I tried moving that over into the new 10.5.4 and change the Info.plist to be 1.1.0 and crossed my fingers - nada, nothing, zip. I can see that the extension loaded, it's just not doing anything.


I cannot copy the 10.5.2 AppleACPIPlatform over- that breaks IOPlatformPluginFamily.kext (ACPI_SMC_PlatformPlugin specifically) and I cannot remove that because that would break IntelEnhancedSpeedStep (http://code.google.com/p/xnu-speedstep/issues/detail?id=2&colspec=ID%20Type%20Status%20Priority%20Owner%20Summary)


Oh what a tangled web of interdependencies. So to cut to the chase, is there any way to get the power button working again? A different kext for it perhaps?



Link to comment
Share on other sites


  • Create New...