Jump to content
thestevo

GMA X3000 Working with QE/CI/OpenGL/Rotation

70 posts in this topic

Recommended Posts

Advertisement

Finally, finally, it works for me, too.

So, just to capture what I did:

  1. I have an ASUS P5B-VM motherboard. I installed Leo4All 10.5.5 PPF3 Beta1.
  2. As theStevo said, I first installed the contents of the theStevoGMAX3000.zip file with kextHelper.
  3. Then I installed the AppleIntelGMAX3100GLDriver.bundle from the first post again with kextHelper.
  4. Just to make sure, in kextHelper I choose the option to rebuild the extension buffer and also repaired permissions.
  5. I also replaced my System/Frameworks/OpenGL.framework with the one in the first post. I rebooted but the whole thing still didn't work (Rotation was supported but not QE which I really wanted).
  6. I tried restoring my OpenGL to the originally installed version (as theStevo adviced on Jan 6 2009) and it suddenly started to work! So now I have 10.5.5 with QE support on an ASUS P5B-VM. Unbeliveable, after so many months of struggle.

Thanks, theStevo and all the others.

Share this post


Link to post
Share on other sites

Hi all,

 

I'm at the same place of Throw_Away, I got the GMAX3100FB kext to load but the GMAX3100 wouldn't load...

I have 10.5.2 leo4all v3.

I don't want to upgrade to 10.5.5.

Isn't there a way for it to work on 10.5.2?

My AppleIntelIntegratedFramebuffer is deleted, it won't load with it.

It looks like a problem in the AppleIntelGMAX3100.kext ...

If I put both files from first post, i get blue screen stuck... it boots in safeboot though but still you can see the gmax3100 isn't really loaded.

I haven't touched any of the other GMAX3100 kexts (GL etc...).

 

Well at least i have normal resolution, that's better than the 1024x768 i had which was havoc, now i'm happy with 1440x900 ^_^

 

Thanks in advance.

Share this post


Link to post
Share on other sites
Now, before I go into details there a few things we need to cover right at the front:

 

First, there is a difference between GMA 3000/3100 GPUs and GMA X3000/X3100/X3500 GPUs. Those WITHOUT the X are related to the GMA 950. WE ARE NOT DISCUSSING THOSE IN THIS POST! Most desktop boards, that I have seen, are without the X and are related to the GMA 950. Quite commonly retailers, or even manufactures, mislabel the products and add Xs. Usually the chipsets are correct, so please reference below.

 

Not in scope of this post: 946GZ, GL960, GM965, Q965, Q963, G31, G33, G35, Q33 and Q35

 

In scope of this post: G965

 

Please, do everybody on this thread a favor and do your research on your hardware before you post. It is easy to get confused, but can be prevented.

 

Second, GMA X3500 discussed on separate thread located here.

 

So, with that, I am happy to announce working drivers for the GMA X3000 that enable QE/CI/OpenGL/Rotation. These kexts are attached and should be installed in the usual manner. If 'usual manner' didn't make sense to you, please google "kext helper b7" and use that utility to install the kexts. There is an additional requirement, Tiger AppleIntelIntegratedFramebuffer must be removed. Tiger versions use an ID mask and will load for all Intel IGPs. Some installation discs include Tiger 950 framebuffers for increased functionality, some do not. If it is present, it will prevent the X3100 Framebuffer from loading properly. Leopard (e.g. vanilla) AppleIntelIntegrateFramebuffers can be present without problems.

 

FYI...

  • 10.5.5 requires additional downgrading of AppleIntelGMAX3100GLDriver.bundle to vanilla version 1.5.28 (download here) and OpenGL to vanilla 1.5.6.22 (download here). Thanks to Speedracer for tracking that down!
  • System Profiler lists it as a X3100. I might look into it when I have the time. If you figure out how to change it, preferably in the kext, then shoot me a PM.
  • Some people get stuck at a blue screen. I'm sorry about that, I haven't yet found a solution. However, if this happens for you, please post ALL your information to help in diagnostics. Roisoft's recent work with a GMA950 DSDT solution may help with this, as it has fixed some similar problems. It will not make it so you can use Vanilla kexts, they still must be modified (hex edited). I am looking into this, but right now focus is on the 950. I'm sure that X3100 progress will come soon, and we can then adapt that to our use.
  • Thanks to BlackCH, you can get X3000 support right off the install with XxX 10.5.6 PPF1 or newer. An installation option has been included on previous installs, but the installation package was missing a critical file. All future releases should be good!

Thanks, and good luck!

theStevo

 

if install this driver, the application "Interface Builder", "Chess" cannot work.

(mac os 10.5.6)

Share this post


Link to post
Share on other sites

Question: I installed the .bundle and the .zip kexts along with the OpenGL framework proved in this thread. I then repaired perms and rebooted. I now have my ideal screen res 1650x1050 however I do not have QE. Is there something I did not do or can do?

Share this post


Link to post
Share on other sites

Hey,

 

I searched a lot for these drivers and on the way installed a lot of kext that "should work", when i also installed your drivers it finaly recognised higher resolutions! But it would stutter when i played movies in windowed mode, full screen worked fine.

Then i uinstalled all GMA drivers, just searched GMA and deleted all kexts and the other kext you explained in your post.

Now almost everything works great, no stutters when i play movies in windowed mode etc.

 

But i still have the problem that Boxee and Plex wont show, its just a window with a gray or black background.

 

Do you have a idea how i could fix this?

 

Thanks for your drivers!,

 

Michiel

 

Edit: Also Coverflow doesnt work, somebody sees a similarity between Boxee, Plex and Coverflow?

Share this post


Link to post
Share on other sites

Stevo amazing work! Can't thank you enough. As an update, the 10.5.8 combo update overwrites the extensions, so you need to copy them back, and use this updated OpenGL.framework from 10.5.8 merged with the OpenGL.framework released in this topic. Here is the link:

 

http://www.mediafire.com/file/n0xmomwmy1z/OpenGL.framework GMA X3000 10.5.8.zip

 

 

Cheers!

Share this post


Link to post
Share on other sites

Hi i have an Asus P5B-VM motherboard with Intel GMA x3000. I downgraded both files, and then did the necessary restarts and such. Then I downloaded the driver files and put both into kext helper b7 and installed, rebooted, and now all i see is a black screen with my cursor and little lines of color. i got into safe mode using -x and was able to view everything. How can i install these drivers? i would really like to have this working. Thanks

 

Motherboard: Asus P5B-VM

 

Graphics: Intel GMA X3000

 

OS X Version: 10.5.8 Retail

Share this post


Link to post
Share on other sites

The same problem happened to me. To solve it, you need to download the OpenGL.framework from the post above yours, and replace the OpenGL.framework in your hackintosh in /System/Library/Frameworks/ with the new above.

It also helps to correct the permissions in the end with:

sudo chown -R root:wheel /System/Library/Frameworks/OpenGL.framework

in Terminal.

Share this post


Link to post
Share on other sites

Hello,

 

trying to get this to work on 10.5.7 (needed because I want to try myself at iPhone development). All drivers seem installed properly, reverted the bundle and OpenGL framework as indicated.

 

I can change all resolutions but CI is still software and QE is not supported... Anyone has an idea how to make this work? Installed using iATKOS v7.

 

Thanks,

mynab

 

PS: if it is not possible to get CI/QE with this card, I plan to buy a nVidia 8400GS based card. Will this one work properly with all hardware acceleration?

Share this post


Link to post
Share on other sites

Hi!

This is the first time i've installed OSx86, on my laptop at that.

Touchpad, ethernet LAN, Keyboard & Graphics ar not working.

I dl:ed Kext Helper B7, Natit.kext (from osx86scebe wiki), and the kext posted in this topic.

 

1 Installed KHB7

2 Drag & Drop Natit + AppleIntelGMAX3100FB

3 Click EasyInstall

4 Graphics are recognised in System Profiler (Says Intel GMA X3100)

 

THEN i thought GMA X3100 is the chipset, and wondered why LAN,TouchPAd,Keyboard are still not working.

SO i decided to give AppleIntelGMAX3100GLDriver.bundle + Natit_ATIauto.kext (because it says auto, not bcuz of ATI, lol poor lazy me) a try.

 

1 Drag & Drop AppleIntelGMAX3100GLDriver.bundle + Natit_ATIauto.kext into KHb7

2 Click EasyInstall

3 System Profiler now only says

Vendor ID: Intel (0x8086)

Device ID: 0x2a02

 

Does anyone know what i've done wrong and/or how i revoke these changes?

Share this post


Link to post
Share on other sites

Anyone having poor opengl performance with the x3000?

 

Mine works, QE, CI, Rotation.... But opengl is slow! Giving me poor scores in xbench, just for reference Quake 3 Arena plays ok at 640x480 but not higher.

 

I have 10.5.6.

Share this post


Link to post
Share on other sites

thestevo

 

Thank you very much for this kext, i really, really need it! But i have a little problem with it - i installed the first kext (not FB) and tried to reboot, but since that, system ceased to run, and reboots right after it starts booting. I have a clean iATKOS 10.5.7, and P5B-VM motherboard. Could you help me, please?

Share this post


Link to post
Share on other sites

well i reinstalled my system upgaded to 10.5.8 and tried to install both kexts, and now i have proper resolution, but still don't have quartz :)

Share this post


Link to post
Share on other sites

Hi All

 

Anybody get QE on x3000?

 

I can change resolution but not QE

(Leo 10.5.8)

 

PS When I install new OpenGL.framework my hackintosh stop running graphic interface. What wrong?

 

PPS I got an interesting effect. I start the computer and when loading has reached the "blue screen", at first nothing worked, and after about 10 minutes all booted and worked fine. ;)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×