Jump to content
charleylabri

Auto Detect Display/HDMI/8500GT

8 posts in this topic

Recommended Posts

So, I installed this mixture of natit and nvinject 2.1 which got my 8500GT working full, and I use a 42" LCD with the HDMI out from the card... things work great- except if i turn off the LCD.

when i do, and then power it back on, the mac seems to auto-configure the display and i get just this blue screen (like the background of the login screen) but i have no input or anything. I can sleep the computer through the power button, and the screen will flash briefly the desktop then sleep.

 

as of yet, i just have to hard power if off. anyone else have this problem?

Share this post


Link to post
Share on other sites
Advertisement

I'm not a god at this but I think I have a clue:

The HDMI-connector is the Secondary port on the Graphics card and when OSX notices that it doesn't have a screen plugged in, the system sort of hangs.

 

I have sort of the same problem with my 8500GT HDMI, when I try to change the resolution on the HDMI-port and thats the only screen connected it does the same thing.

Without having to reboot I connect another screen to the DVI-port to get OSX to jump over to that screen instead and then it goes back to normal but with two screens in extended mode.

 

I will try to edit the NVinject.kext to switch the primary and secondary port and I'll try to come back to you. Don't really know if it's possible but I'll give it a try. :)

Share this post


Link to post
Share on other sites

let me know if you figure something out! im having the exact same problem on my hackintosh. DVI to HDMI cable setup = flash of desktop and then blue screen.

Share this post


Link to post
Share on other sites

Tried to switch the two ports but got a black screen.

I guess I'll have to change the NVCAP also.

I'm going to be a bit busy the couple of coming days but when I have the time I'll try to figure this one out.

Share this post


Link to post
Share on other sites

I unplugged the cable and plugged it in to the other DVI port and everything seems to work fine. I only have one monitor, so it works for me.

Share this post


Link to post
Share on other sites

Any luck on getting auto detect disabled yet? I have an 8800GT connected DVI->HDMI to an LG TV in my living room, so it's not easy to disconnect and reconnect cables at will.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×