Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[solved] Belkin ExpressCard/34 Wireless N Drivers

7 posts in this topic

Recommended Posts

Hi there,


I've a HP laptop which has 4965AGN wireless.. also had a Belkin F5D8073 lying around which supports wireless N too.. I've no idea what chipset it uses or anything.


Has anyone used either cards and got them working? or able to tell me what drivers to aim for?



Many thanks in advance! Having to use Windows in the garden :'[ help!! lol



Share this post

Link to post
Share on other sites

I tried the Ralink drivers from here : http://www.ralinktech.com.tw/Home/Support/Macintosh.html


using the RaLink application I can see wireless access points in the site survey, so the wireless card is active.. however, when I connect.. it doesn't give me an ipaddress when I run ifconfig. I tried to set the ipaddress manually, but that did not work. It's come up as a wired network interface which is strange.. anyone any ideas?

Share this post

Link to post
Share on other sites

I've got it working now.



Downloaded rt2860 drivers, installed.. run the RaLink utility to connect to the wireless.


opened network from sys prefrences and manually assigned an IP address



Share this post

Link to post
Share on other sites

I just got the Belkin F5D8073 Expresscard 3/4 adapter, and can confirm it works perfect for the HP DV9774CA.


Download the driver (RT2860) from:




It's the first link in the list of drivers.


Once download:


1) Run the .dmg, open the installer. Install the software appropriate for your version of OSX (there's 10.3 Panther, 10.4 Tiger, and 10.5 Leopard).


2) Open up applications (Command+Shift+A) and run the Ralink Wireless Utility.


3) Find your network, connect to it (enter password if necessary).


4) Close Ralink Wireless Utility (once step 4 is successful, of course) and open System Preferences/Networking


5) In networking, it will let you know it's found another Ethernet <EN2> connection - fear not, it's wireless less the name. Change connection type from "Automatic" to "Manually"


6) Because you chose to configure "Manually", it's going to ask you to fill in these fields:


- IPaddress

- Subnet Mask

- Router

- DNS Server

- Search Domains


Right off the bat, leave Search Domains empty. All of the other fields can be found in your router's settings. You can access these settings from a computer/laptop that is DIRECTLY CONNETED (BY WIRE) to your router. In I.E/Safari etc type in "http//" or "". Username is usually "Admin" and password is blank, or the same as username. You've got to figure out how to get in yourself.


Inside your router settings, you'll find a DHCP list, and it'll list all the devices connected to your network, and you can see their IPaddresses. HERE'S where you can find out a good IPaddress for your Mac. Just go one number up in the last section.


For example, if the highest IPaddress in the list is "xxx.xxx.x.105", then you should input "xxx.xxx.x.106".


That's it, you're good to go! Enjoy! ;)


Thanks to all who helped ME figure all this out, I'm glad to be a part of this forum :)

Share this post

Link to post
Share on other sites

Working on Snow Leopard 10.6.7 (Lenovo z560 Core i3)


Sorry to bump an old thread, but I thought/hope that this information may be as useful to someone in the future as this thread has been for me today.


— In Snow Leopard 10.6.7 have Expresscard (F5D8073ea) plugged into Expresscard slot.

— Download driver dmg (STA_RT2860D-

— Install the 10.5 Leopard driver and restart.

— On boot, Ralink Wireless Utility automatically loaded and found my router.

— Input password network key and it was connected.


As simple as that.


I hope this helps any Snow Leopard users out there, I also wonder if it would work in Lion/MountainLion?

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.