Jump to content
Kassi

TSC sync XNU patch

212 posts in this topic

Recommended Posts

i've got Darwin Kernel Version 9.5.0: Wed Sep 3 11:29:43 PDT 2008; root:xnu-1228.7.58~1/RELEASE_I386 installed, can I fix the 1 core problem?

Share this post


Link to post
Share on other sites
Advertisement
i've got Darwin Kernel Version 9.5.0: Wed Sep 3 11:29:43 PDT 2008; root:xnu-1228.7.58~1/RELEASE_I386 installed, can I fix the 1 core problem?

 

pretty sure the voodoo kernel fixes this.

Share this post


Link to post
Share on other sites

I have trouble with this patch and Leo 10.5.8. Sometimes parts of the system become laggy and non-responsive, like the terminal and some parts of firefox. Also netbeans' code completion becomes awfuly slow. All this happens some time after boot, when I've been using the computer for a while. Also it fixes itself randomly, but comes back.

My system specs are in my sig. I've used a patched vanilla kernel with -tscsync flag, a stock vanilla kernel with VoodooTSCSync.kext and -tscsync flag, and Voodoo kernel alpha 9.7 with kext and flag.

Please any help or thoughts?

Share this post


Link to post
Share on other sites
I have trouble with this patch and Leo 10.5.8. ...

 

Correction, this happens even when booting with cpus=1, so it might be something else that's making my installation unstable.

Share this post


Link to post
Share on other sites

Hi, I have this:

 

Dell Inspiron 9400

Core 2 Duo T7200

WUXGA 1920x1200 screen

NVidia Geforce go 7900GTX, 100% working (with injectgo)

2GB DDR2 667 RAM

Sigmatel 9200 audio, 100% working (with voodoohda)

 

I installed Kalyway release (10.5.2), updated with the comboupdate 10.5.3.

 

Everything seem to work, but is very slow (and for me it depends on the video): even the screensaver is slow, the activity monitor darken the screen saying I have to restart the computer, Ableton Live shows the track meters with a lot of delay (but the audio is ok).

 

Any suggestions?

 

Thank you in advance,

 

Nicola

 

 

P.S. system log in the attachment.

System_Log_13.07.10.rtf

Share this post


Link to post
Share on other sites

how can i get this working on my Snow leo installation??

am using 10.6.2 kernel version is Darwin 10.2.0 system profiler shows 1 processor 2 cores...activity monitor is showing one active core only...my specs are in the sig but i'll post them anyway:

 

Acer Aspire 5570

Intel Core Duo T2300E 1.67GHz

3GB DDR2 600MHz

GMA950 27A2 32Bit

 

and where to exactly put the voodootscsync.kext?? S/L/E or E/E ?? (System/Library/Extensions) (Extra/Extensions) ??

 

thanx in advance!

Share this post


Link to post
Share on other sites
How can I know if I have this problem???

 

if you are running both cores with your C2D you will notice stuttering. Mouse movements and window closing/opening will be erratic. E.g. the magnification out of the menu won't work smoothly at all or the bouncing...

 

If that is the case you can either run with a single core, which you do in the BIOS. or you use the TSCsync kext. You can install it into S/L/E or into your extra folder if you have one - doesn't make a difference. The TSCsync problem is typical for Dell laptops with core2duos.

Share this post


Link to post
Share on other sites
if you are running both cores with your C2D you will notice stuttering. Mouse movements and window closing/opening will be erratic. E.g. the magnification out of the menu won't work smoothly at all or the bouncing...

 

If that is the case you can either run with a single core, which you do in the BIOS. or you use the TSCsync kext. You can install it into S/L/E or into your extra folder if you have one - doesn't make a difference. The TSCsync problem is typical for Dell laptops with core2duos.

 

 

Well well well, I have this laptop for just one week, I started to notice that the graphic effects are not so fluid, like they should, and stuuters a little bit, could it be i have the problem? probably yes?

 

There is something strange here, if I have a game running on the computer (World of Goo in full screen then I go to Finder with command+tab) the exposé effects are perfect. if I close the game the graphics starts to stutter again.

 

Edit: Now it is working

Share this post


Link to post
Share on other sites
Well well well, I have this laptop for just one week, I started to notice that the graphic effects are not so fluid, like they should, and stuuters a little bit, could it be i have the problem? probably yes?

 

There is something strange here, if I have a game running on the computer (World of Goo in full screen then I go to Finder with command+tab) the exposé effects are perfect. if I close the game the graphics starts to stutter again.

 

Edit: Now it is working

 

the problem is that the terms I used may be misleading. When I say stuttering, I really mean constant stuttering. The bouncing of the icons in the dock is erratic. It's pretty annoying to work with the system in that state.

 

What you are describing sounds more like a CPU intensive program that is running in the background interfering with what you are doing. One culprit could be AppleIntelCPUPowerManagement.kext. I suggest to use the voodoo power kext and remove this one.

 

You second part is strange I agree. It almost sounds like the game itself is enabling some graphic capability that wasn't there before you started it.

Share this post


Link to post
Share on other sites
the problem is that the terms I used may be misleading. When I say stuttering, I really mean constant stuttering. The bouncing of the icons in the dock is erratic. It's pretty annoying to work with the system in that state.

 

What you are describing sounds more like a CPU intensive program that is running in the background interfering with what you are doing. One culprit could be AppleIntelCPUPowerManagement.kext. I suggest to use the voodoo power kext and remove this one.

 

You second part is strange I agree. It almost sounds like the game itself is enabling some graphic capability that wasn't there before you started it.

 

I thought it was fixed, but the problem is still there even after VoodooTSCSync.kext

 

when the game is running it works so beautifully damn damn damn

 

help

Share this post


Link to post
Share on other sites
Thank you thank you thank you thank you!!!!!

 

This for me was the last piece of the puzzle! I've had a successful hour or so, first I found Chun nans kext to allow proper battery level indication in leopard and now this!!! I really thought that I would have to live with just the one core!

 

Thank you so much for this.

 

Dell D620

Kalyway 10.5.2 Vanilla

sleep, speedstep, BOTH CORES!

 

Will this work for iatkos v7? I too have the dell d620 with the core duo cpu.

 

SNOW LEOPARD (Note: NO kernel mod needed)

VoodooTSCSync for snow

 

Leopard (Note: NO kernel mod needed)

VoodooTSCSync for 10.5.x

 

Can you link me to the leopard version? Your link doesn't work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×