Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Kassi

TSC sync XNU patch

212 posts in this topic

Recommended Posts

this is a variation for tsc sync xnu kernel. (9.6)

We add Euraka patch (from voodoo sources) to display correctly setups from Smbios (model/model identifier).

Thanks again to Cosmo1t for compiling:

 

(9.6 kernel) http://rs566.rapidshare.com/files/17592620...l.model.tsc.tgz

 

Attached: original hunk for 9.5 kernel.

 

can someone point me in the right direction in how to patch kernel????

copy the file to parent folder, then open terminal and type:

patch -p0 < yourpatch

model.tar.gz

Share this post


Link to post
Share on other sites

I have tried it sonotone but I am getting lots of error at bootup if I use dsdt.aml file IF I dont no error at all

do I need the file??????

 

I also get when I try to mount dmg computer freezes up {I have seatbelt kext from 10.5.5}

 

This is my log

error9.60.zip

Share this post


Link to post
Share on other sites
this is a variation for tsc sync xnu kernel. (9.6)

We add Euraka patch (from voodoo sources) to display correctly setups from Smbios (model/model identifier).

Thanks again to Cosmo1t for compiling:

 

http://rs566.rapidshare.com/files/17592620...l.model.tsc.tgz

 

Attached: original hunk for 9.5 kernel.

copy the file to parent folder, then open terminal and type:

patch -p0 < yourpatch

 

 

Thanks so much for posting sonotone, and compiling Cosmo1t!!! i can confirm this kernel works with my particular setup which is mostly vanilla right now.

 

--> on a side note, i was able to patch and compile kernels up to 10.5.5, but having difficulty with 10.5.6, there seems to be some issues when i try to build required components and get errors like "TargetConfig not defined." i have exhausted forum and google search resources, and admit im still noobing it and know very little, but would like to learn more and be able to compile these kernels. any ideas or suggestions for this? it is probably something simple but would be a great xmas present if one might throw a bone my way...? thanks for any tips in advance!

:)

Share this post


Link to post
Share on other sites

went back to kernel 9.50 the 9.60 froze my laptop when I mount a dmg.

I even deleted seabelt.kext but no joy still freezing when mounting an image file..........

Share this post


Link to post
Share on other sites
went back to kernel 9.50 the 9.60 froze my laptop when I mount a dmg.

I even deleted seabelt.kext but no joy still freezing when mounting an image file..........

 

Make sure you have System.kext and Seatbelt.kext from the last update before to run this kernel, then fix permissions.

I've got no problems on my side.

-> on a side note, i was able to patch and compile kernels up to 10.5.5, but having difficulty with 10.5.6, there seems to be some issues when i try to build required components and get errors like "TargetConfig not defined." i have exhausted forum and google search resources, and admit im still noobing it and know very little, but would like to learn more and be able to compile these kernels. any ideas or suggestions for this? it is probably something simple but would be a great xmas present if one might throw a bone my way...? thanks for any tips in advance

You can use the voodoobuild by donwloading sources. you have to update files references and disable voodoo patchs. (replace first lines "true" to "false")

 

Or cosnmo1t pointing me this link. Haven't tried: http://darwinbuild.macosforge.org/

Share this post


Link to post
Share on other sites
You can use the voodoobuild by donwloading sources. you have to update files references and disable voodoo patchs. (replace first lines "true" to "false")

 

Or cosnmo1t pointing me this link. Haven't tried: http://darwinbuild.macosforge.org/

 

thanks again, ill check it out!

Share this post


Link to post
Share on other sites

Guys some help please. I was running ToH Kernel 9.2, so I downloaded the TSC 9.2 kernel. Installed via OSX86Tools.

 

I added the Kernel Flags <string>-tscsync</string> and removed cpus=1.

 

 

I rebooted and typed update -v and nothing... I tried -update -v and it comes to the gray apple screen and immediately reboots.

 

I try it without the update flags and the same result... It's only letting me boot via cpus=1 despite patched kernel.

 

A quick point in the right direction please? :)

Share this post


Link to post
Share on other sites

I own an E1705 and have been using this kernel for a while, but I just wanted to make it aware that the voodoo 9.5 kernel also has no stuttering, is this news or am I speaking of the obvious here?

 

This link is not working. Neither is the original. Mediafire seems to be having issues.

 

 

Is there any way to get this file from a source other the mediafire ? It seems to be down at the moment.

 

mediafire is currently down for daily maintanence. should be up again later

Share this post


Link to post
Share on other sites

Thanks for all the hard work that went into this.

However, i'm not entirely sure how to go about patching my kernel. I have a fresh installation: Leo 10.5.6 with a Darwin 9.6.0 kernel.

Any hints/links to how i'm supposed to use the patch file and the diff file would be greately appreciated.

Thanks in advance.

 

L.E.

I managed to solve the problem by using sonotone's post-installer:

http://www.insanelymac.com/forum/index.php?showtopic=97966

Share this post


Link to post
Share on other sites

Any user XPS M1710 can write step by step. How to UNLOCK 2 cores on T7600 - XPM M1710?

 

iPC 10.5.6 - Vanilla 9.6.0

 

tnx

Share this post


Link to post
Share on other sites

You'll hate me for this; but I have no idea what to do, at all, nothing.

 

I'm running Max OS X 10.4.9 with Darwin Kernel Version 8.9.1 on my Dell 6400.

 

What do I do?

Share this post


Link to post
Share on other sites
You'll hate me for this; but I have no idea what to do, at all, nothing.

 

I'm running Max OS X 10.4.9 with Darwin Kernel Version 8.9.1 on my Dell 6400.

 

What do I do?

 

Switch to leopard, this kernel is only for 10.5.

Share this post


Link to post
Share on other sites

All rapidshare links are down. Please somebody reup ifi is possible.

 

Share this post


Link to post
Share on other sites

may ask you to create a newer patched kernel with 9.7?

or help me to create myself?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×