Jump to content

A Good-Old "Still Waiting For Root Device" Problem


6 posts in this topic

Recommended Posts

Yo, Noids! :P


I'm new to the whole OSX/PC thing, and in the last 36 hours I've been trying to learn how to fix this, to no avail. It's the old "Still waiting for root device" problem, and I can't seem to fix it with any of the advice I've found here or on the wiki.


I'm currently using (or trying to) this version of OSX: Leo4All-10.5.2 Universal AMD/INTEL[sSE2/SSE3] and, just in case, I also have a version of Kalyway (is that what it's called?) on standby! But I'd like to stick with the first one. :angel:


Okay, so what's happening is I'm putting the DVD in, and up comes a DOS-like screen (black with white text) that basically says to hit any key to start. I do, and a lot of white text comes up (and a small bit of yellow too). It mentions something to do with sleep, then I get "Still waiting for root device" over and over, every minute or so. I tried making my SATA HDD IDE compliant, but that option isn't available in my Bios. I partitioned some of the HDD into a FAT32 chunk, but that doesn't help either. I've changed my DVD drive from slave to master, my HDD from SATA port 2 port to port 1, and even added an IDE drive and unplugged the SATA one altogether, but none of this changed the symptom (and the IDE drive doesn't seem to work now, but hey, it was old).


I also tried, via MagicISO, to add MeDevil's AppleNForceATA.kext folder to Extensions, and the AppleNForceATA.kext file itself to IOATAFAMILY (or whatever it's called!), overwriting the one that was already there. However, after burning this updated ISO with Alcohol120%,, the computer refuses to boot to it - I think that's MagicISO's fault.


Please help! :D


My current specifications:


Motherboard: Asus M2N-MX SE

Processor: AMD Athlon X2 4800+

Optical Drive: IDE DVD-RW (Primary master)

Hard Drive: 250Gb SATA HDD (SATA port 1)

Graphics Card: Nvidia GeForce 8600GT


Thanks a lot! :)

Link to comment
Share on other sites

external dvd rom MIGHT help, i actually had to use both (internal and external) to complete my installation :P. i don't know if this will help, but boot from the internal dvd rom and when u get the waiting for the root device error, place the dvd in the external usb dvd rom. this worked for me, u can also give it a try :whistle:

Link to comment
Share on other sites


  • Create New...