Jump to content
pifou

Leopard on a dell studio 15 and 17

489 posts in this topic

Recommended Posts

XP will work without changing the Bios, but you have to slipstream the drivers into the install disc. There isn't really a good writeup on how to do it, but it is possible. I have a feeling that support for the 3450 is right around the corner. As I understand it, the X3100 (onboard graphics) works fine?

Share this post


Link to post
Share on other sites
Advertisement

@Conroe Mac:

Yeppers. If you're using iDeneb 10.5.5 then you don't even need to select the X3100 drivers when you customize your install...but you do need to do the sleep trick: unplug your lappy and wait for ~15 minutes. Then go into Expose and set a hot corner for sleep. There's a sleepdisplay program apparently that removes the need for this (check Comprasher's thread) but I haven't gotten it able to work as of yet.

 

Also, I am running XP through ATA mode I believe...what exactly is the difference between AHCI and ATA?

Share this post


Link to post
Share on other sites

ATA is supposedly slower. It's an older standard, hence it being used in XP. I'm not so sure there's a big performance difference.

 

From wikipedia: As their standard interface, SATA controllers use the Advanced Host Controller Interface (AHCI), which allows advanced features of SATA such as hot plug and Native Command Queuing (NCQ). If AHCI is not enabled by the motherboard and chipset, SATA controllers typically operate in "IDE emulation" mode which does not allow features of devices to be accessed if the ATA/IDE standard does not support them. Windows device drivers that are labeled as SATA are usually running in IDE emulation mode unless they explicitly state that they are AHCI. While the drivers included with Windows XP do not support AHCI, AHCI has been implemented by proprietary device drivers.[1] Windows Vista[2], the current version of Mac OS X[citation needed] and Linux with kernel version 2.6.19 onward [3] have native support for AHCI.

 

Basically, even if you use a SATA cable, you're still running in IDE mode (remember those big ribbon cables?). To get the benefits of SATA, you should run in AHCI.

Share this post


Link to post
Share on other sites

Okay guys, and gals.... I have the IDT 92HD73C1X5

I have gotten the internal speakers working however that is all at this time and the audio is going to be controlled by whatever software such as quicktime or iTunes not Mac or keyboard controls however you can adjust the Apple alerts under system preferences. I will continue to work on this however I wanted to provide what I could for the Dell Studio community.

 

 

You must install the 2 files below in order to have working sound....... Please repair permissions......

Shoot any success or issues here

 

I will continue to get the other things working. We only really need the video now and we will be ready to go.

Share this post


Link to post
Share on other sites
Okay guys, and gals.... I have the IDT 92HD73C1X5

I have gotten the internal speakers working however that is all at this time and the audio is going to be controlled by whatever software such as quicktime or iTunes not Mac or keyboard controls however you can adjust the Apple alerts under system preferences. I will continue to work on this however I wanted to provide what I could for the Dell Studio community.

 

 

You must install the 2 files below in order to have working sound....... Please repair permissions......

Shoot any success or issues here

 

I will continue to get the other things working. We only really need the video now and we will be ready to go.

 

 

 

Last night I didn't get a chance to play on the puter, the girlfriend wanted to do stuff - but I'll give this a shot when I get home, looks promising!

Share this post


Link to post
Share on other sites

was not able to get it to work. The folders had a bunch in them. I used kext installer for the first but I did the Unix install for the second... fixed permission and no sound with itunes or youtube...

 

 

Any noobie guide to install?

 

thanks

Share this post


Link to post
Share on other sites

Hi, I want to buy a dell studio, and now dell sells the studio 15 with the Integrierter Intel® Graphics 4500MHD. Is there a chance to run this with the osx86?

 

bye and thanks ;)

Share this post


Link to post
Share on other sites

the 256 ATI works.. I'm on it right now, it's just not perfect or anything... maybe it will work soon. that is what the ATI page says at least. I would get the video card b/c it is better than integrated for video/games.

 

Yo can still run vista and XP and Ubuntu Linux on it

Share this post


Link to post
Share on other sites

dell studio 1535 ati HD 3450 is it MXM card ?

 

is that graphic separate board, or part of the motherboard ?

 

just curious , to think, the graphics card could be replaced by an nvidia card

of the M1530 , 8400M GS , or 8600M GT

or maybe even the quadro NVS from the E-series , 160M what is an G98 nvidia core,

that one should even work with cuda

 

there is a new studio out with centrino 2 P8400,... but don't know the chipset,

looks like the X3100 version is at it's end,...

Share this post


Link to post
Share on other sites
was not able to get it to work. The folders had a bunch in them. I used kext installer for the first but I did the Unix install for the second... fixed permission and no sound with itunes or youtube...

Any noobie guide to install?

 

thanks

 

I used Kexthelper on both to make it easy however you need to set permissions on the HDAEnabler.kext on your own through terminal..... Because it is not in the OS X permissions library....

If you send me or post a copy of your codec dump I could check it for you.

step 1. unzip both files

step 2. kexthelper install both

step 3.In Terminal type the following hitting enter after each line

sudo -s

enter password

 

make sure you are not using any ALCinject or anything like it....

cd /System/Library/Extensions

chown -R root:wheel HDAEnabler.kext

chmod -R 755 HDAEnabler.kext

cd ..

rm -rf Extensions.mkext

exit

exit

reboot and cross your fingers...

Thanks, Mark

Share this post


Link to post
Share on other sites
Okay guys, and gals.... I have the IDT 92HD73C1X5

I have gotten the internal speakers working however that is all at this time and the audio is going to be controlled by whatever software such as quicktime or iTunes not Mac or keyboard controls however you can adjust the Apple alerts under system preferences. I will continue to work on this however I wanted to provide what I could for the Dell Studio community.

 

 

You must install the 2 files below in order to have working sound....... Please repair permissions......

Shoot any success or issues here

 

I will continue to get the other things working. We only really need the video now and we will be ready to go.

 

 

It works! Praise be to you! Now all I need is ethernet and video!

 

But...sound is REALLY crackly, loud, and bad-sounding. Is it like this for you too? Is there any way to turn down the master volume or something?

Share this post


Link to post
Share on other sites
It works! Praise be to you! Now all I need is ethernet and video!

 

But...sound is REALLY crackly, loud, and bad-sounding. Is it like this for you too? Is there any way to turn down the master volume or something?

 

 

At this time the only way for volume control is through the Apple alerts volume meter not the master volume control and of course you can turn the volume down under quicktime or iTunes. I am watching a video via Quicktime and with the volumn controled by the software it makes it a little more tolerable. At least we have some audio and some control...... You can adjust the apple alerts volume under the system/sound settings.

Glad it worked I am still working on it and at the moment I only have the internal speakers running, I am working on updating the driver to include internal Mic and Headphones but it is somewhat confusing and very time consuming. I think I know the problem for the no master volume control however I am not sure how to fix it.

Share this post


Link to post
Share on other sites

I just wanted to mention that I tried the audio kexts here and the sound is perfect. Only problem is the main volume control. Hopefully that will work soon. All we really need now is the video :thumbsdown_anim:

Share this post


Link to post
Share on other sites

On a related note, is there a way to turn down the volume of the sounds in Adium? I'd rather not have to disable them but they are just TOO LOUD at the moment.

Share this post


Link to post
Share on other sites

Hey Elsworth, I don't have my mac booted up right now, but isn't there a slider in the general preferences of Adium for sound? I know there was in older versions.

Share this post


Link to post
Share on other sites
On a related note, is there a way to turn down the volume of the sounds in Adium? I'd rather not have to disable them but they are just TOO LOUD at the moment.

 

 

Yes you can open Adium and then got to where it says adium at in the toolbar and then open preferences you can adjust the volume under events.... I just did

Share this post


Link to post
Share on other sites

Okay Im seeing a lot about wireless cards not working if you have a 1397 and having problems with bcm43xx patcher, grab the driver pack on my tutorial under the genius bar section and install the bcm43xx.kext with kexthelper.

 

If you dont have the 1397, I still might be able to help you out. Send me the following information: The Model of your card, the manufacturer (eg broadcom, atheros, etc), and your product and device ID's. I have had great success with Broadcom cards. I got the hang of it now so it only takes 5 or 10 minutes to inject your information into the driver. I can almost gurantee I can get any broadcom 43xx card working.

 

Hey, it wont hurt just to try, so shoot me a PM with that info and hopefully I can help out. I will be able to send you back a kext file that you can easily install with kext helper

Share this post


Link to post
Share on other sites

Hi,

 

I'll try the Audio kext during the weekend, a question for those who have it working, you can use itunes to play music in the laptop now, right? can you play videos from safari, like you tube videos? Does the Mic Work?

 

this is in order to know what to expect from the kexts :), I'll only have time to try them on the weekend and I'd like to know what could happen.

 

Cheers, great work!

Share this post


Link to post
Share on other sites
Hi,

 

I'll try the Audio kext during the weekend, a question for those who have it working, you can use itunes to play music in the laptop now, right? can you play videos from safari, like you tube videos? Does the Mic Work?

 

this is in order to know what to expect from the kexts :P, I'll only have time to try them on the weekend and I'd like to know what could happen.

 

Cheers, great work!

Okay I am working on getting the mic and Headphones to work over the next couple of days, but to answer your question Yes you can listen to music through iTunes play videos through Safari or Quicktime you just have to use the volume control under each application instead of being able to have a master control. I will post updates as the come available.......

 

You can really have audio to anything you just have to use the applications audio setting for volume control at this time.

Share this post


Link to post
Share on other sites

Hey, thanks!, I can't wait to try it!

 

If you can play videos, what do you mean when you say you need to work on video?

 

Thanks for the fast reply!

Share this post


Link to post
Share on other sites

People typically need to get there video cards fully supported not just running basic 1024x768 you can still play movies and such just would be better with full support and I myself as well as a few others are working on a new video driver

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×