Jump to content

Toshiba Tablet M700


carpao
 Share

8 posts in this topic

Recommended Posts

I'm trying to install Leopard on this machine (I previously used the M400 with success)

 

At the moment I installed Kalyway 10.5.2

 

Graphics (X3100)

VID 8086 PID 2a02

at the moment I removed the Intel video drivers, and I'm going in 1024x768 ... I read about a sleep trick, that I'll try

 

Network (82566MM)

VID 8086 PID 1049

it is not recognized... so this is my main problem at the moment

 

 

I would like to collect the M700 users expirience

 

... when I'll solve the previous problem I'll check other things...

(otherwise on this machine I'll use Ubuntu as main OS... :-( )

 

 

Audio (I'll try Taruga)

Pen (probably with tablet magic)

Touch (??)

BT (it should work withsame of M400)

Wireless 4965AGN VID 8086 PID 4229

 

SD VID 104c PID 803c

Fingerprint (seen as USD, working?) VID 08ff PID 1600

WebCam (seen as USB but seems not working) VID 04f2 PID B008

Link to comment
Share on other sites

  • 4 months later...

I am also attempting to install Kalyway 10.5.2 on my M700 and have had no luck. It just freezes at "6 minutes left".There is very little info online about osx86 on this particular unit and I am contacting everyone from every website I can find who has reported success; even anecdotal. I would really appreciate your help in writing a tutorial for this unit.

 

No, I'm not a salesman but it's worth noting that the M700 has a very loyal following as it is one of the fastest Tablets out right now. It combines long battery life (slice) with robust feature set, low heat expenditure and incredible reliability. In short, IMHO it is THE champ for power tablets right now. Since Apple has no tablets yet, this is exactly the sort of killer app that justifies TOH and a tidy little how-to on the HCL.

 

The lack of a tablet feature is why I DID NOT buy a Macbook. For me, the ability to enter notes into my sheet music editor with a pen is a quantum leap in music editing and worth starting a Blog for. If you've ever tried to edit sheet music with a mouse you'll know that most people hate it so much that staff paper is still the norm. Having access to Mac software would allow me to do some pretty amazing things on the go (yes Windows really is too unreliable and clunky for music).

 

Please let me know what BIOS settings you have, what customization options, cpu=1 flag?, and what progress you have made since July. Do you jave both cores functioning? Have you tried any custom BIOS yet? I would really appreciate it and will try to successfully add to the HCL.

 

All I need for a good DAW is, functioning video (one resolution is fine), USB, Firewire or (better yet) PCExpress slot, and the tablet driver (Tablet Magic). Sound is provided via apogee mac drivers anyways so I assume that is not an issue. The less extraneous functions the more reliable the OS will be.

 

So far I've tried Leo4Allv3, iDeneb 10.5.4 and Kalyway 10.5.2., all checksum accurate and burned on good media with DVDecryptor at 2x speed. iDeneb installs but goes to a strange fading vertical blue line display after successful boot. Leo4All won't boot from disc. I've tried removing the video drivers through darwin commands and not installing any video drivers at all. I've also tried just about every customization setting as well as none. The fact that you succeeded makes me think that a)I'm using bad disc media (non-TDK), I've got the wrong BIOS settings, c)My ignorance of software code is preventing me from making it all come together.

 

Seeing as how I'm using this computer professionally, I would be willing to sponsor a custom BIOS for it or even meet a Hackintosh expert or Software Engineer in the L.A. area who can show me what to do for a modest consultation fee. I will then gladly pass that info on into the community.

 

Please let me know! Thanks.

Link to comment
Share on other sites

Ok, so apparently X3100 is a big problem and most distros won't work with most X3100s. It seems X3100 people are universally frustrated. I had to figure this out on my own.

This is frustrating because in hindsight a good text file could have easily solved my problems. Software programmers are not very good at communicating to non-programmers. Someone has to act as a liason...hmmm

Maybe I should start a website...

 

I succeeded finally after weeks of not-so-casual attempts to install Kalyway 10.5.2 et.al. on my badass 2.5ghz M700 featuring Intel SSD and other nifty doo-dads. I basically just tried several distros, read what I could, understood very little of what I read cuz I'm not a code hacker and systematically experimented with virtually every setting available until blindly stumbling across the answer.

The solution as I'm currently aware is three parts:

 

First you must disable multi-core processing. Here were the BIOS settings that I changed from stock:

 

Multi-Core Processing: Disabled (this sucks and I may have to order a custom BIOS to get this to work). A REAL Deal-Breaker.

Boot Priority: CD-ROM Of course

 

Forgive me, I'm a sound engineer so I don't know what alot of computer code and BIOS terminology means .

 

I can build a Neve mic pre-amp from scratch though.

So here are a couple of examples of the possibly relevant BIOS items that stayed the same:

Execute-Disable Bit Capability: Available

SATA Controller Mode: AHCI

 

Next, after successfully booting to the Customize screen, you must ONLY SELECT INTEL GMA 950 from the graphics drivers customization option.

DO NOT SELECT X3100!!

I know you want to, but don't!

 

Finally: remove the Intel GMA 950 drivers you just freakin installed.??!!

After install it would not boot.

I got the white apple screen with a little circle and a line through it. By Osmosis I have gleaned that this means a driver problem. On a whim I typed some gobbledy-gook into darwin that disables the Intel GMA 950 drivers that you have to install to get the thing to work in the first place.

???

Here's the gobbledy-gook:

 

-s

/sbin/mount -uw /

/sbin/movevideodrivers /

yes

yes

yes

exit

 

I bet that aroused some programmer out there.

Now it boots up fine.

Initially it seems that Firewire and PCExpress are working but that's currently unverified.

Graphics look like a million bucks!

Only 1 core is showing, and I currently have only 1 gig of RAM installed.

I fully expect the computer to crash and burn once I increase the RAM past 2 gig.

So I'm gonna go back and blindly experiment some more as well as try some other distros using the 3 step process outlined above.

I'm also gonna narrow down what customization options are necessary and what aren't.

 

Til then, good luck M700 Hackers and do let me know if you have found somethin else that is working for you.

Or just reply with a snotty software engineer cut-down.

Come-on...you know you want to...

 

P.S. If I save ONE person from waisting as much time as I did figuring this shizzle out, this little diatribe would be more than worth it!

 

P.P.S. If Apple doesn't eventually release OSX for PCs then they are truly insane. Customers are leaving Windows like rats off of a sinking ship!

 

 

 

 

BTW, add CPU=1 flag to the customization options you must select.

Link to comment
Share on other sites

Update: Got both cores working.

Apparently you set the BIOS to Disable Multi Core Processing only for the install.

At boot, press F8 and type platform=x86.

DO NOT select the cpus=1 fix at the customize window!!!

After installing, fixing the video etc., then go back into BIOS and set everything to stock; ie Enable Multi-core Processing.

I shall cease posting from here, all M700 owners need only look at the HCL where I will add the DETAILED install guide in ENGLISH with no steps left unmentioned so that others will not suffer as I have. I am expecting near-total functionality including updates and will post the HCL when I have figured out as much as possible.

Thanks to all ToH and OSX86 Hackers and posters.

You have answered my prayers and this is definitely the coolest thing to ever happen to music PCs!

Link to comment
Share on other sites

  • 3 weeks later...

Here's an expended Tutorial to compliment the HCL.

The Admin. may move this, I dont have time to tell you where to, but I'll leave a note if it gets moved.

 

I succeeded finally after weeks of not-so-casual attempts to install Kalyway 10.5.2 et.al. on my badass 2.5ghz M700 featuring 3g of ram, Intel SSD and other nifty doo-dads. I basically just tried several distros, read what I could, understood very little of what I read cuz I'm not a code hacker and systematically experimented with virtually every setting available until blindly stumbling across the answers.

 

Here's my list of currently functional hardware:

 

Video: Functional out of the box

Dual Cores: Functional out of the box

3 gigs ram: Functional out of the box

Intel X-25 SSD system drive: Functional out of the box

Tablet: Functional after Tablet Magic, but I do NOT have a multi-touch tablet. I have heard that the touchscreen ie; multi-touch M700s are not Tablet Magic-functional yet but I cannot verify this

USB: Functional after tweaking with USB Prober. Works best with USB devices plugged in before powering on.

Firewire 400: Functional out of the box

PCExpress Slot: Recognized in Profiler, appears to be fully functional, but untested

Ethernet Port: Functional after installation of appropriate kext

Intel 4965agn WiFi: Not Functional BUT a solution is pending slowly at iWidarwin!

Phone/Modem Port: Untested but who cares

Dual Monitor: Untested

Audio: Functional via MOTU Ultralite mk3. Works like a champ!

Onboard Speakers: Untested not-functional without kexts available at InsanelyMac

Sleep: Functional out of the box

Battery Saver and Energy Saver Functions: Functional out of the box

Multi-user logins: Functional out of the box

Time machine and virtually anything else you could reasonably expect: Functional out of the box

 

Here's the list of supplies you need:

 

A LEGALLY purchased copy of Apple OSX! Relax and buy it first. It will work for sure as long as you get all of the subsequent install steps right and your computer is fully functional OOTB.

An Apple sticker to place on your M700 (see above)

A Bittorrent Client. uTorrent is my favorite.

Checksum Md5.

DVD Decryptor (this is the ONLY reliable DVD Burning software in my small knowledge).

Good DVD media, preferably TDK.

You can use the onboard DVD burner, I did and it worked like a charm. BUT, make sure you set DVD Decryptor to 2x speed!

Kalyway 10.5.2; you'll have to figure this out on your own and verify the checksum with Checksum Md5 (or else).

Tablet Magic; Google it

Intel 82566.kext.tar.gz available at Insanely Mac or the usual channels

USB Prober; available through the Apple Developer site

OSX86Tools; Google it

Et. al.; The good news: there are some very reliable kexts out there for Camera, onboard sound, bluetooth etc. In my research they have all been reported stable on M700 type equipment!The bad news: there is currently no stable AND publicly available Intel 4965agn kext for wifi. BUT, iWiDarwin is working on one and if you drop by and make a contribution, it will probably encourage them to speed up the process. Or, Hawking makes Wi-Fi USB dongles for OS X that should work out of the box. For my applications, wifi is irrelevant. It will be nice when it is up and running but I'd rather muck-up my windows machines with the internet and keep my Mac clean!

 

The initial prep goes like this:

Download everything above and donate to each site if you are able. These hackers are badasses. Show them your love with your pocket book if you can!

First, carefully read the Kalyway 10.5.2 text file.

Get to know all of the associated hardware on your M700. Chipset ICHX, Ethernet card etc. ALL OF THEM. Use device manager in Windows if you have to.

 

Then you must disable multi-core processing within BIOS. Here were the ONLY BIOS settings that I changed from stock:

 

Multi-Core Processing: Disabled (don't freak out we'll turn it back on later)

Boot Priority: CD-Rom

That's it! Now Save, and Exit BIOS

Insert the Kalyway 10.5.2 disc

At the Darwin prompt hit F8 and type this in

 

platform=x86

 

now hit enter

 

Format your system drive as you would in any standard OSX86 Install. 1 partition,Journaled, Master Boot File etc. Careful to name it something personal and NOT OSX.

Choose said system drive.

Enter the Customization menu.

Choose the sleep kernel. If I remember correctly this is the default so you may not even have to sweat it.

Chipset: You should know this but it's ICHX

You must ONLY SELECT INTEL GMA 950 from the graphics drivers customization option.

DO NOT SELECT X3100!!

I know you want to, but don't!

Don't install any sound drivers, WiFi or Ethernet drivers.

Do not select any patches,bootflags or fixes.

You should be able to figure out the rest if you followed the prep steps.

For the most part, it's a very plain install.

Continue on to install onto your system disk and wait for freakin' ever for it to install. It may pause for a long time towards the end but that pause usually goes away after an hour or less. I have an SSD so who knows how long it will pause on a standard HDD.

Evenetually it WILL show you a little screen saying that it installed successfully and is now rebooting.

 

Here is where it gets a little hairy.

 

Enter the BIOS and set the startup driver to HDD Primary or whatever you are using. Save and Exit.At the Darwin prompt hit F8 and follow the procedure listed in the Kalyway Text File to remove the video drivers. Yeah I know you just installed it so why remove them? All I know is that this is what must be done.

-s

/sbin/mount -uw /

/sbin/movevideodrivers /

yes

yes

yes

yes

exit

 

Then go through the welcome/setup screen. Once booted to the desktop, check the system profiler. It should show 1 core only. Restart the computer and enter the BIOS. Set Multi-core processing to :Enable. Reboot and the profiler should show 2 cores. Now use OSX86 Tools to install all of the above kexts. You will need to use Kexthelper b7 for a few kexts, don't ask me why. Some are just easier that way.

 

Some words of caution: Make frequent descriptively labeled extension backups cuz you will need them. Also, setup an external drive with FAT 32 and Time Machine ASAP. Partition it and get to know Time Machine well. Unfortunately, some kexts and daemons (Tablet Magic) are a little unstable at present so you will probably need to recall some older extensions etc. in order to arrive at a final stable OS. Between TM and OSX86 Tools you should be able to to get every kext working stable.

With a FAT 32 drive you can also transfer Windows files more quickly (and safely) than trying to setup a cross-platform wi-fi network.

For audio, use a dedicated Mac platform. I use MOTU Ultralite mk3 and it is an absolute dream to work with. In general, use as much Mac soft and hardware as possible and you will make your life much easier!

 

That's it! Thanks to all of the ToH wizards out there. Because of you I can now do things with my laptop that used to take an entire studio full of equipment to do!

Not to mention that having a Mac Tablet legitimizes ToH in the first place. This is what it's all about. Creating a Mac product that Apple doesn't even sell. That's not competition, that's invention. Kudos to ToH for making music PCs work after decades of bloody frustration!

Link to comment
Share on other sites

  • 2 weeks later...

I managed to get the audio working using the alc268 kext recommended by the osx86 tools update. My DVD was recognized just fine. Webcam works with camtwist. Sleep works great for me.I did all of these fairly easily with Kalyway 10.5.2. Currently I am working on getting bluetooth, ExpressCard and the SD Card reader working. I never had success with iDeneb. Perhaps you should try Kalyway 10.5.2. It seems like the most full featured distro out right now.

Link to comment
Share on other sites

  • 4 months later...
  • 1 year later...

i've got it running @near perfect video resolution

1280x768x32@75 hz.

 

used ideneb 10.5.7 install dvd

install standard without adding any other drivers

it will boot into 1024x768 resolution.

install natix.kext

reboot

set resolution to above mentioned values in settings.

and voila it is running crisp and clear.

 

anyone knows how to get it to 1280x800?

 

still working on

blue tooth

tablet

touch

wifi

camera

 

p.s. if the boot dvd gives you trouble with a kernel panick at first install, try booting it with the -s -x flags.

somehow it wont load other drivers that cause this problem during install.

Link to comment
Share on other sites

 Share

×
×
  • Create New...