Jump to content
f41qu3

New modified BOOT-132 allows you to boot retail DVDs

1,305 posts in this topic

Recommended Posts

Advertisement

Hi

 

Superhai or

 

anybody.

 

 

 

Under

 

Just a quick guide to add kexts and make iso from OS X

 

 

Do I need a mac Pc or a hackingtosh to do all this?

 

Hi when you said "Download this package" wich one is it? I don't see a link to download.

 

Where or how do you use this "<?php CODE" wicht is on red color follow by "mkdir newiso" under and all the rest?

 

Sorry for all this I'm kind of new in this.

Share this post


Link to post
Share on other sites

I'm trying to boot from the retail Leopard DVD, but the boot hangs on this line:

"Mac Framework successfully initialized

using 16384 buffer headers and 4096 cluster IO buffer headers"

 

I think the problem is with these 2 lines:

"Extension "com.apple.driver.AppleIntelCPUPowerManagement" has immediate dependencies on both com.apple.kernel and com.apple.kpi"

"Extension "com.apple.driver.AppleACPIPlatform" has immediate dependencies on both com.apple.kernel and com.apple.kpi"

 

Booting with cpus=1, -v, x, f make no difference.

 

My guess is that I'm missing a kext, but I have no idea what. The only ones in my initrd.img are:

ACPIPS2Nub.kext

ApplePS2Controller.kext

dsmos.kext

IntelCPUPMDisabler.kext

SMBIOSEnabler.kext

 

Here's my specs:

ASUS G60VX

Intel® Core™2 Duo CPU P7450 @ 2.13GHz

Motherboard Chipset: Intel PM45 (Cantiga-PM) + ICH9M (Enh)

Total Memory Size: 4 GBytes

Video Chipset: nVIDIA GeForce GTX 260M (G92-890)

Video Memory: 1024 MBytes of GDDR3 SDRAM

Hard Drive Controller: Serial ATA 3Gb/s

Hard Drive Model: Seagate ST9320423AS

Hard Drive Capacity: 305,245 MBytes (320 GB)

Disc Drive Model: HL-DT-STDVDRAM GT30N

Disc Drive Controller: Serial ATA 1.5Gb/s

Audio Adapter: Intel 82801IB ICH9 - High Definition Audio [A3]

Network Card: Intel® WiFi Link 5100 AGN

Network Card: Realtek PCIe GBE Family Controller

 

So if anyone could suggest the kexts I need or some other way to fix this issue I'd appreciate it.

Share this post


Link to post
Share on other sites

I will try this out tonight to see if this works on my self-built Desktop ill post results later tonight or tomorrow

Share this post


Link to post
Share on other sites

yea this doesn't work when I get to the first prompt I press [enter] then it asks me for a number like "80" or "81" I do that and picked the right partition/hdd and I get a black screen and my monitor turns off displays the "NO SIGNAL" did it again and this time i press [enter] on both prompts. same thing happened. any Ideas?

Share this post


Link to post
Share on other sites

Hi,

 

Thanks for the tutorial.

 

I tried following the instructions,at first i could get to grey screen and spinning gear with a 'NO' symbol which I resolved by changing the SATA mode to AHCI from IDE.Next time,i went on successfully to the star dust and spinning gear and doesnt move on after even giving 20 mins. Tried searching all the way,even went in verbose mode to see any possible error msgs but it loads in verbose and then comes to star dust screen.

 

I am using an Acer eMachine e725 with PD 2.1GHZ and 2 GB Ram.The motherboards make is not sure as I couldnt see the same in the system information.

 

The DVD drive doesnt show light after the beachball which could mean its not reading it. Is it a problem with the bootloader(i used BOOT-KABYL-BUMBY)?Or is ther any way else..even if it is complicated,i still can manage to do it.I have a macbook,so im quite used to the mac environment.

 

Any help?

Share this post


Link to post
Share on other sites

Hey guys,

 

Rook here at this mac thing but i do have a pretty decent understanding of computers

 

I get this error message after the apple installation screen shows up saying the virtual player needs to shut down.

 

I am using workstation 7

have leopard 10.5.5 retail disk

Boot-kabyl-bumby burned to dvd

 

About my PC:

Intel Core Duo 2 2.53

Windows-7 64-bit

4.0 Gb dual channel DDR3 @ 533

 

I would greatly appreciate any help

post-580559-1267402998_thumb.png

Share this post


Link to post
Share on other sites

Hi!

I have a retail OSX disc I'm trying to install on my Asrock 775Dual board (2gb ddrII, 2TB sata drive, sata dvdrw, xfx video card).

I try booting with boot132, it gets as far as reading the dvd for the first time, and kicks out with ebios errors (sector 0 block 64) over and over again.

I try booting with efi and it gets as far as letting me pick the Leo install dvd, and then freezes at a black screen.

 

I'd greatly appreciate if anyone has any suggestions about what I could do!

Share this post


Link to post
Share on other sites

Can someone please help me? I can't get pass step 3 where it says:

 

 

3. Remove the BootCD and replace it with the Mac OS X Retail DVD. Wait for the blinking light on your DVD drive to stop and then hit Enter (this will read your DVD drive and not your HD).

 

MAC OS X wont install? why? can someone please help me?

Share this post


Link to post
Share on other sites
Hey guys,

 

Rook here at this mac thing but i do have a pretty decent understanding of computers

 

I get this error message after the apple installation screen shows up saying the virtual player needs to shut down.

 

I am using workstation 7

have leopard 10.5.5 retail disk

Boot-kabyl-bumby burned to dvd

 

About my PC:

Intel Core Duo 2 2.53

Windows-7 64-bit

4.0 Gb dual channel DDR3 @ 533

 

I would greatly appreciate any help

 

 

I've the same thing in your picture

 

I tried to do it on my laptop HP dv6-1390ev

 

core2due 2.66GHz, 4GB RAM

Share this post


Link to post
Share on other sites

Hey guys, I got a little question about this boot loader w/e it is called , I downloaded the (noob version ) XD , and burned it with active iso burner , I tryed to reboot and the only result is a little

_ flashing in the left top corner for like 6 seconds then windows7 boot, I changed the boot order for the cd rom btw , I'm just wondering if I was doing something wrong . I just bough the 2 real cds ( Leopard + Snow Leopard today I would like to know how to install them on my Laptop ) thank you very much , giving donation through Paypal for help in live! Thanks! Kev.

 

Kev.simard@gmail.com

Share this post


Link to post
Share on other sites

I did a google search and I landed on this forum. Tested it out and joined to let you know it was a success :D

 

Thank you so much.

Share this post


Link to post
Share on other sites

I just have a Toshiba Satelite Pro L510 with ATI Radeon 4500 series.

 

I tried to install it but get error and would not get in the main gui of the installation process.

 

 

Please help me..

 

 

Thanks

Share this post


Link to post
Share on other sites

Seeing that some ppl have successfully installed your Mac OS, I was wondering if someone can you assist me?

 

I have a LG S1 Pro Express with the following configuration

C2D 2.00GHz

ATI X1600M

P 945 Chipset

Intel 3945ABG Wireless

 

The problem I am having is that I have tried many many instruction to get the Boot 132 and use vanilla SL retail to install but all failed.

 

The error i am getting is the ATI1600Controller KP. So that is why I am trying to create my own Boot132.

 

Using the RETAIL.ISO from http://teknojunkie.com/2009/09/boot-retail...ard-disk-on-pc/ can boot up the SL DVD but i get KP. I have already download the kext for my ATI from http://www.insanelymac.com/forum/index.php?showtopic=163190 but I have never been successfully in creating the boot 132.

 

I have using many programs to add the kext to the initrd.img, TranMac, MacImage, PowerISO, MagicISO, UltraISO. By the way, I am only Win only and dont' have access to a Mac.

 

Can you please give me simple steps as how to create the boot 132 for my computer? Thanks. Many Many Many thanks.

Share this post


Link to post
Share on other sites
Seeing that some ppl have successfully installed your Mac OS, I was wondering if someone can you assist me?

 

I have a LG S1 Pro Express with the following configuration

C2D 2.00GHz

ATI X1600M

P 945 Chipset

Intel 3945ABG Wireless

 

The problem I am having is that I have tried many many instruction to get the Boot 132 and use vanilla SL retail to install but all failed.

 

The error i am getting is the ATI1600Controller KP. So that is why I am trying to create my own Boot132.

 

Using the RETAIL.ISO from http://teknojunkie.com/2009/09/boot-retail...ard-disk-on-pc/ can boot up the SL DVD but i get KP. I have already download the kext for my ATI from http://www.insanelymac.com/forum/index.php?showtopic=163190 but I have never been successfully in creating the boot 132.

 

I have using many programs to add the kext to the initrd.img, TranMac, MacImage, PowerISO, MagicISO, UltraISO. By the way, I am only Win only and dont' have access to a Mac.

 

Can you please give me simple steps as how to create the boot 132 for my computer? Thanks. Many Many Many thanks.

1) You can try boot with GraphicsEnabler=Yes flag to avoid KP.

 

2) You can use linux live CD to edit initrd.img.

Share this post


Link to post
Share on other sites
1) You can try boot with GraphicsEnabler=Yes flag to avoid KP.

 

2) You can use linux live CD to edit initrd.img.

 

Thanks kizwan. Which boot 132 iso I should use? If not how can I make my own. Boot 132 cd to look

My own kext for my system?

 

Many many thanks.

Share this post


Link to post
Share on other sites
Thanks kizwan. Which boot 132 iso I should use? If not how can I make my own. Boot 132 cd to look

My own kext for my system?

 

Many many thanks.

You can use Empire EFI (R2) boot CD. You can install & boot OS X with it. If you got KP, try boot with these flags (try one by one):-

1) PciRoot=1 -v

2) GraphicsEnabler=Yes -v

3) PciRoot=1 GraphicsEnables=Yes -v

4) -x -v

(-v just for verbose mode. So that you can see what is going on.)

Once Mac OS X installed successfully, you can setup EFI boot partition. For this you may require these kexts in Extra folder:-

- AppleACPIPS2Nub.kext, VoodooPS2Controller.kext or ApplePS2Controller.kext

- NullCPUPowerManagement.kext

- OpenHaltRestart.kext (if you have restart/shutdown problem)

- fakesmc.kext

- VoodooBattery.kext (for battery support)

 

Your wireless wouldn't works. So I suggest you to buy Dell wireless card (e.g DW 1395) or any other card which use broadcom chipset. Check their compatibility with Mac OS X before buying it (search in the forum). Good news is, you maybe able to get your GPU working.

Share this post


Link to post
Share on other sites
You can use Empire EFI (R2) boot CD. You can install & boot OS X with it. If you got KP, try boot with these flags (try one by one):-

1) PciRoot=1 -v

2) GraphicsEnabler=Yes -v

3) PciRoot=1 GraphicsEnables=Yes -v

4) -x -v

(-v just for verbose mode. So that you can see what is going on.)

Once Mac OS X installed successfully, you can setup EFI boot partition. For this you may require these kexts in Extra folder:-

- AppleACPIPS2Nub.kext, VoodooPS2Controller.kext or ApplePS2Controller.kext

- NullCPUPowerManagement.kext

- OpenHaltRestart.kext (if you have restart/shutdown problem)

- fakesmc.kext

- VoodooBattery.kext (for battery support)

 

Your wireless wouldn't works. So I suggest you to buy Dell wireless card (e.g DW 1395) or any other card which use broadcom chipset. Check their compatibility with Mac OS X before buying it (search in the forum). Good news is, you maybe able to get your GPU working.

 

 

Thanks. Finally got to try it today. But I get a black screen when using PciRoot=0 GraphicsEnables=Y or PCiRoot=1 GraphicsEnables=Y. I am sure that the installer is running under that black screen cox when i press the keyboard, the hard drive and the CD is spinning. Or there any way or options to fix this black screen? Or is there a way to create my own Boot 132 with my own kexts on the CD too boot up the installer?

 

By the way, many many thanks for your reply.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×