Jump to content
f41qu3

New modified BOOT-132 allows you to boot retail DVDs

1,286 posts in this topic

Recommended Posts

Seeing that some ppl have successfully installed your Mac OS, I was wondering if someone can you assist me?

 

I have a LG S1 Pro Express with the following configuration

C2D 2.00GHz

ATI X1600M

P 945 Chipset

Intel 3945ABG Wireless

 

The problem I am having is that I have tried many many instruction to get the Boot 132 and use vanilla SL retail to install but all failed.

 

The error i am getting is the ATI1600Controller KP. So that is why I am trying to create my own Boot132.

 

Using the RETAIL.ISO from http://teknojunkie.com/2009/09/boot-retail...ard-disk-on-pc/ can boot up the SL DVD but i get KP. I have already download the kext for my ATI from http://www.insanelymac.com/forum/index.php?showtopic=163190 but I have never been successfully in creating the boot 132.

 

I have using many programs to add the kext to the initrd.img, TranMac, MacImage, PowerISO, MagicISO, UltraISO. By the way, I am only Win only and dont' have access to a Mac.

 

Can you please give me simple steps as how to create the boot 132 for my computer? Thanks. Many Many Many thanks.

Share this post


Link to post
Share on other sites
Advertisement
Seeing that some ppl have successfully installed your Mac OS, I was wondering if someone can you assist me?

 

I have a LG S1 Pro Express with the following configuration

C2D 2.00GHz

ATI X1600M

P 945 Chipset

Intel 3945ABG Wireless

 

The problem I am having is that I have tried many many instruction to get the Boot 132 and use vanilla SL retail to install but all failed.

 

The error i am getting is the ATI1600Controller KP. So that is why I am trying to create my own Boot132.

 

Using the RETAIL.ISO from http://teknojunkie.com/2009/09/boot-retail...ard-disk-on-pc/ can boot up the SL DVD but i get KP. I have already download the kext for my ATI from http://www.insanelymac.com/forum/index.php?showtopic=163190 but I have never been successfully in creating the boot 132.

 

I have using many programs to add the kext to the initrd.img, TranMac, MacImage, PowerISO, MagicISO, UltraISO. By the way, I am only Win only and dont' have access to a Mac.

 

Can you please give me simple steps as how to create the boot 132 for my computer? Thanks. Many Many Many thanks.

1) You can try boot with GraphicsEnabler=Yes flag to avoid KP.

 

2) You can use linux live CD to edit initrd.img.

Share this post


Link to post
Share on other sites
1) You can try boot with GraphicsEnabler=Yes flag to avoid KP.

 

2) You can use linux live CD to edit initrd.img.

 

Thanks kizwan. Which boot 132 iso I should use? If not how can I make my own. Boot 132 cd to look

My own kext for my system?

 

Many many thanks.

Share this post


Link to post
Share on other sites
Thanks kizwan. Which boot 132 iso I should use? If not how can I make my own. Boot 132 cd to look

My own kext for my system?

 

Many many thanks.

You can use Empire EFI (R2) boot CD. You can install & boot OS X with it. If you got KP, try boot with these flags (try one by one):-

1) PciRoot=1 -v

2) GraphicsEnabler=Yes -v

3) PciRoot=1 GraphicsEnables=Yes -v

4) -x -v

(-v just for verbose mode. So that you can see what is going on.)

Once Mac OS X installed successfully, you can setup EFI boot partition. For this you may require these kexts in Extra folder:-

- AppleACPIPS2Nub.kext, VoodooPS2Controller.kext or ApplePS2Controller.kext

- NullCPUPowerManagement.kext

- OpenHaltRestart.kext (if you have restart/shutdown problem)

- fakesmc.kext

- VoodooBattery.kext (for battery support)

 

Your wireless wouldn't works. So I suggest you to buy Dell wireless card (e.g DW 1395) or any other card which use broadcom chipset. Check their compatibility with Mac OS X before buying it (search in the forum). Good news is, you maybe able to get your GPU working.

Share this post


Link to post
Share on other sites
You can use Empire EFI (R2) boot CD. You can install & boot OS X with it. If you got KP, try boot with these flags (try one by one):-

1) PciRoot=1 -v

2) GraphicsEnabler=Yes -v

3) PciRoot=1 GraphicsEnables=Yes -v

4) -x -v

(-v just for verbose mode. So that you can see what is going on.)

Once Mac OS X installed successfully, you can setup EFI boot partition. For this you may require these kexts in Extra folder:-

- AppleACPIPS2Nub.kext, VoodooPS2Controller.kext or ApplePS2Controller.kext

- NullCPUPowerManagement.kext

- OpenHaltRestart.kext (if you have restart/shutdown problem)

- fakesmc.kext

- VoodooBattery.kext (for battery support)

 

Your wireless wouldn't works. So I suggest you to buy Dell wireless card (e.g DW 1395) or any other card which use broadcom chipset. Check their compatibility with Mac OS X before buying it (search in the forum). Good news is, you maybe able to get your GPU working.

 

 

Thanks. Finally got to try it today. But I get a black screen when using PciRoot=0 GraphicsEnables=Y or PCiRoot=1 GraphicsEnables=Y. I am sure that the installer is running under that black screen cox when i press the keyboard, the hard drive and the CD is spinning. Or there any way or options to fix this black screen? Or is there a way to create my own Boot 132 with my own kexts on the CD too boot up the installer?

 

By the way, many many thanks for your reply.

Share this post


Link to post
Share on other sites

Hey there guys - i am having no luck trying to install leopoard on my pc

 

tried iatkos, the vanilla install, nothing works. it could probably be my pc

these are my specs

 

intel i7 860

p55 gd65 (Asus) board

nvidia graphics card

 

i guess those 2 are the vital factors to run leopard.

 

when i tried the vanilla install using the generic boot 132 cd, i get no where - it hangs with the message 422f700 right at the beginning of the install.

 

i have tried iatkos v7 and the s3, but i cant get to install it, it halts at mounting the root device(i have tried all combinations of rd=disk[n]s[n]

 

any suggestions? is there a different generic boot 132 cd for my mother board?

 

Thanks

Share this post


Link to post
Share on other sites

try to find some info here about your motherboard

 

my board ASUS P5Q was flashed with a modded bios , and i have to config a few settings in bios to be able to boot osx dvd´s

Share this post


Link to post
Share on other sites

can you re-post a link to the disk with modified kexts i'm doing some tinkering and was wondering if it would make any difference in my machines cooperating with this hackintosh stuff i haven't had much luck lately

Share this post


Link to post
Share on other sites

I got this massge : panic(CPU 0 caller 0x001AF755): "Local APIC error\n"@SourceCache/xnu/xnu-1228.4.31/osfmk/i386/mp.c:683

 

what should I do? how to solve this problem??

 

THX

Share this post


Link to post
Share on other sites

Por favor, deletar este post, pois os links estão corrompidos, e faz as pessoas perderem o tempo!. a não ser que atualizar os links, 

OBS: eu não quis ofender, só estou dando uma dica.!

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.

×