Jump to content
InsanelyMac Forum
Andy4life

[How To] GMA900 with QE and CI support on Leopard.

Recommended Posts

just re installing and ill let you know if it works. appreciated for the speedy reply. fair comment about the different types of hardware. i have checked the device ID, matches up ok.

Share this post


Link to post
Share on other sites
Advertisement

flibblesan, yes , everything is working well. thank you again. i've got full qe & ci.

 

the only thing that doesn't work is ical. it crashes when i open it, but it's not related with this topic.

Share this post


Link to post
Share on other sites
Included AppleIntelIntegratedFramebuffer.kext is verson 1.5.24.9 - this does not give me resolution change, but also does not give me artifacts. If you need resolution change, then you need version 1.4.20.28 which does allow resolution change, but has slight artifacts with heavy applications. You will find this in the folder "to enable resolution change"

Weird, on my GMA950 I used GMA10.5.3 kexts (1.5.28.21) with AppleIntelIntegratedFramebuffer.kext 1.4.20.28, I have resolution change and no artifacts.

 

You are using AppleIntelIntegratedFramebuffer.kext from 10.5.2 update and GMA950 kexts from 10.5.2 also...

Share this post


Link to post
Share on other sites
Weird, on my GMA950 I used GMA10.5.3 kexts (1.5.28.21) with AppleIntelIntegratedFramebuffer.kext 1.4.20.28, I have resolution change and no artifacts.

 

You are using AppleIntelIntegratedFramebuffer.kext from 10.5.2 update and GMA950 kexts from 10.5.2 also...

 

I didn't realize that 10.5.3 updated the intel kexts. Something for me to look at then, they may work better.

Share this post


Link to post
Share on other sites
3) Download GMA900 pack from http://www.megaupload.com/?d=HZ8M543A and drop the kexts for YOUR device ID into the extensions folder. Use kexthelper (supplied) as it's easier.

 

please flibblesan, upload the GMA 900 pack to rapidshare, i can't download from megaupload :):D:( i am in the middle of the installation...

Share this post


Link to post
Share on other sites

thanks fibblesan!!!! finally i can download the pack, and now i hace CI n QE!!!! :D:D:D:D:D:D:D:D:D:D:D:D

Share this post


Link to post
Share on other sites
Weird, on my GMA950 I used GMA10.5.3 kexts (1.5.28.21) with AppleIntelIntegratedFramebuffer.kext 1.4.20.28, I have resolution change and no artifacts.

 

You are using AppleIntelIntegratedFramebuffer.kext from 10.5.2 update and GMA950 kexts from 10.5.2 also...

 

Same here. I'm using the AppleIntelIntegratedFrameBuffer.kext from 10.5.0, though.

Edit: Scratch that, looks like the only place I get artifacts are in firefox in the input fields. No where else though.

Share this post


Link to post
Share on other sites

I'm only getting artifacts in text fields as well, so far the places i've noticed it are:

 

- Firefox

- iTunes (in the search field)

- When I right click a file --> Get Info and try to change the extension

Share this post


Link to post
Share on other sites

I've been trying to make an install package for these using PackageMaker, but the program keeps failing saying "Could not create temporary BOM" and Google brings up nothing useful.

 

Are there any other programs that can do this, that are better? I've tried Iceberg but it's hard to use.

 

Unless somebody else can make a package?

Share this post


Link to post
Share on other sites
Guest h2a

i have this working and stuff, am i correct in noticing that all the transparent menus are no longer transparent with this fix? My menubar is transparent but i had to use an alternate AppleIntegratedframeBuffer. Would this cause that?

Share this post


Link to post
Share on other sites
i have this working and stuff, am i correct in noticing that all the transparent menus are no longer transparent with this fix? My menubar is transparent but i had to use an alternate AppleIntegratedframeBuffer. Would this cause that?

 

Non-transparent menu bar means you don't have QE and CI. Have you checked system properties?

Share this post


Link to post
Share on other sites
Guest h2a
Non-transparent menu bar means you don't have QE and CI. Have you checked system properties?

read my post again. i said that the actual menus are not transparent, meaning i can't subtly see whats behind them when i pull them down. the menu bar is transparent and QE/CI are working fine.

 

EDIT:

just kidding. my menus are transparent, i forgot that the 10.5.2 update made them BARELY transparent.

Share this post


Link to post
Share on other sites
read my post again. i said that the actual menus are not transparent, meaning i can't subtly see whats behind them when i pull them down. the menu bar is transparent and QE/CI are working fine.

 

EDIT:

just kidding. my menus are transparent, i forgot that the 10.5.2 update made them BARELY transparent.

 

I get you now. Phew!

 

I've just found out that the JaS 10.5.3 does not update ANY drivers... great.

Share this post


Link to post
Share on other sites
Guest h2a

yeah. i need 10.5.3 for SSE2. I just try to do Prasys manual installation of it and ended with a kernel panic and the inability to boot.

 

EDIT:

 

I zipped my configuration for Dev 2592 that is working perfectly, with NO artifacts. This solution involved using a combination of the files that have been posted around this thread and finally finding the right bunch so that i had the right AppleIntegratedframeBuffer and kext combination, as i was getting only a blue screen or a completely hosed configuration with all the previously described methods.

 

Using Dell Inspiron B120 laptop

 

Instructions:

 

DOWNLOAD THIS

*not sure if step 1 and 2 are necessary but i did it*

 

1. Download and install Leopard Graphics Update BUT DO NOT RESTART when it promts you

 

2. Delete the following from system/library/extensions

 

AppleIntelGMA950.kext

AppleIntelGMA950GA.plugin

AppleIntelGMA950GLDriver.bundle

AppleIntelGMA950VADriver.bundle

AppleIntelGMAX3100.kext

AppleIntelGMAX3100FB.kext

AppleIntelGMAX3100GA.plugin

AppleIntelGMAX3100GLDriver.bundle

AppleIntelGMAX3100VADriver.bundle

AppleIntelIntegratedFramebuffer.kext

 

3. Allow the graphics update to restart

4. Take the files from my zip and apply them with Kext Helper (included)

5. Reboot.

 

 

this was my first attempt at writing instructions so if its missing something or isn't coherent let me know.

Share this post


Link to post
Share on other sites
yeah. i need 10.5.3 for SSE2. I just try to do Prasys manual installation of it and ended with a kernel panic and the inability to boot.

 

EDIT:

 

I zipped my configuration for Dev 2592 that is working perfectly, with NO artifacts. This solution involved using a combination of the files that have been posted around this thread and finally finding the right bunch so that i had the right AppleIntegratedframeBuffer and kext combination, as i was getting only a blue screen or a completely hosed configuration with all the previously described methods.

 

Using Dell Inspiron B120 laptop

 

Instructions:

 

YOU NEED:

<Link Removed>

 

*not sure if step 1 and 2 are necessary but i did it*

 

1. Download and install Leopard Graphics Update BUT DO NOT RESTART when it promts you

 

2. Delete the following from system/library/extensions

 

AppleIntelGMA950.kext

AppleIntelGMA950GA.plugin

AppleIntelGMA950GLDriver.bundle

AppleIntelGMA950VADriver.bundle

AppleIntelGMAX3100.kext

AppleIntelGMAX3100FB.kext

AppleIntelGMAX3100GA.plugin

AppleIntelGMAX3100GLDriver.bundle

AppleIntelGMAX3100VADriver.bundle

AppleIntelIntegratedFramebuffer.kext

 

3. Allow the graphics update to restart

4. Take the files from my zip and apply them with Kext Helper (included)

5. Reboot.

this was my first attempt at writing instructions so if its missing something or isn't coherent let me know.

 

Does that AppleIntegratedFramebuffer.kext allow you to change resolutions?

Share this post


Link to post
Share on other sites

Looks like you are using 10.5.2 kexts with the 10.5.1 AppleIntelIntegratedFramebuffer.kext which is what I did. The ZIP appears to be corrupted :)

 

I've updated my post on page 1 with kexts from 10.5.2 and 10.5.3 as it seems some people cannot use the newer kexts, but older work. It's not possible for me to do much testing other than that the 10.5.3 kexts work fine for me (and the 10.5.2 worked also).

Share this post


Link to post
Share on other sites
Guest h2a
Does that AppleIntegratedFramebuffer.kext allow you to change resolutions?

 

Yes u can change resolutions with what i'm using.

 

 

EDIT:

 

I can't create compressed zip files with my hackintosh.... it seems to be making finder quit.

Also, i can't open Chess or iCal--they crash. Any ideas about why that might be????

 

 

*ZIP FILE FIXED AND RE-UPLOADED. Andy, if you could edit the giant quote two posts above to keep people from downloading a corrupt zip file, that would be excellent*

Share this post


Link to post
Share on other sites
Yes u can change resolutions with what i'm using.

EDIT:

 

I can't create compressed zip files with my hackintosh.... it seems to be making finder quit.

Also, i can't open Chess or iCal--they crash. Any ideas about why that might be????

*ZIP FILE FIXED AND RE-UPLOADED. Andy, if you could edit the giant quote two posts above to keep people from downloading a corrupt zip file, that would be excellent*

 

 

Artifacts aren't too big of a deal with me, so I'm pretty good (though if there is a way to drop them, I would like to fine out). I'm using 10.5.0, by the way. I wonder why people flipped over the translucent menu bar and menus, I kind of like them!

 

The Chess and iCal problem comes from the SSE2 processor, they both hit a SSE3 command that isn't properly translated into SSE3, which causes the application to crash. I have this problem as well. You can run them with Rosetta (at extremely slow speeds) if you really want them, though.

 

Back to the point, I've been messing around with the artifacts problem, but haven't really gotten a fix yet. I found another program that causes the problem though. Dreamweaver CS4 seems to mock it on all cursor changes within the app.

Share this post


Link to post
Share on other sites
Yes u can change resolutions with what i'm using. EDIT:I can't create compressed zip files with my hackintosh.... it seems to be making finder quit.Also, i can't open Chess or iCal--they crash. Any ideas about why that might be????*ZIP FILE FIXED AND RE-UPLOADED. Andy, if you could edit the giant quote two posts above to keep people from downloading a corrupt zip file, that would be excellent*
I'm gonna give this a go on my 10.5.2 setup right now, by the way iCal has never worked for me... When i just did a fresh install two days ago i tried to run it, before i modified any kexts, or anything like that... like on my first login and it wouldn't run it opens and then crashes.So it's not related to our GMA 900s it's something else.;)
The Chess and iCal problem comes from the SSE2 processor, they both hit a SSE3 command that isn't properly translated into SSE3, which causes the application to crash. I have this problem as well. You can run them with Rosetta (at extremely slow speeds) if you really want them, though.
Had a feeling it was related to the SSE2 processor, good stuff.On a side note: h2a, unfortunately your process above for "artifact-less" kexts didn't work for me, but it didn't do any damage either. I think just replacing kexts the way we're doing isn't of much use, we need to figure out what it is in the kexts that is wrong that creates these artifacts.The issue is how do we figure this out. If the odd person (such as yourself) can get it working without artifacts, then we know it can be done. It's just a matter of how and depending on what.

Share this post


Link to post
Share on other sites

Everything Works great here too nice job guys im using a unbranded laptop

 

spec:

 

ram = 1 gig

cpu = pentium m 1.6 ( sse2)

6 0gig sata HD

chipset = ich6

gfx = gma 900

 

Basically everything works with leopard with the relevent patches but as the post above im having a lil trouble with 1 or 2 programs like dvd player it will start just fine after inserting a dvd soon as play is pressed itll just crash same for the chess game it starts just fine soon as new game is started boom crash loli have full quartz and core ( nice 1 fellas ) these crashes arent gfx related but cpu any ideas

 

thanks

Share this post


Link to post
Share on other sites

Crashes are caused by having a CPU that only supports SSE2. Leopard really needs SSE3

 

VLC should work for you if you need a DVD Player.

Share this post


Link to post
Share on other sites
Crashes are caused by having a CPU that only supports SSE2. Leopard really needs SSE3

 

VLC should work for you if you need a DVD Player.

 

Yeah vlc works a treat funny tho on my desktop i spec below i used to get exact same issues with stuff and never on lappy now im getting it on lappy and desktop is ok lol but i figured its just a rosseta thing thanks

 

who cares apples dvd player is {censored} anyway lol

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×